от Kalin Sabevski(12-06-2009)

рейтинг (11)   [ добре ]  [ зле ]

Printer Friendly Вариант за отпечатване

Как да конфигурираме Микротик рутер за домашно ползване


Инсталирайте Микротик ОС на машина с поне два физически интерфейса. Преди да конфигурирате интерфейсите проверете тяхното състояние и наличност, от менюто /interface

Пример:

[admin@MikroTik] interface> print

Flags: X - disabled, D - dynamic, R - running

# NAME                         TYPE

0 X ether1                        ether

1 X ether2                        ether

[admin@MikroTik] interface>


За да може да ги конфигурирате те трябва да са разрешени, тоест пред тях да няма знака „X“. Използвайте командата /interface enable „име“ за да разрешите или забраните даден интерфейс, като „име“ го заменете с името на вашия интерфейс. Също така е възможно  разрешаването и забраняването на интерфейсите да става по техния номер.

Пример:

[admin@MikroTik] interface> print

Flags: X - disabled, D - dynamic, R - running

# NAME                         TYPE

0 X ether1                        ether

1 X ether2                        ether

[admin@MikroTik] interface> enable ether2
[admin@MikroTik] interface> enable 0

[admin@MikroTik] interface> print

Flags: X - disabled, D - dynamic, R - running

# NAME                         TYPE

0 R ether1                        ether

1 R ether2                        ether

[admin@MikroTik] interface>


Имената на интерфейсите могат да бъдат сменени с командата /interface set последвана от номера на интерфейса.

Пример:

[admin@MikroTik] interface> set 0 name=Public; set 1 name=Local
[admin@MikroTik] interface> print

Flags: X - disabled, D - dynamic, R - running

# NAME                         TYPE             RX-RATE     TX-RATE MTU

0 R Public                     ether            0           0       1500

1 R Local                      ether            0           0       1500

[admin@MikroTik] interface>


     В настоящата постановка ще приемем че машината има 2 физически интерфейса, като за първия интерфейс ще приемем че е свързан с доставчика ни на Интернет, а за втория интерфейс че е свързан с локалната ни домашна мрежа. Адресите на интерфейсите могат да бъдат добавени посредством следните команди:

Пример:


[admin@MikroTik] ip address> add address 10.0.0.217/24 interface Public

[admin@MikroTik] ip address> add address 192.168.0.254/24 interface Local

[admin@MikroTik] ip address> print

Flags: X - disabled, I - invalid, D - dynamic

 #   ADDRESS            NETWORK         BROADCAST       INTERFACE

 0   10.0.0.217/24      10.0.0.217      10.0.0.255      Public

 1   192.168.0.254/24   192.168.0.0     192.168.0.255   Local

[admin@MikroTik] ip address>

    След приключването с добавянето на адреси на съответните интерфейси е необходимо да зададем дефулт рут за нашата мрежа посредством командата / ip route add gateway=x.x.x.x където  x.x.x.x е нашия гейтуей.

[admin@MikroTik] ip route> add gateway=10.0.0.1

[admin@MikroTik] ip route> print

Flags: X - disabled, I - invalid, D - dynamic, J - rejected,

C - connect, S - static, R - rip, O - ospf, B - bgp

   #     DST-ADDRESS        G GATEWAY          DISTANCE INTERFACE

   0 ADC 192.168.0.0/24                                       Local

   1 ADC 10.0.0.0/24                                        Public

   2 A S 0.0.0.0/0          r 10.0.0.1          0      Public

[admin@MikroTik] ip route>


И накрая за да изкарате вашата мрежа през този геитуей и за да имате Интернет на локалния си интерфейс направете NAT с командата /ip firewall nat.

Пример:

[admin@MikroTik] ip firewall nat> add chain=srcnat action=masquerade

out-interface=Public

[admin@MikroTik] ip firewall nat> print

Flags: X - disabled, I - invalid, D - dynamic

0   chain=srcnat out-interface=Public action=masquerade



<< Запознаване с Tor | Как да създадем Vlan под FreeBSD >>