Linux за българи: Форуми

Linux секция за начинаещи => Настройка на програми => Темата е започната от: remotexx в Мар 17, 2017, 17:11



Титла: Chrome 57 няма да обновява Flash (проблеми с Debian, Windows)
Публикувано от: remotexx в Мар 17, 2017, 17:11
Откак ми се обнови Хрома до версия 57 (признавам си без бой под Уиндоус, ама предполагам навсякъде е така) и ми изчезнаха плъгининте т.е. chrome://plugins  и нъцки, но не ми е това основния проблем
Има някакви остатъци/наченки за разрешаване/забраняване само (в настройките) и то само Джава и Флаш, но проблемът е че не го обновява... това си е проблем, направо дупка, в сигурността

те първо го преместиха (няколко версии назад) от Хрома
C:\Program Files (x86)\Google\Chrome\Application\48.0.2564.97\PepperFlash
в глобален (за ОС)
C:\Users\UserName\AppData\Local\Google\Chrome\User Data\PepperFlash\
ама там си ми седи стария - 24.0.0.221 и не го обновява и като ида през Хром на
http://www.adobe.com/software/flash/about/
и там си седи стария 24.0.0.221 вместо новия 25.0.0.127

Както и да е въпросът ми сега е за Дебиян (и деривати т.е. Убунту като по-напред) при положение че ползват/ме
/usr/sbin/update-flashplugin-nonfree
/usr/sbin/update-pepperflashplugin-nonfree
където втория специално ми сваляше целия Хром само за да извлече от него флаша
т.е. сега ще има ли промяна - т.е. каква е генералната линия
1) ще ги обновят утилките да го свалят от друго място
2) да си инсталираме ние и поддържаме/обновяваме сами глобален пепър флаш
3) или нещо съвсем друго
щото ако си остане необновен и смятай че ...все нещо ще налази

П.П. Може ли някой да провери т.е. който има Хром 57 под линукс да иде на линка по-горе и да каже коя версия му е флаша т.е. дали е 25.ххх или е остнала на 24.хх

Корекция: Сега се сетих че имам една Федора във виртуалка и тествах там - обнови се до Хром 57 ама явно федората има друг метод на дистрибуция и не ползва тези утилки или може и направо да си го пакетират пак със новия/последния флаш Хрома [You have version 25,0,0,127 installed] (не съм запознат там с лицензи и пр. права), та... проблема се очертава май само за Дебиян (и подобни)


Титла: Re: Chrome 57 - дупка в сигурността (Debian)
Публикувано от: PaperNick в Мар 17, 2017, 17:37
Аз имам инсталиран само adobe-flashplugin на Chrome Version 57.0.2987.110 (64-bit) и ми изкарва
Цитат
You have version 25,0,0,127 installed

Преди година четох в някакво wiki на ubuntu, че pepperflash не трябва да се използва защото няма да го обновяват (или нещо такова), и да се използва adobe-flashplugin вместо него.


Титла: Re: Chrome 57 - дупка в сигурността (Debian)
Публикувано от: remotexx в Мар 17, 2017, 17:53
Благодаря много
значи минаваме на вариант 2)
и аз така си помислих ама не знаех името на пакета, довечера ще разкарам стария pepperflashplugin-nonfree и ще инсталирам новия adobe-flashplugin

Допълнителен въпрос - тоя новия само пипера или и солта  ;) така де той всички флашове ли замества или само пепър флаша с голбални, щото ако всички ще трябва и другия пакет да разкарам flashplugin-nonfree

и още - това за Дебиян ли е или за Убубту или нещо различно, защото се зачудих как така досега пък dist-upgrade не ми го фана тоя новия и да разкара ония двата... може би ще го направи но по-натам (както знаем Дебиян не е най-напред с новите технологии, да видим колко време ще я има тая 'дупка')


Титла: Re: Chrome 57 - дупка в сигурността (Debian)
Публикувано от: deant01 в Мар 17, 2017, 19:29
Според мен имаш нещо омазано по системите, защото при мени на Вин и на Дебиан всичко е с последна версия. За Pepper  знам, че той е интегриран в Хрома и няма отношение към пакетите на адобе в Дебиан. Самите адобе няколко години не бутаха нищо по флаш за линукс и трябваше от Гугъл да вършат тяхната работа линукс. Адобе се усетиха сега, когато видяха, че флаша им отива в канала вече и никой не иска да го ползва. Лично в момента пробвах и двете версии за Вин/Лин и всичко изглежда ок.


Титла: Re: Chrome 57 - дупка в сигурността (Debian)
Публикувано от: remotexx в Мар 17, 2017, 19:39
Забравих да уточня
1) с Debian testing съм
2) да не би да има пакет от дистрибуцията със Хром щото аз ползвам от Гугъл пакета т.е. репото
3) не съм се прибрал още да видя каква е хавата с Дебияна, но го забелязах първо тук на работа - Уин10 Anniversary даже със
Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/57.0.2987.98 Safari/537.36
а то под Уин няма пакет  (във ОС/Уин)- всичко е от официалния сайт
т.е. до предишната версия 56.хх си го обновяваше
да не би под Уиндоус да разчитат на Уиндоус ама на вчера ми се обнови до последно - нали patch Thursday
та не знам вече какво да си мисля...


Титла: Re: Chrome 57 - дупка в сигурността (Debian)
Публикувано от: PaperNick в Мар 17, 2017, 19:45
Принципно си е глобален пакет и няма нужда от другите флашове, може да ги разкараш.
Иначе сега като разцъках на Firefox и Chromium се оказа, че версията на флаша от adobe-flashplugin е 24,0,0,221. Предния коментар го писах от Google Chrome и изглежда, че идва с някакъв негов си флаш и май игнорира глобално инсталирания.

Тези неща ти ги пиша от Ubuntu 16.04, но мен тази дупка не ме засяга особено защото си използвам предимно Firefox без флаш и Google Chrome само за работа.

п. п. Ето го и линка от wiki-то:
https://wiki.ubuntu.com/Chromium/Getting-Flash

Изглежда че pepperflashplugin-nonfree е depricated, за другите не знам.

п. п. п. Сега видях че преди два дни са сложили актуалната версия и седи на proposed. Явно скоро ще го одобрят и ще влезе.
https://launchpad.net/ubuntu/+source/adobe-flashplugin


Титла: Re: Chrome 57 - дупка в сигурността (Debian)
Публикувано от: deant01 в Мар 17, 2017, 20:07
Забравих да уточня
1) с Debian testing съм
2) да не би да има пакет от дистрибуцията със Хром щото аз ползвам от Гугъл пакета т.е. репото
3) не съм се прибрал още да видя каква е хавата с Дебияна, но го забелязах първо тук на работа - Уин10 Anniversary даже със
Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/57.0.2987.98 Safari/537.36
а то под Уин няма пакет  (във ОС/Уин)- всичко е от официалния сайт
т.е. до предишната версия 56.хх си го обновяваше
да не би под Уиндоус да разчитат на Уиндоус ама на вчера ми се обнови до последно - нали patch Thursday
та не знам вече какво да си мисля...
пиша от Сид, и нямам подобе проблем с флаш. също нямам подобен проблем на работния на работа на Вин10. Специялно се логнах от тука за да пробвам.Пепър е флаш дистрибутиран от Гугъл специялно за Хром под Линукс. Той е вътре и е неразделна част от Хрома (може да бъде спрян но е включен вътре). Т.е. не е нужно да инсталираш НИЩО друго освен Хром, под Дебиан, за да имаш Флаш на Хром. Огнената лисица е друга бира, за която не говорим тук.


Титла: Re: Chrome 57 - дупка в сигурността (Debian)
Публикувано от: PaperNick в Мар 17, 2017, 20:27
пиша от Сид, и нямам подобе проблем с флаш. също нямам подобен проблем на работния на работа на Вин10. Специялно се логнах от тука за да пробвам.Пепър е флаш дистрибутиран от Гугъл специялно за Хром под Линукс. Той е вътре и е неразделна част от Хрома (може да бъде спрян но е включен вътре). Т.е. не е нужно да инсталираш НИЩО друго освен Хром, под Дебиан, за да имаш Флаш на Хром. Огнената лисица е друга бира, за която не говорим тук.

Аха, значи Chrome си има собствен, пък за другите които нямат си важи глобално инсталирания.


Титла: Re: Chrome 57 - дупка в сигурността (Debian)
Публикувано от: remotexx в Мар 17, 2017, 20:33
@deant01 ти явно имаш инсталиран глобално пепър флаш (под Уиндоус говоря) и той оттам си се обновява, но аз нямам т.е. досега съм разчитал на пакетирания с Хрома, него от известно време го преместиха т.е. вместо в Хром папките го инсталираха в глобалната локация (обявено бе официално) и там пак си го обновяваха, но от 57.хх вече официално обявиха че няма да го пакетират и поддържат - и за хора като мене дето тов аим бе единстгвения флаш - остава дупката, за тези като тебе дето някогаш са си инсталирали от адобе явно исталира техен си спайуер такак де сервиз дето да го обновява, ама на моя си остана на старата версия
Официално от Хром 57 - от натройки може само да се разрешава/забранява флаш и джава т.е. вече се водят external plugins

явно не съм само аз
http://www.ghacks.net/2017/01/29/google-removes-plugin-controls-from-chrome/
и явно проблемът е от по-отдавна (Хром 54) но намазването но по-нов Хром го е поддържало но "командно дишане", но явно и това вече не работи
https://bugs.launchpad.net/ubuntu/+source/pepperflashplugin-nonfree/+bug/1632870

Благодаря на всички - сега вече мис е изясни картинката - ще пробвам с новия пакет под линукс, а под уиндоуса ще карам без (да не зарбавя да изтрия остатъците)


Титла: Re: Chrome 57 - дупка в сигурността (Debian)
Публикувано от: petar258 в Мар 17, 2017, 20:39
Проблема не е в потребителя или настройки, а в Гугле. Те са решили да махнат chrome:plugins . Има го доста коментирано из нета но няма решение. Явно Гугле не иска да виждате с какво ви следи.
За подробно инфо https://www.google.bg/?gws_rd=ssl#q=chrome+57+plugins+not+accessible&*
П.С. При мен флаша в хрома е обновен сам до 25,0,0,127. Дистрибуцията е убунту-мате 16.04


Титла: Re: Chrome 57 - дупка в сигурността (Debian)
Публикувано от: remotexx в Мар 17, 2017, 20:40
Значи да уточня
1) Хром си идваше със собствен
2) до версия 54.хх си се инсталираше в Хром директориите
3) в. 54.х до 56.ххх се инсталираше в глобалното (и за Адобе място , но само ако е по-нов)
4) от 57.хх вече нито се инталира нито е в пакета нито се поддържа (т.е. не се поддържа обновяването му, но ако имате инсталиран глобален то може само да го разрешите или забраните)

- ако имате/сте имали глобален (от адобе) той ще се самоподдържа - предполагам исталира сервиз (и пр. спайуер) но ако сте били като мен - тъй и тъй пепър флаш се ползваше само от Хрома и разчитах само на него, си оставате с последната версия т.е. внимание - ако сте го пускали наскоро ще останете (понеже се самообновява ама требе някой да го пуска от време на време) та ще останете с последната версия активна към датата на последното пускане или макс. 24.х - няма да се обнови до 25.х, 26.х и т.н. (а тук  някой разпраяше убедително че след 21.х или 22.х вече щели само цифричките след 22. да се менят)


Титла: Re: Chrome 57 - дупка в сигурността (Debian)
Публикувано от: remotexx в Мар 17, 2017, 20:44
Съгласен съм с Петър
проблема е че ми оставиха старата си версия - като ще го махат да я деинсталират и така да принудят хората да се сетят да инсталират от Адобе, а не да ми оставят нещо което с времето ще става като швейцарското сирене - с повече и повече дупки и повечето потребители даже няма и да разберат че не им се обновява щото флаша си върви
ама мен това ми е най-малкия дерт, проблема ми беше че линукс утилките доколкото знам го извличаха от тези пакети затова запитах и вече ми отговориха че има по - най- нов пакет с друго име , защото там вече се бях притеснил а и dist-upgrade не го хваща (Дебиян тестинг)


Титла: Re: Chrome 57 - дупка в сигурността (Debian)
Публикувано от: remotexx в Мар 17, 2017, 20:52
За съжаление тоя пакет май го няма в Дебиян
adobe-flashplugin

https://www.debian.org/distrib/packages

търсих във всички - стабилни, тестови, експериментални
кой ги знае пак какво ще измислят дебианци

а хич, ама ХИЧ, не ми се разчита на адобе


Титла: Re: Chrome 57 - дупка в сигурността (Debian)
Публикувано от: petar258 в Мар 17, 2017, 20:54
провери за flashplugin-installer възможно е да е набутано някъде из non-free


Титла: Re: Chrome 57 няма да обновява Flash (проблеми с Debian, Windows)
Публикувано от: deant01 в Мар 17, 2017, 21:00
откакто ми спряха любимата флаш игрица, се радвам, че нямам допир с флаш абсолютно никъде. Иначе сега и аз забелязвам, че се е заформила страшна каша, най-вече от страна Гугъл.


Титла: Re: Chrome 57 няма да обновява Flash (проблеми с Debian, Windows)
Публикувано от: remotexx в Мар 17, 2017, 21:02
няма колега - никъде го няма
https://packages.debian.org/search?keywords=flashplugin-installer&searchon=names&suite=all&section=all


Титла: Re: Chrome 57 няма да обновява Flash (проблеми с Debian, Windows)
Публикувано от: remotexx в Мар 17, 2017, 21:13
Предполагам стигаме до съгласие, че:
1) Гугъл направи грешката, че трябваше при обновяване 56.х до 57.х да си разкара техния си флаш пакет
2) проблемът им е предполагам че преди това направиха грешката да преместят техния си плъгин в глобалното място (за съответната ОС) и даже ако там е по-нов не го обновяваха и
3) та при обновяването 56 -> 57 вече не знеха те там в глобалното място техния ли е (че да го разкарат щото веке няма да го поддържат/обновяват) или  е на Адобе т.е. ще си се самобоновява (че като го разкарат да ядосат още  повече хора) та така избрали са по-малкото зло, па и колко ли са тия дето ще забележат че не им се обновява флаша (и дето няма като разберат да идат и да си намажат отгоре официалния от Адобе дето ще си се самообновява)

А сега какво да правим ние Дебиянците - всички утилки заминават на кино, а не ми се слага т.е. не ми се иска да ми го сложат 'глобално' и то баш па Адобе па да ми го сложат  :o


Титла: Re: Chrome 57 - дупка в сигурността (Debian)
Публикувано от: PaperNick в Мар 17, 2017, 21:25
За съжаление тоя пакет май го няма в Дебиян
adobe-flashplugin

https://www.debian.org/distrib/packages

търсих във всички - стабилни, тестови, експериментални
кой ги знае пак какво ще измислят дебианци

а хич, ама ХИЧ, не ми се разчита на адобе

Да, май го има само за Ubuntu в Canonical partners хранилищата...


Титла: Re: Chrome 57 няма да обновява Flash (проблеми с Debian, Windows)
Публикувано от: malin в Мар 17, 2017, 22:24
Т.е. тва не върши работа (не знам, не ползвам Хром-базирани) https://wiki.debian.org/FlashPlayer

По спомен - от сайта на адобето, сваляш архива и хвърляш плеъра в потребителската директория където трябва да е флаш-плеъра и бачкаше на Убунту, ама с ФФ.


Титла: Re: Chrome 57 няма да обновява Flash (проблеми с Debian, Windows)
Публикувано от: go_fire в Мар 17, 2017, 23:40
Те така. Няма го Киберкоп, баш га ти трябва. Той е страшен специалист на фалша. Все едно той го е писал. С две изречения щеше да оправи проблемата.


Титла: Re: Chrome 57 няма да обновява Flash (проблеми с Debian, Windows)
Публикувано от: remotexx в Мар 17, 2017, 23:53
Т.е. тва не върши работа (не знам, не ползвам Хром-базирани) https://wiki.debian.org/FlashPlayer

По спомен - от сайта на адобето, сваляш архива и хвърляш плеъра в потребителската директория където трябва да е флаш-плеъра и бачкаше на Убунту, ама с ФФ.
1) той тоя 'обикновения' ще продължи да си работи - притеснявам се само за ПепърФлаш
2) Аз това го знам щото всеки път трябва да ги оправям на ръка тия скриптове (и двата, че имам някакъв проблем със дебиян https сървъра) т.е. обикновения флаш си го дърпа от официалния сайт - а дебиянци само предоставят един файл с чек сумите ( не знам що адобе не го /ли/ правят, та трябва на Дебиян да разчитам дали Адобе не ме лъжат нещо волно или неволно т.е. някой да ги е хакнал и подменил флаша ... не че му трябва подмяна де), обаче при пепъра не знам що не го правят както с обикновения ами от Гугъл Хрома т.е. ДА всеки път ми свалят към 100 МБ Хром да извадят от него пепър флаш (може би щото Хрома дава и чек сумите :P)

Кибера.. и аз на него разчитах - да каже кой е сега пакета  :(


Титла: Re: Chrome 57 няма да обновява Flash (проблеми с Debian, Windows)
Публикувано от: Acho в Мар 18, 2017, 06:46
Java-та и тя е лашната.


Титла: Re: Chrome 57 няма да обновява Flash (проблеми с Debian, Windows)
Публикувано от: cybercop в Мар 18, 2017, 17:25
1) той тоя 'обикновения' ще продължи да си работи - притеснявам се само за ПепърФлаш
Кибера.. и аз на него разчитах - да каже кой е сега пакета  :(
Да питам, че ми е любопитно. Какво ще правиш с тоя флаш плеър? Аз не ползвам такъв от поне две години.
На чужди компютри съм слагал pepperflashplugin-nonfree за chromuim базираните браузъри и adobe-flashplugin/flashplugin-nonfree за останалите. Преди няколко месеца, ровичках една машина с 32 битова Ubuntu и се оказа, че трябва да бъдат инсталирани едновременно peppeflashplugin-nonfree и adobe-flashplugin (от Partners хранилищата) за да работи плеъра в Chromium.


Титла: Re: Chrome 57 няма да обновява Flash (проблеми с Debian, Windows)
Публикувано от: 4096bits в Мар 18, 2017, 18:12
Има доста хора, дето убиват времето с глупави флаш игрички. Тъпо е да махат плеъра


Титла: Re: Chrome 57 няма да обновява Flash (проблеми с Debian, Windows)
Публикувано от: cybercop в Мар 18, 2017, 18:43
Има доста хора, дето убиват времето с глупави флаш игрички. Тъпо е да махат плеъра
Дай ми връзка към такава игричка. Имам много сериозни подозрения, че браузърите, вече конвертират съдържанието към html5.


Титла: Re: Chrome 57 няма да обновява Flash (проблеми с Debian, Windows)
Публикувано от: 4096bits в Мар 18, 2017, 20:29
Не мога да ти покажа такава игричка, защото трябва да търся такава. Не играя  ::)


Титла: Re: Chrome 57 няма да обновява Flash (проблеми с Debian, Windows)
Публикувано от: lomion в Мар 18, 2017, 20:37
В момента Google Chrome идва без флаш, но може да си го добави и обновява. В адресната лента напишете
chrome://components и ще се покажат компонентите, които могат да се обновяват ръчно. Намерете надписа
Adobe Flash Player, под него има бутон "Проверка за актуализации". Натискате и той си сваля най-новия флаш.
Това важи само за Google Chrome!


Титла: Re: Chrome 57 няма да обновява Flash (проблеми с Debian, Windows)
Публикувано от: remotexx в Мар 19, 2017, 00:40
В момента Google Chrome идва без флаш, но може да си го добави и обновява. В адресната лента напишете
chrome://components и ще се покажат компонентите, които могат да се обновяват ръчно. Намерете надписа
Adobe Flash Player, под него има бутон "Проверка за актуализации". Натискате и той си сваля най-новия флаш.
Това важи само за Google Chrome!

Аха - е те това търсех
Това не го обновява (както преди) автоматично със пускането на браузъра, ама и на ръчна става

Корекция: За да е бозата пълна - това работи но само под Уиндоус, под Дебиян (с pepperflashplugin-nonfree пакета) chrome://components не показва пепъра, а пък като отида на http://www.adobe.com/software/flash/about/ и ми казва че имам флаш...  бозата става все по-мътна, явно ще трябва да я оставя за известно време да ферментира и да се избистри (т.е. да им уврът главите и да го оправят)


Титла: Re: Chrome 57 няма да обновява Flash (проблеми с Debian, Windows)
Публикувано от: remotexx в Мар 20, 2017, 16:10
Оказа се че са се наговорили (както винаги) и от Файърфокса (52.0+) също са ги разкарали (без Флаш - интересно що го държат още на командно дишане само него)

https://www.mozilla.org/en-US/firefox/52.0/releasenotes/
Removed support for Netscape Plugin API (NPAPI) plugins other than Flash. Silverlight, Java, Acrobat and the like are no longer supported.

даже малко поизбъразли та... "Google Hangouts temporarily won't work"  :o
интересно Гугъл дали си порязаха собствения плъгин Hangouts - макар че там едва ли е проблем той отдавна си е външен и си се поддържа сам.
И какво стана сега - Умивам(е) си ръцете и (за всичко ще е виновен Флаш)


Титла: Re: Chrome 57 няма да обновява Flash (проблеми с Debian, Windows)
Публикувано от: go_fire в Мар 20, 2017, 16:23
Ами от Гългъл вкараха като негов заместник PPAPI, като първото Пъ иде от ратишка. Уж за по-сигурно. Да не може много да се шава, че NPAPI-то много права дава. Та тия от Мозила рекоха, че в някакъв момент (неизвестно кога) и те ще го поддържат. Не, че много им трябва, ама заради фалша. И ще сменят олигореничния pdfjs с нещото на Foxit.


Титла: Re: Chrome 57 няма да обновява Flash (проблеми с Debian, Windows)
Публикувано от: remotexx в Мар 20, 2017, 18:18
и какво сега ще минаваме на заместители.. аз от бая време ползвам Pale Moon ($2) и съм доволен