Автор Тема: Starting gnome display manager...           [fail]  (Прочетена 1987 пъти)

mazzzterZ

  • Участник
  • *****
  • Публикации: 37
  • Distribution: Ubuntu
  • Window Manager: Gnome
    • Профил
Не знам дали е точно тука мястото на тази тема, но не съм сигурен каде да я постна, затова я оставям тука.
Ето проблема. Както си работих на компютъра по едно време реших да си пусна клипче, но като го стартирах не тръгна... изобщо VLC-то не ми се зареди(забравих да погледна в процесите да видя дали изобщо се е появило там, но мисля, че не е). Реших да стартирам само VLC и то взе, че тръгна само дето имаше нов скин и нищо не можех да правя с енго беше като замръзнало... Същият ден единственото, което сам правил е, че инсталирах ъпдейтите. Рестартирах, но не ми се зареди ГНОМЕ... вместо това се озовах под ниво 1(Ctrl+Alt+F1) и ми пишеше:
Цитат
Starting up...
Loading, please wait...
usplash: Setting mode 1280x1024 failed
usplash: Setting mode 1152x864 failed
usplash: Using mode 1024x768
kinit: name_to_dev_t(/dev/disk/by-uuid/47480b27-63d6-4fe2-a4fd-ece0750e58db) = sda5(8,5)
kinit: trying to resume from /dev/disk/by-uuid/47480b27-63d6-4fe2-a4fd-ece0750e58db
kinit: No resume image, doing normal boot...

Първо мислех, че от това е проблема, но след акто четох из нета, че други хора, на които им се показва същото съобщение след 1-2мин ГНОМЕ им се стартира, а и при тях работят комади като:
Цитат
startx

, а при мене не работят помислих, че може и да не е от това, но все пак го оправих. Ето как:(swap ми е sda5)
Цитат
swapoff /dev/sda5
mkswap /dev/sda5
update-initramfs -u

Рестартирах и съобщението изчезна, но остана проблема, че не се зарежда ГНОМЕ. След един рестарт забелязах, че ми изписва на един ред:
Цитат
Starting GNOME Display Manager                         [fail]

Опитах:
Цитат
sudo gdm

но ми изписва:
Цитат
gdm: symbol lookup error: /usr/lib/libgtk-x11-2.0.sa.0: undefined symbol:g_signal_accumulator_true_handled

Пробвах и
Цитат
sudo /etc/init.d/gdm start

но на екрана се изписва:
Цитат
*Starting GNOME Display Manager...                   [fail]

Опитах и това:
Цитат
sudo dpkg-reconfigure gdm

и отговора е:
Цитат
invoke-rc.d: initscript gdm, action "reload" failed

Когато рестартирам компютъра виждам на две места, че пише [fail], но не мога да прочета на кое е, защото минават много бързо.
Някой може ли да ми каже каде има лог файл, в който мога да видя, на кое ми пише [fail] или някой ако има представа, защото не иска да ми се стартира Gnome Display Manager-a. Забравих да спомена, че го преинсталирах gdm-то,но никаква промяна нямаше.
Активен

Ivshti

  • Участник
  • *****
  • Публикации: 322
  • Distribution: Linvo 2010.3
  • Window Manager: Gnome
    • Профил
    • WWW
Starting gnome display manager...           [fail]
« Отговор #1 -: Авг 31, 2008, 00:19 »
Проблема със сигурност ти е в зависимостите на gdm. Ъпдейтвал ли си, пипал ли си символични линкове? Намирисва ми на ъпдейт '<img'>
О, да, ти си го писал в поста...
Цитат
gdm: symbol lookup error: /usr/lib/libgtk-x11-2.0.sa.0: undefined symbol:g_signal_accumulator_true_handled

Опитай се да преинсталираш libgtk-x11 '<img'> Или както е пакета, сигурно gtk2-X-Y.deb (X-версия, Y-arch) '<img'> Трябва да си намериш подходящата версия, ако не е възможно хем новия GDM да работи, хем нещата от Gnomе-а, просто ръчно сваляш стара версия на gdm, ръчно даунгрейдваш всичките му зависимости (много кофти '<img'> ) и даунгрейдваш всичко от Gnome-а '<img'> Най-сигурно си намери пакетите, от които си правил инсталацията и инсталирай от тях '<img'>



Активен

mazzzterZ

  • Участник
  • *****
  • Публикации: 37
  • Distribution: Ubuntu
  • Window Manager: Gnome
    • Профил
Starting gnome display manager...           [fail]
« Отговор #2 -: Сеп 04, 2008, 23:15 »
Малко късно пиша, но нямах възможност преди това. Та след като инсталирах най-новата версия на библиотеката GLIB GDM-то тръгна. Забелязах, че като напиша:
Цитат
apt-get update

ми казва, че не може да изтегли новите индекс файлове и предполагам това е била причината да се скапе GDM-то... нова версия на GMD със стари библиотеки. Оправих го като смених да тегли ъпдейтите от други сървъри, а не българският. Сега има още два остатъчни проблеми. Първият е, че не ми се маунтва уиндоуският дял. Имам още един който е NTFS и той в началото не искаше, но днес забелязах, че се е маунтнал. Това дали се дължи на ъпдейта или на това, че е трябвало да рестартирам преди това не помня. Като ми се стартира Убунтуту забелязвам, че ми дава един [fail], за който единственото което мога да прочета, защото се скрива много бързо:
Цитат
*едикакво си* is not file or directory
for more information see /sbin/mounts.ntfs

това или нещо от тоя род. Пробвах да го отворя този файл, но не знам с какво... Ако имате някаква идея как да си оправя маунтването моля пишете.
Вторият проблем е с видео дриверите ми. Предишният път си спомням, че пак минах през някакво огромно мъчение докато заработят както трябва ама сега... Ето в какво по-точно е проблема... Ако отида на System-->Administration-->Hardware Driver и избера отметката за дривера няма никакви промени в системата. Затова пък ако сваля дривера от сайта на NVIDIA(картата ми е GeForce 6600) и после спра X сървъра с:
Цитат
/etc/init.d/gdm stop

навигирам до там кадето сам записал дривера на харда и изпълнявам:
Цитат
sudo sh NVIDIA-Linux-x86-173.14.12-pkg1.run

дривера се иснталира и след рестартдривера уж работи. Но като сменя на 1600x1200(резолюцията, на която бях преди да ми се скапе GDM-то) тя се променя но екрана ми на видимост и той се променя на 800x640 и все едно движа прозорче на целият си десктоп. Този проблем беше и преди и даже и аз не разбрах рпеди как го оправих. По-ниските резолюции ги показва както трябва и даже и ефектите на compiz си работят както трябва и клавишните комбинации, които им бях дал, на някои от тях, преди това. Не знам дали има значение, но забелязах, че след като от System-->Administration-->Hardware Driver избера отметката за дривера като стартирам ми казва, че линукса ще работи в Low Grafic Mode и ми дава възможност да продължа и конфигурирам и като дам да го конфигурирам и избера табчета за видео карта Линукса е решил, че картата ми е GeForce 6800(generic), а тя е GeForce 6600. Пробвах да избера, че картата ми е от 6 сериите, но нямаше никакъв ефект. Ако имате някакви предложения моля споделете.



Активен

Подобни теми
Заглавие Започната от Отговора Прегледи Последна публикация
Забива gnome-volume-manager
Настройка на програми
Knopper 3 1154 Последна публикация Ное 27, 2004, 18:42
от Knopper
Gnome File Manager
Настройка на програми
ulrich 0 864 Последна публикация Мар 01, 2005, 14:45
от ulrich
Gnome Session Manager и КДЕ
Настройки на софтуер
kolche 0 951 Последна публикация Фев 23, 2006, 12:32
от kolche
Gnome-power-manager и Openbox
Настройка на програми
radoshow 4 1565 Последна публикация Дек 13, 2010, 12:50
от radoshow
Display manager за Дебиан 9?
Настройка на програми
Naka 44 3537 Последна публикация Юли 16, 2018, 01:21
от Yasen6275