Автор Тема: Проблем със стартирането на Google Chrome  (Прочетена 6358 пъти)

angie_bg

  • Участник
  • *****
  • Публикации: 842
  • Distribution: Ubuntu 10.04
  • Window Manager: Gnome
    • Профил
    • WWW
Ubuntu 10.04, Google Chrome 20.0.1132.47

След ъпгрейт до версия 20.0.1132.47 Google Chrome спря да се стартира.
- Стартиран от конзола с google-chrome - без (положителен) ефект - без съобщения за грешка, "виси".
- Стартиран с --no-sandbox тръгва, но "не работи" - не може да зареди която и да е страница, с изключение на настройките (wrench).
- Стартиран като root веднага дава съобщение, че трябва да се укаже алтернативна директория за данни.
- Преинсталация - без промяна. gdebi информира, че всички зависимости са изпълнение.

Възможно е проблемът да е във видеокартата (ATI 9600), която не можах да подкарам с ATI драйвери и я карам като vesa, Google Earth не тръгва с нея, но поне дава съобщение.
Вероятно Pepper Flash се бъгясва, затова за мен решението е да се вмъкне в командата за стартиране ключа --disable-bundled-ppapi-flash, т.е. командата за стартиране да се промени от
google-chrome %U
на
google-chrome --disable-bundled-ppapi-flash %U
Активен

backinblack

  • Участник
  • *****
  • Публикации: 3201
    • Профил
Re: Проблем със стартирането на Google Chrome
« Отговор #1 -: Юли 06, 2012, 15:57 »
Аз съм със същата и нямам никакъв проблем!
Активен

angie_bg

  • Участник
  • *****
  • Публикации: 842
  • Distribution: Ubuntu 10.04
  • Window Manager: Gnome
    • Профил
    • WWW
Re: Проблем със стартирането на Google Chrome
« Отговор #2 -: Юли 06, 2012, 18:07 »
Същата какво? Дистрибуция? Видеокарта? Ако става дума за картата - всяка помощ ще ми е от полза.
Активен

backinblack

  • Участник
  • *****
  • Публикации: 3201
    • Профил
Re: Проблем със стартирането на Google Chrome
« Отговор #3 -: Юли 06, 2012, 18:15 »
С 10.04 64бит и същата версия на Хром, но желязото е друго. Може и в картата да ти е проблема.
Активен

angie_bg

  • Участник
  • *****
  • Публикации: 842
  • Distribution: Ubuntu 10.04
  • Window Manager: Gnome
    • Профил
    • WWW
Re: Проблем със стартирането на Google Chrome
« Отговор #4 -: Юли 06, 2012, 18:28 »
Най-вероятно. Затова и публикувах темата - може и някой друг да има подобни проблеми (въпреки, че няма отоврена тема), да не се върти като блондинка в мол...
Активен

kalinik

  • Участник
  • *****
  • Публикации: 539
  • Distribution: LMDE x64 2012/ LM 14 x64
  • Window Manager: Mate / KDE
  • ID user #521433
    • Профил
Re: Проблем със стартирането на Google Chrome
« Отговор #5 -: Юли 06, 2012, 19:29 »
В терминала пишете:
sudo chmod 1777 /dev/shm

и трябва да тръгне. Стар бъг... който явно пропускат почти при всяко обновяване :(
Активен

angie_bg

  • Участник
  • *****
  • Публикации: 842
  • Distribution: Ubuntu 10.04
  • Window Manager: Gnome
    • Профил
    • WWW
Re: Проблем със стартирането на Google Chrome
« Отговор #6 -: Юли 06, 2012, 19:31 »
При 19.х нямаше проблем.
Активен

cybercop

  • Участник
  • *****
  • Публикации: 5559
  • Distribution: Ubuntu LTS, CENTOS 6.x
  • Window Manager: Xfce, Gnome 2
    • Профил
Re: Проблем със стартирането на Google Chrome
« Отговор #7 -: Юли 06, 2012, 19:45 »
Днес и аз го констатирах. Нова инсталация на Lubuntu 11.04 на стар компютър. Google-chrome не стартира, което ми се случава за първи път. Flash - player не работи в Chromium и Firefox. Нямах време да реша проблемите и го оставих за друг ден.
Активен

Ползването на Linux води до пристрастяване. Факт.
http://s19.postimg.cc/4oajwoq5v/xenial2.png

angie_bg

  • Участник
  • *****
  • Публикации: 842
  • Distribution: Ubuntu 10.04
  • Window Manager: Gnome
    • Профил
    • WWW
Re: Проблем със стартирането на Google Chrome
« Отговор #8 -: Юли 06, 2012, 21:54 »
За flash-a: деинсталирах adobe-flashplugin, инсталирах flashplugin-installer и всичко тръгна.
Активен

cybercop

  • Участник
  • *****
  • Публикации: 5559
  • Distribution: Ubuntu LTS, CENTOS 6.x
  • Window Manager: Xfce, Gnome 2
    • Профил
Re: Проблем със стартирането на Google Chrome
« Отговор #9 -: Юли 06, 2012, 23:11 »
Всички са една версия. И нито един не работеше.
Активен

Ползването на Linux води до пристрастяване. Факт.
http://s19.postimg.cc/4oajwoq5v/xenial2.png

kalinik

  • Участник
  • *****
  • Публикации: 539
  • Distribution: LMDE x64 2012/ LM 14 x64
  • Window Manager: Mate / KDE
  • ID user #521433
    • Профил
Re: Проблем със стартирането на Google Chrome
« Отговор #10 -: Юли 07, 2012, 01:06 »
В терминала пишете:
sudo chmod 1777 /dev/shm

и трябва да тръгне. Стар бъг... който явно пропускат почти при всяко обновяване :(

Toва не помага ли ?
Активен

angie_bg

  • Участник
  • *****
  • Публикации: 842
  • Distribution: Ubuntu 10.04
  • Window Manager: Gnome
    • Профил
    • WWW
Re: Проблем със стартирането на Google Chrome
« Отговор #11 -: Юли 20, 2012, 15:49 »
Допълнение към темата:
Ubuntu 10.04, Google Chrome 20.0.1132.57 (след последния ъпгрейт, stable)

1. Сега не е необходимо да се забранява използването на флаша, за да тръгне браузера, т. е. отново командата е (само) google-chrome.
2. От архива свалих adobe-flashplugin_10.2.159.1-0hardy1_i386.deb, от който извадих libflashplayer.so и го поставих в /usr/lib/adobe-flashplugin/ (като предварително преименувах съществуващия файл).
3. От chrome://plugins забраних използването на версия 11.2, а разреших 10.2. Пренебрегнах предупреждението за остарял плъгин и настоятелната покана за ъпгрейд.
4. В момента мога да гледам flash съдържание, като неудобството е в появяващото се предупреждение за остарял плъгин и всеки път го пускам "само този път".
Надявам се да съм бил полезен!


Активен

vesi_snd

  • Участник
  • *****
  • Публикации: 29
  • Distribution: Ubuntu 10.04.4
  • Window Manager: Gnome
    • Профил
Re: Проблем със стартирането на Google Chrome
« Отговор #12 -: Юли 21, 2012, 19:55 »
В терминала пишете:
sudo chmod 1777 /dev/shm

и трябва да тръгне. Стар бъг... който явно пропускат почти при всяко обновяване :(

 
При мен проблем е същия и тази команда не оправя нещата.

При опит да пусна пакета даден от линка се чупи някакъв пакет и се прекъсва инсталацията това е заради версията, коята ползвам 10.04.4 предполагам.
angie_bg можеш ли да споделиш този файл libflashplayer.so и да видя дали ще тръгне при мен.
« Последна редакция: Юли 21, 2012, 20:00 от vesi_snd »
Активен

vesi_snd

  • Участник
  • *****
  • Публикации: 29
  • Distribution: Ubuntu 10.04.4
  • Window Manager: Gnome
    • Профил
Re: Проблем със стартирането на Google Chrome
« Отговор #13 -: Юли 22, 2012, 12:29 »
Благодаря на angie_bg за начина по който е решил проблема.
При мен сработи всичко
1. Премахнах текущия libflashplayer.so в /usr/lib/adobe-flashplugin с командата sudo rm libflashplayer.so
2. Изтеглих този файл, http://ubuntuone.com/5LMMNToby2fd4lqKbrBG9W и го премстих в /usr/lib/adobe-flashplugin с командата
sudo mv libflashplayer.so /usr/lib/adobe-flashplugin
и сега всичко е наред.
Искам да изкажа благодарността на всички и по специално на dejuren, който ми помага!
« Последна редакция: Юли 22, 2012, 12:31 от vesi_snd »
Активен