Автор Тема: PulseAudio  (Прочетена 4043 пъти)

elfenlied

  • Участник
  • *****
  • Публикации: 205
  • Distribution: Sabayon 5.3
  • Window Manager: Gnome 2.30.2
    • Профил
PulseAudio
« -: Май 04, 2010, 08:15 »
Една вечер си включвам филм и гледам, че няма звук от колонките на лаптопа, проверявам нещо да не е намалено, но всичко си е точно. Пускам в жака слушалките и се чува звук. Нямам никаква идея от какво става така ???
На Sabayon 5.2 съм и Pulse Audio 0.9.21.1. Чакам с нетърпение идеите ви.
Активен

PC Cases: DELL 400W. Pentium IV, CPU speeds: 1700 MHz, MMX, SSE, SSE2,  FSB speeds: 400 MHz, x86. RAM MEMORY: RDRAM 2x256MB,  400Mhz. SVGA: NVidia TNT2 Memory: 32MB.
HDD: 40GB, 7400 RPM.
Motherboard Dell Dimension 8200

tyuio

  • Гост
Re: PulseAudio
« Отговор #1 -: Май 04, 2010, 15:00 »
чакай сега слушалките в същия вход дето слагаш и колонките ли или друг?
В alamixer в конзолата всичко ли е вдигнато?
Активен

elfenlied

  • Участник
  • *****
  • Публикации: 205
  • Distribution: Sabayon 5.3
  • Window Manager: Gnome 2.30.2
    • Профил
Re: PulseAudio
« Отговор #2 -: Май 04, 2010, 15:57 »
чакай сега слушалките в същия вход дето слагаш и колонките ли или друг?
В alamixer в конзолата всичко ли е вдигнато?
Да всичко е точно. Слушалките са в жак, а колонките са вградени в лаптопа. От колонките няма звук, но като вкарам слушалките си има, е на тях само. Колонките ги тествах и работят от жив диск. Някъде има проблем с Pulseaudio-то.
Има и 2-ри проблем с миксера. При смяна на настройките звука ми се губи изцяло. След връщане на настройките звук пак няма да има (дори и да премахна .pulse папката). За второто проблемче знам от личен опит.
Мога и без pulseaudio, само да има нормален звук :)
« Последна редакция: Май 04, 2010, 16:14 от elfenlied »
Активен

PC Cases: DELL 400W. Pentium IV, CPU speeds: 1700 MHz, MMX, SSE, SSE2,  FSB speeds: 400 MHz, x86. RAM MEMORY: RDRAM 2x256MB,  400Mhz. SVGA: NVidia TNT2 Memory: 32MB.
HDD: 40GB, 7400 RPM.
Motherboard Dell Dimension 8200

dejuren

  • Участник
  • *****
  • Публикации: 1025
  • Distribution: Ubuntu, RedHat
  • Window Manager: lxde KDE4
    • Профил
Re: PulseAudio
« Отговор #3 -: Май 04, 2010, 18:27 »
Пробвай това решенийце:
Цитат
1. Backup and remove old configuration files:

$ mkdir ~/pulse-backup && cp -r ~/.pulse ~/.asound* /etc/asound.conf /etc/pulse -t ~/pulse-backup/
$ rm -r ~/.pulse* ~/.asound*
$ sudo rm /etc/asound.conf

2. Install necessary packages:

$ sudo apt-get install libasound2-plugins padevchooser libsdl1.2debian-pulseaudio

3. Remove “libflashsupport” (if present):

$ sudo apt-get remove --purge libflashsupport flashplugin-nonfree-extrasound

4. Run the mixer and set the defaults:

$ pulseaudio && pavucontrol

5. Reboot
Активен

http://webchat.freenode.net/?channels=ubuntu-bg
The quieter you become, the more you are able to hear.
Две седмици цъкане с мишката спестяват два часа четене на документацията.

elfenlied

  • Участник
  • *****
  • Публикации: 205
  • Distribution: Sabayon 5.3
  • Window Manager: Gnome 2.30.2
    • Профил
Re: PulseAudio
« Отговор #4 -: Май 04, 2010, 23:23 »
Интересно:
cp: cannot stat `/home/rpg/.asound*': No such file or directory
cp: cannot stat `/etc/asound.conf': No such file or directory
Все пак ще продължа напред :)
edit:

rpg@Peter ~/Desktop $ pulseaudio && pavucontrol
E: module-protocol-stub.c: Failed to create socket directory '/tmp/.esd/socket': Permission denied
E: module.c: Failed to load  module "module-esound-protocol-unix" (argument: ""): initialization failed.
E: main.c: Module load failed.
E: main.c: Failed to initialize daemon.
Само от слушалките има звук :(
« Последна редакция: Май 04, 2010, 23:33 от elfenlied »
Активен

PC Cases: DELL 400W. Pentium IV, CPU speeds: 1700 MHz, MMX, SSE, SSE2,  FSB speeds: 400 MHz, x86. RAM MEMORY: RDRAM 2x256MB,  400Mhz. SVGA: NVidia TNT2 Memory: 32MB.
HDD: 40GB, 7400 RPM.
Motherboard Dell Dimension 8200

ivanatora

  • Участник
  • *****
  • Публикации: 658
  • Distribution: Ubuntu 10.04
  • Window Manager: Fluxbox
    • Профил
    • WWW
Re: PulseAudio
« Отговор #5 -: Май 05, 2010, 08:45 »
Същия проблем го имам и аз. В миксерите всичко е увеличено на максимум и unmute. Съществува следния workaround: alsamixergui. Не знам какво й е различното от нормалния alsamixer, но там ясно си показва че главния канал е mute и намален до минимум. Мискера с gui-я показва реалните стойности, а всички останали миксери... не.
Това е така на две десктоп и на лаптоп машини. На лаптопа махнах пакета pulseaudio и от тогава насам не съм имал проблеми. Всъщност и доста други проблеми със звука се оправиха с премахването на pulseaudio, примерно накъсването на звука в wine.
Активен

elfenlied

  • Участник
  • *****
  • Публикации: 205
  • Distribution: Sabayon 5.3
  • Window Manager: Gnome 2.30.2
    • Профил
Re: PulseAudio
« Отговор #6 -: Май 05, 2010, 10:41 »
Същия проблем го имам и аз. В миксерите всичко е увеличено на максимум и unmute. Съществува следния workaround: alsamixergui. Не знам какво й е различното от нормалния alsamixer, но там ясно си показва че главния канал е mute и намален до минимум. Мискера с gui-я показва реалните стойности, а всички останали миксери... не.
Това е така на две десктоп и на лаптоп машини. На лаптопа махнах пакета pulseaudio и от тогава насам не съм имал проблеми. Всъщност и доста други проблеми със звука се оправиха с премахването на pulseaudio, примерно накъсването на звука в wine.
Сега слагам alsamixergui. Ако почна премахване на pulseaudio се налага да махна много мапкети:
Едит:
Всичко се нареди :) Просто Mute и после unmute всичко под ред. Pulseaudio продължава да се прекацква при смяна :(
« Последна редакция: Май 05, 2010, 14:11 от elfenlied »
Активен

PC Cases: DELL 400W. Pentium IV, CPU speeds: 1700 MHz, MMX, SSE, SSE2,  FSB speeds: 400 MHz, x86. RAM MEMORY: RDRAM 2x256MB,  400Mhz. SVGA: NVidia TNT2 Memory: 32MB.
HDD: 40GB, 7400 RPM.
Motherboard Dell Dimension 8200

Подобни теми
Заглавие Започната от Отговора Прегледи Последна публикация
Ubuntu hardy и pulseaudio
Настройка на програми
Whisper 1 1955 Последна публикация Сеп 16, 2008, 17:43
от Hapkoc
Pulseaudio ?!?
Настройка на програми
Oxy 2 2406 Последна публикация Фев 08, 2009, 22:44
от BULFON
Опит с Slackware и Pulseaudio
Настройка на хардуер
Ivshti 0 1326 Последна публикация Юни 21, 2009, 18:40
от Ivshti
Slackware64 13.1 как да подкарам pulseaudio.
Настройка на програми
bazu 3 2649 Последна публикация Мар 01, 2011, 17:27
от bazu
Аплет за звука в панела на Ubuntu 10.04 след премахване на pulseaudio.
Настройка на програми
cybercop 16 8180 Последна публикация Юли 10, 2011, 18:03
от satir