Автор Тема: Хардуерно ускорение за декодиране на видео с ATI видеокарта.  (Прочетена 1925 пъти)

tolostoi

  • Участник
  • *****
  • Публикации: 1335
  • Distribution: Ubuntu
  • Window Manager: Unity
  • левел: авераж :)
    • Профил
Видях преди малко, че вече имало работещо ускорение за новите карти на ati (Radeon HD xxxx) не съм чел подробности, някой да сподели.
Според текста в този линк

Цитат
Lucid and Maverick already have everything you need. Furthermore, Maverick has va-api integrated into VLC. When you install VLC, it will pull in everything you want except vdpau-va-driver (for nvidia chips) or i965-va-driver (for Intel gma4500 or newer chips) -- install them manually. If you have a newer ATI/AMD chip (Radeon HD xxxx) you can go here to install the xvba-video package for your arch:
http://www.splitted-desktop.com/~gbeauchesne/xvba-video/
Note: you have to be using the fglrx graphics driver we all love so much for this to work, and even then there's no guarantee.
So, Maverick has to be one of the first Linux distros that includes support for hardware-accelerated video decoding on almost any graphics chip made in the past couple of years. How freakin' cool is that?
Би трябвало да работи ако имате:
Последните излезли драйвери fglrx
Да сте инсталирали пакета xvba-video http://www.splitted-desktop.com/~gbeauchesne/xvba-video/
Да сте инсталирали последната версия на vlc плеъра (тази която е в Ubuntu 10.10, предполагам и по-нова става, аз съм с 1.1.5 но съм с 10.4, ползвам ppa) трябва да му се зададе за видеоизход xvba (предполагам, при мен го няма, но аз не съм с Убунту 10.10, версията на плеъра ми е друга и съм с nvidia) прилагам снимка за опцията.

Хайде някой с ати да пробва и да каже дали работи, понеже съм се наслушал на обещания  :D
Активен


... в Столичен инспекторат една година след миграцията, продължават да работят под Linux. Което, май прави "експеримента" успешен
by entusiast

gat3way

  • Участник
  • *****
  • Публикации: 5420
  • Relentless troll
    • Профил
    • WWW
Имам Radeon HD4670 и HD6870. За vlc не знам, но съм си играл с opensource-ския flash player (gnash ли кво беше там). Той подържа xvba и _би_ трябвало youtube филмчетата да вървят по-мазно. На практика обаче на full screen нещата са по-зле, отколкото с adobe-ския плеър, който не ползва тези благини.

Има три варианта: или gnash не е написан като хората, или 4670-цата не струва, или съм тествал с някакъв калпав Catalyst (по това време ползвах 10.7 май) и истината според мен е някъде по средата.

С 6870-цата предполагам ще е _значително_ по-добре, проблемът е че линукс подръжка като хората ще има в средата на декември. Засега нещата са много зле - колкото да се показва нещо, дори aticonfig реве че не може да разпознае ATI хардуер на системата :)

Ммм само че не мисля да вадя 6870-цата и да слагам старата боза, за да тествам vlc.

П.П mplayer мислят ли да го подържат скоро?
Активен

64 KB ought to be enough for anybody" - Bill "Heartbleed" Gates

nigl

  • Участник
  • *****
  • Публикации: 49
  • Distribution: Debian
  • Window Manager: Gnome
    • Профил
10.7 версията е скапана, затова да не се е получило. По-добре с 10.8- имам добри впечатления от нея.Бих пробвал това, ама нямам време и нерви. Може по-нататък
Активен

n00b

  • Участник
  • *****
  • Публикации: 1144
  • Distribution: OSX
  • Window Manager: 10.6, 10.8, 10.9
  • Live to hack, hack to live.
    • Профил
ATI имат проблем с изпреварващ хардуер и драйвери дето се чакат по няколко месеца от има-няма 20 години.

Чудно ми е как има още вързали се на партенките им...
Активен

mobilio - професионални мобилни приложения

gat3way

  • Участник
  • *****
  • Публикации: 5420
  • Relentless troll
    • Профил
    • WWW
Има, понеже хардуерът е наистина изпреварващ в сравнение с аналозите на nvidia - взимайки хардуерни възможности и цената като параметри. За времето, за което се очаква заветния драйвер, това няма да се промени (въпреки че по първоначални сметки трябваше вече да е излязъл :) ). Също така (за това за което аз я ползвам поне) nvidia ужасно много си осраха драйверите, по същият начин по който ATI го направиха в първите месеци на тая година и сега берат същите .....

Но по принцип да де, АТИ са малко..."ей, имаме мнооооого яка карта на голяма далавера!" - "взех я, ами драйвери?" - "ами драйвери утре" - "нали казахте че ще има драйвери днес?" - "не, казах УТРЕ"
Активен

64 KB ought to be enough for anybody" - Bill "Heartbleed" Gates

n00b

  • Участник
  • *****
  • Публикации: 1144
  • Distribution: OSX
  • Window Manager: 10.6, 10.8, 10.9
  • Live to hack, hack to live.
    • Профил
//off

Аз затова обичам nVidia обаче нямам от новите модели GF 1,2,3,4,5, etc
Активен

mobilio - професионални мобилни приложения

b2l

  • Участник
  • *****
  • Публикации: 4786
  • Distribution: MCC Interim
  • Window Manager: - // - // -
  • ...sometimes I feel like screaming... || RTFM!
    • Профил
    • WWW
@gat3way - във форума на ATI какво казват? Май там пишеше, че драйвъра е излязъл вече или се бъркам?
Активен

"Човекът е въже, опънато между звяра и свръхчовека, въже над пропаст. Човекът е нещо, което трябва да бъде превъзмогнато." - Фр. Ницше

n00b

  • Участник
  • *****
  • Публикации: 1144
  • Distribution: OSX
  • Window Manager: 10.6, 10.8, 10.9
  • Live to hack, hack to live.
    • Профил
//off

Абе тук има един югенд ROKO__ който ще ти помогне с най-голямо удоволствие... ама нещо не го виждам наскоро...
Активен

mobilio - професионални мобилни приложения

gat3way

  • Участник
  • *****
  • Публикации: 5420
  • Relentless troll
    • Профил
    • WWW
Мне, 10.11 дори не подържат barts и върху уиндоус. Засега единствено един хотфикс за 10.10 го подържа, но само за уиндоус. Тъпото е че при представянето на 6850/6870 са раздавали работещ линукс драйвер, но са ги карали да подписват NDA и сега този драйвер го няма никъде. А що се отнася до простотиите, които правят с драйверите, Stream SDK-то и подръжката на тази серия, мога да кажа много неща, повечето псувни.
Активен

64 KB ought to be enough for anybody" - Bill "Heartbleed" Gates

tolostoi

  • Участник
  • *****
  • Публикации: 1335
  • Distribution: Ubuntu
  • Window Manager: Unity
  • левел: авераж :)
    • Профил
Хайде де, никой ли не пробва, пише, че работи а всеки го мързи да инсталира няколко деб-а, дори няма компилиране   :o ако имах ати до сега да съм тествал всички варианти.
Активен


... в Столичен инспекторат една година след миграцията, продължават да работят под Linux. Което, май прави "експеримента" успешен
by entusiast

gat3way

  • Участник
  • *****
  • Публикации: 5420
  • Relentless troll
    • Профил
    • WWW
Току-що пробвах. Не стана - checkbox-а за GPU-ускорено декодване на видеото не е активен. Не знам дали причината е с подръжката на картата, защото четох да се споменава и втора теза - че ffmpeg не е билднат с va подръжка. Да прекомпилирам софтуер обаче не ми се занимава.
Активен

64 KB ought to be enough for anybody" - Bill "Heartbleed" Gates

ROKO__

  • Участник
  • *****
  • Публикации: 1531
  • Distribution: Calculate Linux Workstation amd64
  • Window Manager: GNOME 2.30
  • AMD Athlon64 4000+ Dual Core 2100 MHz 2MB L2 cache
    • Профил
Току-що пробвах. Не стана - checkbox-а за GPU-ускорено декодване на видеото не е активен. Не знам дали причината е с подръжката на картата, защото четох да се споменава и втора теза - че ffmpeg не е билднат с va подръжка. Да прекомпилирам софтуер обаче не ми се занимава.

/off n00b не виждам смисъл да пиша във форум където само ме банват за щяло и нещяло

gat3way

Правих наскоро тестове на една чужда машина разполагаща с Radeon HD5850 като крайните и най добри резултати постигнах с:

Gentoo
Sabayon
ArchLinux
Slackware
Calculate
Agilia
Mandriva

Но от цялата поредица тук ArchLinux са най напред с писането на фиксове и съвсем разбираемо с ArchLinux вървеше най добре (Смятам че и с Gentoo може но може би съм пропуснал нещо)
Активен

Не е важно да си добър, важно е да си най добрия!!!

http://www.calculate-linux.ru/
http://www.agilialinux.ru/