Автор Тема: [decision] intel video / kubuntu 10.10 not enable desktop effects after restart.  (Прочетена 1672 пъти)

c111100101

  • Гост
След два месеца опити най-после намерих решение на проблема.
Проблема се наблюдава при интелско вградено видео чипсет G41 и KDE версии 4.5.1, 4.5.2, 4.5.3
На чиста инсталация при опит за пускане на ефектите или не се стартират или се стартират но след рестарт отново ги няма. Решението е на система Kubuntu 10.10 с пълни ъпдейти включително и предварително издадените и инсталирано KDE 4.5.3.
Проблема се оправя с редактиране на два файла.

Единия е:
//home/user/.kde/share/config/kwinrc
Променяме DisableChecks=false на ---> DisableChecks=true


Втория е:
/etc/profile
Добавяме най-отдолу след последното fi и преди umask 022 следният ред ---> export LIBGL_ALWAYS_INDIRECT=1


Рестартирате системата и би трябвало всичко вече да работи.
Успех!  :)
Активен

vyrgozunqk

  • Гост
това според мен не е добър вариант, аз интелската карта на лаптопа също трябва дa disable-вам проверките, но примерно блур ефекта ми прави проблеми и т.н.
А опцията за always indirect не е добра идея, защото цялото рендиране пада в/у професора и товари излишно, особено на тези които не са с quad core  :P
Най-добрият вариант засега май си остава да ги изключим и да чакаме да оправят скапаните интелски драйвери...

Мамка му, та аз още кретам с поддръжка само на OpenGL 1.4 на интел 3150 ... Това ме връща 7 години назад във времето... не е нормално :/
« Последна редакция: Ное 10, 2010, 22:48 от vyrgozunqk »
Активен

c111100101

  • Гост
В предварителните ъпдейти имаше нова версия на интелските драйвери. Аз лично в този вариант на решение не съм забелязал дефекти във визуализирането на ефектите.
Процесора ми е двуядрен и натоварването само с пуснати стандартните системни услуги и firefox варира между 3 и 5 процента.
Между другото сега пробвах и ефектите ми работят и с DisableChecks=false а вграденото видео по принцип винаги товари процесора, няма как да се разминеш с това.
« Последна редакция: Ное 11, 2010, 07:30 от c111100101 »
Активен

c111100101

  • Гост
Някой знае ли при включена тази опция export LIBGL_ALWAYS_INDIRECT=1 има ли значение дали опцията Enable direct rendering за OpenGL в настройките е включена или не.
Аз не забелязах някакви промени с включена и изключена тази опция.
Активен

vyrgozunqk

  • Гост
Не, не би трябвало да има...
А относно вградените карти, в моя случай товара е точно толкова колкото и от дискретното ати на настолния комп....  ::)
Активен

c111100101

  • Гост
Проблема с интелското видео видео вече е решен. На Убунту 10.10 със всички ъпдейти включително и предварителните, както и последното kde 4.6 rc 1 вече не забелязвам никакви проблеми с видеото.
Последната версия на кде има два дребни бъга, които не влияят като цяло на работата на системата. Надявам се с новия RC2 на 5-ти януари проблемите да бъдат изчистени. :)
Активен

cybercop

  • Участник
  • *****
  • Публикации: 5559
  • Distribution: Ubuntu LTS, CENTOS 6.x
  • Window Manager: Xfce, Gnome 2
    • Профил
Точно такива проблеми ми правеше Кубунту 10.10. След рестарт все едно, че нямаше ефекти. Но не бяха само тези проблемите. Ако не бях ъпгрейдвал, още да съм с Кубунту 10.04, но от 10.10 се отвратих и сложих гном.
Активен

Ползването на Linux води до пристрастяване. Факт.
http://s19.postimg.cc/4oajwoq5v/xenial2.png

Подобни теми
Заглавие Започната от Отговора Прегледи Последна публикация
Проблем с desktop-a при kubuntu
Настройка на хардуер
Zbelsrud 2 1342 Последна публикация Окт 17, 2006, 23:47
от Zbelsrud
Desktop effects
Настройка на програми
cRu3l_3v1l 10 2353 Последна публикация Сеп 24, 2007, 11:16
от tolostoi
Desktop effects could not be enabled
Настройка на програми
allusion 4 1662 Последна публикация Юни 24, 2008, 21:30
от angeldimitroff
Продавам Ubuntu Desktop 9.04:Kubuntu Desktop 9.04:Ubuntu Server 9.04 x64
Кошче
anakinchoo 34 14371 Последна публикация Юни 04, 2010, 16:32
от ROKO__
webgl and intel video
Настройка на програми
tyuio 5 1157 Последна публикация Юли 15, 2010, 10:41
от tyuio