Автор Тема: Debian Jessie и кернел 4.8.0-0.bpo.2-amd64  (Прочетена 2517 пъти)

qmxnmz

  • Участник
  • *****
  • Публикации: 14
    • Профил
Debian Jessie и кернел 4.8.0-0.bpo.2-amd64
« -: Яну 06, 2017, 23:00 »
Здрасти, наскоро инсталирах кернел 4.8.0-0.bpo.2-amd64 на Acer Aspire V3 772G, i7-4702MQ 2.2GHz с Nvidia Geforce GTX 760M и интегрирана видокарта на Интел 4-то поколение. Имам проблем не само с липсващ firmware но и с дисплея, когато стигна до логин скрийна и екрана ми започва да премигва, затъмнява и след това пак изсветлява и така постоянно даже и в команден ред без графична среда, просто самия екран побелява става на пиксели и като почна да натискам спейса например и изведнъж се оправя.

Липсващия firmware, който не мога да намеря

Цитат
W: Possible missing firmware /lib/firmware/i915/kbl_guc_ver9_14.bin for module i915
W: Possible missing firmware /lib/firmware/i915/bxt_guc_ver8_7.bin for module i915
W: Possible missing firmware /lib/firmware/i915/skl_guc_ver6_1.bin for module i915





Активен

mystical

  • Участник
  • *****
  • Публикации: 307
  • Distribution: Debian, FreeBSD
  • Window Manager: XFCE
    • Профил
    • WWW
Re: Debian Jessie и кернел 4.8.0-0.bpo.2-amd64
« Отговор #1 -: Яну 07, 2017, 09:25 »
https://tracker.debian.org/pkg/linux

Погледни колко бързо сменят линукс ядрото в различните версии с изключение на стабилна. Почти винаги когато съм правил подобни промени, дебиан се омазва и го преинсталирам. Няма начин нещо да не се омаже, понеже всичко е компилирано с хедерите на ядро 3.16
Ако си решил да използваш Debian, стоиш само на стабилен, без внасяне на външни пакети, използвай пакетите на съответния стабилен релийз.
Активен

Ако не можеш да градиш, поне не руши!

cybercop

  • Участник
  • *****
  • Публикации: 5296
  • Distribution: Ubuntu LTS, CENTOS 6.x
  • Window Manager: Xfce, Gnome 2
    • Профил
Re: Debian Jessie и кернел 4.8.0-0.bpo.2-amd64
« Отговор #2 -: Яну 07, 2017, 09:41 »
Ядрата от backports-main хранилището са си много добри и не ми се е случвало да правят проблеми. Стига да ги е инсталирал коректно (linux-headers + linux-image). Драйвъра за видеото, трябва да е инсталиран - xserver-xorg-video-intel.
Ако става въпрос за карта на нов интелски процесор - смяната на ядрото не е достатъчна. Драйвъра за видеото също трябва да се обнови. В такъв случай е по- добре да се ползва направо тестовата версия на Stretch. Освен един набиващ се на очи дефект с LightDM, тя е в готов за работа вид.

Извън темата : Някой забелязал ли е, как лекичко, програмите почват да мигрират към usr директорията. Мислях, че ще стане чак в десета версия, но, вчера погледнах, откъде стартира лисицата и доста се изненадах.
http://s19.postimg.org/551x54w37/usr_lib.png
« Последна редакция: Яну 07, 2017, 09:52 от cybercop »
Активен

Ползването на Linux води до пристрастяване. Факт.
http://s19.postimg.org/4oajwoq5v/xenial2.png

cybercop

  • Участник
  • *****
  • Публикации: 5296
  • Distribution: Ubuntu LTS, CENTOS 6.x
  • Window Manager: Xfce, Gnome 2
    • Профил
Re: Debian Jessie и кернел 4.8.0-0.bpo.2-amd64
« Отговор #3 -: Яну 07, 2017, 10:00 »
Здрасти, наскоро инсталирах кернел 4.8.0-0.bpo.2-amd64 на Acer Aspire V3 772G, i7-4702MQ 2.2GHz с Nvidia Geforce GTX 760M и интегрирана видокарта на Интел 4-то поколение. Имам проблем не само с липсващ firmware но и с дисплея, когато стигна до логин скрийна и екрана ми започва да премигва, затъмнява и след това пак изсветлява и така постоянно даже и в команден ред без графична среда, просто самия екран побелява става на пиксели и като почна да натискам спейса например и изведнъж се оправя.

Липсващия firmware, който не мога да намеря

Цитат
W: Possible missing firmware /lib/firmware/i915/kbl_guc_ver9_14.bin for module i915
W: Possible missing firmware /lib/firmware/i915/bxt_guc_ver8_7.bin for module i915
W: Possible missing firmware /lib/firmware/i915/skl_guc_ver6_1.bin for module i915
Направо, инсталирай седмично издание на Stretch. След инсталацията, добави хранилища (от опит с Jessie си видял, че идва без конфигуриран за работа списък) и linux-headers за ядрото, което ти е инсталирано. Примерно - linux-headers-amd64.
Активен

Ползването на Linux води до пристрастяване. Факт.
http://s19.postimg.org/4oajwoq5v/xenial2.png

qmxnmz

  • Участник
  • *****
  • Публикации: 14
    • Профил
Re: Debian Jessie и кернел 4.8.0-0.bpo.2-amd64
« Отговор #4 -: Яну 07, 2017, 17:32 »
https://tracker.debian.org/pkg/linux

Погледни колко бързо сменят линукс ядрото в различните версии с изключение на стабилна. Почти винаги когато съм правил подобни промени, дебиан се омазва и го преинсталирам. Няма начин нещо да не се омаже, понеже всичко е компилирано с хедерите на ядро 3.16
Ако си решил да използваш Debian, стоиш само на стабилен, без внасяне на външни пакети, използвай пакетите на съответния стабилен релийз.

Не винаги, инсталирал съм и други ядра от бакпортс от 4.0 до 4.5 и до сега не съм имал сериозни проблеми.Тази мизерия с видеокартите ми започна от 4.5 където просто изтрих драйвера за нвидиата и си ползвах само вградената интелка, която си беше напълно достатъчна за леките анимацийки на гнома.

Цитат
Драйвъра за видеото, трябва да е инсталиран - xserver-xorg-video-intel.

Докато инсталирах новото ядро ми изкочи предупреждение, че има конфликт между драйверите съответно изтрих предишните и ми остана само грешката за липсващия firmware.Драйверите си идват заредени в ядрото, явно докато съм махал драйвера съм завлякал и съответните бинарки от по-старото ядро.Този firmware си идва с допълнителни пакети от бакпортс, като firmware-misc-nonfree и firmware-linux-nonfree.Тези бинарки, които търся са от пакета firmware-misc-nonfree но не са включени в него на сайта на интел имаше само един, който ми пасна.Мисля, че ще се оправи, ако ги имам всичките, интересното е че и двете видеокарти са разпознати само интелката неработи както трябва.Докато бях със Stretch там положението беше още по-трагично с драйвера за нвидиата там пък екрана ми изгасяше и изобщо не се включваше и процесора вдигаше много висока температура, лаптопа ми беше като духалка затова преминах на стейбъл и реших да си ъпгрейдна софтуера малко.




Активен

cybercop

  • Участник
  • *****
  • Публикации: 5296
  • Distribution: Ubuntu LTS, CENTOS 6.x
  • Window Manager: Xfce, Gnome 2
    • Профил
Re: Debian Jessie и кернел 4.8.0-0.bpo.2-amd64
« Отговор #5 -: Яну 07, 2017, 18:55 »
Драйверите си идват заредени в ядрото, явно докато съм махал драйвера съм завлякал и съответните бинарки от по-старото ядро.
Какво означава това ? Откъде идват ?
Активен

Ползването на Linux води до пристрастяване. Факт.
http://s19.postimg.org/4oajwoq5v/xenial2.png

jet

  • Участник
  • *****
  • Публикации: 1146
  • Distribution: debian sid
  • Window Manager: kde
    • Профил
Re: Debian Jessie и кернел 4.8.0-0.bpo.2-amd64
« Отговор #6 -: Яну 07, 2017, 18:58 »

Извън темата : Някой забелязал ли е, как лекичко, програмите почват да мигрират към usr директорията. Мислях, че ще стане чак в десета версия, но, вчера погледнах, откъде стартира лисицата и доста се изненадах.
http://s19.postimg.org/551x54w37/usr_lib.png
Дай един: which firefox
Активен

Linux: From WTF to OMG

cybercop

  • Участник
  • *****
  • Публикации: 5296
  • Distribution: Ubuntu LTS, CENTOS 6.x
  • Window Manager: Xfce, Gnome 2
    • Профил
Re: Debian Jessie и кернел 4.8.0-0.bpo.2-amd64
« Отговор #7 -: Яну 07, 2017, 19:39 »
master@master-laptop:~$ which firefox
/usr/bin/firefox
master@master-laptop:~$

Но, там е само пряк път : http://s19.postimg.org/3tyraepv7/firefox1.png
Това е източника : http://s19.postimg.org/bb7ypmfeb/firefox2.png
« Последна редакция: Яну 07, 2017, 19:42 от cybercop »
Активен

Ползването на Linux води до пристрастяване. Факт.
http://s19.postimg.org/4oajwoq5v/xenial2.png

jet

  • Участник
  • *****
  • Публикации: 1146
  • Distribution: debian sid
  • Window Manager: kde
    • Профил
Re: Debian Jessie и кернел 4.8.0-0.bpo.2-amd64
« Отговор #8 -: Яну 07, 2017, 19:59 »
Те повечето GUI програми винаги са си били в /usr.
Активен

Linux: From WTF to OMG

qmxnmz

  • Участник
  • *****
  • Публикации: 14
    • Профил
Re: Debian Jessie и кернел 4.8.0-0.bpo.2-amd64
« Отговор #9 -: Яну 07, 2017, 20:07 »
Драйверите си идват заредени в ядрото, явно докато съм махал драйвера съм завлякал и съответните бинарки от по-старото ядро.
Какво означава това ? Откъде идват ?

Това означава, че модула е зареден, в случая i915 на който му липсва само firmware. Ето и кратка дискусия относно това https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=800835
Активен

cybercop

  • Участник
  • *****
  • Публикации: 5296
  • Distribution: Ubuntu LTS, CENTOS 6.x
  • Window Manager: Xfce, Gnome 2
    • Профил
Re: Debian Jessie и кернел 4.8.0-0.bpo.2-amd64
« Отговор #10 -: Яну 07, 2017, 20:11 »
Както и в голяма част от останалите директории. Но, четох, че новата тенденция, която са възприели е, приложенията да са концентрирани само в usr директорията.
Активен

Ползването на Linux води до пристрастяване. Факт.
http://s19.postimg.org/4oajwoq5v/xenial2.png

cybercop

  • Участник
  • *****
  • Публикации: 5296
  • Distribution: Ubuntu LTS, CENTOS 6.x
  • Window Manager: Xfce, Gnome 2
    • Профил
Re: Debian Jessie и кернел 4.8.0-0.bpo.2-amd64
« Отговор #11 -: Яну 07, 2017, 20:18 »
Това означава, че модула е зареден, в случая i915 на който му липсва само firmware. Ето и кратка дискусия относно това https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=800835
Модула се поддържа от firmware-misc-nonfree. Комплектът е наличен в хранилищата на Stretch.
https://packages.debian.org/stretch/firmware-misc-nonfree
Опитай да инсталираш пакет с gdebi. Инсталация с dpkg -i, няма да ти покаже предварително, дали имаш неудовлетворени зависимости.
Активен

Ползването на Linux води до пристрастяване. Факт.
http://s19.postimg.org/4oajwoq5v/xenial2.png

qmxnmz

  • Участник
  • *****
  • Публикации: 14
    • Профил
Re: Debian Jessie и кернел 4.8.0-0.bpo.2-amd64
« Отговор #12 -: Яну 07, 2017, 20:37 »
Това означава, че модула е зареден, в случая i915 на който му липсва само firmware. Ето и кратка дискусия относно това https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=800835
Модула се поддържа от firmware-misc-nonfree. Комплектът е наличен в хранилищата на Stretch.
https://packages.debian.org/stretch/firmware-misc-nonfree
Опитай да инсталираш пакет с gdebi. Инсталация с dpkg -i, няма да ти покаже предварително, дали имаш неудовлетворени зависимости.

Именно firmware-misc-nonfree инсталирал съм го от бакпортс, но просто несработва!? За Stretch ги има, но не и за стейбъл, а stretch не ми върви да не говорим и за постоянните промени на кернела.Трябва ми нещо стабилно с по-нов софтуер.
Активен

cybercop

  • Участник
  • *****
  • Публикации: 5296
  • Distribution: Ubuntu LTS, CENTOS 6.x
  • Window Manager: Xfce, Gnome 2
    • Профил
Re: Debian Jessie и кернел 4.8.0-0.bpo.2-amd64
« Отговор #13 -: Яну 07, 2017, 21:04 »
Нещо, като Ubuntu 16.04 LTS, предполагам.
В Stretch ще се изредят още няколко ядра, докато замразят версията. Надявам се да изберат 4.9 LTS, но, последните години съм се надявал на много неща, които не са си мръднали пръста да оправят или е ставало по- зле.
« Последна редакция: Яну 07, 2017, 21:11 от cybercop »
Активен

Ползването на Linux води до пристрастяване. Факт.
http://s19.postimg.org/4oajwoq5v/xenial2.png

qmxnmz

  • Участник
  • *****
  • Публикации: 14
    • Профил
Re: Debian Jessie и кернел 4.8.0-0.bpo.2-amd64
« Отговор #14 -: Яну 07, 2017, 21:12 »
Нещо, като Ubuntu 16.04, предполагам.
В Stretch ще се изредят още няколко ядра, докато замразят версията. Надявам се да изберат 4.9 LTS, но, последните години съм се надявал на много неща, които не са си мръднали пръста да оправят или е ставало по- зле.
Да ама до релийза на Stretch ще отнеме още почти 2 години  незнам защо Jessie са го оставили с 3.16 затова искам да го ъпдейтна до нещо по-новичко.
Активен