Автор Тема: Как да заредя тестови Дебиян (systemd) в чист текстов режим  (Прочетена 1298 пъти)

remotexx

  • Участник
  • *****
  • Публикации: 363
    • Профил
При последното обновяване на тестовия ми Дебиян нещо се прецака видео драйвъра. Проблема е че се прецаква още по средата на зареждането т.е. преди да стигне до Х, точно там където превключва от чист текст на гадните конзолни видео режими (само и само да ми събере по 130 символа на ред - не че съм го искал, така е по подразбиране). Друг проблем е че вече добаване на опции към ядрото 1, single  и т.н. не важат - Дебиянци решили че всички режими от 2 до 5 ще са графични и винаги ми зависва на черен екран.
Та въпросът ми е - как със systemd и само с опции на ядрото/гръб при зареждане да вляза в чист текстови режим ..е или в rescue mode (щото даже и той ми зависва)
само стандартния текстови режим ми работи т.е. VGA всичко останало VESA  и нагоре се прецаква - включтелно и safe/rescue mode
..не изключвам и systemd да се е омазал нещо при обновяването (а не видео драйвера)

та при сегашното положение (systemd и всички др. екстри) как се стига до чист текстов логин та да почна отнякъде да търся какво аджеба се е прецакало?
« Последна редакция: Сеп 09, 2017, 22:31 от remotexx »
Активен

Stancho_25

  • Участник
  • *****
  • Публикации: 216
    • Профил
Пробвал ли си да добавиш "nomodeset" параметър при началното зареждане?
Активен

remotexx

  • Участник
  • *****
  • Публикации: 363
    • Профил
Благодаря, това nomodeset спаси положението.
Сега някой може ли да ми каже как се преинсталира Х целия под дебиян,че си нямам на идея какво друго се е омазало, бях го оставил да инсталира и то заключило екрана и после имаше два процеса и аз убих единия логин и се оправи... до първия рестарт. Можеха барем едно предупреждение да сложат че се обновява работещ Х/КДЕ , че все го забравям тоя  бръснарски момент. напр. Федората ме е предупреждвала когато се опитах, по погрешка, да преинсталирам работещо ядро.
« Последна редакция: Сеп 09, 2017, 22:32 от remotexx »
Активен

deant01

  • Участник
  • *****
  • Публикации: 179
  • Distribution: Debian/sid
  • Window Manager: Gnome 3
    • Профил
първо бих се спрял на gdm  ако си с него. смени го а lightdm или някое друго.
не би следвало да махаш Х и да го слагаш пак. пробва да го преконфигурираш -

 dpkg-reconfigure -phigh xserver-xorg


и още нещо, по някое време дебиян сложиха wayland по подразбиране, виж да не ми да се мъчи да влезе с него а картата ти да не го поддържа.
Активен

Ripples of paradox spread out across the sea of causality.

remotexx

  • Участник
  • *****
  • Публикации: 363
    • Профил
Благодаря за съветите - мисля че съм с lightdm, сега ще пробвам само с прекофигуриране...

Значи интересна ситуация се получи само с nomodeset не тръгва, като добавя single също не тръгва и чак като добавих 1 едва тогава зацепи и то само в текстов режим и по-интересното е че и VESA режима тръгна (по много /повече от 80/ символа на ред), иначе забиваше точно на него т.е. още много преди Х но то като знае че няма да е чист текст /ниво 1/ тоя режим (ВЕСАта) не го ли подкарва през Х?

то може и да не е до драйвер - някой знае ли какво подкарва тия конзолните графчини режими  -същия драйвър ли е - в моя случай Радеон...

остава и другия вариант systemd да се е омазал нещо, но интересното е че няма счупени пакети - сега ще ровна целия лог на последното обновяване и после Х, после ако няма нищо... ще гелдам къде да търся
« Последна редакция: Сеп 09, 2017, 22:33 от remotexx »
Активен

remotexx

  • Участник
  • *****
  • Публикации: 363
    • Профил
Благодаря много на всички
за протокола
- тръгна само след добавяне на: 1 single nomodeset
- ВЕСА режима тръгна също от конзола
- после вместо паролата му давам Ctrl+D да продължи нормално
- зарежда логин мениджъра
- зарежда и КДЕ и всичко си работи

пуснах пак Синаптика - няма счупени, обаче обнови и намери нови пакети та обнових и тях - аз съм егати каръка от половин г. не съм обновявал и мисля закачих само половината пакети от последния ъпдейт т.е. баш като са качвали още пакети съм обновил и съм пропуснал последните /но не се оплака за счупени зависимости де/ и естествено systemd беше обновен отново втория път

сега рестартирам - стискайте палци, ако не се оправи пак ще пиша, но поне знам как да заредя Х/КДЕ и борбата ще е по-лесна

- предполагам systemd се е омотал нещо защото като пуснах Х на ръка веднъж и се оправи (явно презаписа някои конфиг файлове)... дано ги е оправил за постоянно, ч еинае не знам systemd как ще боря

П.П. Оправи се след рестарта (и до-обновявнето) и сега си работи явно при пускане на ръка си (п)оправя конфигурационните файлове а през systemd не т.е. той си го пуска с едни и същи (кой знае къде набити) опции и ако не тръгне това си е наш проблем а не техен  :P

..остава и варианта да е и хардуерен проблем т.е. след рестарта наблюдавам някой артефакти напр. анимиран gif (imdb.com - засега само на тяхното лого), но те "звездичките" може да са и от драйвера, гледам lm-sensors показват 60 градуса на видеокартата, но не съм запомнил преди какво е показвало, нормално ли е 60 градуса за карта без вентилатор?
Caicos [Radeon HD 6450/7450/8450 / R5 230 OEM] [1002:6779]
« Последна редакция: Сеп 09, 2017, 21:55 от remotexx »
Активен

deant01

  • Участник
  • *****
  • Публикации: 179
  • Distribution: Debian/sid
  • Window Manager: Gnome 3
    • Профил
Благодаря много на всички
за протокола
- тръгна само след добавяне на: 1 single nomodeset
- ВЕСА режима тръгна също от конзола
- после вместо паролата му давам Ctrl+D да продължи нормално
- зарежда логин мениджъра
- зарежда и КДЕ и всичко си работи

пуснах пак Синаптика - няма счупени, обаче обнови и намери нови пакети та обнових и тях - аз съм егати каръка от половин г. не съм обновявал и мисля закачих само половината пакети от последния ъпдейт т.е. баш като са качвали още пакети съм обновил и съм пропуснал последните /но не се оплака за счупени зависимости де/ и естествено systemd беше обновен отново втория път

сега рестартирам - стискайте палци, ако не се оправи пак ще пиша, но поне знам как да заредя Х/КДЕ и борбата ще е по-лесна

- предполагам systemd се е омотал нещо защото като пуснах Х на ръка веднъж и се оправи (явно презаписа някои конфиг файлове)... дано ги е оправил за постоянно, ч еинае не знам systemd как ще боря
дебиан най-добре го ъпдейтвай сутрин около 07.00 ч
Активен

Ripples of paradox spread out across the sea of causality.

remotexx

  • Участник
  • *****
  • Публикации: 363
    • Профил
Е аз точно около 7 am го обновявах когато ми се случи ...случката аз съм в UTC+5 а ти коя имаше предвид?

А нормално ли тази видео карта да вдига 60 по целзий (обик. много бързо дига от 40 до 60-61 и цял ден си стои там) - картата е без-вентилаторна (та сега се чудя след голямото обновяване - артефактите дали са софтуерни или хардуерни, вградената му също е АМД и драйвера е същия та не мога да тествам по тоя начин)
Caicos [Radeon HD 6450/7450/8450 / R5 230 OEM] [1002:6779]
« Последна редакция: Сеп 09, 2017, 21:59 от remotexx »
Активен

deant01

  • Участник
  • *****
  • Публикации: 179
  • Distribution: Debian/sid
  • Window Manager: Gnome 3
    • Профил
Е аз точно около 7 am го обновявах когато ми се случи ...случката аз съм в UTC+5 а ти коя имаше предвид?

А нормално ли тази видео карта да вдига 60 по целзий (обик. много бързо дига от 40 до 60-61 и цял ден си стои там) - картата е без-вентилаторна (та сега се чудя след голямото обновяване - артефактите дали са софтуерни или хардуерни, вградената му също е АМД и драйвера е същия та не мога да тествам по тоя начин)
Caicos [Radeon HD 6450/7450/8450 / R5 230 OEM] [1002:6779]
дедукция:
ако артефактите са се появили след обновяването 95% е виновно обновяването.
ако няма вентилатор може и да е нормално да вдига 60ц. не ползвам нищо различно от интел под линукс за да имам наблюдения.
аз съм в България и не знам 7 сутринта наше време при тебе колко часа е. но имах предвид 7 сутринта, което изпуснах да кажа.
Активен

Ripples of paradox spread out across the sea of causality.

remotexx

  • Участник
  • *****
  • Публикации: 363
    • Профил
ами аз съм GMT+5 т.е. спрямо БГ съм +8 или +9 (понякога, докато всички минем на зимно/лятно време) та това обяснява нещата 7-8 AM тука е къде 17:00 или 5 PM - ракиено време и да бутнем днешния билд преди да си тръгнем от работа  ;D

и аз не съм обърнал внимание досега дали 60 ц е нормално за тая карта - интересно че във Хрома няма проблем с ИМДБ логото а само във Файърфокса (и двата им е разрешено - ползване на хардуерно ускорение ако има)

А бе ще я карам тая карта докато ме остави - после за изв. време на вградената (със същия драйвър) докато си намеря нова.
Активен

Naka

  • Участник
  • *****
  • Публикации: 1971
    • Профил
Ами много просто, ако се съмняваш в меренто на температурата просто и пипни радиатора. Ако можеш да си задържиш пръстите не е повече от 60 градуса. Според мен е нормално да се вдига до 60 но не и повече и то само пиково.

А да сега видях че е пасивна... Според мен е нормално

За артефактите. Рестарт, ресет и изключване на захранването не са еднакви работи. Наблюдавал съм артефакти които остават даже и след ресет ако например някоя карта е инициализирана на криво от бъгав драйвер. Ако обаче не изчезват след повер офф това не е хубаво.

Виждал съм и карти така повредени че в техт режим и свега графика всичо им е наред, но като се пусне истинки драйвер показват артефакти. Всичко може да е.

Пусни някой Кнопикс и виж там как е. Но задължително след повер офф!  (за да и се изчистят регистрите )
« Последна редакция: Сеп 09, 2017, 23:17 от Naka »
Активен

Perl - the only language that looks the same before and after encryption.

remotexx

  • Участник
  • *****
  • Публикации: 363
    • Профил
ами и с изключване от контакта пак така - справка прикачения файл.
добрата новина е че само под файърфокс и само но това лого т.е. то май има полу-прозрачен овърлей само за анимацията та само той вероятно (ОпънГЛ). Хрома със същата настройка ("ползвай хардуерно ускорение ако има") си го показва нормално освен единия да детектва че има а другия че няма хардуер за ускорение  ;D

т.е. артефактите не са случайни и навсякъде т.е. на случайни места а "засега" само и винаги на едно място
между другото "View Image" не ми показва надписа а некъв овърлей

П.П. Егати то било видео тва - даже две , едното овърлей и явно това му идва в повече на лисика
http://www.imdb.com/h5avt/2017/aerec/00091776-outlander/Outlander-custom-logo-alphalfa.webm
http://www.imdb.com/h5avt/2017/aerec/00091776-outlander/Outlander-custom-logo-alphalfa.mp4
и после едни канави дето не им пасват размерите ..те така (ама до вчера фокса си работеше нормално)
canvas class="alphalfa-buffer" style="display:none;" height="168px" width="140px"
canvas class="alphalfa-output" height="84px" width="140px"

може да се окаже и нов бъг на лисика - то не го показва където трябва горе на черния фон ами бая по-долу и енда част пада върху бял фон и точно и само тя се прецаква, когато се падне цялото на бял фон - цялото е прецакано (както на видеото) но понякога само една лентичка отдолу и само тя е на снежинки - явно го рендва като за горе (черен фон) и като се падне на бял и се омотва...
Здраве да е..
ха наздраве  [_]3 [_]3 [_]3
и благодаря за помощта, че аз вече бях изпържил един диск по случая (ще го запазя за друг път, но дано не се налага да го ползвам)
« Последна редакция: Сеп 10, 2017, 00:04 от remotexx »
Активен

ddantgwyn

  • Участник
  • *****
  • Публикации: 775
    • Профил
Та въпросът ми е - как със systemd и само с опции на ядрото/гръб при зареждане да вляза в чист текстови режим ..е или в rescue mode (щото даже и той ми зависва)
само стандартния текстови режим ми работи т.е. VGA всичко останало VESA  и нагоре се прецаква - включтелно и safe/rescue mode

Погледни това -- https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux/6/html/Installation_Guide/s1-grub-runlevels.html

Вярно, за Red Hat е, но може би ще ти свърши работа.

PS А, късно видях, че си се оправил, така че може да игнорираш моето предложение :)
« Последна редакция: Сеп 10, 2017, 09:49 от ddantgwyn »
Активен

--
the lamer's team honourable member

cybercop

  • Участник
  • *****
  • Публикации: 5253
  • Distribution: Ubuntu LTS, CENTOS 6.x
  • Window Manager: Xfce, Gnome 2
    • Профил

може да се окаже и нов бъг на лисика
Не е, като да няма. Вчера се наложи да кача бета версия на компютъра на баща ми (Ubuntu 16.04), защото текущата за Ubuntu - Firefox 55.02 имаше проблем с отварянето на PDF файлове. Вместо да ги отваря се стартираше презаписване. А, той е свикнал да ползва браузъра за четец на PDF документи. След обновяването, този проблем се оправи, но, кой знае колко нови съм си навлякъл с бета изданието.
Активен

Ползването на Linux води до пристрастяване. Факт.
http://s19.postimg.org/4oajwoq5v/xenial2.png

Подобни теми
Заглавие Започната от Отговора Прегледи Последна публикация
какво мислите за systemd?
Живота, вселената и някакви други глупости
lunarvalley 379 30378 Последна публикация Дек 03, 2016, 17:24
от Acho
boycott systemd
Коментар
lunarvalley 19 2985 Последна публикация Юни 01, 2014, 10:00
от go_fire
Създаване на systemd unit
Настройка на програми
senser 5 1317 Последна публикация Ное 24, 2014, 19:38
от go_fire
Systemd в Ubuntu 14.04
Настройка на програми
cybercop 0 486 Последна публикация Фев 16, 2016, 20:49
от cybercop
Ред на стартиране/спиране на systemd services
Настройка на програми
senser 1 730 Последна публикация Апр 26, 2017, 12:05
от senser