Автор Тема: teamviewer 12 install на Debian 9 64 bit.  (Прочетена 2422 пъти)

Astor

  • Участник
  • *****
  • Публикации: 329
    • Профил
teamviewer 12 install на Debian 9 64 bit.
« -: Окт 01, 2017, 20:06 »
Здравейте, нещо ударих на камък, когато се опитам да инсталирам teamviewer12 на Дебиан 9 (64 битова архитектура).

Както пише в сайта на teamviewer-a няма 64 битова версия за линукс.

Опитвам се да го инсталирам така:
Цитат
-rw-r--r-- 1 user user 46549564 окт  1 19:54 teamviewer_12.0.85001_i386.deb
root@x1:~/TMP# dpkg --add-architecture i386
root@x1:~/TMP# dpkg -i teamviewer_12.0.85001_i386.deb
Selecting previously unselected package teamviewer:i386.
(Reading database ... 101559 files and directories currently installed.)
Preparing to unpack teamviewer_12.0.85001_i386.deb ...
Unpacking teamviewer:i386 (12.0.85001) ...
dpkg: dependency problems prevent configuration of teamviewer:i386:
 teamviewer:i386 depends on libasound2.
 teamviewer:i386 depends on libdbus-1-3.
 teamviewer:i386 depends on libexpat1.
 teamviewer:i386 depends on libfontconfig1.
 teamviewer:i386 depends on libfreetype6.
 teamviewer:i386 depends on libsm6.
 teamviewer:i386 depends on libxdamage1.
 teamviewer:i386 depends on libxext6.
 teamviewer:i386 depends on libxfixes3.
 teamviewer:i386 depends on libxinerama1.
 teamviewer:i386 depends on libxrandr2.
 teamviewer:i386 depends on libxrender1.
 teamviewer:i386 depends on libxtst6.

dpkg: error processing package teamviewer:i386 (--install):
 dependency problems - leaving unconfigured
Processing triggers for desktop-file-utils (0.23-1) ...
Processing triggers for mime-support (3.60) ...
Processing triggers for hicolor-icon-theme (0.15-1) ...
Errors were encountered while processing:
 teamviewer:i386
root@x1:~/TMP# apt-get update
Ign:1 http://debian.spnet.net/debian stretch InRelease
Get:2 http://debian.spnet.net/debian stretch-updates InRelease [91.0 kB]
Ign:3 http://dl.google.com/linux/chrome/deb stable InRelease
Hit:4 http://debian.spnet.net/debian stretch Release                     
Hit:5 http://dl.google.com/linux/chrome/deb stable Release               
Hit:8 https://repo.skype.com/deb stable InRelease 
Hit:9 https://download.sublimetext.com apt/stable/ InRelease
Fetched 91.0 kB in 1s (80.1 kB/s)
Reading package lists... Done
root@x1:~/TMP# apt-get -f install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  gconf-service gconf2-common libappindicator1 libdbusmenu-gtk4 libgconf-2-4
  libindicator7
Use 'apt autoremove' to remove them.
The following packages will be REMOVED:
  google-chrome-stable teamviewer:i386
0 upgraded, 0 newly installed, 2 to remove and 0 not upgraded.
1 not fully installed or removed.
After this operation, 425 MB disk space will be freed.

с gdebi казва следното (като преди това съм пуснал "apt --fix-broken install") :
Цитат
root@x1:~/TMP# gdebi teamviewer_12.0.85001_i386.deb
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Reading state information... Done
This package is uninstallable
Cannot install 'libdbus-1-3:i386'

Този пакет: libdbus-1-3:i386 дава следната грешка:
Цитат
libdbus-1-3:i386 : Depends: libsystemd0:i386 (>= 209) but it is not going to be installed

Та освен че ми деинсталира google-chrome нищо друго не направих.

Може ли някой да съдейства?
Активен

Няма начин, да няма начин!

jet

  • Участник
  • *****
  • Публикации: 1119
  • Distribution: debian sid
  • Window Manager: kde
    • Профил
Re: teamviewer 12 install на Debian 9 64 bit.
« Отговор #1 -: Окт 01, 2017, 23:01 »
Пробвай да го инсталираш с gdebi
Той ще си свали зависимостите.
Активен

"Guy who put "logout" in tiny text right next to "restart", also in tiny text, in Windows Server 2012, making every logout of production systems a test in fine motor skills. I'd really like to speak to that person for a few minutes"

Astor

  • Участник
  • *****
  • Публикации: 329
    • Профил
Re: teamviewer 12 install на Debian 9 64 bit.
« Отговор #2 -: Окт 01, 2017, 23:05 »
Jet, благодаря за отговора, но както съм писал:
Цитат
с gdebi казва следното (като преди това съм пуснал "apt --fix-broken install") :
Цитат
root@x1:~/TMP# gdebi teamviewer_12.0.85001_i386.deb
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Reading state information... Done
This package is uninstallable
Cannot install 'libdbus-1-3:i386'
Активен

Няма начин, да няма начин!

malin

  • Участник
  • *****
  • Публикации: 502
  • Distribution: Lubuntu 14.04.1
  • Window Manager: Openbox
    • Профил
Re: teamviewer 12 install на Debian 9 64 bit.
« Отговор #3 -: Окт 02, 2017, 00:35 »
Що не ползваш apt-get или aptitude (за обновяване и инсталиране)? И дали да вярвам на това, че едно обновяване може да реши проблема. Или пък libdbus-1-3:i386 за Джеси.
« Последна редакция: Окт 02, 2017, 00:58 от malin »
Активен

Няма проблем, който да е толкова сериозен, че да не можеш да избягаш от него.

deant01

  • Участник
  • *****
  • Публикации: 196
  • Distribution: Debian/sid
  • Window Manager: Gnome 3
    • Профил
Re: teamviewer 12 install на Debian 9 64 bit.
« Отговор #4 -: Окт 02, 2017, 04:36 »
debian sid ли е това?
ето какво става при мен на Сид:

Код:
~# apt install /home/deant/Downloads/teamviewer_12.0.85001_i386.deb
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Note, selecting 'teamviewer:i386' instead of '/home/deant/Downloads/teamviewer_12.0.85001_i386.deb'
The following NEW packages will be installed:
  teamviewer:i386
0 upgraded, 1 newly installed, 0 to remove and 1 not upgraded.
Need to get 0 B/46.5 MB of archives.
After this operation, 151 MB of additional disk space will be used.
Get:1 /home/deant/Downloads/teamviewer_12.0.85001_i386.deb teamviewer i386 12.0.85001 [46.5 MB]
Selecting previously unselected package teamviewer:i386.
(Reading database ... 381927 files and directories currently installed.)
Preparing to unpack .../teamviewer_12.0.85001_i386.deb ...
Unpacking teamviewer:i386 (12.0.85001) ...
Processing triggers for mime-support (3.60) ...
Processing triggers for desktop-file-utils (0.23-2) ...
Setting up teamviewer:i386 (12.0.85001) ...
Processing triggers for gnome-menus (3.13.3-9) ...
Processing triggers for hicolor-icon-theme (0.17-1) ...
root@home:~#

т.е. всичко е без проблеми. да не си на много стара версия на дебиян?

пп. Сега обърнах внимание, че е Дебиан 9. Не знам за него аз рядко ползвам stable. Сега съм на buster/sid - buster си е готов за употреба, както беше и stretch пред да стане stable.
« Последна редакция: Окт 02, 2017, 12:50 от deant01 »
Активен

Ripples of paradox spread out across the sea of causality.

orangutan_baby

  • Участник
  • *****
  • Публикации: 20
    • Профил
Re: teamviewer 12 install на Debian 9 64 bit.
« Отговор #5 -: Окт 02, 2017, 15:52 »
Цитат "Та освен че ми деинсталира google-chrome нищо друго не направих"
от къде накъде ще деинсталира chrom, къде е връзката хе хе.
Едно бараш, то къде се пука.
Активен

remotexx

  • Участник
  • *****
  • Публикации: 395
    • Профил
Re: teamviewer 12 install на Debian 9 64 bit.
« Отговор #6 -: Окт 03, 2017, 01:40 »
пп. Сега обърнах внимание, че е Дебиан 9. Не знам за него аз рядко ползвам stable. Сега съм на buster/sid - buster си е готов за употреба, както беше и stretch пред да стане stable.

Готов е за употреба - ама дуг пъ-ъ-ъ-т. Наскоро си качих един пакет дето показва важни бъгове в новите ъпдейти (и после вече си инсталираш на своя отговорност) и то точно щото съм на тестинг в сл. Бъстър (понеже там изначално си те предупреждават че за тестовата и нестабилна версии секюрити пачове и обновявания няма ами си чакаш да излезе по-нова версия и се надяваш там да са го фикснали) и вече ми влезе в употреба - вчера при обновяване ми изкара тоя бъг и реших да не рискувам т.е. прескочих нетуърк-мениджъра в обновяването (сега баш на мойта конфигурация бъга може и да не работи - ама нямам време/нервички за тестване, че наскоро се борих с подобен проблем дето след обновяване на ядро и ми се прецакваха конзолните режими /тия графичните с по много символи на ред/ и не ми зареждаше въобще - едвам намерих уъркараунд)

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=877085
network-manager installation crashes debian buster
Severity: critical
Found in version network-manager/1.8.4-1

та ето колко сигурен е Бъстър - направо е като Бъстър Кийтън смело с рогите напред.. и да се надяваме чутурата да е дебела да издържи (на напрежението)
« Последна редакция: Окт 03, 2017, 01:42 от remotexx »
Активен

jet

  • Участник
  • *****
  • Публикации: 1119
  • Distribution: debian sid
  • Window Manager: kde
    • Профил
Re: teamviewer 12 install на Debian 9 64 bit.
« Отговор #7 -: Окт 03, 2017, 01:58 »
B Sid има ъпдейти всеки ден, трябва търпение и все пак не търкаляш сървър. Тук няма нужда да чакаш като Майкрософтските бози - веднъж месечно (като му дойде времето).
Активен

"Guy who put "logout" in tiny text right next to "restart", also in tiny text, in Windows Server 2012, making every logout of production systems a test in fine motor skills. I'd really like to speak to that person for a few minutes"

Astor

  • Участник
  • *****
  • Публикации: 329
    • Профил
Re: teamviewer 12 install на Debian 9 64 bit.
« Отговор #8 -: Окт 03, 2017, 23:48 »
@Malin, Debian 9 - stretch/текущия stable.
Ето какво става като пробвам (реално изкача един и същ проблем):
Цитат
oot@x1:~/TMP# apt install /home/user/TMP/teamviewer_12.0.85001_i386.deb
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Note, selecting 'teamviewer:i386' instead of '/home/user/TMP/teamviewer_12.0.85001_i386.deb'
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 teamviewer:i386 : Depends: libdbus-1-3:i386 but it is not going to be installed
                   Depends: libexpat1:i386 but it is not going to be installed
                   Depends: libfontconfig1:i386 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

А като се опитам да инсталирам libdbus-1-3:i386:
Цитат
root@x1:~/TMP# apt-get install libdbus-1-3:i386
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libdbus-1-3:i386 : Depends: libsystemd0:i386 (>= 209) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
Продължавам като се мъча да инсталирам това което няма:
Цитат
libsystemd0:i386 : PreDepends: libgcrypt20:i386 (>= 1.7.0) but it is not going to be installed.
И накрая като се опитам да инсталирам libgcrypt20:i386 ми казва че трябва да премахне 269 пакете, след което не съм сигурен дали ще мога да си стартирам системата.

Тъпотията е че няма 64 битова версия, която да си инсталирам и да забравя...
Активен

Няма начин, да няма начин!

deant01

  • Участник
  • *****
  • Публикации: 196
  • Distribution: Debian/sid
  • Window Manager: Gnome 3
    • Профил
Re: teamviewer 12 install на Debian 9 64 bit.
« Отговор #9 -: Окт 04, 2017, 06:30 »
@Malin, Debian 9 - stretch/текущия stable.
Ето какво става като пробвам (реално изкача един и същ проблем):
Цитат
oot@x1:~/TMP# apt install /home/user/TMP/teamviewer_12.0.85001_i386.deb
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Note, selecting 'teamviewer:i386' instead of '/home/user/TMP/teamviewer_12.0.85001_i386.deb'
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 teamviewer:i386 : Depends: libdbus-1-3:i386 but it is not going to be installed
                   Depends: libexpat1:i386 but it is not going to be installed
                   Depends: libfontconfig1:i386 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

А като се опитам да инсталирам libdbus-1-3:i386:
Цитат
root@x1:~/TMP# apt-get install libdbus-1-3:i386
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libdbus-1-3:i386 : Depends: libsystemd0:i386 (>= 209) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
Продължавам като се мъча да инсталирам това което няма:
Цитат
libsystemd0:i386 : PreDepends: libgcrypt20:i386 (>= 1.7.0) but it is not going to be installed.
И накрая като се опитам да инсталирам libgcrypt20:i386 ми казва че трябва да премахне 269 пакете, след което не съм сигурен дали ще мога да си стартирам системата.

Тъпотията е че няма 64 битова версия, която да си инсталирам и да забравя...

пробвай да добавиш това хранилище в /etc/apt/sources.list

deb http://ftp.us.debian.org/debian jessie-backports main contrib non-free

след това задължително:

apt update
apt full-upgrade

нямам представа дали ще сработи, но там понякога има пакети които трябват за такива случаи. Аз съм на СИД, сложил съм това хранилище и нямах проблеми с инсталацията на teamviewer.
« Последна редакция: Окт 04, 2017, 06:32 от deant01 »
Активен

Ripples of paradox spread out across the sea of causality.

bvbfan

  • Участник
  • *****
  • Публикации: 1051
  • Distribution: KaOS
  • Window Manager: Plasma 5
    • Профил
Re: teamviewer 12 install на Debian 9 64 bit.
« Отговор #10 -: Окт 04, 2017, 21:17 »
За какво ти е тва лайно rdp (в случая TeamViewr) това много неуспешен и лайнян опит да се копира ssh -X.
Активен

Astor

  • Участник
  • *****
  • Публикации: 329
    • Профил
Re: teamviewer 12 install на Debian 9 64 bit.
« Отговор #11 -: Окт 04, 2017, 23:31 »
@deant01, благодаря за отговора, но абослютно същото се получава.

Може би имаш в предвид stretch-backports, а не jessie-backports.

Оставих само ифициалното stretch + stretch-backports репота, но същите грешки.
талира
Cannot install 'libdbus-1-3:i386'
Пробвах да си сваля този пакет, но той пак не иска да се инсталира, защото зависел от: libsystemd0:i386 и така по веригата, в крайна сметак стигам до предложението да ми премахне 269 пакета...

Мисля си дали да не напавя dumy пакет libdbus-1-3:i386, който да си го инсталирам и да го излъжа.

Цитат
За какво ти е тва лайно rdp...
Налага ми се да управлявам отдалечено windows OS машини :(

« Последна редакция: Окт 04, 2017, 23:34 от Astor »
Активен

Няма начин, да няма начин!

remotexx

  • Участник
  • *****
  • Публикации: 395
    • Профил
Re: teamviewer 12 install на Debian 9 64 bit.
« Отговор #12 -: Окт 05, 2017, 01:40 »
И понеже го няма Ачката, нека тоя път и аз да се изкажа..
И с какво аджеба баш тоя клиент е по-различен от един билюк други?

Аз лично за връзка с джамеци ползвам rdesktop направо от конзола
Ама и едно бързо търсене ми изрови и някой други, очевидно по-известни макар че някой не съм ги и чувал още

https://www.maketecheasier.com/best-linux-remote-desktop-apps/amp/
« Последна редакция: Окт 05, 2017, 01:42 от remotexx »
Активен

makeme

  • Участник
  • *****
  • Публикации: 187
  • Distribution: Many
  • Window Manager: Mate
    • Профил
Re: teamviewer 12 install на Debian 9 64 bit.
« Отговор #13 -: Окт 05, 2017, 02:10 »
И понеже го няма Ачката, нека тоя път и аз да се изкажа..
И с какво аджеба баш тоя клиент е по-различен от един билюк други?

Аз лично за връзка с джамеци ползвам rdesktop направо от конзола
Ама и едно бързо търсене ми изрови и някой други, очевидно по-известни макар че някой не съм ги и чувал още

https://www.maketecheasier.com/best-linux-remote-desktop-apps/amp/

RDP е много добро решение, но в случай, че имаш клиенти (компютърно неграмотни хора, които плащат) има мнооого препятствия. РДП трябва да е пуснато на прозореца, КЛИЕНТА ТРЯБВА ДА ИМА ПАРОЛА НА ПРОЗОРЕЦА :) , рутера трябва да му е настроен (пренасочен порт), трябва да има реално ИП и трябва доставчика да не му е ограничил порт 3389, понеже после следват 1 час инструкции как се сменя порта по телефона. Относно другите решения... -> всички са шит. Стане ли въпрос за работа на отдалечен прозорец (да кажем в US) TeamViwer и РДП нямат дори и близки решения. Що се отнася до ssh -X (-Y) за прозорци не върши работа плюс това за далечни връзки е ужастно. Просто хаби огромно количество трафик дори и с "-C".

ПП: При РДП не можеш да показваш на клиента (обучение) как да прави дадено нещо с даден продукт, тъй като го логаутва :)
« Последна редакция: Окт 05, 2017, 02:18 от makeme »
Активен

Distributions:  UbuntuMate 14.04; 15.10; 16.04, CentOS 6.x, 7.x, Kali 2.0 ...

jet

  • Участник
  • *****
  • Публикации: 1119
  • Distribution: debian sid
  • Window Manager: kde
    • Профил
Re: teamviewer 12 install на Debian 9 64 bit.
« Отговор #14 -: Окт 05, 2017, 02:20 »
И понеже го няма Ачката, нека тоя път и аз да се изкажа..
И с какво аджеба баш тоя клиент е по-различен от един билюк други?

Аз лично за връзка с джамеци ползвам rdesktop направо от конзола
Ама и едно бързо търсене ми изрови и някой други, очевидно по-известни макар че някой не съм ги и чувал още

https://www.maketecheasier.com/best-linux-remote-desktop-apps/amp/
Всичките ти решения изискват отваряне на портове и порт форуърд в рутера на стрина ти, което малко хора могат да го направят. На TeamViewer-a не му се налагат такива гимнастики.
Активен

"Guy who put "logout" in tiny text right next to "restart", also in tiny text, in Windows Server 2012, making every logout of production systems a test in fine motor skills. I'd really like to speak to that person for a few minutes"

Подобни теми
Заглавие Започната от Отговора Прегледи Последна публикация
Debian 3.0 Install
Настройка на програми
millennium 1 739 Последна публикация Авг 23, 2003, 17:13
от videff
Debian 3r1 - Install
Настройка на програми
Agent_SMITH 46 5719 Последна публикация Мар 10, 2004, 04:31
от Agent_SMITH
install na debian
Настройка на програми
kostadinz 0 529 Последна публикация Ное 13, 2003, 10:45
от kostadinz
Fedora 20 проблем teamviewer
Настройка на програми
prsandrei 41 3370 Последна публикация Май 05, 2014, 00:37
от prsandrei
ПРЕМЕСТЕНО: Fedora 20 проблем teamviewer
Хардуерни и софтуерни проблеми
neter 0 411 Последна публикация Апр 24, 2014, 23:48
от neter