Автор Тема: AverMedia TV GO Series Tuner проблеми  (Прочетена 2857 пъти)

ifr

  • Участник
  • *****
  • Публикации: 1
    • Профил
AverMedia TV GO Series Tuner проблеми
« -: Дек 12, 2004, 16:24 »
M*M,
Прочетох темите тук, инсталирах XawTV, оправих му настройките очевидните, пуснах bttv, ядрото ми поддържа тв тунера ми, той се разпознава като Brooktree/bt878, добавих каквото казвахте в /etc/modules.conf и пак отказва съдействие този мой тунер. Направик скан на каналите също, няма сигнал никъде, на pal съм го пуснал да търси, B/G не намерих.

Сега пре-инсталирах системата си и се обърках и незнам откъде да започна вече, не се сещам и какво друго инфо да дам...:)

OS: Mandrake 10.0 Download version, Official.
Video Card: Asus v7100 Series 32 MB, разпозната по подразбиране като някаква nVdiaa.
ТВ тунер: AverMedia TV GO Series, разпознат като Brooktree/878.

Това е, има само една тема на този форум за тази карта и информацията не е достатъчна. Драйверите са по подразбиране, защото просто не открих такива, по официалните сайтове също няма.

Откъде да започна?:)

B*B,
ifr
Активен

hary

  • Участник
  • *****
  • Публикации: 73
    • Профил
AverMedia TV GO Series Tuner проблеми
« Отговор #1 -: Дек 13, 2004, 11:39 »
Със същата карта съм и tvtime бачка като пушка '<img'>
Сега не мога точно да ти кажа параметрите но мисля че бяха такива:
карта - Avermedia98 ( 13 )
тунер - 2 или 1 (пробвай)
Ако не успееш - довечера ще ти пратя точните параметри за modprobe.conf.
Активен

  • Гост
AverMedia TV GO Series Tuner проблеми
« Отговор #2 -: Дек 13, 2004, 20:22 »
Прати ми параметрите ако успееш..
Активен

hary

  • Участник
  • *****
  • Публикации: 73
    • Профил
AverMedia TV GO Series Tuner проблеми
« Отговор #3 -: Дек 13, 2004, 23:38 »
# i2c
alias char-major-89     i2c-dev
options i2c-core        i2c_debug=1
options i2c-algo-bit    bit_test=1
  
# bttv
alias char-major-81     videodev
alias char-major-81-0   bttv
options bttv            card=13 radio=1
options tuner           type=1
alias char-major-61     lirc_gpio
Активен

  • Гост
AverMedia TV GO Series Tuner проблеми
« Отговор #4 -: Дек 15, 2004, 00:01 »
M*M,
Ами не успявам. Какво е i2c и как да разбера дали го имам? И какви са тези настройки, как да разбера моите параметри какви трябва да са?
И XawTV какви настройки трябва да има, примерно каква frequenct table трябва да ползва?
TVTime има още повече настройки, там съвсем се обърках... Сканира и нищо не намира, двете програми нямат изобщо нямат PAL B/G ili PAL D/K, само PAL някакъв.
И къде е инфото, тези настройки ако трябва сам да ги правя трябва в кристалното кълбо ли да гледам? Откъде сте ги взели всички?
Трябва ли ми Video4Linux и ако да - как да проверя дали вече го имам?

И защо като питам нещо и всеки ми предлага различни настройки, ама съвсем различни? '<img'>

Пример човек 1:

rmmod bttv
modprobe tuner type=5 /ili 3/
modprobe bttv cadr=13 pll=1

Пример човек 2:

# i2c
alias char-major-89     i2c-dev
options i2c-core        i2c_debug=1
options i2c-algo-bit    bit_test=1
 
# bttv
alias char-major-81     videodev
alias char-major-81-0   bttv
options bttv            card=13 radio=1
options tuner           type=1
alias char-major-61     lirc_gpio


Нереално различни са, а ако добавя и другите 7, който ми дадоха услужливи хора на този форум, направо щееее....

Къде е истината, какво правя?

Може би ми трябва нещо, което не съм инсталирал?

Никой в канал Линук в UniBG не дава помощ....  Ако някой има време за една среща онлайн ще бъде супер..:))

Успех и благодаря на човека по-горе за параметрите, оценявам.

ifr
Активен

hary

  • Участник
  • *****
  • Публикации: 73
    • Профил
AverMedia TV GO Series Tuner проблеми
« Отговор #5 -: Дек 16, 2004, 11:23 »
Да твърде вероятно да нямаш нещо в кернела. Можеш да прочетеш в документацията на кернела тук:
/usr/src/linux-2.6.9-1.6_FC2/Documentation/video4linux/
Препоръчвам първо CARDLIST и всичко в bttv.
Video4linux ти трябва '<img'>. Използвам PAL и Russian обхват за тvtime. Пак ти казвам - имам същата карта.
След като заредиш с параметрите посочени от мен, пусни lsmod и дай да го видим какво показва, така ще разберем дали нямаш/имаш нещо, огледай и /var/log/messages дали няма нещо интересно вътре за модулите които се опитваме да заредим , най вече за bttv. С кой Линикс си, кернела stock ли е или си го прекомпилирал?
Активен

  • Гост
AverMedia TV GO Series Tuner проблеми
« Отговор #6 -: Дек 16, 2004, 20:38 »
M*M,

lsmod показва това :

[root@Sascha sascha]# lsmod
Module                  Size  Used by
md5                     3872  1
ipv6                  232352  6
sg                     38044  0
sr_mod                 17060  0
snd-seq-midi            8160  0
snd-opl3-synth         15140  0
snd-seq-instr           8160  1 snd-opl3-synth
snd-seq-midi-emul       7776  1 snd-opl3-synth
snd-ainstr-fm           2624  1 snd-opl3-synth
snd-seq-oss            31232  0
snd-seq-midi-event      7552  2 snd-seq-midi,snd-seq-oss
snd-seq                51024  8 snd-seq-midi,snd-opl3-synth,snd-seq-instr,snd-seq-midi-emul,snd-seq-oss,snd-seq-midi-event

snd-pcm-oss            51812  0
snd-mixer-oss          17952  2 snd-pcm-oss
snd-es1938             20644  1
snd-pcm                93156  2 snd-pcm-oss,snd-es1938
snd-opl3-lib            9984  2 snd-opl3-synth,snd-es1938
snd-timer              24484  3 snd-seq,snd-pcm,snd-opl3-lib
snd-hwdep               8928  1 snd-opl3-lib
gameport                4480  1 snd-es1938
snd-page-alloc         11972  2 snd-es1938,snd-pcm
snd-mpu401-uart         7072  1 snd-es1938
snd-rawmidi            23616  2 snd-seq-midi,snd-mpu401-uart
snd-seq-device          8008  6 snd-seq-midi,snd-opl3-synth,snd-seq-oss,snd-seq,snd-opl3-lib,snd-rawmidi
snd                    52484  16 snd-seq-midi,snd-opl3-synth,snd-seq-instr,snd-seq-oss,snd-seq-midi-event,snd-seq,snd-pcm-o
ss,snd-mixer-oss,snd-es1938,snd-pcm,snd-opl3-lib,snd-timer,snd-hwdep,snd-mpu401-uart,snd-r
awmidi,snd-seq-device
af_packet              20520  0
hid                    53312  0
ide-floppy             18752  0
ide-tape               34864  0
ide-cd                 40548  0
cdrom                  37184  2 sr_mod,ide-cd
floppy                 59444  0
8139too                23712  0
mii                     4992  1 8139too
nls_iso8859-1           3904  1
nls_cp850               4736  1
vfat                   13760  1
fat                    45120  1 vfat
supermount             37876  1
intel-agp              17372  1
agpgart                31016  1 intel-agp
bttv                  146956  0
video-buf              20388  1 bttv
i2c-algo-bit            9512  1 bttv
v4l2-common             6144  1 bttv
btcx-risc               4712  1 bttv
i2c-core               23044  2 bttv,i2c-algo-bit
videodev                9536  1 bttv
soundcore               9248  3 snd,bttv
ppa                    12296  0
parport_pc             32832  0
imm                    12360  0
scsi_mod              114744  4 sg,sr_mod,ppa,imm
parport                38952  3 ppa,parport_pc,imm
uhci-hcd               29104  0
usbcore                99132  4 hid,uhci-hcd
rtc                    11576  0
ext3                  110376  1
jbd                    54328  1 ext3

Ядрото не е прекомпилирано.
Тази папка е празна, няма нищо в нея. Ще потърся къде се намира на друго място, просто за сега не успявам, но търся. '<img'>

Линукса ми е Mandrake 10.0 Download version, Official, няма updates.

/var/log/messages  :

Dec 12 15:47:26 Sascha syslogd 1.4.1: restart.
Dec 12 15:47:26 Sascha kernel: klogd 1.4.1, log source = /proc/kmsg started.
Dec 12 15:47:26 Sascha kernel: Inspecting /boot/System.map-2.6.3-4mdk
Dec 12 15:47:26 Sascha kernel: Loaded 29308 symbols from /boot/System.map-2.6.3-4mdk.
Dec 12 15:47:26 Sascha kernel: Symbols match kernel version 2.6.3.
Dec 12 15:47:26 Sascha kernel: No module symbols loaded - kernel modules not enabled.
Dec 12 15:47:26 Sascha kernel: Linux version 2.6.3-4mdk (nplanel@n3.mandrakesoft.com) (gcc version 3.3.2 (Mandrake Linux 10.0 3.3.2-6mdk)) #1 Tue Mar 2 07:26:13 CET 2004
Dec 12 15:47:26 Sascha kernel: BIOS-provided physical RAM map:
Dec 12 15:47:26 Sascha kernel:  BIOS-e820: 0000000000000000 - 000000000009fc00 (usable)
Dec 12 15:47:26 Sascha kernel:  BIOS-e820: 000000000009fc00 - 00000000000a0000 (reserved)
Dec 12 15:47:26 Sascha kernel:  BIOS-e820: 00000000000f0000 - 0000000000100000 (reserved)
Dec 12 15:47:26 Sascha kernel:  BIOS-e820: 0000000000100000 - 000000000bffd000 (usable)
Dec 12 15:47:26 Sascha kernel:  BIOS-e820: 000000000bffd000 - 000000000bfff000 (ACPI data)
@
"messages" 7461L, 582382C                                     1,1           Top

Не видях нищо интересно, а и освен това тези съобщения са чак от 12-ти...

Отивам да потърся Video4Linux.

B*B,
ifr
Активен

nforcer

  • Участник
  • *****
  • Публикации: 213
    • Профил
AverMedia TV GO Series Tuner проблеми
« Отговор #7 -: Дек 17, 2004, 17:59 »
# i2c
alias char-major-89     i2c-dev
options i2c-core        i2c_debug=1
options i2c-algo-bit    bit_test=1

# bttv
alias char-major-81     videodev
alias char-major-81-0   bttv
options bttv            card=13 radio=1
options tuner           type=1
alias char-major-61     lirc_g

tova go slagash v modules.conf ako si s 2.4.x iadro ili v modprobe.conf ako si s 2.6.x iadro.
Posle pishesh tova

rmmod bttv
modprobe tuner type=5 /ili 3/
modprobe bttv cadr=13 pll=1

za da mahnesh bttv modula i posle da go zaredish s novite nastroiki.
Активен

No Microsoft products were used in any way for the creation of this message.
If you are using a Microsoft product to view it, BEWARE!
I'm not responsible for any harm you might encounter as a result.

  • Гост
AverMedia TV GO Series Tuner проблеми
« Отговор #8 -: Дек 18, 2004, 13:03 »
M*M,

nforcer:

Разбрах аз какво да правя с тях, но не ми беше ясно какво е изобщо това, което пиша в modules.conf '<img'> Просто copy-paste.

---

Vide4Linux трябва да се компилира с ядрото ли? Прочетох разни неща по сайтовете, намерих дори някакви rpm-и, но има 100 различни варианта...

Документацията за ядрото ми не успях да я открия в Линукса ми, може би не съм я сложил при инсталация?....

Пробвах настройките на TVTime, инсталирах XawTV отново, а също и Zapping с неговите libs, виждам само звездички....:)

Дали ако сменя дистрибуцията си ще успея да го пусна? Намерих си Slackware 10 и някакъв Debian, но Mandrake има по-човешка инсталация просто... SuSE не харесвам.:)

Какво да правя по-нататък, да търся инфо за Video4Linux?

Blessed Be,
ifr
Активен

nforcer

  • Участник
  • *****
  • Публикации: 213
    • Профил
AverMedia TV GO Series Tuner проблеми
« Отговор #9 -: Дек 18, 2004, 15:41 »
Да v4l се компилира заедно с ядрото но трябва да са компилирани и i2c и rtc .За по нова версия можеш да пробваш 2.6 ядро или да дръпнеш само v4l от bytesex.org.
Я сложи тук какво ти казва dmesg след като напищеш rmmod bttv
modprobe bttv xxx
modprobe tuner xxx
А и виж там в xawtv смени режима на overlay мисля че беше опцията пробвай различните стойности на мен тунера ми беше тръгнал но аз не бях разбрал защото там стойноста беше грешна и екрана оставаше черен.
И спокойно на мен ми трябваше поне седмица докато подкарам напълно моя и все още не съм разбрал как да проработи mute опцията и го спирам с смяна на входното устройство на различно от TV mono only.
Активен

No Microsoft products were used in any way for the creation of this message.
If you are using a Microsoft product to view it, BEWARE!
I'm not responsible for any harm you might encounter as a result.

  • Гост
AverMedia TV GO Series Tuner проблеми
« Отговор #10 -: Дек 18, 2004, 16:46 »
M*M,

Това е след dmesg :

PCI: Probing PCI hardware (bus 00)
PCI: Using IRQ router PIIX/ICH [8086/7110] at 0000':0'0':0'4.0
vesafb: framebuffer at 0xd8000000, mapped to 0xcc800000, size 16384k
vesafb: mode is 800x600x16, linelength=1600, pages=3
vesafb: protected mode interface info at c000:0f3e
vesafb: scrolling: redraw
vesafb: directcolor: size=0:5:6:5, shift=0:11:5':0'
fb0: VESA VGA frame buffer device
SBF: Simple Boot Flag extension found and enabled.
SBF: Setting boot flags 0x1
apm: BIOS version 1.2 Flags 0x03 (Driver version 1.16ac)
ikconfig 0.7 with /proc/config*
VFS: Disk quotas dquot_6.5.1
devfs: 2004-01-31 Richard Gooch (rgooch@atnf.csiro.au)
devfs: boot_options: 0x1
Initializing Cryptographic API
Limiting direct PCI/PCI transfers.
isapnp: Scanning for PnP cards...
isapnp: No Plug & Play device found
bootsplash 3.1.3-2003/11/14: looking for picture.... silentjpeg size 14856 bytes, found (800x600, 14808 bytes, v3).
Console: switching to colour frame buffer device 92x32
pty: 1024 Unix98 ptys configured
Serial: 8250/16550 driver $Revision: 1.90 $ 8 ports, IRQ sharing enabled
ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
ttyS1 at I/O 0x2f8 (irq = 3) is a 16550A
RAMDISK driver initialized: 16 RAM disks of 32000K size 1024 blocksize
Uniform Multi-Platform E-IDE driver Revision: 7.00alpha2
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
PIIX4: IDE controller at PCI slot 0000':0'0':0'4.1
PIIX4: chipset revision 1
PIIX4: not 100% native mode: will probe irqs later
    ide0: BM-DMA at 0xd800-0xd807, BIOS settings: hda:DMA, hdb:pio
    ide1: BM-DMA at 0xd808-0xd80f, BIOS settings: hdc:pio, hdd:DMA
hda: ST38420A, ATA DISK drive
Using anticipatory io scheduler
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
hdd: CD-532E, ATAPI CD/DVD-ROM drive
ide1 at 0x170-0x177,0x376 on irq 15
hda: max request size: 128KiB
hda: 16841664 sectors (8622 MB) w/512KiB Cache, CHS=16708/16/63, UDMA(33)
 /dev/ide/host0/bus0/target0/lun0: p1 p2 < p5 p6 >
Console: switching to colour frame buffer device 92x32
mice: PS/2 mouse device common for all mice
serio: i8042 AUX port at 0x60,0x64 irq 12
input: PS/2 Generic Mouse on isa0060/serio1
serio: i8042 KBD port at 0x60,0x64 irq 1
input: AT Translated Set 2 keyboard on isa0060/serio0
md: md driver 0.90.0 MAX_MD_DEVS=256, MD_SB_DISKS=27
EISA: Probing bus 0 at eisa0
NET: Registered protocol family 2
IP: routing cache hash table of 1024 buckets, 8Kbytes
TCP: Hash tables configured (established 16384 bind 32768)
NET: Registered protocol family 1
BIOS EDD facility v0.12 2004-Jan-26, 1 devices found
Please report your BIOS at http://linux.dell.com/edd/results.html
Resume Machine: resuming from /dev/hda6
Resuming from device hda6
Resume Machine: This is normal swap space
PM: Reading pmdisk image.
PM: Resume from disk failed.
md: Autodetecting RAID arrays.
md: autorun ...
md: ... autorun DONE.
RAMDISK: Compressed image found at block 0
VFS: Mounted root (ext2 filesystem).
Mounted devfs on /dev
kjournald starting.  Commit interval 5 seconds
EXT3-fs: mounted filesystem with ordered data mode.
Mounted devfs on /dev
Freeing unused kernel memory: 272k freed
Real Time Clock Driver v1.12
drivers/usb/core/usb.c: registered new driver usbfs
drivers/usb/core/usb.c: registered new driver hub
drivers/usb/host/uhci-hcd.c: USB Universal Host Controller Interface driver v2.1PCI: Found IRQ 9 for device 0000':0'0':0'4.2
uhci_hcd 0000':0'0':0'4.2: UHCI Host Controller
uhci_hcd 0000':0'0':0'4.2: irq 9, io base 0000d400
uhci_hcd 0000':0'0':0'4.2: new USB bus registered, assigned bus number 1
hub 1-0:1.0: USB hub found
hub 1-0:1.0: 2 ports detected
EXT3 FS on hda1, internal journal
Adding 229280k swap on /dev/hda6.  Priority:-1 extents:1
SCSI subsystem initialized
imm: Version 2.05 (for Linux 2.4.0)
parport0: PC-style at 0x378 (0x778) [PCSPP,TRISTATE,EPP]
parport0: irq 7 detected
parport0: cpp_daisy: aa5500ff(38)
parport0: assign_addrs: aa5500ff(38)
parport0: cpp_daisy: aa5500ff(38)
parport0: assign_addrs: aa5500ff(38)
ppa: Version 2.07 (for Linux 2.4.x)
Linux video capture interface: v1.00
bttv: driver version 0.9.12 loaded
bttv: using 8 buffers with 2080k (520 pages) each for capture
bttv: Host bridge needs ETBF enabled.
bttv: Bt8xx card found (0).
PCI: Found IRQ 11 for device 0000':0'0:0c.0
PCI: Sharing IRQ 11 with 0000':0'0:0c.1
bttv0: Bt878 (rev 17) at 0000':0'0:0c.0, irq: 11, latency: 32, mmio: 0xd7000000
bttv0: using:  *** UNKNOWN/GENERIC ***  [card=0,autodetected]
bttv0: enabling ETBF (430FX/VP3 compatibilty)
bttv0: gpio: en=00000000, out=00000000 in=00e6fff3 [init]
bttv: readee error
bttv0: using tuner=-1
bttv0: i2c: checking for MSP34xx @ 0x80... not found
bttv0: i2c: checking for TDA9875 @ 0xb0... not found
bttv0: i2c: checking for TDA7432 @ 0x8a... not found
bttv0: registered device video0
bttv0: registered device vbi0
Linux agpgart interface v0.100 © Dave Jones
agpgart: Detected an Intel 440BX Chipset.
agpgart: Maximum main memory to use for agp memory: 149M
agpgart: AGP aperture is 64M @ 0xe4000000
Supermount version 2.0.4 for kernel 2.6
8139too Fast Ethernet driver 0.9.27
PCI: Found IRQ 10 for device 0000':0'0:0b.0
eth0: RealTek RTL8139 at 0xcd9f2000, 00':0'0:e8:84:e0:f3, IRQ 10
eth0:  Identified 8139 chip type 'RTL-8139A'
inserting floppy driver for 2.6.3-4mdk
Floppy drive(s): fd0 is 1.44M
FDC 0 is a post-1991 82077
hdd: ATAPI 32X CD-ROM drive, 128kB Cache, DMA
Uniform CD-ROM driver Revision: 3.20
ide-floppy driver 0.99.newide
drivers/usb/core/usb.c: registered new driver hiddev
drivers/usb/core/usb.c: registered new driver hid
drivers/usb/input/hid-core.c: v2.0:USB HID core driver
NET: Registered protocol family 17
eth0: link up, 100Mbps, half-duplex, lpa 0x40A1
PCI: Found IRQ 5 for device 0000':0'0:0a.0
eth0: link up, 100Mbps, half-duplex, lpa 0x40A1
mtrr: 0xd8000000,0x2000000 overlaps existing 0xd8000000,0x1000000
atkbd.c: Unknown key released (translated set 2, code 0x7a on isa0060/serio0).
atkbd.c: This is an XFree86 bug. It shouldn't access hardware directly.
eth0: link up, 100Mbps, half-duplex, lpa 0x40A1
bootsplash 3.1.3-2003/11/14: looking for picture.... found (800x600, 11943 bytes, v3).
bootsplash: status on console 0 changed to on
bootsplash 3.1.3-2003/11/14: looking for picture.... found (800x600, 11943 bytes, v3).
bootsplash: status on console 1 changed to on
bootsplash 3.1.3-2003/11/14: looking for picture.... found (800x600, 11943 bytes, v3).
bootsplash: status on console 2 changed to on
bootsplash 3.1.3-2003/11/14: looking for picture.... found (800x600, 11943 bytes, v3).
bootsplash: status on console 3 changed to on
bootsplash 3.1.3-2003/11/14: looking for picture.... found (800x600, 11943 bytes, v3).
bootsplash: status on console 4 changed to on
bootsplash 3.1.3-2003/11/14: looking for picture.... found (800x600, 11943 bytes, v3).
bootsplash: status on console 5 changed to on
NET: Registered protocol family 10
Disabled Privacy Extensions on device c035fa20(lo)
IPv6 over IPv4 tunneling driver
eth0: no IPv6 routers present
cdrom: This disc doesn't have any tracks I recognize!
bttv0: unloading
bttv: Unknown parameter `cadr'
bttv: driver version 0.9.12 loaded
bttv: using 8 buffers with 2080k (520 pages) each for capture
bttv: Host bridge needs ETBF enabled.
bttv: Bt8xx card found (0).
PCI: Found IRQ 11 for device 0000':0'0:0c.0
PCI: Sharing IRQ 11 with 0000':0'0:0c.1
bttv0: Bt878 (rev 17) at 0000':0'0:0c.0, irq: 11, latency: 32, mmio: 0xd7000000
bttv0: using: AVerMedia TVCapture 98 [card=13,insmod option]
bttv0: enabling ETBF (430FX/VP3 compatibilty)
bttv0: gpio: en=00000000, out=00000000 in=00e6fff3 [init]
bttv0: Hauppauge/Voodoo msp34xx: reset line init [11]
tuner: chip found @ 0xc2
tuner: type forced to 5 (Philips PAL_BG (FI1216 and compatibles)) [insmod]
tuner: type already set (5)
bttv: readee error
bttv0: Avermedia eeprom[0x0000]: tuner=2 radio:no remote control:no
bttv0: using tuner=2
tuner: type already set (5)
bttv0: i2c: checking for MSP34xx @ 0x80... not found
bttv0: i2c: checking for MSP34xx (alternate address) @ 0x88... not found
bttv0: i2c: checking for TDA9875 @ 0xb0... not found
bttv0: i2c: checking for TDA7432 @ 0x8a... not found
tvaudio: TV audio decoder + audio/video mux driver
tvaudio: known chips: tda9840,tda9873h,tda9874h/a,tda9850,tda9855,tea6300,tea6420,tda8425,pic16c54 (PV951),ta8874z
bttv0: registered device video0
bttv0: registered device vbi0
bttv0: PLL: 28636363 => 35468950 .. ok
bttv0: unloading
bttv: driver version 0.9.12 loaded
bttv: using 8 buffers with 2080k (520 pages) each for capture
bttv: Host bridge needs ETBF enabled.
bttv: Bt8xx card found (0).
PCI: Found IRQ 11 for device 0000':0'0:0c.0
PCI: Sharing IRQ 11 with 0000':0'0:0c.1
bttv0: Bt878 (rev 17) at 0000':0'0:0c.0, irq: 11, latency: 32, mmio: 0xd7000000
bttv0: using: AVerMedia TVCapture 98 [card=13,insmod option]
bttv0: enabling ETBF (430FX/VP3 compatibilty)
bttv0: gpio: en=00000000, out=00000000 in=00e6fff3 [init]
bttv0: Hauppauge/Voodoo msp34xx: reset line init [11]
tuner: chip found @ 0xc2
tuner: type forced to 5 (Philips PAL_BG (FI1216 and compatibles)) [insmod]
tuner: type already set (5)
bttv: readee error
bttv0: Avermedia eeprom[0x0000]: tuner=2 radio:no remote control:no
bttv0: using tuner=2
tuner: type already set (5)
bttv0: i2c: checking for MSP34xx @ 0x80... not found
bttv0: i2c: checking for MSP34xx (alternate address) @ 0x88... not found
bttv0: i2c: checking for TDA9875 @ 0xb0... not found
bttv0: i2c: checking for TDA7432 @ 0x8a... not found
bttv0: registered device video0
bttv0: registered device vbi0
bttv0: PLL: 28636363 => 35468950 . ok
[root@Sascha sascha]# clear
 
[root@Sascha sascha]# dmesg
Linux version 2.6.3-4mdk (nplanel@n3.mandrakesoft.com) (gcc version 3.3.2 (Mandrake Linux 10.0 3.3.2-6mdk)) #1 Tue Mar 2 07:26:13 CET 2004
BIOS-provided physical RAM map:
 BIOS-e820: 0000000000000000 - 000000000009fc00 (usable)
 BIOS-e820: 000000000009fc00 - 00000000000a0000 (reserved)
 BIOS-e820: 00000000000f0000 - 0000000000100000 (reserved)
 BIOS-e820: 0000000000100000 - 000000000bffd000 (usable)
 BIOS-e820: 000000000bffd000 - 000000000bfff000 (ACPI data)
 BIOS-e820: 000000000bfff000 - 000000000c000000 (ACPI NVS)
 BIOS-e820: 00000000ffff0000 - 0000000100000000 (reserved)
191MB LOWMEM available.
On node 0 totalpages: 49149
  DMA zone: 4096 pages, LIFO batch:1
  Normal zone: 45053 pages, LIFO batch:10
  HighMem zone: 0 pages, LIFO batch:1
DMI 2.0 present.
ACPI disabled because your bios is from 00 and too old
You can enable it with acpi=force
Built 1 zonelists
Kernel command line: auto BOOT_IMAGE=linux ro root=301 devfs=mount acpi=ht resume=/dev/hda6 splash=silent
bootsplash: silent mode.
Local APIC disabled by BIOS -- reenabling.
Found and enabled local APIC!
Initializing CPU#0
PID hash table entries: 1024 (order 10: 8192 bytes)
Detected 501.355 MHz processor.
Using tsc for high-res timesource
Console: colour dummy device 80x25
Memory: 190580k/196596k available (1815k kernel code, 5364k reserved, 846k data, 272k init, 0k highmem)
Checking if this processor honours the WP bit even in supervisor mode... Ok.
Calibrating delay loop... 989.18 BogoMIPS
Dentry cache hash table entries: 32768 (order: 5, 131072 bytes)
Inode-cache hash table entries: 16384 (order: 4, 65536 bytes)
Mount-cache hash table entries: 512 (order: 0, 4096 bytes)
checking if image is initramfs...it isn't (no cpio magic); looks like an initrd
Freeing initrd memory: 133k freed
CPU:     After generic identify, caps: 0183fbff 00000000 00000000 00000000
CPU:     After vendor identify, caps: 0183fbff 00000000 00000000 00000000
CPU: L1 I cache: 16K, L1 D cache: 16K
CPU: L2 cache: 128K
CPU:     After all inits, caps: 0183fbff 00000000 00000000 00000040
Intel machine check architecture supported.
Intel machine check reporting enabled on CPU#0.
CPU: Intel Celeron (Mendocino) stepping 05
Enabling fast FPU save and restore... done.
Checking 'hlt' instruction... OK.
POSIX conformance testing by UNIFIX
enabled ExtINT on CPU#0
ESR value before enabling vector: 00000000
ESR value after enabling vector: 00000000
Using local APIC timer interrupts.
calibrating APIC timer ...
..... CPU clock speed is 501.0035 MHz.
..... host bus clock speed is 66.0804 MHz.
NET: Registered protocol family 16
EISA bus registered
PCI: PCI BIOS revision 2.10 entry at 0xf0720, last bus=1
PCI: Using configuration type 1
mtrr: v2.0 (20020519)
ACPI: Subsystem revision 20040211
ACPI: Interpreter disabled.
Linux Plug and Play Support v0.97 © Adam Belay
PnPBIOS: Disabled
PCI: Probing PCI hardware
PCI: Probing PCI hardware (bus 00)
PCI: Using IRQ router PIIX/ICH [8086/7110] at 0000':0'0':0'4.0
vesafb: framebuffer at 0xd8000000, mapped to 0xcc800000, size 16384k
vesafb: mode is 800x600x16, linelength=1600, pages=3
vesafb: protected mode interface info at c000:0f3e
vesafb: scrolling: redraw
vesafb: directcolor: size=0:5:6:5, shift=0:11:5':0'
fb0: VESA VGA frame buffer device
SBF: Simple Boot Flag extension found and enabled.
SBF: Setting boot flags 0x1
apm: BIOS version 1.2 Flags 0x03 (Driver version 1.16ac)
ikconfig 0.7 with /proc/config*
VFS: Disk quotas dquot_6.5.1
devfs: 2004-01-31 Richard Gooch (rgooch@atnf.csiro.au)
devfs: boot_options: 0x1
Initializing Cryptographic API
Limiting direct PCI/PCI transfers.
isapnp: Scanning for PnP cards...
isapnp: No Plug & Play device found
bootsplash 3.1.3-2003/11/14: looking for picture.... silentjpeg size 14856 bytes, found (800x600, 14808 bytes, v3).
Console: switching to colour frame buffer device 92x32
pty: 1024 Unix98 ptys configured
Serial: 8250/16550 driver $Revision: 1.90 $ 8 ports, IRQ sharing enabled
ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
ttyS1 at I/O 0x2f8 (irq = 3) is a 16550A
RAMDISK driver initialized: 16 RAM disks of 32000K size 1024 blocksize
Uniform Multi-Platform E-IDE driver Revision: 7.00alpha2
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
PIIX4: IDE controller at PCI slot 0000':0'0':0'4.1
PIIX4: chipset revision 1
PIIX4: not 100% native mode: will probe irqs later
    ide0: BM-DMA at 0xd800-0xd807, BIOS settings: hda:DMA, hdb:pio
    ide1: BM-DMA at 0xd808-0xd80f, BIOS settings: hdc:pio, hdd:DMA
hda: ST38420A, ATA DISK drive
Using anticipatory io scheduler
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
hdd: CD-532E, ATAPI CD/DVD-ROM drive
ide1 at 0x170-0x177,0x376 on irq 15
hda: max request size: 128KiB
hda: 16841664 sectors (8622 MB) w/512KiB Cache, CHS=16708/16/63, UDMA(33)
 /dev/ide/host0/bus0/target0/lun0: p1 p2 < p5 p6 >
Console: switching to colour frame buffer device 92x32
mice: PS/2 mouse device common for all mice
serio: i8042 AUX port at 0x60,0x64 irq 12
input: PS/2 Generic Mouse on isa0060/serio1
serio: i8042 KBD port at 0x60,0x64 irq 1
input: AT Translated Set 2 keyboard on isa0060/serio0
md: md driver 0.90.0 MAX_MD_DEVS=256, MD_SB_DISKS=27
EISA: Probing bus 0 at eisa0
NET: Registered protocol family 2
IP: routing cache hash table of 1024 buckets, 8Kbytes
TCP: Hash tables configured (established 16384 bind 32768)
NET: Registered protocol family 1
BIOS EDD facility v0.12 2004-Jan-26, 1 devices found
Please report your BIOS at http://linux.dell.com/edd/results.html
Resume Machine: resuming from /dev/hda6
Resuming from device hda6
Resume Machine: This is normal swap space
PM: Reading pmdisk image.
PM: Resume from disk failed.
md: Autodetecting RAID arrays.
md: autorun ...
md: ... autorun DONE.
RAMDISK: Compressed image found at block 0
VFS: Mounted root (ext2 filesystem).
Mounted devfs on /dev
kjournald starting.  Commit interval 5 seconds
EXT3-fs: mounted filesystem with ordered data mode.
Mounted devfs on /dev
Freeing unused kernel memory: 272k freed
Real Time Clock Driver v1.12
drivers/usb/core/usb.c: registered new driver usbfs
drivers/usb/core/usb.c: registered new driver hub
drivers/usb/host/uhci-hcd.c: USB Universal Host Controller Interface driver v2.1PCI: Found IRQ 9 for device 0000':0'0':0'4.2
uhci_hcd 0000':0'0':0'4.2: UHCI Host Controller
uhci_hcd 0000':0'0':0'4.2: irq 9, io base 0000d400
uhci_hcd 0000':0'0':0'4.2: new USB bus registered, assigned bus number 1
hub 1-0:1.0: USB hub found
hub 1-0:1.0: 2 ports detected
EXT3 FS on hda1, internal journal
Adding 229280k swap on /dev/hda6.  Priority:-1 extents:1
SCSI subsystem initialized
imm: Version 2.05 (for Linux 2.4.0)
parport0: PC-style at 0x378 (0x778) [PCSPP,TRISTATE,EPP]
parport0: irq 7 detected
parport0: cpp_daisy: aa5500ff(38)
parport0: assign_addrs: aa5500ff(38)
parport0: cpp_daisy: aa5500ff(38)
parport0: assign_addrs: aa5500ff(38)
ppa: Version 2.07 (for Linux 2.4.x)
Linux video capture interface: v1.00
bttv: driver version 0.9.12 loaded
bttv: using 8 buffers with 2080k (520 pages) each for capture
bttv: Host bridge needs ETBF enabled.
bttv: Bt8xx card found (0).
PCI: Found IRQ 11 for device 0000':0'0:0c.0
PCI: Sharing IRQ 11 with 0000':0'0:0c.1
bttv0: Bt878 (rev 17) at 0000':0'0:0c.0, irq: 11, latency: 32, mmio: 0xd7000000
bttv0: using:  *** UNKNOWN/GENERIC ***  [card=0,autodetected]
bttv0: enabling ETBF (430FX/VP3 compatibilty)
bttv0: gpio: en=00000000, out=00000000 in=00e6fff3 [init]
bttv: readee error
bttv0: using tuner=-1
bttv0: i2c: checking for MSP34xx @ 0x80... not found
bttv0: i2c: checking for TDA9875 @ 0xb0... not found
bttv0: i2c: checking for TDA7432 @ 0x8a... not found
bttv0: registered device video0
bttv0: registered device vbi0
Linux agpgart interface v0.100 © Dave Jones
agpgart: Detected an Intel 440BX Chipset.
agpgart: Maximum main memory to use for agp memory: 149M
agpgart: AGP aperture is 64M @ 0xe4000000
Supermount version 2.0.4 for kernel 2.6
8139too Fast Ethernet driver 0.9.27
PCI: Found IRQ 10 for device 0000':0'0:0b.0
eth0: RealTek RTL8139 at 0xcd9f2000, 00':0'0:e8:84:e0:f3, IRQ 10
eth0:  Identified 8139 chip type 'RTL-8139A'
inserting floppy driver for 2.6.3-4mdk
Floppy drive(s): fd0 is 1.44M
FDC 0 is a post-1991 82077
hdd: ATAPI 32X CD-ROM drive, 128kB Cache, DMA
Uniform CD-ROM driver Revision: 3.20
ide-floppy driver 0.99.newide
drivers/usb/core/usb.c: registered new driver hiddev
drivers/usb/core/usb.c: registered new driver hid
drivers/usb/input/hid-core.c: v2.0:USB HID core driver
NET: Registered protocol family 17
eth0: link up, 100Mbps, half-duplex, lpa 0x40A1
PCI: Found IRQ 5 for device 0000':0'0:0a.0
eth0: link up, 100Mbps, half-duplex, lpa 0x40A1
mtrr: 0xd8000000,0x2000000 overlaps existing 0xd8000000,0x1000000
atkbd.c: Unknown key released (translated set 2, code 0x7a on isa0060/serio0).
atkbd.c: This is an XFree86 bug. It shouldn't access hardware directly.
eth0: link up, 100Mbps, half-duplex, lpa 0x40A1
bootsplash 3.1.3-2003/11/14: looking for picture.... found (800x600, 11943 bytes, v3).
bootsplash: status on console 0 changed to on
bootsplash 3.1.3-2003/11/14: looking for picture.... found (800x600, 11943 bytes, v3).
bootsplash: status on console 1 changed to on
bootsplash 3.1.3-2003/11/14: looking for picture.... found (800x600, 11943 bytes, v3).
bootsplash: status on console 2 changed to on
bootsplash 3.1.3-2003/11/14: looking for picture.... found (800x600, 11943 bytes, v3).
bootsplash: status on console 3 changed to on
bootsplash 3.1.3-2003/11/14: looking for picture.... found (800x600, 11943 bytes, v3).
bootsplash: status on console 4 changed to on
bootsplash 3.1.3-2003/11/14: looking for picture.... found (800x600, 11943 bytes, v3).
bootsplash: status on console 5 changed to on
NET: Registered protocol family 10
Disabled Privacy Extensions on device c035fa20(lo)
IPv6 over IPv4 tunneling driver
eth0: no IPv6 routers present
cdrom: This disc doesn't have any tracks I recognize!
bttv0: unloading
bttv: Unknown parameter `cadr'
bttv: driver version 0.9.12 loaded
bttv: using 8 buffers with 2080k (520 pages) each for capture
bttv: Host bridge needs ETBF enabled.
bttv: Bt8xx card found (0).
PCI: Found IRQ 11 for device 0000':0'0:0c.0
PCI: Sharing IRQ 11 with 0000':0'0:0c.1
bttv0: Bt878 (rev 17) at 0000':0'0:0c.0, irq: 11, latency: 32, mmio: 0xd7000000
bttv0: using: AVerMedia TVCapture 98 [card=13,insmod option]
bttv0: enabling ETBF (430FX/VP3 compatibilty)
bttv0: gpio: en=00000000, out=00000000 in=00e6fff3 [init]
bttv0: Hauppauge/Voodoo msp34xx: reset line init [11]
tuner: chip found @ 0xc2
tuner: type forced to 5 (Philips PAL_BG (FI1216 and compatibles)) [insmod]
tuner: type already set (5)
bttv: readee error
bttv0: Avermedia eeprom[0x0000]: tuner=2 radio:no remote control:no
bttv0: using tuner=2
tuner: type already set (5)
bttv0: i2c: checking for MSP34xx @ 0x80... not found
bttv0: i2c: checking for MSP34xx (alternate address) @ 0x88... not found
bttv0: i2c: checking for TDA9875 @ 0xb0... not found
bttv0: i2c: checking for TDA7432 @ 0x8a... not found
tvaudio: TV audio decoder + audio/video mux driver
tvaudio: known chips: tda9840,tda9873h,tda9874h/a,tda9850,tda9855,tea6300,tea6420,tda8425,pic16c54 (PV951),ta8874z
bttv0: registered device video0
bttv0: registered device vbi0
bttv0: PLL: 28636363 => 35468950 .. ok
bttv0: unloading
bttv: driver version 0.9.12 loaded
bttv: using 8 buffers with 2080k (520 pages) each for capture
bttv: Host bridge needs ETBF enabled.
bttv: Bt8xx card found (0).
PCI: Found IRQ 11 for device 0000':0'0:0c.0
PCI: Sharing IRQ 11 with 0000':0'0:0c.1
bttv0: Bt878 (rev 17) at 0000':0'0:0c.0, irq: 11, latency: 32, mmio: 0xd7000000
bttv0: using: AVerMedia TVCapture 98 [card=13,insmod option]
bttv0: enabling ETBF (430FX/VP3 compatibilty)
bttv0: gpio: en=00000000, out=00000000 in=00e6fff3 [init]
bttv0: Hauppauge/Voodoo msp34xx: reset line init [11]
tuner: chip found @ 0xc2
tuner: type forced to 5 (Philips PAL_BG (FI1216 and compatibles)) [insmod]
tuner: type already set (5)
bttv: readee error
bttv0: Avermedia eeprom[0x0000]: tuner=2 radio:no remote control:no
bttv0: using tuner=2
tuner: type already set (5)
bttv0: i2c: checking for MSP34xx @ 0x80... not found
bttv0: i2c: checking for MSP34xx (alternate address) @ 0x88... not found
bttv0: i2c: checking for TDA9875 @ 0xb0... not found
bttv0: i2c: checking for TDA7432 @ 0x8a... not found
bttv0: registered device video0
bttv0: registered device vbi0
bttv0: PLL: 28636363 => 35468950 . ok

Ще потърся ново ядро, само се надявам да не е много голямо..:)

XawTV бях оправил тези настройки, за които ти каза.

dmesg показва някаква cadr и дава грешка, но в modules.conf е правилно написана, може би съм copy-paste-нал нещо по грешка. '<img'>

B*B,
ifr
Активен

nforcer

  • Участник
  • *****
  • Публикации: 213
    • Профил
AverMedia TV GO Series Tuner проблеми
« Отговор #11 -: Дек 20, 2004, 14:00 »
Не виждам никъде да се зареждат модули за i2c почти съм сигурен че това е причината. Можеш да прекомпилираш само модулите без ядрото.Отиваш в /usr/src/linux или ако нямаш такава връзка в /usr/src/linux-версията на ядрото ти пишеш make xconfig или make menuconfig включваш i2c suport и най добре нащракваш всички възможни опции там с M след това пишеш make modules; make modules_install и за всеки модул там пишеш modprobe i2c-xxx и би трябвало да стане.
Активен

No Microsoft products were used in any way for the creation of this message.
If you are using a Microsoft product to view it, BEWARE!
I'm not responsible for any harm you might encounter as a result.

hary

  • Участник
  • *****
  • Публикации: 73
    • Профил
AverMedia TV GO Series Tuner проблеми
« Отговор #12 -: Дек 20, 2004, 20:39 »
nforcer , w lsmod se wijda:
i2c-algo-bit            9512  1 bttv
v4l2-common             6144  1 bttv
btcx-risc               4712  1 bttv
i2c-core               23044  2 bttv,i2c-algo-bit
videodev                9536  1 bttv
т.е има i2c.
ifr ти АБСОЛЮТНО сигурен ли си че картата ти е такава?
Я я извади и огледай внимателно всички букви по нея '<img'>
Активен

dafo

  • Участник
  • *****
  • Публикации: 293
  • Distribution: Fedora
  • Window Manager: KDE
    • Профил
AverMedia TV GO Series Tuner проблеми
« Отговор #13 -: Дек 21, 2004, 13:08 »
Разтършувай https://www.redhat.com/mailman/listinfo/video4linux-list
това е пощенския списък който ти трябва.
Активен

Подобни теми
Заглавие Започната от Отговора Прегледи Последна публикация
HP Scanjet 3500 series
Настройка на хардуер
apogza 0 711 Последна публикация Юни 16, 2004, 23:23
от apogza
ASUS Eee PC Series
Лаптопи
PRECEDENT 3 2818 Последна публикация Юли 22, 2010, 22:27
от spec1
Продавам 3com hub и Cisco Catalyst 1900 Series и IBM xSeries
Кошче
billabongnet 0 1120 Последна публикация Мар 14, 2011, 16:49
от billabongnet
Мнения и размишления за Lenovo Thinkpad T series.
Лаптопи
woodman 2 3890 Последна публикация Май 11, 2016, 08:26
от woodman
Seasonic Prime W 750 Titanium или Corsair RMi Series RM850i 850W Gold? Кое е по-
Десктопи
ignorant 227 17875 Последна публикация Окт 20, 2018, 22:19
от spec1a