Начало Вход/Регистрация Помощ Tazi stranica s latinski bukwi
Области
 Новини
 Актуална тема
 Linux портали
 Какво е Линукс?
 Въпроси-отговори
 Форуми
   •Трудова борса
   •Конкурс
 Статии
 Дистрибуции
   •Поръчка на CD
 Made In BG
 Файлове
 Връзки
 Галерия
 Конференции
Настройки
 Външен вид
 Предложения
 Направи си сам
И още ...
 За нас
 Линукс за българи ЕООД
 Линк към нас
 Предложения

Подкрепяно от:
TelePoint - Място за хора със свободни идеи

SiteGround

initLab

Adsys Group

SAP Bulgaria

Въпроси отговори
Въпрос: Проблем с рутиране
[Търси: ]

ВНИМАНИЕ: Използвайте форумите на сайта за дa зададете вашите въпроси.

Към началото |Добави въпрос |Отговори
 
Въпрос
От: Валентин Дата: 10/20/2006
Здр,
Имам следния проблем:

 Направих си рутер под Slackware 11,и всичко си варви като
 хората,с изключение на това че нямам никакъв http,всеки чат
работи...

/etc/rc.d/rc.local
 ifconfig eth0 10.103.0.47 netmask 255.255.255.0 broadcast
10.103.0.255
 ifconfig eth1 192.168.0.1 netmask 255.255.255.0 broadcast
192.168.0.255
pppoe-start
iptables -A POSTROUTING -t nat -o ppp0 -j MASQUERADE
 iptables -t nat -A POSTROUTING -o ppp0 -j SNAT --to
192.168.0.1
sysctl -p


iptables:
Chain INPUT (policy ACCEPT)
target     prot opt source               destination

Chain FORWARD (policy ACCEPT)
target     prot opt source               destination

Chain OUTPUT (policy ACCEPT)
target     prot opt source               destination

 в crontab няма нищо.. Веднъж от там бях го оправял... с
crontab -d


 просто на всички машини след рутера няма http, а на рутера
 си върви перфекно... Другите могат само скайп да ползват и
чат...Няма защитна стена да съм го спрял от там.... 

НЯКАКВИ ИДЕИ ???


Отговор #1
От: plamen Дата: 10/20/2006
iptables -L -t nat


Отговор #2
От: botzko (tdenev__at__gmail< dot >com) Дата: 10/20/2006
DNS-ите оправил ли си им?



Отговор #3
От: Валентин Дата: 10/20/2006
 Сега съм на работа, довечера ще пратя всичко.Да имат си
 ДНС-и раздават се по dhcp и там всичко е 6.Получават си
адресите.
iptables -L -t nat
Довечера ще ти пратя какво пише.


Отговор #4
От: Dean Дата: 10/20/2006
А твоите ДНС-и оправил ли си ги?



Отговор #5
От: Dean Дата: 10/20/2006
 Сега го прочетох цялото..., проблема най-вероятно е в
потребителските ДНС-и



Отговор #6
От: plamen Дата: 10/20/2006
Още нещо  - /etc/rc.d/rc.inet1.conf


Отговор #7
От: noname Дата: 10/26/2006
 "ppp0" - Проблем с размера на пакета. Намали го и ще се
оправи web-a. ;)


Отговор #8
От: Вальо Дата: 10/30/2006
 Ами всъщност проблема се оказа в ДНС-ите, задал съм ДНС-а на
 рутера 192.168.0.1 а съм забравил да пусна ДНС сървъра :-)
извинявам се за излишната тема :-)


<< Как да кача video codacs на SuSE 10.1? (4 ) | xmms Font (1 ) >>

 
© 2011-... Асоциация "Линукс за българи"
© 2007-2010 Линукс за българи ЕООД
© 1999-2006 Slavej Karadjov
Ако искате да препечатате или цитирате информация от този сайт прочетете първо това
Външния вид е направен от MOMCHE
Code Version: 1.0.8 H (Revision: 23-09-2011)
 
Изпълнението отне: 0 wallclock secs ( 0.06 usr + 0.00 sys = 0.06 CPU)