Автор Тема: SuSE8.2 + Yast + Cyrilic = killall X  (Прочетена 1642 пъти)

Acidtrance

  • Напреднали
  • *****
  • Публикации: 65
    • Профил
SuSE8.2 + Yast + Cyrilic = killall X
« -: Aug 25, 2003, 07:01 »
Здравейте!
Значи имам един проблем с SuSE8.2. Става дума при самата кирилизация на KDE. При самата инсталация отначало, можете д си изберете език за инсталиране, който би трябвало - казвам би трябвало да работи успешно при вече инсталирана система. Има и един пакет, не се сещам сега точно как се казва, но става въпрос за кирилизация на KDE (менюта на бги т.н.). Другият пакет занимаващ се с кирилизиране е за Yast2. Та значи. Инсталирам гореспоменатия пакет за кирилизиране на KDE, естествено след това, трябва да рестартирам. Рестартирам, появява се login manager, и в този прекрасен момент XFree86 сървъра автоматично се изключва. След няколко безплодни опита да стартира Х-а ме изкарва в конзолата, където се логвам като root и чета в /var/log/ че пакетът за кирилизиране на KDE не може да си намери шрифтовете за кирилизация, които съм инсталирам преди това (?!?). Инсталирах bglinux, оправих ръчно charset-selection-a от /etc/gtk/ и пак рестартирах. Този път успях да видя десктопа на KDE, но в следващия момент сървърът пак падна долу. Мисля, че при сама конфигурация на пакета за българизация на KDE прави проблем автоматично настроеният CP1251 - glibc.
Ако някой има идея как мойе да се оправи тва чудо - нека ми каже, още от сега му казвам благодаря
Активен

CaBA

  • Напреднали
  • *****
  • Публикации: 303
    • Профил
    • WWW
SuSE8.2 + Yast + Cyrilic = killall X
« Отговор #1 -: Sep 01, 2003, 13:22 »
Проблемът е в пакета kde3-i18n-bg, където е преведен стринг, който не е трябвало да бъде превеждан и в резултат се рути KDE-то, което повлича със себе си и Х. Деинсталирай този пакет, за да се оправиш. Ако целта ти е само да пишеш и четеш на кирилица, той не ти е необходим - пакетът превежда менютата на български и добавя някои настройки (валута, мерни единици, формат на датата и такива подобни), които и ти можеш да направиш ръчно в Control Center -> Regional & Accessibility -> Country/Region & Language. За да пишеш на кирилица, в Control Center -> Regional & Accessibility -> Keyboard Layout избери Enable keyboard layouts и отдолу чекни Bulgarian, във Variant пък избери bds или phonetic в зависимост от предпочитанията. В Control Center -> Regional & Accessibility -> Keyboard shortcuts можеш да промениш клавишната комбинация, с която сменяш подредбите. При мене превключването с клавиатура работеше само в посока us -> bg и трябваше да си дефинирам алтернативен шорткът за обратната посока, който беше същата клавишна комбинация, само че на кирилица. bglinux не ми е бил необходим за да чета и пиша на кирилица в SuSE 8.2 Какво точно се дъни в kde3-i18n-bg можеш да разбереш от това писмо в пощенския списък на потребителите на Линукс в България
Активен

10 години ябълкова диета стигат, стигат!

Подобни теми
Заглавие Започната от Отговора Прегледи Последна публикация
SuSe8.2 + KDE на български
Настройка на програми
rat 2 1585 Последна публикация Jul 11, 2003, 11:52
от DonAngel
Instalirane na SuSE8.2
Настройка на програми
IvanST 0 1080 Последна публикация Sep 10, 2003, 09:58
от IvanST
bglinux i Suse8.2
Настройка на програми
ivodn 2 1371 Последна публикация Nov 20, 2003, 16:55
от
Zashto zapisva4kata mi neshte pod SuSe8.2?
Настройка на хардуер
Al_Kapone 4 2076 Последна публикация Apr 04, 2004, 20:10
от Al_Kapone
RQ. za X i Cyrilic
Настройка на програми
eNeX 4 1958 Последна публикация Oct 17, 2004, 13:20
от braun100