Автор Тема: Slackware BUGS  (Прочетена 3023 пъти)

vladi4ko

  • Напреднали
  • *****
  • Публикации: 36
    • Профил
Slackware BUGS
« -: Mar 11, 2006, 17:57 »
Здравейте, дано да съм уцелил раздела.
Имам няколко машинки с хардове и други програми напускани на тях. От както почнах да ползвам KDE-то забелязах че нещо не е както трябва с две думи под X среда нищо почти неможе да се свърши нормално, ще копирам някой от грешките в сислог.

Примерен код
Mar 10 21:56:20 slackware kernel: Bad page state at free_hot_cold_page (in process 'artsd', page c1521420)
Mar 10 21:56:20 slackware kernel: flags:0x80000414 mapping:00000000 mapcount:0 count:0
Mar 10 21:56:20 slackware kernel: Backtrace:
Mar 10 21:56:20 slackware kernel:  [<c013806f>] bad_page+0x5f/0xa0
Mar 10 21:56:20 slackware kernel:  [<c013884f>] free_hot_cold_page+0x3f/0xf0
Mar 10 21:56:20 slackware kernel:  [<c0141e17>] zap_pte_range+0x147/0x220
Mar 10 21:56:20 slackware kernel:  [<c0141f97>] unmap_page_range+0xa7/0x140
Mar 10 21:56:20 slackware kernel:  [<c014210f>] unmap_vmas+0xdf/0x1c0
Mar 10 21:56:20 slackware kernel:  [<c0145da6>] unmap_region+0x76/0xf0
Mar 10 21:56:20 slackware kernel:  [<c0146057>] do_munmap+0xa7/0x100
Mar 10 21:56:20 slackware kernel:  [<c01460e3>] sys_munmap+0x33/0x50
Mar 10 21:56:20 slackware kernel:  [<c0102e59>] syscall_call+0x7/0xb
Mar 10 21:56:20 slackware kernel: Trying to fix it up, but a reboot is needed
............. и още 10-тина странички с същия еррор

Това е първия еррор при тръгването на програмата мисля че xine при всичкото просвирване на звук се появява проблем като до тук добре X среда няма да е ползвам но кофтито е че по същото време излиза още един пробелем

Примерен код
Mar 11 06:31:54 slackware kernel: hde: dma_timer_expiry: dma status == 0x61
Mar 11 06:32:04 slackware kernel: hde: DMA timeout error
Mar 11 06:32:04 slackware kernel: hde: 0 bytes in FIFO
Mar 11 06:32:04 slackware kernel: hde: timeout waiting for DMA
Mar 11 06:32:04 slackware kernel: hde: dma timeout error: status=0x35 { DeviceFault SeekComplete CorrectedError Error }
Mar 11 06:32:04 slackware kernel: hde: dma timeout error: error=0x35 { DriveStatusError SectorIdNotFound AddrMarkNotFound }, L
BAsect=8830590465333, high=526344, low=3487029, sector=65743
Mar 11 06:32:04 slackware kernel: ide: failed opcode was: unknown
Mar 11 06:32:04 slackware kernel: hde: DMA disabled
Mar 11 06:32:04 slackware kernel: hdf: DMA disabled
Mar 11 06:32:04 slackware kernel: ide2: reset: master: error (0x0a?)
Mar 11 06:32:04 slackware kernel: hde: status error: status=0x34 { DeviceFault SeekComplete CorrectedError }
Mar 11 06:32:04 slackware kernel: ide: failed opcode was: unknown
Mar 11 06:32:04 slackware kernel: hde: no DRQ after issuing MULTWRITE_EXT
Mar 11 06:32:04 slackware kernel: ide2: reset: master: error (0x0a?)
Mar 11 06:32:04 slackware kernel: end_request: I/O error, dev hde, sector 65743
Mar 11 06:32:04 slackware kernel: Buffer I/O error on device hde1, logical block 8210
Mar 11 06:32:04 slackware kernel: lost page write due to I/O error on hde1
Mar 11 06:32:04 slackware kernel: end_request: I/O error, dev hde, sector 6375
Mar 11 06:32:04 slackware kernel: Buffer I/O error on device hde1, logical block 789
Mar 11 06:32:04 slackware kernel: lost page write due to I/O error on hde1
Mar 11 06:32:04 slackware kernel: end_request: I/O error, dev hde, sector 6383
Mar 11 06:32:04 slackware kernel: Buffer I/O error on device hde1, logical block 790
Mar 11 06:32:04 slackware kernel: lost page write due to I/O error on hde1
Mar 11 06:32:04 slackware kernel: REISERFS: abort (device hde1): Journal write error in flush_commit_list
Mar 11 06:32:04 slackware kernel: REISERFS: Aborting journal for filesystem on hde1
Mar 11 06:32:04 slackware kernel: ReiserFS: hde1: warning: journal-837: IO error during journal replay
Mar 11 06:32:04 slackware kernel: end_request: I/O error, dev hde, sector 6399
Mar 11 06:32:04 slackware kernel: Buffer I/O error on device hde1, logical block 792
Mar 11 06:32:04 slackware kernel: lost page write due to I/O error on hde1
Mar 11 06:32:04 slackware kernel: end_request: I/O error, dev hde, sector 6407
Mar 11 06:32:04 slackware kernel: Buffer I/O error on device hde1, logical block 793
Mar 11 06:32:04 slackware kernel: lost page write due to I/O error on hde1
Mar 11 06:32:27 slackware kernel: hde: set_drive_speed_status: status=0x6f { DriveReady DeviceFault DataRequest CorrectedError
 Index Error }

umount ръчно до последния
последва един ребуут
като се очакваше да има проблем с тези хардове защото лампичката още светеше
някой път минава номера с hdparm ама този път немина
идва буута ама нещо се поскараха хардовете за irq
спирането беше с захранващия кабел идва нов старт
всичко тръгва нормално без един хард
Примерен код

Mar 11 06:51:45 slackware kernel: ReiserFS: hdb1: found reiserfs format "3.6" with standard journal
Mar 11 06:51:45 slackware kernel: hdb: dma_intr: status=0x51 { DriveReady SeekComplete Error }
Mar 11 06:51:45 slackware kernel: hdb: dma_intr: error=0x40 { UncorrectableError }, LBAsect=300941375, high=17, low=15728703,
Mar 11 06:51:45 slackware kernel: ide: failed opcode was: unknown
Mar 11 06:51:45 slackware kernel: end_request: I/O error, dev hdb, sector 300941375

буа няма моунтване ровене в гуугле някви сканове за
лоши сектори и лоша памет се мятат дето проблем там
няма. Та всеки път така все гора с по 300гб инфо та
реших че линукса е много умен да закача харда на
един бъгав уиндоус първо ползвах YAReG-1.0.zip и
какво да вида всичко си е там на мястото му та
от един приятел бях чул за total commander + plugins ext2fs
който подържа и reiserfs (в момнета копира си копира през уиндоса съвсем нормално).
Та тук стигам до извода че reiserfs e ялова файлова система. Преди време пак имах същия проблем. Някаде пусках тема за жалост се стигна
до извода че хардовете и захранването са негодни ама
тия хардове още си бачкат и то без нинкакви въртели.
Решил съм да мина на XFS по точно новите хардове съм
ги форматнал с тази FS да чукна на дърво неса се обаждали. reiserfsck все стига до това че имам проблем с
хардуера и неможе да намери някъв map.
та питанката е има ли хора с такива проблеми
и дали може да споделят някво решение на въпроса
все пак идеята да разглабам цяло пц за да свала харда
и да го слагам ва уиндоус ми се струва някак си смешно.
В моммента съм разкачил всички хардове. Проблема
доколкото аз разбирам идва от звука. реших да пробвам
с друг пелеар

Примерен код
Mar 11 15:18:51 slackware kernel: Bad page state at free_hot_cold_page (in process 'gmplayer', page c15e75e0)
Mar 11 15:18:51 slackware kernel: flags:0x80000414 mapping:00000000 mapcount:0 count:0
Mar 11 15:18:51 slackware kernel: Backtrace:
Mar 11 15:18:51 slackware kernel:  [<c013806f>] bad_page+0x5f/0xa0
Mar 11 15:18:51 slackware kernel:  [<c013884f>] free_hot_cold_page+0x3f/0xf0
Mar 11 15:18:51 slackware kernel:  [<c0141e17>] zap_pte_range+0x147/0x220
Mar 11 15:18:51 slackware kernel:  [<c0141f97>] unmap_page_range+0xa7/0x140
Mar 11 15:18:51 slackware kernel:  [<c014210f>] unmap_vmas+0xdf/0x1c0
Mar 11 15:18:51 slackware kernel:  [<c0145da6>] unmap_region+0x76/0xf0
Mar 11 15:18:51 slackware kernel:  [<c0146057>] do_munmap+0xa7/0x100
Mar 11 15:18:51 slackware kernel:  [<c01460e3>] sys_munmap+0x33/0x50
Mar 11 15:18:51 slackware kernel:  [<c0102e59>] syscall_call+0x7/0xb
Mar 11 15:18:51 slackware kernel: Trying to fix it up, but a reboot is needed

Някой има ли такива проблеми и ако може да сподели решение
добре че всичко кадето се пуска под конзола може да ме погребе

за калпак смених и видео картата от nvidia с ati
опитах и със друга рам
но проблемите си остават същите
имам същите проблеми и със друг пц

Примерен код
Linux slackware 2.6.15.3 #1 Mon Feb 6 22:21:55 CST 2006 i686 athlon-4 i386 GNU/Linux

Брой процесори 1
Модел на процесор AMD Athlon(tm) XP 2500+
Честота 1.83 GHz
Размер на кешa  512 KB
Bogomips индекс 3670.93
PCI устройства 00:00.1 RAM memory: nVidia Corporation nForce2 Memory Controller 1
00:00.2 RAM memory: nVidia Corporation nForce2 Memory Controller 4
00:00.3 RAM memory: nVidia Corporation nForce2 Memory Controller 3
00:00.4 RAM memory: nVidia Corporation nForce2 Memory Controller 2
00:00.5 RAM memory: nVidia Corporation nForce2 Memory Controller 5
00:01.1 SMBus: nVidia Corporation MCP2A SMBus
00:06.0 Multimedia audio controller: nVidia Corporation MCP2S AC'97 Audio Controller
00:09.0 IDE interface: nVidia Corporation MCP2A IDE
00:0b.0 IDE interface: nVidia Corporation nForce2 Serial ATA Controller
01:06.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+
01:07.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8169 Gigabit Ethernet
01:08.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8169 Gigabit Ethernet
01:09.0 Mass storage controller: Triones Technologies, Inc. HPT366/368/370/370A/372/372N
01:0a.0 Network controller: Intersil Corporation Prism 2.5 Wavelan chipset
01:0b.0 Mass storage controller: Triones Technologies, Inc. HPT366/368/370/370A/372/372N
01:0d.0 FireWire
02:00.0 VGA compatible controller: ATI Technologies Inc Rage 128 PF/PRO AGP 4x TMDS
 
IDE устройства няма
SCSI устройства ATA ST3200822AS (Direct-Access)

Интерфейси Получени Изпратени Грешки/Изпуснати
lo 3.15 MB 3.15 MB 0/0
eth0 1.72 GB 1.92 GB 0/0
eth1 1.63 GB 2.15 GB 0/0
eth2 745.30 MB 95.32 MB 0/0
gre0 0.00 KB 0.00 KB 0/0
neta 726.84 MB 1.70 GB 0/0
netb 103.25 KB 2.09 MB 0/0
netc 733.25 KB 788.20 KB 0/0
tunnel0 0.00 KB 0.00 KB 0/0
sit0 0.00 KB 0.00 KB 0/0

Активен

GoodT

  • Напреднали
  • *****
  • Публикации: 361
    • Профил
Slackware BUGS
« Отговор #1 -: Mar 11, 2006, 19:08 »
Все ми се струва ,че проблема идва от това ,че на SCSI дисковете интерфейса им е sdX ,а не hdX.
Добре е да погледнеш и в BIOS-а дали детектва коректно хардовете.
С какъв интерфейс са другите хардове?
Активен

Activity

  • Напреднали
  • *****
  • Публикации: 105
  • Distribution: Slackware 13.1
  • Window Manager: KDE 3.5.10
    • Профил
Slackware BUGS
« Отговор #2 -: Mar 11, 2006, 20:44 »
и аз като си смених на 2.6.13 и КДЕ 3.5 започнаха да ми излизат същите проблеми ама от страна на XMMS-а като сменя песента и то изпише грешката '<img'>
Активен

Success represents the 1% of your work which results from the 99% that is called failure.
... - Soichiro Honda

vladi4ko

  • Напреднали
  • *****
  • Публикации: 36
    • Профил
Slackware BUGS
« Отговор #3 -: Mar 11, 2006, 21:00 »
Примерен код
root@slackware:/# cat /etc/fstab
#!/bin/sh
/dev/sda2  swap          swap      defaults  0   0
/dev/sda1  /             reiserfs  defaults  1   1
#/dev/hda3  /mnt/hd/hd1  reiserfs  defaults  0   0
#/dev/hdb1  /mnt/hd/hd2  reiserfs  defaults  0   0
#/dev/hdc1  /mnt/hd/hd3  reiserfs  defaults  0   0
#/dev/hdd1  /mnt/hd/hd4  reiserfs  defaults  0   0
#/dev/hde1  /mnt/hd/hd5  reiserfs  defaults  0   0
#/dev/hdf1  /mnt/hd/hd6  reiserfs  defaults  0   0
#/dev/hdg1  /mnt/hd/hd7  reiserfs  defaults  0   0
#/dev/hdh1  /mnt/hd/hd8  reiserfs  defaults  0   0
#/dev/hdi1  /mnt/hd/hd9   xfs      defaults  0   0
#/dev/hdj1  /mnt/hd/hd10         xfs       defaults  0   0
#/dev/hdk1  /mnt/hd/hd11         reiserfs  defaults  0   0
#/dev/hdl1  /mnt/hd/hd12         reiserfs  defaults  0   0
#/dev/sda3  /mnt/hd/hd13         reiserfs  defaults  0   0
#/dev/sdb1  /mnt/hd/hd14         reiserfs  defaults  0   0

на проблема невиждам решение '<img'>
навсякъде се споменава рам, провери за лоши сектори
и други дреболиики който според мене са наред
Примерен код

#/dev/hdi1  /mnt/hd/hd9   xfs      defaults  0   0
#/dev/hdj1  /mnt/hd/hd10         xfs       defaults  0   0

тези двата ги смених наскоро реших да пробвам на XFS
нещо неми харесва това че с един ребуут се скапва
цяло FS на reiserfs
кофти че всичкото това нещо е домашен сървър за
удоволствие и несъм чак толкова запознат с нещата
Активен

vladi4ko

  • Напреднали
  • *****
  • Публикации: 36
    • Профил
Slackware BUGS
« Отговор #4 -: Mar 11, 2006, 21:16 »
пише че в новата алса е коригирано
компилирах и кернела даде че не може да зареди модула
но пак има нещо гнило в текущата версия (а това незнам в предните версии X дали е вървяло така)
досега съм си правил всичко в конзола
права се някви опити да ползвам X средата но все без успех
нещо се омагьосват IRQ-тата, и на 2.4 си ги прави тея въртележки и то само когато работи кде-то
звуковите ми карти са все със AC97 чип
Активен

Goust

  • Напреднали
  • *****
  • Публикации: 249
    • Профил
Slackware BUGS
« Отговор #5 -: Mar 11, 2006, 22:28 »
Споредмен най-добре пробвай да ъпгреиниш кернела до 2.6.15.3 ,намене неми прави абсолютно никакви проблеми  (ето ти линк има си и пакети за алсата) :  linux-2.6.15.3
Активен

Ubuntu

“The Future is Open”

"Прави каквото трябва, пък да става каквото ще."

_DeXteR_

  • Напреднали
  • *****
  • Публикации: 27
    • Профил
    • WWW
Slackware BUGS
« Отговор #6 -: Mar 11, 2006, 22:33 »
Цитат
Activity : и аз като си смених на 2.6.13 и КДЕ 3.5 започнаха да ми излизат същите проблеми ама от страна на XMMS-а като сменя песента и то изпише грешката

Здравей може ли да те попитам как си оправил тази грешка за ХММС защото и аз я имам.
с стандартният кернел на слак10.2 съм.
Активен

;)

vladi4ko

  • Напреднали
  • *****
  • Публикации: 36
    • Профил
Slackware BUGS
« Отговор #7 -: Mar 11, 2006, 23:16 »
Цитат (Goust @ Март 11 2006,23:28)
Споредмен най-добре пробвай да ъпгреиниш кернела до 2.6.15.3 ,намене неми прави абсолютно никакви проблеми  (ето ти линк има си и пакети за алсата) :  linux-2.6.15.3

гледам през ден за ъпдейти с надеждата да се опрай проблема сам '<img'>

root@slackware:~# uname -a
Linux slackware 2.6.15.3 #1 Mon Feb 6 22:21:55 CST 2006 i686 athlon-4 i386 GNU/Linux
root@slackware:~# cat /root/slackchk
rsync -az --stats --progress --delete --force slackware.mirrors.tds.net::slackware/slackware-current/ ~ftp/slackware-current/

имам и пуснат rsync че после има още бараки зад тази
на предния кернел пак имаше същите грешки
ъпдейтвам със слакчек и неща който компилирам аз
ги слагам в съвсем различен път
ама само на две ползвам или по точно се опитвам да ползвам kde-то
Активен

Goust

  • Напреднали
  • *****
  • Публикации: 249
    • Профил
Slackware BUGS
« Отговор #8 -: Mar 13, 2006, 11:40 »
Пробвай да смениш arts-1.5.1-i486-1.tgz със стария arts-1.4.2-i486-1.tgz мисля , че така ще стане (и след това рестартирваш)  и пак си следи докато непуснат по-нова примерно arts-1.5.1-i486-2.tgz
Активен

Ubuntu

“The Future is Open”

"Прави каквото трябва, пък да става каквото ще."

vladi4ko

  • Напреднали
  • *****
  • Публикации: 36
    • Профил
Slackware BUGS
« Отговор #9 -: Mar 15, 2006, 16:36 »
огря ме за единия проблем '<img'>
Примерен код
testing/packages/linux-2.6.15.6/alsa-driver-1.0.11rc3_2.6.15.6-i486-1.tgz
  Upgraded to alsa-driver-1.0.11rc3 compiled for Linux 2.6.15.6.
  This should fix the "free_hot_cold_page" issue that was occuring with
  alsa-driver-1.0.10 and the 2.6.15+ kernels.  It fixes it here,
  anyway.  :-)

който е имал проб в алсата може да ъпдейтне
Активен

_DeXteR_

  • Напреднали
  • *****
  • Публикации: 27
    • Профил
    • WWW
Slackware BUGS
« Отговор #10 -: Mar 21, 2006, 10:33 »
Здравейте със слак 10.2 съм и искам да ви задам 1 въпрос и ако е възможно да ми отговорите.
Немога да разбера защо панела ми се крашва става въпрос за този панел  кадето стои часовника, и заредените програми. '<img'>
крашва се и после отново се зарежда наново...
Активен

;)

Goust

  • Напреднали
  • *****
  • Публикации: 249
    • Профил
Slackware BUGS
« Отговор #11 -: Mar 21, 2006, 18:54 »
Дай повече информация (грешки които ти изписва ,на коя графична среда ти прави това нещо ,нейната версия ,нещо ъпгреидвал ли си )
Активен

Ubuntu

“The Future is Open”

"Прави каквото трябва, пък да става каквото ще."

_DeXteR_

  • Напреднали
  • *****
  • Публикации: 27
    • Профил
    • WWW
Slackware BUGS
« Отговор #12 -: Mar 21, 2006, 22:42 »
Ами КДЕ 3.5
със слак 10.2 не съм я ъпдейвтвал освен да я напрая 3.5 макар че искам по голяма от 3.5 '<img'>

когато ми изпише грешката ще ви пиша благодаря все пак! помня само че имаше .so във края '<img'> '<img'>
Активен

;)

loxs

  • Напреднали
  • *****
  • Публикации: 307
    • Профил
Slackware BUGS
« Отговор #13 -: Mar 22, 2006, 11:15 »
Ами мисля, че човека пуснал темата определено много е сгрешил мястото. Тук и да се оплакваме, няма голяма полза. Тези логове от сислог трябва да се пратят директно в централата на слак.
Преди време аз пратих доста неща но забравих каква е процедурата. Вижте на http://www.slackware.com
Активен

Linux is like a wigwam - no windows, no gates, apache inside!
We shall walk together through all eternity. Wandering in the shadows, spreading the fear!
Gentoo - Baselayout 1.12.9-r2
Linux 2.6.21-suspend2-r6 Mon Jun 25 17:48:08 EEST 2007

Goust

  • Напреднали
  • *****
  • Публикации: 249
    • Профил
Slackware BUGS
« Отговор #14 -: Apr 01, 2006, 12:08 »
Ето и решението arts-1.5.2 .Можете да го дръпнете от ww.kde.org
Активен

Ubuntu

“The Future is Open”

"Прави каквото трябва, пък да става каквото ще."

Подобни теми
Заглавие Започната от Отговора Прегледи Последна публикация
Slackware QT проблем
Настройка на програми
kikcho 1 2854 Последна публикация Nov 11, 2002, 08:48
от mrvoland
Обновяване към Slackware 9.0
Хардуерни и софтуерни проблеми
FreeJak 3 2915 Последна публикация Mar 25, 2003, 00:53
от FreeJak
Slackware
Настройка на програми
ivo3d 1 2233 Последна публикация Mar 27, 2003, 23:53
от ivo3d
Slackware 9.0
Хардуерни и софтуерни проблеми
ivo3d 3 2454 Последна публикация Apr 07, 2003, 03:48
от ivo3d
Bugs in acpi-support
Хардуерни и софтуерни проблеми
Slevin_ 0 1282 Последна публикация Mar 30, 2008, 12:47
от Slevin_