Автор Тема: Gaim + OpenSSL  (Прочетена 1541 пъти)

amnesiac

  • Участници
  • ***
  • Публикации: 7
    • Профил
Gaim + OpenSSL
« -: Apr 03, 2005, 02:12 »
Едва ли някой ще иска да знае, но аз все пак ще се похваля.

Аз гледам да имам инсталирани колкото се може по-малко неща, като част от причината за това е, че нямам пакетен мениджър. Всичките ми инсталирани неща, които искат SSL/TLS, ползват OpenSSL. Обаче Gaim не иска, защото лицензите им били несъвместими, а на мен ми трябва SSL за MSN плъгина (шефа иска да си говорим с него). Доста време търсих патч, но сигурно не съм търсил добре и не намерих.

Така реших и успях да накарам Gaim да ползва OpenSSL за SSL/TLS поддръжка. Не беше трудно, но все пак нямах никакви познания за Gaim и SSL/TLS.
Активен

the_real_maniac

  • Напреднали
  • *****
  • Публикации: 1258
  • Kernel panic, me - no panic ;-) :-)
    • Профил
Gaim + OpenSSL
« Отговор #1 -: Apr 03, 2005, 12:18 »
Хъх ...

Това твоето , ако трябва да му се дава някакво име е "дуене" (и така поставено лично за мен е смешно и трагично).

Искаш да се похвалиш , ами добре направи го - кажи как си се борил и си успял да го пребориш проблема.
Активен

Powered by Debian GNU / LINUX /// Intel inside ...

„Насилието е последното убежище на некомпетентността“ - Айзък Азимов (1920 — 1992)

alabal

  • Напреднали
  • *****
  • Публикации: 2173
  • cat /earth/europe/bg/sofia | grep Nacamura
    • Профил
Gaim + OpenSSL
« Отговор #2 -: Apr 03, 2005, 16:02 »
Мисля, че го пише нейде из FAQ секцията на Gaim. Ползат се nss и nrsp на Mozilla. Ако конфигурираш от сорсе трябва да е така:
./configure --with-nss --with-nspr
А че си се справил без тези пакети на Mozilla - браво - пиши на Gaim - ще се зарадват.
Активен

It makes you awful glad that you were born a man.

amnesiac

  • Участници
  • ***
  • Публикации: 7
    • Профил
Gaim + OpenSSL
« Отговор #3 -: Apr 03, 2005, 19:10 »
Добре де, не съм очаквал кой знае какво разбиране.

За не чак толкова челите и запознатите ще кажа, че OpenSSL вече не се поддържа официално от Gaim, защото лицензите им са несъвместими. Официално се поддържат GNUTLS и NSS, но не и OpenSSL. Това не е лошо, но все пак да инсталирам GNUTLS само за една програма или пък още една версия на NSS освен несъвместимата с Gaim, инсталирана от Firefox...

Това, което направих бе, че написах по подобие на GNUTLS и NSS поддръжка за OpenSSL в SSL плъгина на Gaim и добавих опции за OpenSSL в configure скрипта и съответните Makefile-ове.
Активен

  • Гост
Gaim + OpenSSL
« Отговор #4 -: Apr 03, 2005, 22:26 »
Браво.
Активен

Подобни теми
Заглавие Започната от Отговора Прегледи Последна публикация
Омазах си openssl пакета
Хардуерни и софтуерни проблеми
ivanatora 0 926 Последна публикация Aug 11, 2003, 00:59
от ivanatora
Apache 2.2.2 с openssl 0.9.8b
Настройки на софтуер
never_mind 3 1728 Последна публикация Jul 12, 2006, 17:34
от never_mind
Openssl nist валидация
Идеи и мнения
growchie 0 1115 Последна публикация Jul 27, 2006, 11:56
от growchie
Apache1.3+mod_ssl+openssl
Хардуерни и софтуерни проблеми
_rincewind 2 1704 Последна публикация Jan 04, 2008, 18:59
от _rincewind
openssl pkcs12 private key password
Хардуерни и софтуерни проблеми
lod 2 3496 Последна публикация Jan 15, 2010, 13:57
от lod