Автор Тема: Слагaли ли сте Viber за десктоп/linux  (Прочетена 3814 пъти)

spec1a

  • Напреднали
  • *****
  • Публикации: 2142
    • Профил
Re: Слагaли ли сте Viber за десктоп/linux
« Отговор #15 -: Nov 13, 2021, 11:27 »
   A centos 8/centos stream ?

Иначе варианта с виртуалката е добър,но аз бих си сложил убунту или минт.
Активен

Nik123

  • Напреднали
  • *****
  • Публикации: 1072
  • Distribution: Mageia
    • Профил
Re: Слагaли ли сте Viber за десктоп/linux
« Отговор #16 -: Nov 13, 2021, 11:28 »
Нака, при мен тази версия за PCLOS работи на Магея 6. Долу са му написани зависимостите. При мен ги имаше в мирърите на магеята.

https://pclinuxos.pkgs.org/rolling/pclinuxos-x86_64/viber-13.3.1.22-1pclos2021.x86_64.rpm.html

Не знам дали би тръгнала на CentOS, но ако ти се занимава, може да пробваш.
Активен

"-Аз съм орех и приличам на мозък!" "-Аз съм карфиол и приличам на дърво!" "-А аз съм гъба и мразя тази игра.. "

Naka

  • Напреднали
  • *****
  • Публикации: 3108
    • Профил
Re: Слагaли ли сте Viber за десктоп/linux
« Отговор #17 -: Nov 13, 2021, 12:17 »
Цитат
Магея 6

Аз едно време бях фен на Мандрейк. Имаше един период от време, когато Мандрейк беше по добър от редхат-а, а пък имаше пълна съвместимост. От тогова не съм я ползвал, но предползгам духа на дистрибуцията се е запазаил.

Незнам дали знаеш но glibc е основната библиотека в линукса. По важен компонет е дори от кърнела. И всичко, всички други библиотеки завиясят от нея. Ако там има зависимост нищо нищо не може да се направи. Смяната на glibc е равносилна на смяна на дистрибуцията.....Поне в редхатите е така.

Но ще пробвам пакета от маге-та да видим какво ще каже.....
Активен

Perl - the only language that looks the same before and after encryption.

Nik123

  • Напреднали
  • *****
  • Публикации: 1072
  • Distribution: Mageia
    • Профил
Re: Слагaли ли сте Viber за десктоп/linux
« Отговор #18 -: Nov 16, 2021, 20:36 »
Naka, тръгна ли вайбъра?
П.П. Това, което съм посочил като линк, не е пакет на магеята, а на PCLinuxOS, но работи на магеята, .rpm е.
Активен

"-Аз съм орех и приличам на мозък!" "-Аз съм карфиол и приличам на дърво!" "-А аз съм гъба и мразя тази игра.. "

Naka

  • Напреднали
  • *****
  • Публикации: 3108
    • Профил
Re: Слагaли ли сте Viber за десктоп/linux
« Отговор #19 -: Nov 16, 2021, 20:57 »
Нямах време да го пробвам.

Но тръгна във виртуалка с Дебиан 11.....от официалбия пакет от страницата на вайбър някакъв бинарен пакет viber.AppImage    ??? (пълна мистика, какво има вътре), който нищо не инсталира...само се стартира...

Само че нещо този дебиан 11 не ми харесва  >:(
Ще пробвам и mint. ... както много съфорумци препоръчаха.... :)
Активен

Perl - the only language that looks the same before and after encryption.

go_fire

  • Global Moderator
  • Напреднали
  • *****
  • Публикации: 7003
  • Distribution: Дебиан Сид
  • Window Manager: ROX-Desktop / е17
  • кашик с гранатомет в танково поделение
    • Профил
    • WWW
Re: Слагaли ли сте Viber за десктоп/linux
« Отговор #20 -: Nov 16, 2021, 21:09 »
AppImage е продължение на идеята на Rox filer app folder, което реално ще рече — RISK OS. Ако се сещате преди имаше едно Zero install, то е предтечата на AppImage. После имаше едно pen linux. Та в общи линии app folder е почти като зандан (jail, chroot, zones), но е опакован и се монтира в движение.

Проблема е, както каза Наката, че не е точно пълна изолация. Например най-големия проблем е glibc. Но далеч не е само той. Например един Ungoogled Chromium е абсурд да го пуснеш по този начин. Трябва да ти обновена кажи-речи цялата система. А то, ако е така, просто си го слагаш от пакет.

Аз с AppImage най-често пускам лубимата си игрица — supertux.org. Много ме кефи да си подскачам. И с всяка версия ефектите са все по-яки. Имах статия за нея във вестника за версия 0,3.

Активен

В $por4e2 e истината  ;)

***

Aко даваха стипендия за най-глупави, щях да съм човека с най-много Mини Kупъри

***

Reborn since 1998 || 15.09.2007 totally М$ free && conscience clear

Nik123

  • Напреднали
  • *****
  • Публикации: 1072
  • Distribution: Mageia
    • Профил
Re: Слагaли ли сте Viber за десктоп/linux
« Отговор #21 -: Nov 16, 2021, 21:31 »
Е явно си го подкарал, пък там виртуалка ли било, дебиан ли било, важното е да ти върши работа.
Активен

"-Аз съм орех и приличам на мозък!" "-Аз съм карфиол и приличам на дърво!" "-А аз съм гъба и мразя тази игра.. "

Naka

  • Напреднали
  • *****
  • Публикации: 3108
    • Профил
Re: Слагaли ли сте Viber за десктоп/linux
« Отговор #22 -: Nov 17, 2021, 11:17 »
В интерес на спорта пробвах и версията на PCLinuxOS.

Цитат
[root@sabi 4]# rpm -ivh viber-13.3.1.22-1pclos2021.x86_64.rpm
error: Failed dependencies:
        gstreamer1.0-plugins-base is needed by viber-13.3.1.22-1pclos2021.x86_64
        gstreamer1.0-libav is needed by viber-13.3.1.22-1pclos2021.x86_64
        gstreamer1.0-plugins-bad is needed by viber-13.3.1.22-1pclos2021.x86_64
        gstreamer1.0-plugins-good is needed by viber-13.3.1.22-1pclos2021.x86_64
        gstreamer1.0-plugins-ugly is needed by viber-13.3.1.22-1pclos2021.x86_64
        lib64pulseaudio0 is needed by viber-13.3.1.22-1pclos2021.x86_64
        lib64nss3 is needed by viber-13.3.1.22-1pclos2021.x86_64
        lib64openssl1.0.0 is needed by viber-13.3.1.22-1pclos2021.x86_64
[root@sabi 4]#

Поразгледах ги....Имената на пакетите в центос-а са други са други
например  gstreamer1.0-plugins-base  (PCLinuxOS) e gstreamer1-plugins-base (Центос, без нулата .0), но вътре библиотеките ги имам, че и по нови....Така е и с другите пакети

Обаче след  rpm -ivh --nodeps viber
viber
Цитат
[naka@sabi 4]$ viber
/opt/viber/Viber: /lib64/libstdc++.so.6: version `GLIBCXX_3.4.20' not found (required by /opt/viber/Viber)
/opt/viber/Viber: /lib64/libstdc++.so.6: version `CXXABI_1.3.8' not found (required by /opt/viber/Viber)
/opt/viber/Viber: /lib64/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by /opt/viber/Viber)
/opt/viber/Viber: /lib64/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by /opt/viber/Viber)
/opt/viber/Viber: /lib64/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by /opt/viber/lib/libQt5Sql.so.5)
/opt/viber/Viber: /lib64/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by /opt/viber/lib/libQt5Multimedia.so.5)
/opt/viber/Viber: /lib64/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by /opt/viber/lib/libQt5WebSockets.so.5)
....


Та те така....Пробвах го..Много ми се щеше да го пусна native, без вируалка...
Активен

Perl - the only language that looks the same before and after encryption.

Naka

  • Напреднали
  • *****
  • Публикации: 3108
    • Профил
Re: Слагaли ли сте Viber за десктоп/linux
« Отговор #23 -: Nov 17, 2021, 11:37 »
Та в общи линии app folder е почти като зандан (jail, chroot, zones), но е опакован и се монтира в движение.

Проблема е, както каза Наката, че не е точно пълна изолация. Например най-големия проблем е glibc.

Абе незнам какъв jail е, обаче пише в хоме директорията. А щом пише там значи може да пише навсякъде по юзера.



Активен

Perl - the only language that looks the same before and after encryption.

Подобни теми
Заглавие Започната от Отговора Прегледи Последна публикация
Dual boot Linux and Windows XP (Linux installed first) ПРОБЛЕМ !!!
Настройка на програми
XaMeLeOnA 36 34914 Последна публикация Nov 06, 2011, 02:58
от Compare
Проблем с viber
Настройка на програми
ivakaa 3 2020 Последна публикация Sep 17, 2014, 09:34
от Ekspert
Viber
Настройка на програми
gogov1111 4 2457 Последна публикация Oct 10, 2016, 00:15
от gogov1111
Отново за Viber
Настройка на програми
gogov1111 2 1704 Последна публикация Dec 11, 2016, 22:50
от bazu
VIBER за Elive 3.0 stable...
Настройка на програми
tukmak 1 1107 Последна публикация Sep 20, 2018, 11:18
от lastcyrol