Автор Тема: Mail server!  (Прочетена 3362 пъти)

tishovo

  • Участници
  • ***
  • Публикации: 10
    • Профил
Mail server!
« -: Jan 21, 2007, 14:53 »
Здравейте,
проблема ми е следния. На машина с Debian Etch съм инсталирал mail-server като се водих по  ръководството на господин Н. Антонов от тук.
Postfix Admin Setup Checker-а казва че всичко е OK, но когато кликна на "admin section" ми излиза следното съобщение:

Warning: pg_last_error() [function.pg-last-error]: No PostgreSQL link opened yet in /var/www/postfixadmin/functions.inc.php on line 925

малко инфо: OS Debian Etch, PostgreSQL 7.4

1. server:/mail# netstat -tanp | grep 5432
tcp        0      0 0.0.0.0:5432            0.0.0.0:*               LISTEN     2654/postmaster
tcp        0      0 127.0.0.1:5432          127.0.0.1:54046         TIME_WAIT  -
tcp6       0      0 :::5432                 :::*                    LISTEN     2654/postmaster

2. В php.ini съм добавил този ред extension=pgsql.so

3. server:/mail# psql -U postfix postfix
Welcome to psql 7.4.14, the PostgreSQL interactive terminal.

Type:  \copyright for distribution terms
       \h for help with SQL commands
       \? for help on internal slash commands
       \g or terminate with semicolon to execute query
       \q to quit

Ако някой може да помогне ще съм много благодарен.
Активен

tishovo

  • Участници
  • ***
  • Публикации: 10
    • Профил
Mail server!
« Отговор #1 -: Jan 21, 2007, 15:41 »
Сега виждам това в /var/log/mail.log

Jan 21 17:51:41 ms postfix/trivial-rewrite[4222]: warning: connect to pgsql server localhost: FATAL:  IDENT authentication failed for user "postfix"?
Jan 21 17:51:41 ms postfix/trivial-rewrite[4222]: warning: connect to pgsql server localhost: FATAL:  IDENT authentication failed for user "postfix"?
Jan 21 17:51:41 ms postfix/trivial-rewrite[4222]: fatal: pgsql:/etc/postfix/pgsql_virtual_alias_maps.cf(0,lock|fold_fix): table lookup problem
Jan 21 17:51:42 ms postfix/qmgr[4209]: warning: premature end-of-input on private/rewrite socket while reading input attribute name
Jan 21 17:51:42 ms postfix/qmgr[4209]: warning: problem talking to service rewrite: Success
Jan 21 17:51:42 ms postfix/master[4203]: warning: process /usr/lib/postfix/trivial-rewrite pid 4222 exit status 1
Jan 21 17:51:42 ms postfix/master[4203]: warning: /usr/lib/postfix/trivial-rewrite: bad command startup -- throttling

А във /var/log/mail.err трупа това:

Jan 21 19:24:31 ms postfix/trivial-rewrite[5228]: fatal: pgsql:/etc/postfix/pgsql_virtual_alias_maps.cf(0,lock|fold_fix): table lookup problem



Активен

n_antonov

  • Напреднали
  • *****
  • Публикации: 1185
    • Профил
    • WWW
Mail server!
« Отговор #2 -: Jan 21, 2007, 23:22 »
Здравей,

Най-вероятно PGSQL не слуша на TCP сокет, както е по подразбиране във версията за Etch.

Трябва да имаш:

'tcpip_socket = true'

Това се отнася за файла '/etc/postgresql/7.4/main/postgresql.conf'.
Активен

-------------------------------------------------------------------------
./debian/rules

n_antonov

  • Напреднали
  • *****
  • Публикации: 1185
    • Профил
    • WWW
Mail server!
« Отговор #3 -: Jan 22, 2007, 13:43 »
Опс, извинявай, сега видях, че PGSQL-а слуша на TCP. Значи единствената причина да се получава това е липсата на правилни настройки в pg_hba.conf.
Активен

-------------------------------------------------------------------------
./debian/rules

tishovo

  • Участници
  • ***
  • Публикации: 10
    • Профил
Mail server!
« Отговор #4 -: Jan 22, 2007, 18:18 »
Благодаря за бързото съдействие, точно това се оказа причината. Май не съм внимавал много в онази част от HOWTO-то в която се обеснява настройката на pg_hba.conf '<img'>. Сега обаче Postfix admin се опитва да ми говори на кирилица и всичко ми излиза на символи в браузъра и на всяко цъкване трябва да сменям енкодинга на cp1251. Опитах да  сменя езика да е на английски но нещо не успявам засега.
Активен

mom

  • Напреднали
  • *****
  • Публикации: 266
  • Distribution: Ubuntu
  • Window Manager: Compiz
    • Профил
Mail server!
« Отговор #5 -: Jan 22, 2007, 19:33 »
Я погледни в /etc/apache/httpd.conf дали ти е включен AddDefaultCharset? Ако да - коментирай го и рестартирай apache-а
Активен

tishovo

  • Участници
  • ***
  • Публикации: 10
    • Профил
Mail server!
« Отговор #6 -: Jan 22, 2007, 21:01 »
Мерси mom, правилно ме насочи. Само че го разкоментирах и промених на "AddDefaultCharset CP-1251". В Debian файла е /etc/apache2/apache2.conf. Сега кирилицата в браузера е наред.



Активен

tishovo

  • Участници
  • ***
  • Публикации: 10
    • Профил
Mail server!
« Отговор #7 -: Jan 23, 2007, 00:32 »
Хмм, така се вижда добре, но само с Opera?!?! Със Firefox и IE си е същата маймуница? wtf?! ':crazy:'



Активен