Автор Тема: проблем с radeon 9250  (Прочетена 4251 пъти)

hateati

  • Напреднали
  • *****
  • Публикации: 32
    • Профил
проблем с radeon 9250
« -: Mar 21, 2007, 23:49 »
здравейте,
имам проблем с подкарването на ATI Radeon 9250.ровичках из гуглето, влизах във форуми, блогове и т.н., ама все тая. '<img'>
инсталирах Mandriva 2007, след рестарта Х ми заби, екрана стана черен а клавиатурата блокира.с много зор успях да се добера до страницата на ATI  и свалих fglrx_6_8_0-8.28.8-1.i386.rpm и ati-driver-installer-8.28.8.run.
ati-driver-installer-8.28.8.run ми изкарва следното съобщение
Примерен код
Detected configuration:
Architecture: i686 (32-bit)
X Server: Xorg 7.1.1
find: install/usr/X11R6/lib/modules/dri: No such file or directory
find: install/usr/bin/fireglcontrolpanel: No such file or directory

с fglrx_6_8_0-8.28.8-1.i386.rpm успях да кача некви драйвери обаче не ми тръгва 3d.
fglrxinfo ми изкарва
Примерен код
X Error of failed request:  GLXBadContext
  Major opcode of failed request:  144 (GLX)
  Minor opcode of failed request:  5 (X_GLXMakeCurrent)
  Serial number of failed request:  15
  Current serial number in output stream:  15

а aticonfig
Примерен код
Found fglrx primary device section
Nothing to do, terminating.


тва е xorg.conf
Примерен код
# File generated by XFdrake (rev 57713)
# **********************************************************************
# Refer to the xorg.conf man page for details about the format of
# this file.
# **********************************************************************

Section "ServerLayout"
   Identifier     "layout1"
   Screen      0  "aticonfig-Screen[0]" 0 0
   InputDevice    "Keyboard1" "CoreKeyboard"
   InputDevice    "Mouse1" "CorePointer"
EndSection

Section "Files"

    # font server independent of the X server to render fonts.
    # minimal fonts to allow X to run without xfs
   FontPath     "unix/:-1"
   FontPath     "/usr/share/fonts/misc:unscaled"
EndSection

Section "Module"
   Load  "dbe" # Double-Buffering Extension
   Load  "v4l" # Video for Linux
   Load  "extmod"
   Load  "type1"
   Load  "freetype"
   Load  "glx" # 3D layer
   Load  "dri" # direct rendering
EndSection

Section "ServerFlags"

    #DontZap # disable <Crtl><Alt><BS> (server abort)
 # allows the server to start up even if the mouse does not work
    #DontZoom # disable <Crtl><Alt><KP_+>/<KP_-> (resolution switching)
   Option       "allowmouseopenfail"
EndSection

Section "InputDevice"
   Identifier  "Keyboard1"
   Driver      "kbd"
   Option       "XkbModel" "pc105"
   Option       "XkbLayout" "us,bg(phonetic)"
   Option       "XkbOptions" "grp:alt_shift_toggle,grp_led:scroll,compose:rwin"
EndSection

Section "InputDevice"
   Identifier  "Mouse1"
   Driver      "mouse"
   Option       "Protocol" "ExplorerPS/2"
   Option       "Device" "/dev/mouse"
EndSection

Section "Monitor"

    # Monitor preferred modeline (60.0 Hz vsync, 64.0 kHz hsync, ratio 5/4)
   Identifier   "monitor1"
   VendorName   "Plug'n Play"
   ModelName    "Philips 170C"
   HorizSync    30.0 - 83.0
   VertRefresh  56.0 - 76.0
   ModeLine     "1280x1024" 108.0 1280 1328 1440 1688 1024 1025 1028 1066 +hsync +vsync
   ModeLine     "768x576" 50.0 768 832 846 1000 576 590 595 630
   ModeLine     "768x576" 63.1 768 800 960 1024 576 578 590 616
EndSection

Section "Monitor"
   Identifier   "aticonfig-Monitor[0]"
   Option       "VendorName" "ATI Proprietary Driver"
   Option       "ModelName" "Generic Autodetecting Monitor"
   Option       "DPMS" "true"
EndSection

Section "Device"
   Identifier  "device1"
   Driver      "ati"
   VendorName  "ATI Technologies Inc."
   BoardName   "ATI Radeon (fglrx)"
   Option       "DPMS"
   Option       "XaaNoOffscreenPixmaps" "1"
EndSection

Section "Device"
   Identifier  "aticonfig-Device[0]"
   Driver      "fglrx"
EndSection

Section "Screen"
   Identifier "screen1"
   Device     "device1"
   Monitor    "monitor1"
   DefaultDepth     16
   SubSection "Display"
      Depth     8
      Modes    "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
   EndSubSection
   SubSection "Display"
      Depth     15
      Modes    "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
   EndSubSection
   SubSection "Display"
      Depth     16
      Modes    "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
   EndSubSection
   SubSection "Display"
      Depth     24
      Modes    "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
   EndSubSection
EndSection

Section "Screen"
   Identifier "aticonfig-Screen[0]"
   Device     "aticonfig-Device[0]"
   Monitor    "aticonfig-Monitor[0]"
   DefaultDepth     24
   SubSection "Display"
      Viewport   0 0
      Depth     24
   EndSubSection
EndSection

Section "Extensions"
   Option       "Composite"
EndSection


ми някой ко може да помогне, да свирка, аз ше наминавам.



Активен

hateati

  • Напреднали
  • *****
  • Публикации: 32
    • Профил
проблем с radeon 9250
« Отговор #1 -: Mar 22, 2007, 18:57 »
никой ли няма да изкаже поне предположение  '<img'>
Активен

pvt

  • Напреднали
  • *****
  • Публикации: 35
  • Distribution: Kubuntu
  • Window Manager: KDE
    • Профил
проблем с radeon 9250
« Отговор #2 -: Mar 22, 2007, 21:15 »
Аз имам същата карта, но съм с друго дистро, така че не мога да ти дам дейтайлни съвети. Проблемът с нея е, че ATI вече не я поддържат, но пък си има свободни драйвери radeon със сносно 3D (quake3, beryl).

Ей тук (beranger.org) има кратко напътствие за сходен с твоя случай, виж дали ще ти бъде от полза.
Активен

hateati

  • Напреднали
  • *****
  • Публикации: 32
    • Профил
проблем с radeon 9250
« Отговор #3 -: Mar 22, 2007, 23:22 »
благодаря ти pvt14.всъщност това което е обяснено в линка ти вече съм го правил и не проработи, тоест имаше частичен успех защото поне успя да ми подкара Х, но само дотам.като отворех някоя програма или квото и да е, липсваха бутоните за минимизаране и затваряне, не беше само тва ма не ми се разпростира повече, въпреки всичко, благодаря!

edit:
само искам да добавя, че винаги съм имал проблем с драйверите на ATI, под линукс.
с предната rage fury, имах сходен проблем, инсталацията ми протичаше нормално но след рестарта Х забиваше зверски по абсолютно същия начин, тогава, както и сега междувпрочем, опитах няколко дистрибуции ... все тая.накрая взех да си мисля, че е няква несъвместимост между proview-то ми и видеото, сега обаче смених монитора и тцъ, никъв ефект.явно проблема е в ATI.така че да го духат!тва последното няма много отношение към темата и едва ли ше ми олекне като го споделя, ама все пак ...



Активен

pvt

  • Напреднали
  • *****
  • Публикации: 35
  • Distribution: Kubuntu
  • Window Manager: KDE
    • Профил
проблем с radeon 9250
« Отговор #4 -: Mar 23, 2007, 02:29 »
'<img'> Да, Ати са ни приятели, много ги обичам и аз. И точно с Мандрива, 2006 ,целият ми екран беше лилав, но това е друга тема. Съжалявам, дано някой друг успее да ти помогне. Ето за всеки случай как ми изглежда моят xorg.conf - съответната част, закоментираните работи съм ги оставил от времето, когато настройвах Берил:

Примерен код


[...]

  Option        "Type"          "cursor"
  Option        "ForceDevice"   "ISDV4"               # Tablet PC ONLY
EndSection

Section "Device"
   Identifier   "ATI Technologies, Inc. RV280 [Radeon 9200 PRO]"
   Driver      "radeon"
#   Option      "DRI" "true"
#   Option      "AccelMethod" "EXA"
# Comment the FOLLOWING 2 lines if in trouble
#   Option      "AccelMethod" "XAA"
#   Option      "XAANoOffscreenPixmaps" "true"
#   Option      "RenderAccel" "true"
   Option      "AGPMode" "8"
#   Option      "AGPFastWrite" "yes"
   BusID      "PCI:1:0:0"
   Option      "UseFBDev" "true"
   Option      "EnablePageFlip" "true"
   Option      "ColorTiling" "on"
EndSection

Section "Monitor"
   Identifier   "AOC HT7x1"
   Option      "DPMS"
EndSection

Section "Screen"
   Identifier   "Default Screen"
   Device      "ATI Technologies, Inc. RV280 [Radeon 9200 PRO]"
   Monitor      "AOC HT7x1"
   DefaultDepth   24
   SubSection "Display"
      Depth      1
      Modes      "1280x1024" "1280x960" "1024x768" "800x600" "640x480"
   EndSubSection

[...]





Активен

ray

  • Напреднали
  • *****
  • Публикации: 1456
    • Профил
проблем с radeon 9250
« Отговор #5 -: Mar 23, 2007, 02:39 »
Здравейте,
За съжаление не е за Мандрива, но ето линк за ATI (до 9200/9250 е със свободния драйвер) - http://www.gentoo.org/doc/en/ati-faq.xml.
При мен (9200-ПРо) работи без проблеми (доколкото знам 9250 е съвместим със 9200 - чипсети: R200, R250, R280).
Успех. Румен
Активен

hateati

  • Напреднали
  • *****
  • Публикации: 32
    • Профил
проблем с radeon 9250
« Отговор #6 -: Mar 23, 2007, 09:02 »
благодаря ви!довечера, като ми остане повечко време, ще я мисля пак  '<img'>
Активен

Подобни теми
Заглавие Започната от Отговора Прегледи Последна публикация
ATI All In Wonder Radeon
Настройка на хардуер
dmvic 0 3294 Последна публикация Oct 29, 2002, 02:04
от dmvic
Ati radeon 9250
Настройка на хардуер
Bu7cher 1 2942 Последна публикация Jun 13, 2007, 20:33
от Todir
Tv out на radeon 9250 под Убунту
Настройка на хардуер
digitalbeast 7 3644 Последна публикация Jul 05, 2007, 13:08
от triplek
Проглем с ATI Radeon 9250 Хардоер
Настройка на хардуер
Pmen 2 3348 Последна публикация Dec 24, 2009, 22:54
от tyuio
ATI RADEON 9250 проблем с драивърите
Десктопи
ZaK4o 7 5176 Последна публикация Aug 21, 2010, 11:09
от ROKO__