Автор Тема: Проблем с Apache  (Прочетена 1258 пъти)

gergito

  • Участници
  • ***
  • Публикации: 7
    • Профил
Проблем с Apache
« -: Sep 14, 2009, 12:20 »
Здравейте,

става въпрос за CentOS 4 - до вчера Apache-то си работеше нормално без никакви проблеми,
и изведнъж умря.
В лога има следните записи:

[Mon Sep 14 03:04:26 2009] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
[Mon Sep 14 03:04:28 2009] [notice] Digest: generating secret for digest authentication ...
[Mon Sep 14 03:04:28 2009] [notice] Digest: done
[Mon Sep 14 03:04:28 2009] [notice] LDAP: Built with OpenLDAP LDAP SDK
[Mon Sep 14 03:04:28 2009] [notice] LDAP: SSL support unavailable
[Mon Sep 14 03:04:28 2009] [notice] FastCGI: process manager initialized (pid 9237)
[Mon Sep 14 03:04:28 2009] [alert] FastCGI: read() from pipe failed (0)
[Mon Sep 14 03:04:28 2009] [alert] FastCGI: the PM is shutting down, Apache seems to have disappeared - bye

Като проверя статуса на Apache-то ми дава:

# service httpd status
httpd dead but subsys locked
#

Търсих в Google  за "httpd dead but subsys locked", и за последните два реда от лога,
почти навсякъде пише да се изтрият httpd.pid файла и lock файла от /var/lock/subsys/
и да се пробва да се пусне.
При мен httpd.pid го няма, а след като изтрия # rm -f /var/lock/subsys/httpd, ми дава на
# service httpd status
httpd is stopped
но след старт пак същото - httpd dead but subsys locked.

Някакви идеи и препоръки ?
Активен

ntrance

  • Напреднали
  • *****
  • Публикации: 696
    • Профил
Re: Проблем с Apache
« Отговор #1 -: Sep 14, 2009, 13:58 »
Килни процеса
1.во това ако не стане по долнуто    killall -9 apache2 ili httpd
ps -aux |grep apache2   ili httpd  и му виждаш процеса който си седи ...  после killall -9  номера на процеса  и старт да видим лога какво ще  каже
Активен

gergito

  • Участници
  • ***
  • Публикации: 7
    • Профил
Re: Проблем с Apache
« Отговор #2 -: Sep 14, 2009, 14:07 »
Ами то не се стартира .. няма процес, липсва httpd.pid .. рестартирах няколко пъти машината резултата е същия.
Махнах FastCGI - не помогна, добавих ServerName localhost .. итрих /var/lock/subsystem/httpd .. търсих httpd.pid .. пуснах update с yum и ми вдигна версията .. пак същото не иска да тръгва ..
Активен

RealEnder

  • Напреднали
  • *****
  • Публикации: 160
  • Distribution: Ubuntu
  • Window Manager: Unity
    • Профил
    • WWW
Re: Проблем с Apache
« Отговор #3 -: Sep 14, 2009, 14:20 »
А след като прочисти конфигурацията какво има в error лога? Опитай да го стартираш от терминала, там ще ти изплюе също някакви съобщения...
Активен

gergito

  • Участници
  • ***
  • Публикации: 7
    • Профил
Re: Проблем с Apache
« Отговор #4 -: Sep 14, 2009, 14:33 »
Аз от конзолата се мъча да го пусна . По принцип нищо не ми дава като грешка даже като го стартирам с :
#service httpd start .. ми дава [OK] .. ама като заредя сайта неще .. на #service httpd status ми дава : httpd dead but subsys locked .. и трябва да трия ръчно /var/lock/subsystem/httpd .. като стартирам с : #apachectl start , после на # apachectl status ми дава : ERROR at dump.c:188: Connection refused а на #service httpd status ако съм изтрил lock-a #httpd is stopped .. сбъркана работа.
Активен

RealEnder

  • Напреднали
  • *****
  • Публикации: 160
  • Distribution: Ubuntu
  • Window Manager: Unity
    • Профил
    • WWW
Re: Проблем с Apache
« Отговор #5 -: Sep 14, 2009, 14:41 »
Свали летвата за LogLevel по-ниско: http://httpd.apache.org/docs/2.2/mod/core.html#loglevel
Барем напише нещо, че понякога апаха е малко мълчалив
Активен

gergito

  • Участници
  • ***
  • Публикации: 7
    • Профил
Re: Проблем с Apache
« Отговор #6 -: Sep 14, 2009, 14:51 »
LogLevel debug
=================================================================================================
[Mon Sep 14 06:57:58 2009] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
[Mon Sep 14 06:57:58 2009] [info] Init: Initializing OpenSSL library
[Mon Sep 14 06:57:58 2009] [info] Init: Seeding PRNG with 256 bytes of entropy
[Mon Sep 14 06:57:58 2009] [info] Init: Generating temporary RSA private keys (512/1024 bits)
[Mon Sep 14 06:57:58 2009] [info] Init: Generating temporary DH parameters (512/1024 bits)
[Mon Sep 14 06:57:58 2009] [info] Init: Initializing (virtual) servers for SSL
[Mon Sep 14 06:57:58 2009] [info] Server: Apache/2.0.52, Interface: mod_ssl/2.0.52, Library: OpenSSL/0.9.7a
[Mon Sep 14 06:57:59 2009] [notice] Digest: generating secret for digest authentication ...
[Mon Sep 14 06:57:59 2009] [notice] Digest: done
[Mon Sep 14 06:57:59 2009] [debug] util_ldap.c(1256): LDAP merging Shared Cache conf: shm=0x9817c28 rmm=0x9817c48 for VHOST: http://www.domain.com
........... /същото за всички VHOST/
[Mon Sep 14 06:57:59 2009] [debug] util_ldap.c(1256): LDAP merging Shared Cache conf: shm=0x9817c28 rmm=0x9817c48 for VHOST: http://www.domainxx.net
[Mon Sep 14 06:57:59 2009] [notice] LDAP: Built with OpenLDAP LDAP SDK
[Mon Sep 14 06:57:59 2009] [notice] LDAP: SSL support unavailable
[Mon Sep 14 06:57:59 2009] [notice] FastCGI: process manager initialized (pid 10283)
[Mon Sep 14 06:57:59 2009] [info] Init: Initializing OpenSSL library
[Mon Sep 14 06:57:59 2009] [info] Init: Seeding PRNG with 256 bytes of entropy
[Mon Sep 14 06:57:59 2009] [info] Init: Generating temporary RSA private keys (512/1024 bits)
[Mon Sep 14 06:57:59 2009] [info] Init: Generating temporary DH parameters (512/1024 bits)
[Mon Sep 14 06:57:59 2009] [debug] ssl_scache_shmcb.c(364): shmcb_init allocated 512000 bytes of shared memory
[Mon Sep 14 06:57:59 2009] [debug] ssl_scache_shmcb.c(550): entered shmcb_init_memory()
[Mon Sep 14 06:57:59 2009] [debug] ssl_scache_shmcb.c(572): for 512000 bytes, recommending 4266 indexes
[Mon Sep 14 06:57:59 2009] [debug] ssl_scache_shmcb.c(615): shmcb_init_memory choices follow
[Mon Sep 14 06:57:59 2009] [debug] ssl_scache_shmcb.c(617): division_mask = 0x1F
[Mon Sep 14 06:57:59 2009] [debug] ssl_scache_shmcb.c(619): division_offset = 64
[Mon Sep 14 06:57:59 2009] [debug] ssl_scache_shmcb.c(621): division_size = 15998
[Mon Sep 14 06:57:59 2009] [debug] ssl_scache_shmcb.c(623): queue_size = 1604
[Mon Sep 14 06:57:59 2009] [debug] ssl_scache_shmcb.c(625): index_num = 133
[Mon Sep 14 06:57:59 2009] [debug] ssl_scache_shmcb.c(627): index_offset = 8
[Mon Sep 14 06:57:59 2009] [debug] ssl_scache_shmcb.c(629): index_size = 12
[Mon Sep 14 06:57:59 2009] [debug] ssl_scache_shmcb.c(631): cache_data_offset = 8
[Mon Sep 14 06:57:59 2009] [debug] ssl_scache_shmcb.c(633): cache_data_size = 14386
[Mon Sep 14 06:57:59 2009] [debug] ssl_scache_shmcb.c(646): leaving shmcb_init_memory()
[Mon Sep 14 06:57:59 2009] [info] Shared memory session cache initialised
[Mon Sep 14 06:57:59 2009] [info] Init: Initializing (virtual) servers for SSL
[Mon Sep 14 06:57:59 2009] [info] Server: Apache/2.0.52, Interface: mod_ssl/2.0.52, Library: OpenSSL/0.9.7a
[Mon Sep 14 06:57:59 2009] [alert] FastCGI: read() from pipe failed (0)
[Mon Sep 14 06:57:59 2009] [alert] FastCGI: the PM is shutting down, Apache seems to have disappeared - bye
=================================================================================================
Активен

RealEnder

  • Напреднали
  • *****
  • Публикации: 160
  • Distribution: Ubuntu
  • Window Manager: Unity
    • Профил
    • WWW
Re: Проблем с Apache
« Отговор #7 -: Sep 14, 2009, 15:00 »
Остави му само базовите модули да видим дали ще тръгне, след това по един по един ги разкоментарявай тези, които ти трябват.
Активен

gergito

  • Участници
  • ***
  • Публикации: 7
    • Профил
Re: Проблем с Apache
« Отговор #8 -: Sep 14, 2009, 15:32 »
и това не помага за съжаление  :(
Активен

gergito

  • Участници
  • ***
  • Публикации: 7
    • Профил
Re: Проблем с Apache
« Отговор #9 -: Sep 15, 2009, 15:41 »
Не можах да го възстановя и днес преинсталирах.. Сега всичко е ОК
Благодаря за съветите.  [_]3
Активен

Подобни теми
Заглавие Започната от Отговора Прегледи Последна публикация
Apache 2.0.48
Настройка на програми
O_M_E_G_A 0 2574 Последна публикация Jan 23, 2004, 22:45
от O_M_E_G_A
APACHE SQL PHP RED HAT
Общ форум
svetoslav 3 4055 Последна публикация Mar 09, 2004, 14:43
от svetoslav
SQL PHP APACHE
Настройка на програми
svetoslav 1 3147 Последна публикация Mar 11, 2004, 04:09
от Acidtrance
Apache  неволи :-)
Настройка на програми
maniac 5 4330 Последна публикация Mar 15, 2004, 17:46
от maniac
Apache + PHP
Настройка на програми
Lukather 4 2075 Последна публикация Mar 17, 2004, 08:53
от Lukather