Автор Тема: Искам да инсталирам Debian или Mint вместо сегашния ми Manjaro XFCE  (Прочетена 13632 пъти)

go_fire

  • Global Moderator
  • Напреднали
  • *****
  • Публикации: 7964
  • Distribution: Дебиан Сид
  • Window Manager: ROX-Desktop / е17
  • кашик с гранатомет в танково поделение
    • Профил
    • WWW
Доколкото виждам трябва да се обнови самият Пакман. И изобщо по принцип преди да се инсталира нещо е добре да се обнови цялата система.
Активен

В $por4e2 e истината  ;)

***

Aко даваха стипендия за най-глупави, щях да съм човека с най-много Mини Kупъри

***

Reborn since 1998 || 15.09.2007 totally М$ free && conscience clear

3p0

  • Напреднали
  • *****
  • Публикации: 354
    • Профил
Код:
[emil@manjaro ~]$ sudo pacman -Syu
[sudo] password for emil:
:: Synchronizing package databases...
error: failed retrieving file 'basis.db' from mirrors.mycraft.eu : The requested URL returned error: 404 Not Found
 basis is up to date
error: failed retrieving file 'platform.db' from mirrors.mycraft.eu : The requested URL returned error: 404 Not Found
 platform is up to date
error: failed retrieving file 'addon.db' from mirrors.mycraft.eu : The requested URL returned error: 404 Not Found
 addon is up to date
error: failed retrieving file 'extra.db' from mirrors.mycraft.eu : The requested URL returned error: 404 Not Found
 extra is up to date
error: failed retrieving file 'community.db' from mirrors.mycraft.eu : The requested URL returned error: 404 Not Found
 community is up to date
error: failed retrieving file 'basis-multilib.db' from mirrors.mycraft.eu : The requested URL returned error: 404 Not Found
 basis-multilib is up to date
error: failed retrieving file 'multilib.db' from mirrors.mycraft.eu : The requested URL returned error: 404 Not Found
 multilib is up to date
:: The following packages should be upgraded first :
    manjaro-system  pacman
:: Do you want to cancel the current operation
:: and upgrade these packages now? [Y/n] y

resolving dependencies...
looking for inter-conflicts...
error: failed to prepare transaction (could not satisfy dependencies)
:: package-query: requires pacman<4.1
:: packagekit: requires pacman<4.1.0
[emil@manjaro ~]$ sudo pacman -S pacman
resolving dependencies...
looking for inter-conflicts...
error: failed to prepare transaction (could not satisfy dependencies)
:: package-query: requires pacman<4.1
:: packagekit: requires pacman<4.1.0
[emil@manjaro ~]$

Разбирам , че му търябва пакман, но аз нямам такъв ....
« Последна редакция: May 02, 2013, 14:21 от 3p0 »
Активен

MX Linux version 18 "Continuum"
PC: Intel® Celeron® CPU G540 2.50GHz; MB=Gigabyte GA-H61M-S2V-B3 rev.1.0; RAM=16Гб DDR3.

cybercop

  • Напреднали
  • *****
  • Публикации: 5623
  • Distribution: Ubuntu LTS, CENTOS 6.x
  • Window Manager: Xfce, Gnome 2
    • Профил
Провери си хранилищата :
/etc/pacman.conf

#[testing]
#SigLevel = PackageRequired
#Include = /etc/pacman.d/mirrorlist

[core]
SigLevel = PackageRequired
Include = /etc/pacman.d/mirrorlist

[extra]
SigLevel = PackageRequired
Include = /etc/pacman.d/mirrorlist

#[community-testing]
#SigLevel = PackageRequired
#Include = /etc/pacman.d/mirrorlist

[community]
SigLevel = PackageRequired
Include = /etc/pacman.d/mirrorlist

# Users If you want to run 32 bit applications on your x86_64 system,
# enable the multilib repositories as required here.

#[multilib-testing]
#SigLevel = PackageRequired
#Include = /etc/pacman.d/mirrorlist

#[multilib]
#SigLevel = PackageRequired
#Include = /etc/pacman.d/mirrorlist

# An example of a custom package repository.  See the pacman manpage for
# tips on creating your own repositories.
#[custom]
#SigLevel = Optional TrustAll

При 32 битова система multilib хранилищата не ти трябват.
Активен

Ползването на Linux води до пристрастяване. Факт.
http://s19.postimg.cc/4oajwoq5v/xenial2.png

3p0

  • Напреднали
  • *****
  • Публикации: 354
    • Профил
Код:
[basis]
SigLevel = PackageRequired
Include = /etc/pacman.d/mirrorlist

[platform]
SigLevel = PackageRequired
Include = /etc/pacman.d/mirrorlist

[addon]
SigLevel = PackageRequired
Include = /etc/pacman.d/mirrorlist

[extra]
SigLevel = PackageRequired
Include = /etc/pacman.d/mirrorlist

[community]
SigLevel = PackageRequired
Include = /etc/pacman.d/mirrorlist

# If you want to run 32 bit applications on your x86_64 system,
# enable the multilib repositories as required here.

[basis-multilib]
SigLevel = PackageRequired
Include = /etc/pacman.d/mirrorlist

[multilib]
SigLevel = PackageRequired
Include = /etc/pacman.d/mirrorlist

# An example of a custom package repository.  See the pacman manpage for
# tips on creating your own repositories.
#[custom]
#SigLevel = Optional TrustAll
#Server = file:///home/custompkgs
Активен

MX Linux version 18 "Continuum"
PC: Intel® Celeron® CPU G540 2.50GHz; MB=Gigabyte GA-H61M-S2V-B3 rev.1.0; RAM=16Гб DDR3.

cybercop

  • Напреднали
  • *****
  • Публикации: 5623
  • Distribution: Ubuntu LTS, CENTOS 6.x
  • Window Manager: Xfce, Gnome 2
    • Профил
Опитай
su
pacman -Scc
pacman -Syu
Активен

Ползването на Linux води до пристрастяване. Факт.
http://s19.postimg.cc/4oajwoq5v/xenial2.png

3p0

  • Напреднали
  • *****
  • Публикации: 354
    • Профил
Код:
[emil@manjaro ~]$ su
Password:
[root@manjaro emil]# pacman -Scc
Cache directory: /var/cache/pacman/pkg/
Do you want to remove ALL files from cache? [y/N] y
removing all files from cache...

Database directory: /var/lib/pacman/
Do you want to remove unused repositories? [Y/n] y
removing unused sync repositories...
[root@manjaro emil]# pacman -Syu
:: Synchronizing package databases...
error: failed retrieving file 'basis.db' from mirrors.mycraft.eu : The requested URL returned error: 404 Not Found
 basis is up to date
error: failed retrieving file 'platform.db' from mirrors.mycraft.eu : The requested URL returned error: 404 Not Found
 platform is up to date
error: failed retrieving file 'addon.db' from mirrors.mycraft.eu : The requested URL returned error: 404 Not Found
 addon is up to date
error: failed retrieving file 'extra.db' from mirrors.mycraft.eu : The requested URL returned error: 404 Not Found
 extra is up to date
error: failed retrieving file 'community.db' from mirrors.mycraft.eu : The requested URL returned error: 404 Not Found
 community is up to date
error: failed retrieving file 'basis-multilib.db' from mirrors.mycraft.eu : The requested URL returned error: 404 Not Found
 basis-multilib is up to date
error: failed retrieving file 'multilib.db' from mirrors.mycraft.eu : The requested URL returned error: 404 Not Found
 multilib is up to date
:: The following packages should be upgraded first :
    manjaro-system  pacman
:: Do you want to cancel the current operation
:: and upgrade these packages now? [Y/n] y

resolving dependencies...
looking for inter-conflicts...
error: failed to prepare transaction (could not satisfy dependencies)
:: package-query: requires pacman<4.1
:: packagekit: requires pacman<4.1.0
[root@manjaro emil]#
Активен

MX Linux version 18 "Continuum"
PC: Intel® Celeron® CPU G540 2.50GHz; MB=Gigabyte GA-H61M-S2V-B3 rev.1.0; RAM=16Гб DDR3.

bvbfan

  • Напреднали
  • *****
  • Публикации: 1056
  • Distribution: KaOS
  • Window Manager: Plasma 5
    • Профил
3р0 имаш 2 пакета, които чупят зависимостите и не може да продължиш с тях. Трябва да ги премахнеш и тогава да надграждаш
Код
GeSHi (Bash):
  1. pacman -R package-query packagekit
  2. pacman -Syu
  3. mv /etc/pacman.conf.pacnew /etc/pacman.conf
  4. pacman -Syu
и после може да опиташ да си върнеш 2-та пакета, вероятно има нови.
Активен

3p0

  • Напреднали
  • *****
  • Публикации: 354
    • Профил
Код:
[emil@manjaro ~]$ su
Password:
[root@manjaro emil]# pacman -R package-query packagekit
checking dependencies...
error: failed to prepare transaction (could not satisfy dependencies)
:: gnome-packagekit: requires packagekit
:: yaourt: requires package-query>=1.0
[root@manjaro emil]#
Активен

MX Linux version 18 "Continuum"
PC: Intel® Celeron® CPU G540 2.50GHz; MB=Gigabyte GA-H61M-S2V-B3 rev.1.0; RAM=16Гб DDR3.

bvbfan

  • Напреднали
  • *****
  • Публикации: 1056
  • Distribution: KaOS
  • Window Manager: Plasma 5
    • Профил
Активен

3p0

  • Напреднали
  • *****
  • Публикации: 354
    • Профил
Искам да отворя с gedit /etc/pacman.conf, така че да мога да запиша малка промяна, която ще направя във файла.
Как да направя това ?
Активен

MX Linux version 18 "Continuum"
PC: Intel® Celeron® CPU G540 2.50GHz; MB=Gigabyte GA-H61M-S2V-B3 rev.1.0; RAM=16Гб DDR3.

dejuren

  • Напреднали
  • *****
  • Публикации: 1025
  • Distribution: Ubuntu, RedHat
  • Window Manager: lxde KDE4
    • Профил
Код:
gedit /etc/pacman.conf
;D
Активен

http://webchat.freenode.net/?channels=ubuntu-bg
The quieter you become, the more you are able to hear.
Две седмици цъкане с мишката спестяват два часа четене на документацията.

go_fire

  • Global Moderator
  • Напреднали
  • *****
  • Публикации: 7964
  • Distribution: Дебиан Сид
  • Window Manager: ROX-Desktop / е17
  • кашик с гранатомет в танково поделение
    • Профил
    • WWW
Предполагам, че ще трябва едно su -c отпред.
Активен

В $por4e2 e истината  ;)

***

Aко даваха стипендия за най-глупави, щях да съм човека с най-много Mини Kупъри

***

Reborn since 1998 || 15.09.2007 totally М$ free && conscience clear

3p0

  • Напреднали
  • *****
  • Публикации: 354
    • Профил
Не мога да го ъпдейтна Manjaro Linux по никакъв начин ....
Или трябва да инсталирам чисто нов Manjaro;
Или трябва да инсталирам чисто нов Mint;
Или трябва да инсталирам чисто нов Debian;
Или трябва да инсталирам чисто нов ???? Linux.

Активен

MX Linux version 18 "Continuum"
PC: Intel® Celeron® CPU G540 2.50GHz; MB=Gigabyte GA-H61M-S2V-B3 rev.1.0; RAM=16Гб DDR3.

v13

  • Гост
Инсталирай едно чисто Ubuntu 13.04 просто работи.
Активен

3p0

  • Напреднали
  • *****
  • Публикации: 354
    • Профил
Инсталирай едно чисто Ubuntu 13.04 просто работи.
Ubuntu има ли десктопи: XFCE и LXDE ?
Активен

MX Linux version 18 "Continuum"
PC: Intel® Celeron® CPU G540 2.50GHz; MB=Gigabyte GA-H61M-S2V-B3 rev.1.0; RAM=16Гб DDR3.