Автор Тема: Изключване на WOL и LAN-адаптер в Suspend при Debian ?  (Прочетена 2272 пъти)

maxich

  • Напреднали
  • *****
  • Публикации: 119
    • Профил
Последният Debian явно е с включена Wake-on-LAN функция by Default, така че, когато приспиш компютъра в Suspend, мрежовия адаптер (след като се изключи за секунда-две в процеса на заспиване, пак се включва и) продължава да светка, все едно че слуша за т.нар. Magic пакети да го събудят. Твърде неприятно, когато човек не се нуждае от подобна функция да гледаш как Eth-адаптера ти не спира, да си почива заедно с всичко останало, а продължава, докато не извадиш кабела. В pm-suspend.log редовно пише „Having NetworkManager put all interaces to sleep...Failed“. Изчетох сумати в мрежата и навсякъде е пълно със съвети как да си включиш WOL, не обратното.. Това с 'ethtool -s eth0 wol d' не върши работа, защото адаптера пак продължава да светка в Suspend, а след рестарт и автоматично си се връща на „Wake-on: g“. Дори в BIOS-а, като се изключи съответната способност на LAN-адаптер да boot-ва, нищо желано не се постига и в Sleep продължава да работи. Затова отварям темата, да питам, как може напълно да се изключи WOL, така че когато човек си приспива компютъра и мрежовия-адаптер да спира. В последното Ubuntu работи по този начин, но нали там са правили доста промени в *.conf файловете и не е ясно точно къде да се пипне, за да може и когато го събуждаш, разбира се, мрежата отново да се включва
« Последна редакция: Jul 21, 2013, 22:02 от maxich »
Активен

maxich

  • Напреднали
  • *****
  • Публикации: 119
    • Профил
Намерих решение -- http://www.hecticgeek.com/2012/09/disabling-wake-on-lan-in-ubuntu-might-save-a-tiny-bit-of-power-on-your-laptop/ -- и след 6-а стъпка, наистина, работи. Прилагам го за всички тук, които случайно имат същия проблем. Честита нова година и бъдете здрави  :)
Активен

runtime

  • Напреднали
  • *****
  • Публикации: 807
  • Distribution: Ubuntu 14.04
  • Window Manager: Unity
  • LZ1DOT
    • Профил
    • WWW
Аз да ползвам темата, ако автора няма нищо против  [_]3

При мен в Debian Wheezy при изключен wireless адаптор (единият от двата), то изключения се опитва да се свързва на определен период от време към мрежата по необясними причини и дразни постоянно защото всеки път на ~10-20 мин трябва да му давам cancel. :) Някакви идеи защо изключен адапптор сам решава да се пуска и да се свързва?

Активен

maxich

  • Напреднали
  • *****
  • Публикации: 119
    • Профил
Е как е 'изключен'? При мен от страни има хардуеърен ключ, който се щраква за да действат или да не действат всякакви безжични комуникации, вкл. bluetooth. И когато този ключ е в действащо положение, разбира се, също WiFi-то непрекъснато се пуска да търси и опитва да се свързва, независимо че към момента може да ползвам и жична мрежа. А при теб, доколкото разбирам, след като ползваш безжична връзка, значи wireless-а ти е включен. И проблемът, явно, е че имаш два адаптера
Активен

Acho

  • Напреднали
  • *****
  • Публикации: 4084
  • Distribution: Slackware, MikroTik - сървърно
  • Window Manager: console only
    • Профил
    • WWW
За лаптоп ли говори колегата, който пусна темата ?
Активен

CPU - Intel Quad-Core Q8400, 2.66 GHz; Fan - Intel Box; MB - Intel G41M-T2; RAM - DDR2-800, Kingston HyperX, 2X2048 MB; VC - onboard, Intel G41 Express Chipset; HDD - SeaGate, 160 GB, SATAII; SB - Realtek HD Audio; DVD-RW - TSSTcorp DVD-RW; LAN - Realtek PCI-E GBE Controller; PSU - Fortron 350 Watt.

maxich

  • Напреднали
  • *****
  • Публикации: 119
    • Профил
Разбира се, какъв е проблема
Активен

Acho

  • Напреднали
  • *****
  • Публикации: 4084
  • Distribution: Slackware, MikroTik - сървърно
  • Window Manager: console only
    • Профил
    • WWW
Ами не знаех за каква машина става дума. Защото ако е настолен компютър с външна, примерно PCI-ска LAN карта, към нея си има едно кабелче за WOL. Та, ако не го закачиш кабелчето към дъното - няма да работи WOL функцията. Затуй те попитах, не че имало някакъв ПРОБЛЕМ.
Активен

CPU - Intel Quad-Core Q8400, 2.66 GHz; Fan - Intel Box; MB - Intel G41M-T2; RAM - DDR2-800, Kingston HyperX, 2X2048 MB; VC - onboard, Intel G41 Express Chipset; HDD - SeaGate, 160 GB, SATAII; SB - Realtek HD Audio; DVD-RW - TSSTcorp DVD-RW; LAN - Realtek PCI-E GBE Controller; PSU - Fortron 350 Watt.

runtime

  • Напреднали
  • *****
  • Публикации: 807
  • Distribution: Ubuntu 14.04
  • Window Manager: Unity
  • LZ1DOT
    • Профил
    • WWW
@Acho това не е много вярно. :)  Не е задължително да го има кабелчето по простата причина, че при новите декстоп машини от биоса може да зададеш PCI да е активен и да чака меджик пакета от там. Resume by PCI Card май беше опцията при някои и от сорта аналогично за други.

Цитат
Е как е 'изключен'?
http://blog.giuseppeurso.net/wp-content/uploads/2013/06/gnome-network-manager.png  - снимката е от интернет и е информативна,

Е те там с плъзгача е на OFF :) Хардуерния ключ ми спира и двете карти и не е ренение. Обаче! От вчера от как писах нещо се уплаши и не е мрънкала да се връзва.
Активен