Автор Тема: Състоянието на тестовия Дебиян към Декември 2020?  (Прочетена 5714 пъти)

remotexx

  • Напреднали
  • *****
  • Публикации: 1251
    • Профил
Гледам има баят Дебиянци из форума - дано някой знае какво (си мислят че) правят тия хора..
Забелзвам че от бая време моя тестови Дебиян иска да маха полoвината КДЕ за да обнови другата половина!?
Забелязах още (което е и най-вероятната причина) нова версия на gcc - която предполагам чупи всичко дето не е копилирано под най-новата версия - ядрото и важните пакети са ОК ама КДЕ с хиляди зависимости май не е
Та въпросът ми е
1) да изчакам ли още 10-12 г. (Debian) докато всички зависимости са оправени и вече работят с gcc10 (макар че към него момент активната версия ще е gcc20)
или
2) може-би идеята е тия 50% (по скоро към 1/3) пакети да ги направят излишни ..ама що не си оправят пакетния мениджър да ги показва като излишни а не да ми чупят обновяванията (от последние 5-6м.)
- предполагам ще ги obsolete-нат чак на следващата стабилна версия като излезе, освен ако не ги оправят

Ако некой запознат има вътрeшна иформация да казва - да не мълчи като родната полиция ни пази ни (и без бой нищо да не признава)
https://tinyurl.com/ybd8pdtl


П.П. някой от пакетите които иска да премахне за да разреши зависмостите:
айде важните пакети разбирам ама - breeze, k3b и някой не от КДЕ-то - тях защо (само ще да е от gcc-то, дано не требе да се чака пак с години, макар че тя новата година дойде)
accountwizard
akonadiconsole
akregator
bluedevil - KDE Bluetooth stack
breeze - Default Plasma theme (Metapackage)
sddm-theme-breeze
calibre
calligra
dolphin
gwenview
k3b
kaddressbook
kate
kde-baseapps
kde-cli-tools
kde-full
mariadb-server-10.3
mariadb-server-core-10.3
plasma-desktop
print-manager
...
systemsettings
user-manager

другата половина (2/3) са ОК - напр. тези могат да се обновят
kdeaccessibility
kdeadmin
kded5
etc.
...
« Последна редакция: Dec 28, 2020, 20:09 от remotexx »
Активен

malin1

  • Напреднали
  • *****
  • Публикации: 261
  • Distribution: Debian
  • Window Manager: Openbox
    • Профил
Това го имам на отметка като информация. Не ползвам и не се интересувам от КДЕ, докъде е и какво става, осен ако не ми го наврат няколко пъти в лицето.
Активен

jet

  • Напреднали
  • *****
  • Публикации: 2266
  • Distribution: debian
  • Window Manager: kde
    • Профил
Не знам за Тестовия, ама аз съм на нестабилният Дебиан, и при мен превключиха към новото КДЕ 5.20.4 преди седмица.
Предполагам, че тази промяна е стигнала и до Тестинга - изчакай още една седмица.
Или давай с apt upgrade всеки ден вместо apt dist-upgrade (за да не трие нищо)
Аз имам два Дебиана монтирани към общ /home и си правя всякакави експерименти с единия, без да развалям другия.

Другарят NORBERT PREINING ·се включи в отбора на КДЕ за Дебиан и помогна за минаването към новата версия и свързаните с това QT библиотеки (те се бориха с това от бая време). Той от много време предлагаше негови репо-та за най-новите версии на КДЕ за Дебиан и Сусе, но вече това е официално.
https://www.preining.info/blog/2020/12/debian-kde-status-for-bullseye/
Активен

..⢀⣴⠾⠻⢶⣦⠀
  ⣾⠁⢠⠒⠀⣿⡁
  ⢿⡄⠘⠷⠚⠋
  ⠈⠳⣄⠀⠀⠀⠀  Debian, the universal operating system.

remotexx

  • Напреднали
  • *****
  • Публикации: 1251
    • Профил
Предполагам, че тази промяна е стигнала и до Тестинга - изчакай още една седмица.

Само да вметна, че аз (края на) тая седмица чекам вече от няколко месеца  ??? иначе нямаше да си правя труда да пущам тема тука.
Забелязах че освен КДЕ и Qt е на същото дередже... няколко седмици преди да забележа този проблем имаше подобен ама с gcc и там чекането си струваше (е и разкарах няколко пакета - дето му проблемни и не ползвам) ама  с КДЕ е различно - там си го ползвам и не искам да го прецаквам още

По повод препратката по-горе - те точно 5.20.04 ми работи т.е. обновен съм вече до 5.20.04 сега проблемът е 5.20.04 -> 5.20.08, явно и за всяка следваща версия ще е така и ще го дебнем да го е.нем - а са вкарали един пакет дето не е точно версията в хранилищата а са прецакали обновяването.

"Today, finally, I have uploaded Frameworks 5.77 and Plasma 5.20.4 to unstable, the end of a long story."

напр. долното ако се опитам да го обновя (1. влачи цялото КДЕ като зависимости и 2. иска да ми махне половината КДЕ)
akonadiconsole
Installed: 4:20.04.1-2
Latest:     4:20.08.3-1

Явно или ще трябва да чакам(е) пича отново да качи цялото 5.20.08 или пък има пакет който е 5.20.08-- или  5.20.08++ и прецаква цялата работа.
Язък - ще трябва да минавам на стабилен Дебиян май (с Федората няма чак такива проблеми - там обик. са единични пакети и бързо ги оправят)
« Последна редакция: Dec 28, 2020, 23:31 от remotexx »
Активен

remotexx

  • Напреднали
  • *****
  • Публикации: 1251
    • Профил
Благодаря за подсещането за АПТ-а, аз по принцип ползвам или Синаптик или Аптитюда ама и двата предлагат да ги махант тия 814 пакета дето пречат ама явно (новия) АПТ са го оправили вече и САМО ТОЙ предлага:
1458 upgraded, 55 newly installed, 0 to remove and 814 not upgraded.
Need to get 3,649 MB/3,844 MB of archives. - личи си откога я чакам тая седмица да свърши
After this operation, 1,216 MB of additional disk space will be used.
Do you want to continue? [Y/n]

Та какво е там дереджето - ще ги (до)убиват ли вече - synaptic & aptitude?

П.П. synaptic & aptitude и преди са ми правили (подобни) проблеми, но само на единични пакети - не винаги намираха най-доброто решение временно да замразят нещо колкото да мине обновяването а все искаха (като първо предложение) да махат пакети, добре поне че даваха да си избираш най-подходящото решение, но при цялостен ъпдейт (на всичко) /поне досега/ винаги се справяха т.е. само там съм виждал 'временно' замразени пакети та да мине обновяването. Явно и тях ги отсвирват вече ама можеха поне едно obsolete да им сложат (ако не и да ги махнат веднага)

П.П.П. И още нещо което беше по-лесно с (псевдо)графичните пакетни мениджъри - единичното редактиране на списъка за обновяване:
Код
GeSHi (Bash):
  1. Parsing Found/Fixed information... Done
  2. grave bugs of libgcc-s1:i386 (10.2.0-9 → 10.2.1-1) <Outstanding>
  3. b1 - #972936 - libgcc-s1 needs Breaks: libgcc1 (<< 1:10)
  4. grave bugs of libgcc-s1 (10.2.0-9 → 10.2.1-1) <Outstanding>
  5. b2 - #972936 - libgcc-s1 needs Breaks: libgcc1 (<< 1:10)
  6. serious bugs of libgtk-3-0 (3.24.23-1 → 3.24.24-1) <Outstanding>
  7. b3 - #977961 - It fails to build, I will attach the log
  8. serious bugs of texlive-base (2020.20200925-12020.20201203-2) <Outstanding>
  9. b4 - #978431 - texlive-base: dist-upgrade buster->bullseye fails
  10. serious bugs of libllvm11:i386 (1:11.0.0-5+b1) <Forwarded>
  11. b5 - #975931 - libgpuarray autopkgtest using pocl on armhf triggers segfault in LLVM
  12. serious bugs of libllvm10:i386 (1:10.0.1-61:10.0.1-8+b1) <Forwarded>
  13. b6 - #975931 - libgpuarray autopkgtest using pocl on armhf triggers segfault in LLVM
  14. serious bugs of libllvm10 (1:10.0.1-61:10.0.1-8+b1) <Forwarded>
  15. b7 - #975931 - libgpuarray autopkgtest using pocl on armhf triggers segfault in LLVM
  16. Summary:
  17. libgcc-s1:i386(1 bug), libgcc-s1(1 bug), libgtk-3-0(1 bug), libllvm11:i386(1 bug), texlive-base(1 bug), libllvm10:i386(1 bug), libllvm10(1 bug)
  18. Are you sure you want to install/upgrade the above packages? [Y/n/?/...]
  19.  
« Последна редакция: Dec 29, 2020, 00:01 от remotexx »
Активен

cybercop

  • Напреднали
  • *****
  • Публикации: 5603
  • Distribution: Ubuntu LTS, CENTOS 6.x
  • Window Manager: Xfce, Gnome 2
    • Профил
Благодаря за подсещането за АПТ-а, аз по принцип ползвам или Синаптик или Аптитюда ама и двата предлагат да ги махант тия 814 пакета дето пречат ама явно (новия) АПТ са го оправили вече и САМО ТОЙ предлага:

Новият не е старият (пакетният мениджър APT), а само вторичен инструмент, който ползва наличните apt-get и apt-cache. Никога не е бил развалян за да го поправят. Още при излизането си работеше напълно коректно. Все пак, само трансформира една команда в една или няколко други.
Активен

Ползването на Linux води до пристрастяване. Факт.
http://s19.postimg.cc/4oajwoq5v/xenial2.png

remotexx

  • Напреднали
  • *****
  • Публикации: 1251
    • Профил
Явно това е нещо което синаптика и аптитюда не правят
.. т е. вероятно не ползват наличните инструменти наготово ами.. знам ли само като библиотеки/DLL или знам ли, но вече не се държат като новия АПТ туул.

По мои спомени официалният TUI - aptitude, GUI - synaptic, но явно вече не е така щом apt се справя а UI-тата не могат
« Последна редакция: Dec 30, 2020, 02:30 от remotexx »
Активен

go_fire

  • Global Moderator
  • Напреднали
  • *****
  • Публикации: 6506
  • Distribution: Дебиан Сид
  • Window Manager: ROX-Desktop / е17
  • кашик с гранатомет в танково поделение
    • Профил
    • WWW
Aptitude e един умен инструмент. Толкова е умен, че винаги е бил по-умен от мен. Но всички стари дебианци го ползват и затова няма да бъде зарязан. За твое съжаление обаче май не го ползват пакетиращите КДЕ. Синоптика преди съм го ползвал много усилено. Главно беше да търся файл в кой пакет се намира и съдържанието на едно хранилище. Първото е много неприятно с наличния инструментариум, а второто е бая трудоемко.

Всъщност нещата, които пишете в темата бяха причината да зарежа първо нестабилния, а после и тестовия Дебиан. Обновявания на десетки и стотици пакети ежедневно. Непрестанно теглене по стотици и хиляди мегабайти. Пакети обновени едва наполовина, което чупи произволни неща.

Е Киберкоп да разправя, как пък неговото, любимо Мишле редовно го чупят по този начин. Обновят едни пакети, ама други не обновят и става мазало.

Без да се заяждам, ама за какво ползваш Аконади? Аз се чудя как да го разкарам. Но пък нямам действаща поща и не ползвам Kmail, KAddress и сие.
Активен

В $por4e2 e истината  ;)

***

Aко даваха стипендия за най-глупави, щях да съм човека с най-много Mини Kупъри

***

Reborn since 1998 || 15.09.2007 totally М$ free && conscience clear

cybercop

  • Напреднали
  • *****
  • Публикации: 5603
  • Distribution: Ubuntu LTS, CENTOS 6.x
  • Window Manager: Xfce, Gnome 2
    • Профил

Е Киберкоп да разправя, как пък неговото, любимо Мишле редовно го чупят по този начин. Обновят едни пакети, ама други не обновят и става мазало.


Нямам спомени да се е чупила. Тя е само от десет базови пакета. Често вкарват добавки за нови версии, но досега не е имало случаи да не работят.
Козметичен проблем е, примерно в GTK2 базиран панел да сложат GTK3 базирана добавка. Тогава не следва добре GTK темата. В такъв случай, аз деинсталирам новата добавка (примерно Wiskermenu), свалям .deb пакета от стара версия, разархивирам го и копирам ръчно файловете във файловата система. Добавката си работи, но пакетния мениджър не я отчита, като инсталирана и не се налага да я фиксирам, за да не се надгражда при обновяване.
Активен

Ползването на Linux води до пристрастяване. Факт.
http://s19.postimg.cc/4oajwoq5v/xenial2.png

jet

  • Напреднали
  • *****
  • Публикации: 2266
  • Distribution: debian
  • Window Manager: kde
    • Профил
   Аз съм на 1Gb/s интернет, стотина МБ изобщо не мога да ги отразя. Аз искам нов софтуер на десктопа си, точка. А с нестабилния Дебиан проблема е, че аз съм нетърпелив. Той трябва да се пуска да се обновява на 3 или 6 месеца (а браузърите през ден), ама аз го дебна всеки ден. Просто процеса им на билдване на пакетите е много бавен и не е синхронизиран с обовяването на мирърите, но евентуално всичко си идва на мястото.
   Дебианци трябва да направят и един вариант между Стабилен и Тестинг, който да се мигрира от Тестинг автоматично на два месеца и става идеалното десктоп дистро.

   Някой може да напише и скрипт за правене на снапшоти в btrfs на системния дял, преди обновяване.
Аз съм го решил с дуал боот.

Иначе когато се замотаят пакетите и нищо не може да ги оправи - aptitude е инструмента дето оправя и най-бозавата боза.


Абе в този форум, защо все като отговарям отива в някой друга тема.
Активен

..⢀⣴⠾⠻⢶⣦⠀
  ⣾⠁⢠⠒⠀⣿⡁
  ⢿⡄⠘⠷⠚⠋
  ⠈⠳⣄⠀⠀⠀⠀  Debian, the universal operating system.

go_fire

  • Global Moderator
  • Напреднали
  • *****
  • Публикации: 6506
  • Distribution: Дебиан Сид
  • Window Manager: ROX-Desktop / е17
  • кашик с гранатомет в танково поделение
    • Профил
    • WWW
Познат проблем в самия SMF. Когато имаш няколко отворени ушета (tabs) двигателя се обърква, в коя тема си бил последно и ти праща мнението на някакво друго място. И на мен ми се е случвало много пъти.
Активен

В $por4e2 e истината  ;)

***

Aко даваха стипендия за най-глупави, щях да съм човека с най-много Mини Kупъри

***

Reborn since 1998 || 15.09.2007 totally М$ free && conscience clear

danaildr

  • Напреднали
  • *****
  • Публикации: 158
  • Distribution: Debian Buster
  • Window Manager: KDE Plasma
    • Профил
Но всички стари дебианци го ползват и затова няма да бъде зарязан.
Аз пък никога не съм го ползвал, ползвах си apt-get и останалите от пакета, а сега  apt. Не съм имал проблеми от описания по-горе тип.
Но пък и аз съм на стабилния дебиан, та не се знае знае ли се.
Активен

Закона на Мърфи е: Точното определение и логичното по-нататъшно развитие на общото ентропично учение, според което всички частички във вселената се стремят да се подредят във възможно най-голям безпорядък. Познанието, че на път за там споменатите частички поне веднъж ти се изпречват в краката.

go_fire

  • Global Moderator
  • Напреднали
  • *****
  • Публикации: 6506
  • Distribution: Дебиан Сид
  • Window Manager: ROX-Desktop / е17
  • кашик с гранатомет в танково поделение
    • Профил
    • WWW
И аз съм на стабилния десятка (по-точно на Beowulf), защото ме мързи да обновявам. Специално Ungoogled Chromium си има свое хранилище, затова не го мисля. Сигурно КДЕ и Либре офис имат, ама не ми трябват толкова.

APT не ползвам, apt-get и apt-cache (show и search) са всичко, което ми трябва обикновено. Не помня откога не съм ползвал Синоптик. Може би защото вече не ползвам много софтуер.
Активен

В $por4e2 e истината  ;)

***

Aко даваха стипендия за най-глупави, щях да съм човека с най-много Mини Kупъри

***

Reborn since 1998 || 15.09.2007 totally М$ free && conscience clear

remotexx

  • Напреднали
  • *****
  • Публикации: 1251
    • Профил
Synaptic & Aptitude не казвам че са счупени, а че вече се държат различно от Apt
Гога - не е само до Аконади, който и да е от ония 8хх пакета да барна и горните две вече искат да премахант всичките 8хх пакета, само новия АПТ разбра и ги блокира докато се разреши там каквото ги блокира...
Основният проблем на Дебиянските инструменти е че за разлика от напр. dnf (Fedora) не казват какво налага блокирането или премахването на тия (8хх) пакети докато ДНФ винаги си казва - може да е едно малко приложенийце дето да не ми трябва и като го разкарам всичко се оправя.

По-въпроса за Аконади и т.п. (всичките 8хх), аз и преди питах (но никой не отг.) - да не би да се налага дистро синк т.е. да са ги махнали от следващата версия на дистрото (или ще ги махат по-натам та да поизчакам - ама си изчаках чакалото)

Сега ако някой може да ми отговори Защо т.е как да разбера защо тия пакети са блокирани - ще го призная за експерт
- Федора има skip-brorken опция която показва кой ше пропусне (като зависимости на счупен пакет) а по подразбиране си показва кои са счупени - т.е. случвало ми се е 1 счупен да повлече няколко стотин блокирани ...ама за ден-два - докато го оправят и само веднъж досега ми се размина вече с distro-sync ама това са Федорини вълнения, с Дебра & Ян тръпката е къде по-голяма.. а бе какво правят тия хора - живи ли са още?

П.П. Синаптика, за разлика от Аптитюда, не предлага алтернативни (раз)решения, но (доскоро) винаги като му давах да обнови Всичко и се оправяше (кои да разкара, кои да обнови и кои да задържи), от друга страна Аптитюда по-често ми помагаше да позная кой е поблеминя пакет щото при него може да превърташ (със . и ,) (всички) възможни решения и да си избереш некое - ама със 800 и кусур пакета иди че познай кой е проблемния
https://www.debian.org/doc/manuals/aptitude/ch02s05s02.en.html
NextSolution   .   Advance the dependency resolver to the next solution.
PrevSolution   ,   Return the dependency resolver to the previous solution.

даже и един бъг им изхващах днес:
FirstSolution   <   Select the first solution produced by the problem resolver.
LastSolution   <   Select the last solution produced by the problem resolver.
« Последна редакция: Dec 30, 2020, 21:46 от remotexx »
Активен

go_fire

  • Global Moderator
  • Напреднали
  • *****
  • Публикации: 6506
  • Distribution: Дебиан Сид
  • Window Manager: ROX-Desktop / е17
  • кашик с гранатомет в танково поделение
    • Профил
    • WWW
... с Дебра & Ян тръпката е къде по-голяма.. а бе какво правят тия хора - живи ли са още?


Ян беше жертва на полицейско насилие преди точно две години. Тъкмо се беше цанил за 500 хил. на година в кита, който влачи контейнери. И тъкмо се беше върнал. За Дебора нищо не се знае. Най-вероятно към момента на убийството му вече са били разведени.
Активен

В $por4e2 e истината  ;)

***

Aко даваха стипендия за най-глупави, щях да съм човека с най-много Mини Kупъри

***

Reborn since 1998 || 15.09.2007 totally М$ free && conscience clear

Подобни теми
Заглавие Започната от Отговора Прегледи Последна публикация
dos през 2020-та година
Настройка на програми
stealth01 4 917 Последна публикация Apr 04, 2020, 19:59
от go_fire