Автор Тема: Как да инсталирам електронен подпис на Инфонотари под Manjaro Linux и под Arch ?  (Прочетена 21488 пъти)

3p0

  • Напреднали
  • *****
  • Публикации: 354
    • Профил
Re: Кой измежду четири Линукса да избера ?
« Отговор #60 -: Nov 18, 2012, 12:43 »
Мисля, че последните две команди станаха без никаква грешка:
Код:
[emil@manjaro infonotary-scardmanager_2.1.0-1_i386]$ sudo cp -r etc/ /
[sudo] password for emil:
[emil@manjaro infonotary-scardmanager_2.1.0-1_i386]$ sudo cp -r usr/ /
[emil@manjaro infonotary-scardmanager_2.1.0-1_i386]$
Активен

MX Linux version 18 "Continuum"
PC: Intel® Celeron® CPU G540 2.50GHz; MB=Gigabyte GA-H61M-S2V-B3 rev.1.0; RAM=16Гб DDR3.

Kras

  • Напреднали
  • *****
  • Публикации: 155
  • Distribution: Arch
    • Профил
Re: Кой измежду четири Линукса да избера ?
« Отговор #61 -: Nov 18, 2012, 12:48 »
Мисля, че последните две команди станаха без никаква грешка:
Код:
[emil@manjaro infonotary-scardmanager_2.1.0-1_i386]$ sudo cp -r etc/ /
[sudo] password for emil:
[emil@manjaro infonotary-scardmanager_2.1.0-1_i386]$ sudo cp -r usr/ /
[emil@manjaro infonotary-scardmanager_2.1.0-1_i386]$
ОК. Това горното би трябвало да копира "програмите" ръчно където им е мястото... или нещо такова:)
Това http://wiki.infonotary.com/wiki/%D0%98%D0%BD%D1%81%D1%82%D0%B0%D0%BB%D0%B0%D1%86%D0%B8%D1%8F_%D0%BD%D0%B0_%D0%B4%D1%80%D0%B0%D0%B9%D0%B2%D0%B5%D1%80%D0%B8_%D0%B7%D0%B0_%D1%87%D0%B5%D1%82%D0%B5%D1%86_%D0%B8_%D1%81%D0%BC%D0%B0%D1%80%D1%82_%D0%BA%D0%B0%D1%80%D1%82%D0%B0_%D0%B2_Linux
Чел ли си го?
Аз ся го погледнах и като гледам отдолу нагоре го карам трябва да се инсталира
sudo pacman -S opensc

Всъщност я дай малко инфо - Какъв модел ти е карточетеца, каква е картата...?
« Последна редакция: Nov 18, 2012, 12:54 от Kras »
Активен

3p0

  • Напреднали
  • *****
  • Публикации: 354
    • Профил
Re: Кой измежду четири Линукса да избера ?
« Отговор #62 -: Nov 18, 2012, 12:52 »
Не съм го чел.
Предполагам, че трябва да го прочета ..
Активен

MX Linux version 18 "Continuum"
PC: Intel® Celeron® CPU G540 2.50GHz; MB=Gigabyte GA-H61M-S2V-B3 rev.1.0; RAM=16Гб DDR3.

stealth01

  • Гост
Re: Кой измежду четири Линукса да избера ?
« Отговор #63 -: Nov 18, 2012, 12:55 »
тъкмо щях да поствам, но Kras ме изпреварил :)

на практика тоя scardmanager не е нужен. върши работа само за някакви тестове...
трябва само да си инсталираш драйвърите за четеца/картата и след това да кажеш на firefox-а да ползва това устройство. чети wiki-то на инфонотари, а за по-специфични въпроси направо питай тях - отговарят и на linux въпроси :)
Активен

Kras

  • Напреднали
  • *****
  • Публикации: 155
  • Distribution: Arch
    • Профил
Re: Кой измежду четири Линукса да избера ?
« Отговор #64 -: Nov 18, 2012, 12:59 »
Кажи на първо време кой от тези четците е твоя:http://wiki.infonotary.com/wiki/%D0%94%D1%80%D0%B0%D0%B9%D0%B2%D0%B5%D1%80%D0%B8_%D0%B7%D0%B0_%D1%87%D0%B5%D1%82%D1%86%D0%B8
« Последна редакция: Nov 18, 2012, 13:06 от Kras »
Активен

3p0

  • Напреднали
  • *****
  • Публикации: 354
    • Профил
Re: Кой измежду четири Линукса да избера ?
« Отговор #65 -: Nov 18, 2012, 13:00 »
Карточетецът е OK ( OmniKey ) - прилича на флашка ..
Картата е SIEMENS ( Чух в банката, като си говреха по телефона )
Активен

MX Linux version 18 "Continuum"
PC: Intel® Celeron® CPU G540 2.50GHz; MB=Gigabyte GA-H61M-S2V-B3 rev.1.0; RAM=16Гб DDR3.

Kras

  • Напреднали
  • *****
  • Публикации: 155
  • Distribution: Arch
    • Профил
Re: Кой измежду четири Линукса да избера ?
« Отговор #66 -: Nov 18, 2012, 13:07 »
Карточетецът е OK ( OmniKey ) - прилича на флашка ..
Картата е SIEMENS ( Чух в банката, като си говреха по телефона )

Сваляш му драйверите за Linux x86 Предполагам си с такъв Manjaro linux (Linux x86 Изтегляне на драйвера): http://repository.infonotary.com/drivers/HIDGlobal/ifdokccid_lnx_i686-3.7.0.tar.gz

Отиваш в директорията където си свалил файла и го разархивираш.
След това с терминала отиваш в тази директория и пишеш:
$ sudo ./install
Активен

3p0

  • Напреднали
  • *****
  • Публикации: 354
    • Профил
Re: Кой измежду четири Линукса да избера ?
« Отговор #67 -: Nov 18, 2012, 13:12 »
Стана успешно:
Код:
[emil@manjaro INFONOTARY]$ sudo ./install
[sudo] password for emil:

Installing HID Global OMNIKEY CCID Smartcard reader driver ...

which: no pcscd in (/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/sbin:/usr/bin/site_perl:/usr/bin/vendor_perl:/usr/bin/core_perl)
PCSC-Lite is not found in current path!
Retry with appropriate user or go visit
http://alioth.debian.org/projects/pcsclite/
and install the latest version of pcsc-lite.
Copying ifdokccid_lnx_i686-3.7.0.bundle to /usr/local/pcsc/drivers/ ...

Installation finished!
Активен

MX Linux version 18 "Continuum"
PC: Intel® Celeron® CPU G540 2.50GHz; MB=Gigabyte GA-H61M-S2V-B3 rev.1.0; RAM=16Гб DDR3.

Kras

  • Напреднали
  • *****
  • Публикации: 155
  • Distribution: Arch
    • Профил
Re: Кой измежду четири Линукса да избера ?
« Отговор #68 -: Nov 18, 2012, 13:23 »
Я пробвай първо това да инсталираш(Преинсталираш ако го имаш)
sudo pacman -S pcsclite
и после пак
sudo ./install


А по-горе където ти бях писал дали инстаира opensc? Ако не инсталирай го и него сега:
sudo pacman -S opensc
« Последна редакция: Nov 18, 2012, 13:26 от Kras »
Активен

3p0

  • Напреднали
  • *****
  • Публикации: 354
    • Профил
Re: Кой измежду четири Линукса да избера ?
« Отговор #69 -: Nov 18, 2012, 13:35 »
Първо изпълних двете команди ..
Този път е по-кратка инсталацията:
Код:
[emil@manjaro INFONOTARY]$ sudo ./install

Installing HID Global OMNIKEY CCID Smartcard reader driver ...

PCSC-Lite found: /usr/sbin/pcscd
Copying ifdokccid_lnx_i686-3.7.0.bundle to /usr/lib/pcsc/drivers ...

Installation finished!
Активен

MX Linux version 18 "Continuum"
PC: Intel® Celeron® CPU G540 2.50GHz; MB=Gigabyte GA-H61M-S2V-B3 rev.1.0; RAM=16Гб DDR3.

Kras

  • Напреднали
  • *****
  • Публикации: 155
  • Distribution: Arch
    • Профил
Re: Кой измежду четири Линукса да избера ?
« Отговор #70 -: Nov 18, 2012, 13:50 »
Първо изпълних двете команди ..
Този път е по-кратка инсталацията:
Код:
[emil@manjaro INFONOTARY]$ sudo ./install

Installing HID Global OMNIKEY CCID Smartcard reader driver ...

PCSC-Lite found: /usr/sbin/pcscd
Copying ifdokccid_lnx_i686-3.7.0.bundle to /usr/lib/pcsc/drivers ...

Installation finished!
Така по-добре изглежда.:)
Сега като гледам трябва да си готов, поне отчасти.
тук намерих едно wiki за подобен четец: https://wiki.archlinux.org/index.php/Omnikey_Cardman_5321#Start_pcscd
Те като ги гледам инсталират и pcsc-tools
sudo pacman -S pcsc-tools

после пробвай:
/etc/rc.d/pcscd start
и кажи какво ти изкарва (при мен за съжаление не ще да захапе)
Цитат
[kras@manjaro ifdokccid_lnx_i686-3.7.0]$ /etc/rc.d/pcscd start
/etc/rc.d/pcscd: line 3: /etc/rc.conf: Няма такъв файл или директория
/etc/rc.d/pcscd: line 4: /etc/rc.d/functions: Няма такъв файл или директория
/etc/rc.d/pcscd: line 14: stat_busy: командата не е открита
/etc/rc.d/pcscd: line 17: stat_fail: командата не е открита
Малиии ся кат' са загледах и гледай какво намерих: https://aur.archlinux.org/packages/omnikey_cardman_x21/ то си го имало пакета в AUR-то, но нищо ти го инсталира и без готов пакет!
Активен

3p0

  • Напреднали
  • *****
  • Публикации: 354
    • Профил
Re: Кой измежду четири Линукса да избера ?
« Отговор #71 -: Nov 18, 2012, 13:57 »
Код:
[emil@manjaro INFONOTARY]$ cd ifdokccid_lnx_i686-3.7.0
[emil@manjaro ifdokccid_lnx_i686-3.7.0]$ /etc/rc.d/pcscd start
/etc/rc.d/pcscd: line 3: /etc/rc.conf: No such file or directory
/etc/rc.d/pcscd: line 4: /etc/rc.d/functions: No such file or directory
/etc/rc.d/pcscd: line 14: stat_busy: command not found
/etc/rc.d/pcscd: line 17: stat_fail: command not found
« Последна редакция: Nov 18, 2012, 14:04 от 3p0 »
Активен

MX Linux version 18 "Continuum"
PC: Intel® Celeron® CPU G540 2.50GHz; MB=Gigabyte GA-H61M-S2V-B3 rev.1.0; RAM=16Гб DDR3.

Kras

  • Напреднали
  • *****
  • Публикации: 155
  • Distribution: Arch
    • Профил
Re: Кой измежду четири Линукса да избера ?
« Отговор #72 -: Nov 18, 2012, 14:13 »
Код:
[emil@manjaro INFONOTARY]$ cd ifdokccid_lnx_i686-3.7.0
[emil@manjaro ifdokccid_lnx_i686-3.7.0]$ /etc/rc.d/pcscd start
/etc/rc.d/pcscd: line 3: /etc/rc.conf: No such file or directory
/etc/rc.d/pcscd: line 4: /etc/rc.d/functions: No such file or directory
/etc/rc.d/pcscd: line 14: stat_busy: command not found
/etc/rc.d/pcscd: line 17: stat_fail: command not found
И при мен е така и това е поради факта, че Manjaro не поддържа rc.conf
Цитат
First of all: Manjaro uses no initscripts at all. We have no /etc/rc.conf  file to configure your system. In near future we will provide a simpe  UI-tool to configure things like timezone, locales etc. For now you have  to use systemd's native configure files.
т.е. Manjaro е като Arch ама не точно:)
Иначе е симпатична дистрибуция и много бърза...
Сигурно има начин да се излъже стартирането на  /etc/rc.d/pcscd но аз не знам как. Нека някой по знаещ да помага.
Активен

3p0

  • Напреднали
  • *****
  • Публикации: 354
    • Профил
Re: Кой измежду четири Линукса да избера ?
« Отговор #73 -: Nov 18, 2012, 14:17 »
Благодаря !!!!
Очевидно Линуксите се различават един от друг и някои програми не могат да тръгнат под Линукс, за който не са създадени.
Manjaro наистина ми харесва, доколкото новак като мене може да има меродавно мнение ....
« Последна редакция: Nov 18, 2012, 14:19 от 3p0 »
Активен

MX Linux version 18 "Continuum"
PC: Intel® Celeron® CPU G540 2.50GHz; MB=Gigabyte GA-H61M-S2V-B3 rev.1.0; RAM=16Гб DDR3.

Kras

  • Напреднали
  • *****
  • Публикации: 155
  • Distribution: Arch
    • Профил
Re: Кой измежду четири Линукса да избера ?
« Отговор #74 -: Nov 18, 2012, 14:23 »
Благодаря !!!!
Очевидно Линуксите се различават един от друг и някои програми не могат да тръгнат под Линукс, за който не са създадени.
Не мисля, че е така, всяка програма за линукс би следвало да тръгне на всяка дистрибуция! Просто Manjaro е доста нова дистрибуция, а аз не съм експерт и нямам достатъчно знания за да ти помогна, но съм сигурен, че ако някой от разбиращите тук инсталира Manjaro във VirtualBox-а което ще му отнеме 15-20 мин. ще ти помогне и ще подкараш ел. подпис..
Ако беше чист Arch Linux съм почти сигурен, че щеше да тръгне.

За сега ми се струва най-удачно да свалиш едно Убунту и да го инсталираш във виртуалната машина.
Успех от мен.
« Последна редакция: Nov 18, 2012, 14:42 от Kras »
Активен