Автор Тема: Убунту и кирилица  (Прочетена 2007 пъти)

Darks

  • Напреднали
  • *****
  • Публикации: 46
    • Профил
Убунту и кирилица
« -: Apr 06, 2008, 03:59 »
Сигурно тая тема е изтъркана моля за малко помощ и се извинявам но аз сам новак с линукс и съм си сложил убунту и незнам как но си направих да е на кирилица написах в конзолата май setxkbmap bg phonetic може ли някой да ми каже какво да направя за да ми се превключи на латиница ?
Активен

nedpetko

  • Напреднали
  • *****
  • Публикации: 445
  • Distribution: Debian GNU/Linux
  • Window Manager: KDE
    • Профил
Убунту и кирилица
« Отговор #1 -: Apr 06, 2008, 09:02 »
Darks '<img'> няма нужда от сто теми.
Сега дай да видим xorg.conf или направо редактирай следната секция:
Цитат
Section "InputDevice"
        Identifier      "Generic Keyboard"
        Driver          "kbd"
        Option          "CoreKeyboard"
        Option          "XkbRules"      "xorg"
        Option          "XkbModel"      "pc104"
        Option          "XkbLayout"     "us,bg(phonetic)"
        Option  "XkbVariant" "phonetic"
        Option  "XkbOptions" "grp:ctrl_shift_toggle,grp_led:scroll"
EndSection

да добие такъв или подобен вид.Но това в конзолен режим.
$sudo /etc/init.d/gdm stop
Активен

Debian amd64 squeeze/sid

neter

  • Global Moderator
  • Напреднали
  • *****
  • Публикации: 3408
  • Distribution: Debian, SailfishOS, CentOS
  • Window Manager: LXDE, Lipstick
    • Профил
    • WWW
Убунту и кирилица
« Отговор #2 -: Apr 06, 2008, 13:07 »
От показания цитат, тази част
Цитат
Option "XkbLayout" "us,bg(phonetic)"
Option "XkbVariant" "phonetic"

трябва да бъде
Цитат
Option "XkbLayout" "us,bg"
Option  "XkbVariant" ",phonetic"

Не трябва да се задава bg(phonetic) в XkbLayout, а в XkbVariant запетайката е важна. Сетете се защо '<img'>
Активен

"Да си добре приспособен към болно общество не е признак за добро здраве" - Джиду Кришнамурти

viv1111

  • Напреднали
  • *****
  • Публикации: 250
  • Distribution: Slackware, Ubuntu, Knoppix
  • Window Manager: Gnome
    • Профил
Убунту и кирилица
« Отговор #3 -: Apr 06, 2008, 15:33 »
Леле, колко сложно му обяснявате всички!! Иди на „Система“, „Администрация“ и след това на „Езикови поддръжки“. После на „Система“, „Настройки“ и следва „Клавиатура“. Мисля, че сам ще можеш да се оправиш. Следващия път пиши на коя версия на Убунту си и дали те допуска да влезеш, въобще.
Активен

nedpetko

  • Напреднали
  • *****
  • Публикации: 445
  • Distribution: Debian GNU/Linux
  • Window Manager: KDE
    • Профил
Убунту и кирилица
« Отговор #4 -: Apr 06, 2008, 21:53 »
@neter
Да съгласен съм, копирах си частта от файла под Debian
иначе онзи от Ubuntu изглежда както ти си указал.

@viv1111
Универсалният начин е редакцията на xorg.conf, ако знаеш колко пъти не ми е тръгвала поддръжката на клавиатури под KDE.
Та затова го препоръчваме, а пък си го и ползваме '<img'>



Активен

Debian amd64 squeeze/sid