Автор Тема: Debian lenny ati radeon и тотално забиване...  (Прочетена 7028 пъти)

never_mind

  • Напреднали
  • *****
  • Публикации: 215
  • Distribution: Debian/Testing
  • Window Manager: Xfce4
    • Профил
Имам следният проблем от месеци наред и не мога да намеря решение... дано някой тук успее да ми помогне...
Debian lenny, Ati Radeon 9200, драйвър "radeon", при гледане на филм с който и да е плеър ( kaffeine, mplayer ) ... без причина и съвсем в произволно време от филма, без значение филма и формата ( avi, mpeg, flv ) ... тотално забиване на всичко, при което само копчето оправя нещата... смених 10 ядра поне, половината от които аз съм си компилирал, другата половина компилирани от хранилищата... и няма оправия и тва е... графична среда xfce... нищо не намирам по логовете... просто си умира и тва е... Идеи?
« Последна редакция: Oct 30, 2008, 19:54 от zeridon »
Активен

gizi_

  • Напреднали
  • *****
  • Публикации: 521
  • Distribution: Debian/Lenny, SLES/9-11
  • Window Manager: Gnome 2.22.3
    • Профил
Debian lenny и тотално забиване...
« Отговор #1 -: Oct 28, 2008, 19:53 »
Ами аз бих ти препоръчал да си добавиш non-free хранилища в sources.list да си инсталираш fglrx драйверите и да си добавиш Option "UseInternalAGPGART" "no" и Option "KernelModuleParm" "agplock=0" в Section "Device" и да видим тогава дали ще забива.



Активен

never_mind

  • Напреднали
  • *****
  • Публикации: 215
  • Distribution: Debian/Testing
  • Window Manager: Xfce4
    • Профил
Debian lenny и тотално забиване...
« Отговор #2 -: Oct 28, 2008, 20:59 »
Ок... с ядро 2.6.26-1 съм, което е последното от хранилището за лени... свалих fglrx-... пакетите, с m-a компилирах модул, заредих го през xorg.conf с опциите, които си посочил горе, но X не тръгна, грешката е:

fglrx: no screen found on PCI 1:0:1 ... а видеото ми е там, демек fglrx не разпознава ati-то... Идеи?

А да, и при опит ръчно да заредя fglrx става следното:

#modprobe fglrx
FATAL: Error inserting fglrx (/lib/modules/2.6.26-1-686/misc/fglrx.ko): Operation not permitted

като този ред е последен,преди него плюе хиляди неща, но са прекалено много...
Активен

gizi_

  • Напреднали
  • *****
  • Публикации: 521
  • Distribution: Debian/Lenny, SLES/9-11
  • Window Manager: Gnome 2.22.3
    • Профил
Debian lenny и тотално забиване...
« Отговор #3 -: Oct 28, 2008, 21:45 »
След като си инсталирал драйверите пробвай с aticonfig --initial --input=/etc/X11/xorg.conf и дали ще ти тръгне Х-са. Аз лично ползвам драйверите от testing хранилищата на дебиян и честно казано бях много скептичен в началото, че ще работят. Обаче нямам никави проблеми. А относно това твоето забиване принципно четох в една немската уикипедия на убунту, че може да се стигне до този момент ако 1. ползваш ATI Xpress и 2. ако ползваш fglrx обаче при теб нито едното нито другото. Аз съм на notebook-a с ATI XPress 200M и го имах този проблем преди да прочета това. След това по начина който ти описах си реших проблема. Дай си xorg.conf както и дай да видим покрай времето в което е "замръзнал" компа какво пише из /var/log/ и особенно kern.log.



Активен

never_mind

  • Напреднали
  • *****
  • Публикации: 215
  • Distribution: Debian/Testing
  • Window Manager: Xfce4
    • Профил
Debian lenny и тотално забиване...
« Отговор #4 -: Oct 28, 2008, 22:21 »
# aticonfig --initial --input=/etc/X11/xorg.conf
Uninitialised file found, configuring.
Segmentation fault
#

....

... kern.log неясно защо ми е от 31.03.2007... '<img'> ... а в syslog няма нищо за проблема...

Примерен код

Section "Module"
   Load   "i2c"
   Load   "bitmap"
   Load   "ddc"
   Load   "dri"
   Load   "extmod"
   Load   "freetype"
   Load   "glx"
   Load   "int10"
   Load   "vbe"
EndSection

Section "InputDevice"
   Identifier   "Generic Keyboard"
   Driver      "kbd"
   Option      "CoreKeyboard"
   Option      "XkbRules"   "xorg"
   Option      "XkbModel"   "pc104"
   Option      "XkbLayout"   "us,bg(phonetic)"
   Option       "XkbOptions" "grp:alt_shift_toggle,grp_led:scroll,compose:rwin"
EndSection

Section "InputDevice"
   Identifier   "Configured Mouse"
   Driver      "mouse"
   Option      "CorePointer"
   Option      "Device"      "/dev/input/mice"
   Option      "Protocol"      "auto"
   #Option      "Emulate3Buttons" "false"
     #Option       "Buttons" "7"
       #Option       "ButtonMapping" "1 2 3 6 7"
       Option       "ZAxisMapping" "4 5"
EndSection

Section "Device"
   Identifier   "ATI Technologies Inc RV280 [Radeon 9200]"
   Driver      "ati"
   BusID      "PCI:1:0:0"
   Option "UseInternalAGPGART" "no"
   Option "KernelModuleParm" "agplock=0"
EndSection

Section "Monitor"
   Identifier   "Philips 190S"
   Option      "DPMS"
#   HorizSync    30.0 - 83.0
#        VertRefresh  75.0 - 75.0
EndSection

Section "Screen"
   Identifier   "Default Screen"
   Device      "ATI Technologies Inc RV280 [Radeon 9200]"
   Monitor      "Philips 190S"
   DefaultDepth   24
#   SubSection "Display"
#      Depth      1
#      Modes      "1280x1024" "1280x960" "1024x768" "832x624" "800x600" "720x400" "640x480"
#   EndSubSection
#   SubSection "Display"
#      Depth      4
#      Modes      "1280x1024" "1280x960" "1024x768" "832x624" "800x600" "720x400" "640x480"
#   EndSubSection
#   SubSection "Display"
#      Depth      8
#      Modes      "1280x1024" "1280x960" "1024x768" "832x624" "800x600" "720x400" "640x480"
#   EndSubSection
##   SubSection "Display"
#      Depth      15
#      Modes      "1280x1024" "1280x960" "1024x768" "832x624" "800x600" "720x400" "640x480"
##   EndSubSection
#   SubSection "Display"
#      Depth      16
#      Modes      "1280x1024" "1280x960" "1024x768" "832x624" "800x600" "720x400" "640x480"
#   EndSubSection
   SubSection "Display"
      Depth      24
      Modes      "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
   EndSubSection
EndSection

Section "ServerLayout"
   Identifier   "Default Layout"
   Screen      "Default Screen"
   InputDevice   "Generic Keyboard"
   InputDevice   "Configured Mouse"
   Option "StandbyTime" "7"
   Option "SuspendTime" "7"
   Option "OffTime" "10"
EndSection

Section "DRI"
   Mode   0666
EndSection




Активен

gizi_

  • Напреднали
  • *****
  • Публикации: 521
  • Distribution: Debian/Lenny, SLES/9-11
  • Window Manager: Gnome 2.22.3
    • Профил
Debian lenny и тотално забиване...
« Отговор #5 -: Oct 28, 2008, 22:41 »
Сложи си драйверите и пробвай с това може да тръгне:
Section "Device"
    Identifier "ATI Technologies Inc RV280 [Radeon 9200]"
    Driver "fglrx"
    Option "UseInternalAGPGART" "no"
    Option "KernelModuleParm" "agplock=0"
EndSection

Но първо бъди сигурен, че ти работят драйверите на fglrx.
Активен

never_mind

  • Напреднали
  • *****
  • Публикации: 215
  • Distribution: Debian/Testing
  • Window Manager: Xfce4
    • Профил
Re: Debian lenny и тотално забиване...
« Отговор #6 -: Oct 29, 2008, 21:49 »
Не става пак, пак казва, че на PCI 1:0:1 няма device...
И как да съм сигурен, дали fglrx работи както трябва..
Активен

nedpetko

  • Напреднали
  • *****
  • Публикации: 445
  • Distribution: Debian GNU/Linux
  • Window Manager: KDE
    • Профил
Re: Debian lenny и тотално забиване...
« Отговор #7 -: Oct 29, 2008, 22:12 »
Ами в твоя xorg.conf пише, че видокартата ти се намира на:
Цитат
Section "Device"
   Identifier   "ATI Technologies Inc RV280 [Radeon 9200]"
   Driver      "ati"
   BusID      "PCI:1:0:0"
   Option "UseInternalAGPGART" "no"
   Option "KernelModuleParm" "agplock=0"
EndSection
Две видеокарти ли имаш?
За по сигурно дай тука изхода от:
Код:
lspci
Ако действително имаш две видеокарти пробвай да спреш вгардената от BIOS-а, а ако ли не ще продължаваме да мислим :)
(edit)
P.S. /офт Само виж в коя секция е темата? :)
« Последна редакция: Oct 29, 2008, 22:34 от nedpetko »
Активен

Debian amd64 squeeze/sid

never_mind

  • Напреднали
  • *****
  • Публикации: 215
  • Distribution: Debian/Testing
  • Window Manager: Xfce4
    • Профил
Re: Debian lenny и тотално забиване...
« Отговор #8 -: Oct 29, 2008, 23:38 »
Да, две са:

#lspci
lspci
00:00.0 Host bridge: VIA Technologies, Inc. CN700/VN800/P4M800CE/Pro Host Bridge
00:00.1 Host bridge: VIA Technologies, Inc. CN700/VN800/P4M800CE/Pro Host Bridge
00:00.2 Host bridge: VIA Technologies, Inc. CN700/VN800/P4M800CE/Pro Host Bridge
00:00.3 Host bridge: VIA Technologies, Inc. PT890 Host Bridge
00:00.4 Host bridge: VIA Technologies, Inc. CN700/VN800/P4M800CE/Pro Host Bridge
00:00.7 Host bridge: VIA Technologies, Inc. CN700/VN800/P4M800CE/Pro Host Bridge
00:01.0 PCI bridge: VIA Technologies, Inc. VT8237/VX700 PCI Bridge
00:0f.0 IDE interface: VIA Technologies, Inc. VT8251 AHCI/SATA 4-Port Controller
00:0f.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 07)
00:10.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 90)
00:10.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 90)
00:10.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 90)
00:10.3 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 90)
00:10.4 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 90)
00:11.0 ISA bridge: VIA Technologies, Inc. VT8251 PCI to ISA Bridge
00:11.5 Multimedia audio controller: VIA Technologies, Inc. VT8233/A/8235/8237 AC97 Audio Controller (rev 70)
00:11.7 Host bridge: VIA Technologies, Inc. VT8251 Ultra VLINK Controller
00:12.0 Ethernet controller: VIA Technologies, Inc. VT6102 [Rhine-II] (rev 7c)
00:13.0 PCI bridge: VIA Technologies, Inc. VT8251 Host Bridge
01:00.0 VGA compatible controller: ATI Technologies Inc RV280 [Radeon 9200] (rev 01)
01:00.1 Display controller: ATI Technologies Inc RV280 [Radeon 9200] (Secondary) (rev 01)
02:00.0 PCI bridge: VIA Technologies, Inc. VT8251 PCIE Root Port
02:00.1 PCI bridge: VIA Technologies, Inc. VT8251 PCIE Root Port

... и съм почти сигурен, че си постнах темата в "начинаещи", предполагам, че за това говориш...
и вградената мисля че е забранена.. по-точно единствената опция в BIOS-а е Primary adapter и е настроена на AGP...
« Последна редакция: Oct 29, 2008, 23:50 от never_mind »
Активен

gizi_

  • Напреднали
  • *****
  • Публикации: 521
  • Distribution: Debian/Lenny, SLES/9-11
  • Window Manager: Gnome 2.22.3
    • Профил
Re: Debian lenny и тотално забиване...
« Отговор #9 -: Oct 30, 2008, 00:23 »
Не става пак, пак казва, че на PCI 1:0:1 няма device...
И как да съм сигурен, дали fglrx работи както трябва..

.....
00:13.0 PCI bridge: VIA Technologies, Inc. VT8251 Host Bridge
01:00.0 VGA compatible controller: ATI Technologies Inc RV280 [Radeon 9200] (rev 01)
01:00.1 Display controller: ATI Technologies Inc RV280 [Radeon 9200] (Secondary) (rev 01)
02:00.0 PCI bridge: VIA Technologies, Inc. VT8251 PCIE Root Port
.....

Добре де сега като гледам каде кое се намира и грешката която ти дава ми се струва, че леко се разминават в числата. Смисъл в ид-то. Другото което е защо не пробваш след като "мрънка", че на 1:00.1 няма а ти си на 1:00.0 що не го смениш. Надявам се да си ме разбрал много съм уморен и може да не ми много ясно изказването.
Активен

luda_glawa

  • Напреднали
  • *****
  • Публикации: 652
  • Distribution: Kubuntu
  • Window Manager: KDE
    • Профил
    • WWW
Re: Debian lenny и тотално забиване...
« Отговор #10 -: Oct 30, 2008, 07:36 »
Преди време се борих с един Radeon 9200 на debian lenny. Главния проблем е, че подръжката му е спряна т.е. последния излязъл драйвер е от Aug. 18, 2006 :(( Евентуално би могъл да пробваш с него, но ще започне да реве, че иска пакети с по ниски версии ... Решението ми беше качване на etch. Тогава драйвера си се компилира и инсталира, но нещо с OpenGL подръжката не беше наред.
Активен

С Уважение:

Luda Glawa ;-)

never_mind

  • Напреднали
  • *****
  • Публикации: 215
  • Distribution: Debian/Testing
  • Window Manager: Xfce4
    • Профил
Re: Debian lenny и тотално забиване...
« Отговор #11 -: Oct 30, 2008, 08:43 »
Не разбрах на какво да го сменя... в xorg да задам 1.0.1 ли? Защото това съм го пробвал и не става...
Активен

phantomlord

  • Напреднали
  • *****
  • Публикации: 1832
  • Distribution: Debian Sid
  • Window Manager: KDE 4
  • Fall to your knees and bow to the Phantom Lord
    • Профил
    • WWW
Re: Debian lenny и тотално забиване...
« Отговор #12 -: Oct 30, 2008, 10:09 »
Ок... с ядро 2.6.26-1 съм, което е последното от хранилището за лени... свалих fglrx-... пакетите, с m-a компилирах модул, заредих го през xorg.conf с опциите, които си посочил горе, но X не тръгна, грешката е:

fglrx: no screen found on PCI 1:0:1 ... а видеото ми е там, демек fglrx не разпознава ati-то... Идеи?

А да, и при опит ръчно да заредя fglrx става следното:

#modprobe fglrx
FATAL: Error inserting fglrx (/lib/modules/2.6.26-1-686/misc/fglrx.ko): Operation not permitted

като този ред е последен,преди него плюе хиляди неща, но са прекалено много...

Operation not permitted излиза, защото докато се опитваш да заредиш fglrx модула, radeon модула ти е още зареден. Можеш да сложиш Driver "fglrx"в xorg.conf и да рестартираш. Виж и това: http://myfreesoft.net/phpBB2/viewtopic.php?t=558
При мен работи без грешка.
Активен

http://myfreesoft.net/phpBB2/index.php?c=7
Помогни си сам, за да ти помогне и Господ
Linux - connecting people...

never_mind

  • Напреднали
  • *****
  • Публикации: 215
  • Distribution: Debian/Testing
  • Window Manager: Xfce4
    • Профил
Re: Debian lenny и тотално забиване...
« Отговор #13 -: Oct 30, 2008, 19:26 »
Мда... изглежда добре... но ето какво става при мен...

# ./sgfxi
ERROR: (250) You must be out of X/KDE to run this graphics installer.
Exiting script now.
#

демек не ми намира X-са... а при следното

# ./ati-driver-installer-8.26.18-x86.run
Creating directory fglrx-install
Verifying archive integrity... All good.
Uncompressing ATI Proprietary Linux Driver-8.26.18...
==================================================
 ATI Technologies Linux Driver Installer/Packager
==================================================
Detected configuration:
Architecture: i686 (32-bit)
X Server: unable to detect
Removing temporary directory: fglrx-install
#

какво ми липсва, че скриптовете не ми намират Х-са... ?

~$ Xorg -version

X.Org X Server 1.4.2
Release Date: 11 June 2008
X Protocol Version 11, Revision 0
Build Operating System: Linux Debian (xorg-server 2:1.4.2-7)
Current Operating System: Linux debian 2.6.26-1-686 #1 SMP Thu Oct 9 15:18:09 UTC 2008 i686
Build Date: 30 September 2008  01:48:58AM
 
   Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
Module Loader present
$
« Последна редакция: Oct 30, 2008, 19:52 от never_mind »
Активен

phantomlord

  • Напреднали
  • *****
  • Публикации: 1832
  • Distribution: Debian Sid
  • Window Manager: KDE 4
  • Fall to your knees and bow to the Phantom Lord
    • Профил
    • WWW
Re: Debian lenny ati radeon и тотално забиване...
« Отговор #14 -: Oct 30, 2008, 19:59 »
Цитат
# ./sgfxi
ERROR: (250) You must be out of X/KDE to run this graphics installer.
Exiting script now.
#
демек не ми намира X-са...
Явно не си добре с английския, а и не си чел като хората в линка... Съобщението е, че трябва да си ИЗВЪН ГРАФИЧНА СРЕДА, за да пуснеш скрипта. А не, че не ти намира Х. Спря ли gdm/kde, както пише в линка???
« Последна редакция: Oct 30, 2008, 20:01 от phantomlord »
Активен

http://myfreesoft.net/phpBB2/index.php?c=7
Помогни си сам, за да ти помогне и Господ
Linux - connecting people...

Подобни теми
Заглавие Започната от Отговора Прегледи Последна публикация
Segmentation fault - debian lenny/sid ?
Настройка на програми
inst 2 1754 Последна публикация Jul 05, 2007, 10:45
от gizi_
Debian lenny инсталационен проблем
Настройка на програми
petkoned 23 5918 Последна публикация Dec 04, 2009, 09:38
от nedpetko
Rc.local в debian lenny
Настройка на програми
winman 15 4859 Последна публикация Apr 16, 2008, 18:13
от winman
Debian/Lenny не ми засича микрофона
Настройка на хардуер
Ekspert 5 4043 Последна публикация Feb 08, 2009, 22:14
от dedal
CDRW проблем под Debian lenny
Настройка на хардуер
ivan1979 1 1729 Последна публикация Nov 27, 2008, 16:28
от zeridon