Автор Тема: проблем при инсталация на Google Earth  (Прочетена 7246 пъти)

nasko711206

  • Напреднали
  • *****
  • Публикации: 18
    • Профил
Здравейте на вси4ки !
зна4и имам следния проблем ,когато се опитам да инсталирам Гугъл Ърф-а , ми дава съобщение
 No protocol specified
 С Кубунту 10.4 съм Linux lp 2.6.32-24-generic #38-Ubuntu ядро
видео картата е Mobility Radeon X600
тази дистрибуция няма xorg.conf , помислих ,4е проблема е от там сложих един такъв файл , но без ефект

Активен

chen_dzen

  • Напреднали
  • *****
  • Публикации: 623
  • Distribution: Debian 6.0 Squeeze
  • Window Manager: GNOME
    • Профил
Re: проблем при инсталация на Google Earth
« Отговор #1 -: Jul 16, 2010, 21:23 »
как се поитваш да го инсталираш. При мен на Ubuntu 10.04 става така :

 # sudo gdebi googleearth_5.1.3535.3218+0.5.6-1_i386.deb

 ако става въпрос за GoogleEarth5

 # bash GoogleEarthLinux.bin

nasko711206

  • Напреднали
  • *****
  • Публикации: 18
    • Профил
Re: проблем при инсталация на Google Earth
« Отговор #2 -: Jul 16, 2010, 21:30 »
dpkg -i googleearth_5.2.1.1329+0.5.7-1_amd64.deb

Processing triggers for python-gmenu ...
Rebuilding /usr/share/applications/desktop.en_US.utf8.cache...
Processing triggers for menu ...
Processing triggers for shared-mime-info ...
Unknown media type in type 'all/all'

Unknown media type in type 'all/allfiles'

Unknown media type in type 'uri/mms'

Unknown media type in type 'uri/mmst'

Unknown media type in type 'uri/mmsu'

Unknown media type in type 'uri/pnm'

Unknown media type in type 'uri/rtspt'

Unknown media type in type 'uri/rtspu'

Unknown media type in type 'fonts/package'

Unknown media type in type 'interface/x-winamp-skin'

Processing triggers for python-support ...


След този ред се връща в командния ред на конзолата



или
sh GoogleEarthLinux.bin

No protocol specified

това в рутска конзола
аз съм с 64 битовата версия на 10.4
« Последна редакция: Jul 16, 2010, 21:35 от nasko711206 »
Активен

chen_dzen

  • Напреднали
  • *****
  • Публикации: 623
  • Distribution: Debian 6.0 Squeeze
  • Window Manager: GNOME
    • Профил
Re: проблем при инсталация на Google Earth
« Отговор #3 -: Jul 16, 2010, 22:09 »
Код
GeSHi (Bash):
  1. bash GoogleEarthLinux.bin
  2. gdebi googleearth_5.2.1.1329+0.5.7-1_amd64.deb
« Последна редакция: Jul 16, 2010, 22:16 от chen_dzen »
Активен

nasko711206

  • Напреднали
  • *****
  • Публикации: 18
    • Профил
Re: проблем при инсталация на Google Earth
« Отговор #4 -: Jul 16, 2010, 22:31 »
Инсталирах го. Проблемът беше, че трябва да се инсталира с потребителя, с който е заредена графичната среда. Но сега не се стартира. Показва се само началната картинка с надписа и след това умира.


редакция от neter: Редактирано, съгласно т.3 от правилата на форума. Нека не се повтаря ;)

Съжалявам за шльокавицата ,но за малко нямах кирилица  :)
« Последна редакция: Jul 16, 2010, 22:56 от nasko711206 »
Активен

vyrgozunqk

  • Гост
Re: проблем при инсталация на Google Earth
« Отговор #5 -: Jul 16, 2010, 22:42 »
Aз имам абсолютно същия проблем, а това излиза от логовете, като нищо не намерих по въпроса, гледам само, че и други хора го срещат.

Цитат
Major Version 5
Minor Version 2
Build Number 0001
Build Date Jun 10 2010
Build Time 16:15:55
OS Type 3
OS Major Version 2
OS Minor Version 6
OS Build Version 34
OS Patch Version 0
Crash Signal 6
Crash Time 1279308987
Up Time 2,92771

Stacktrace from glibc:
./libgoogleearth_free.so(+0xd030b)[0xb785530b]
[0xffffe400]
/lib/i686/libc.so.6(abort+0x182)[0xb5b8d3d2]
/usr/lib/dri/r300_dri.so(+0xb7c6)[0xac91f7c6][/quote[
Активен

chen_dzen

  • Напреднали
  • *****
  • Публикации: 623
  • Distribution: Debian 6.0 Squeeze
  • Window Manager: GNOME
    • Профил
Re: проблем при инсталация на Google Earth
« Отговор #6 -: Jul 16, 2010, 22:44 »
 да и при мен така се получава кaто опитах да си инсталирам по новата версия ето и резолтатите от
 /home/user/.googleearth/crashlogs/crashlog-4c40b5c8.txt

Major Version 5
Minor Version 2
Build Number 0001
Build Date Jun 10 2010
Build Time 16:15:55
OS Type 3
OS Major Version 2
OS Minor Version 6
OS Build Version 31
OS Patch Version 0
Crash Signal 6
Crash Time 1279309256
Up Time 0.622373

Stacktrace from glibc:
./libgoogleearth_free.so[0xf1c30b]
[0x347400]
/lib/tls/i686/cmov/libc.so.6(abort+0x182)[0x6e9932]
/usr/lib/dri/i965_dri.so[0x6fddb6f]
/usr/lib/dri/i965_dri.so[0x6ff2216]
/usr/lib/dri/i965_dri.so[0x6fdbe69]
/usr/lib/libGL.so.1[0xb775f9]
/usr/lib/libGL.so.1[0xb5402b]
/usr/lib/libGL.so.1[0xb4f63a]
/usr/lib/libGL.so.1(glXChooseVisual+0x36)[0xb503e6]
./librender.so[0xaf3673]
./librender.so(_ZN12RenderWidget4initEv+0x116)[0xaf4056]
./librender.so(_ZN12RenderWidgetC1EP7QWidgetPKc6QFlagsIN2Qt10WindowTypeEE+0x16c)[0xaf4eac]
./librender.so(_ZN5earth6render12RenderWindow12createWidgetEv+0x82)[0xad7432]
./libgoogleearth_free.so(_ZN5earth6client12ModuleWidget9showEventEP10QShowEvent+0x94)[0xef92d4]
./libQtGui.so.4(_ZN7QWidget5eventEP6QEvent+0xabb)[0x11007ef]
./libQtGui.so.4(_ZN19QApplicationPrivate13notify_helperEP7QObjectP6QEvent+0xa0)[0x10b0e20]
./libQtGui.so.4(_ZN12QApplication6notifyEP7QObjectP6QEvent+0x16f)[0x10ba8a3]
./libQtCore.so.4(_ZN16QCoreApplication14notifyInternalEP7QObjectP6QEvent+0x70)[0x58ed50]
./libQtGui.so.4(_ZN14QWidgetPrivate11show_helperEv+0xcc)[0x110355c]
« Последна редакция: Jul 16, 2010, 22:51 от chen_dzen »
Активен

nasko711206

  • Напреднали
  • *****
  • Публикации: 18
    • Профил
Re: проблем при инсталация на Google Earth
« Отговор #7 -: Jul 16, 2010, 22:53 »
При мен логовете показват това

Major Version 5
Minor Version 2
Build Number 0001
Build Date Jun 10 2010
Build Time 16:15:55
OS Type 3
OS Major Version 2
OS Minor Version 6
OS Build Version 32
OS Patch Version 0
Crash Signal 6
Crash Time 1279307146
Up Time 1.14151

Stacktrace from glibc:
/usr/lib/googleearth/libgoogleearth_free.so(+0xd030b)[0xf76ed30b]
[0xf7746400]






А това се полу4ава когато се опитах да го инстална като рут в X


Uncompressing Google Earth for GNU/Linux 5.2.1.1329...............................................................

(setup.gtk2:32022): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libqtcurve.so: wrong ELF class: ELFCLASS64
loki_setup: Suspect size value for option option

loki_setup: Suspect size value for option option

loki_setup: Suspect size value for option option

Installing mimetypes...
Installing desktop menu entries...
Installing desktop icon...
Fatal error in __driConfigOptions line 1, column 0: unknown encoding.
Google Earth has caught signal 6.



We apologize for the inconvenience, but Google Earth has crashed.
 This is a bug in the program, and should never happen under normal
 circumstances. A bug report and debugging data have been written
 to this text file:

    /root/.googleearth/crashlogs/crashlog-4c40aeb2.txt

Please include this file if you submit a bug report to Google.
Активен

sisosiso

  • Напреднали
  • *****
  • Публикации: 91
    • Профил
Re: проблем при инсталация на Google Earth
« Отговор #8 -: Jul 16, 2010, 22:54 »
Пробвай да го инсталираш през хранилището на Medibuntu.
Активен

nasko711206

  • Напреднали
  • *****
  • Публикации: 18
    • Профил
Re: проблем при инсталация на Google Earth
« Отговор #9 -: Jul 16, 2010, 23:33 »
Такааа :) , първо благодаря на sisosiso , за съвета деинсталирах вси4ки предишни инсталации и през Medibuntu-то тръгна , но до положение интерфейса на програмата без глобус4ето , като вади съобщение ,4е не може да се върже към kh.google.com:80 през същото IP уиндоуски гугъл работи нормално
Активен

nasko711206

  • Напреднали
  • *****
  • Публикации: 18
    • Профил
Re: проблем при инсталация на Google Earth
« Отговор #10 -: Jul 17, 2010, 00:58 »
Най-после заработи нормално , само дето не мога да си обясня как :)
Активен

vyrgozunqk

  • Гост
Re: проблем при инсталация на Google Earth
« Отговор #11 -: Jul 17, 2010, 01:49 »
И аз го подкарах, след много ровене в нета намерих това решение:

sudo  wget http://librarian.launchpad.net/7037027/libGL.so.1 -O libGL.so.1
в папката на гугъл-ърт.
Не знам на какво се дължи точно, но явно е нещо в libGL.so библиотеките, на по-новите дистрота..

Както и да е имам основен проблем с рендирането на шрифтовете вътре по самият глобус, менютата са си на български и всичко е ок, но вътре всичко ми е на бели/жълти правоъгълници...
За бъга, с нетръгването изобщо на програмата и увисването на сплаш екрана има стотици постове, но никаква реакция от гугъл, проблема е много стар...
Следователно без коментар.
Активен

vas_68

  • Напреднали
  • *****
  • Публикации: 12
  • Distribution: PCLinuxOS
  • Window Manager: KDE
    • Профил
Re: проблем при инсталация на Google Earth
« Отговор #12 -: Jul 17, 2010, 18:12 »
Както и да е имам основен проблем с рендирането на шрифтовете вътре по самият глобус, менютата са си на български и всичко е ок, но вътре всичко ми е на бели/жълти правоъгълници...
Здравейте!
При мен пък менютата са на квадратчета, а в глобуса всичко си е наред (като изключим грозния шрифт). Ако някой знае как се настройват щрифтовете в Google Earth моля да сподели.
Поздрави!
Активен

vyrgozunqk

  • Гост
Re: проблем при инсталация на Google Earth
« Отговор #13 -: Jul 17, 2010, 20:24 »
До колкото помня трябваше да се инсталират майкрософтските шрифтове, би трябвало да ги има в non-free хранилището на твойта дистрибуция, ако си с дебиан в ги има в debian-multimedia хранилището...
Активен

ROKO__

  • Напреднали
  • *****
  • Публикации: 1531
  • Distribution: Calculate Linux Workstation amd64
  • Window Manager: GNOME 2.30
  • AMD Athlon64 4000+ Dual Core 2100 MHz 2MB L2 cache
    • Профил
Re: проблем при инсталация на Google Earth
« Отговор #14 -: Jul 18, 2010, 07:22 »
До колкото помня трябваше да се инсталират майкрософтските шрифтове, би трябвало да ги има в non-free хранилището на твойта дистрибуция, ако си с дебиан в ги има в debian-multimedia хранилището...

И защо са му MS фонтовете?
Активен

Не е важно да си добър, важно е да си най добрия!!!

http://www.calculate-linux.ru/
http://www.agilialinux.ru/