Автор Тема: Bridge eth0 and eth1  (Прочетена 2563 пъти)

Pulear

  • Напреднали
  • *****
  • Публикации: 72
    • Профил
Bridge eth0 and eth1
« -: Apr 02, 2006, 00:43 »
Здравейте...
Сложих си втора лан карта с мисълта да bridg-на двете карти
за да има мрежа на друго пц.
След като монтирах втората лан карта дебиана каза че всичко си е наред разпозна си я.Конфигурирах я бачка си но когато работеше eth1 не бях пуснал eth0.
След това активирах и двете лан карти всичко изглежадеше наред
при мен, другото пц нямаше мрежа след рестарт на дебиан се оказа че
eth1: ERROR while getting interface flags: No such device
а преди това бях ползвал eth1.До тук разбрах че нещо пречи двете лан карти да работят едновременно.
ето го и /etc/network/interfaces/
Примерен код

auto eth0
iface eth0 inet static
name Мрежова (LAN) карта
address 192.168.0.2
netmask 255.255.255.0
broadcast 192.168.0.255
network 192.168.0.0
gateway 192.168.0.1


auto eth1
iface eth1 inet static
name Мрежова (LAN) карта
address 192.168.0.3
netmask 255.255.255.0
broadcast 192.168.0.255
network 192.168.0.0
#Попринцип така мисля да bridg-на двете карти.
auto br0
iface br0 inet static
    address 192.168.0.2
    netmask 255.255.255.0
    network 192.168.0.0
    broadcast 192.168.0.255
    gateway 192.168.0.1
    bridge_ports eth0 eth1

Debian Gnu/Linux  2.4.27-2-k7
Ако някой има решение на проблема и желание да сподели решението...добре дошъл.

Поздрави.
Активен

Shift to the left!
Shift to the right!
Pop up,Push down,
BYTE,BYTE,BYTE.

jasonsmith

  • Напреднали
  • *****
  • Публикации: 41
    • Профил
Bridge eth0 and eth1
« Отговор #1 -: Apr 03, 2006, 20:27 »
хаха и аз имам същият проблем само че втората карта ще я ползвам за voip на slackware 10.2. При мен подозирам че след като включих втората карта се омешаха двете карти и eth0 стана eth1. Направих едни промени в /etc/rc.d/rc.inet1.conf промених eth0 с eth1 и се надявам да стане, но все още не съм го пробвал да видя. надявам се така да стане че утре идват да ми го поставят voip - to ':huh:'
# Config information for eth0:
IPADDR[1]="62.234.138.8"
NETMASK[1]="255.255.255.192"
USE_DHCP[1]=""
DHCP_HOSTNAME[1]=""

# Config information for eth1:
IPADDR[0]="192.168.1.2"
NETMASK[0]="255.255.255.0"
USE_DHCP[0]=""
DHCP_HOSTNAME[0]=""
Активен

Slackware 12.0

jasonsmith

  • Напреднали
  • *****
  • Публикации: 41
    • Профил
Bridge eth0 and eth1
« Отговор #2 -: Apr 04, 2006, 16:55 »
за съжаление не стана при мен, имам чуввстово че някой модул не ми зарежда ли какво ли, но след като поставя втората карта на дъното и не успявам да си стартирам слака, някой има ли идея от какво може да е '<img'> , лошото е че съобщението не го запомних което ми изписва, а не се сеща, в кой лог файл го записва
Активен

Slackware 12.0

redcure

  • Напреднали
  • *****
  • Публикации: 914
    • Профил
Bridge eth0 and eth1
« Отговор #3 -: Apr 04, 2006, 17:04 »
http://linux-net.osdl.org/index.php/Bridge
 '<img'>
Ask google!
Активен

Debian testing 2.6.18, Enlightenment DR17

http://www.debian.org/doc/manuals/apt-howto/index.en.html

mom

  • Напреднали
  • *****
  • Публикации: 266
  • Distribution: Ubuntu
  • Window Manager: Compiz
    • Профил
Bridge eth0 and eth1
« Отговор #4 -: Apr 04, 2006, 20:19 »
Сещам се за 2 идеи:
1. Конфликт м-у ресурсите на картите - и двете седят на едбо и също IRQ и/или MemoryAddress
2. в Setup-a на BIOS-а ти е разрешено Plug & Play OS
Активен

jasonsmith

  • Напреднали
  • *****
  • Публикации: 41
    • Профил
Bridge eth0 and eth1
« Отговор #5 -: Apr 04, 2006, 20:21 »
Да като се прибера ще проверя за BIOS -а , тъй като си мисля че наистина може да е от това, а ако е от IRQ и/или MemoryAddressi как бих могъл да го оправя?
Активен

Slackware 12.0

hary

  • Напреднали
  • *****
  • Публикации: 73
    • Профил
Bridge eth0 and eth1
« Отговор #6 -: Apr 06, 2006, 13:22 »
премести новата карта на друг ПЦИ слот '<img'>

btw някои у-ва могат да шерват безпроблемно прекъсвания а други не , имай го в предвид
Активен

jasonsmith

  • Напреднали
  • *****
  • Публикации: 41
    • Профил
Bridge eth0 and eth1
« Отговор #7 -: Apr 07, 2006, 11:45 »
При мен стана, но смених лан картата с друга с реалтек чип и съм много доволен '<img'> ; сега остава само да си шерна нета от едната към другата, но се оказа че не се сещам как става ':huh:'
02:08.0 Ethernet controller: Intel Corporation 82801BA/BAM/CA/CAM Ethernet Controller (rev 01)
02:09.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
eth0      Link encap:Ethernet  HWaddr 00:50:FC:FA:A3:DD
          inet addr:192.168.1.2  Bcast:192.168.1.255  Mask:255.255.255.0
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 'B)'  TX bytes:180 (180.0 'B)'
          Interrupt:10 Base address:0xc000

eth1      Link encap:Ethernet  HWaddr 00:02:A5:64:3E:CA
          inet addr:62.204.xxx.x Bcast:62.204.138.63  Mask:255.255.255.192
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:26739 errors:0 dropped:0 overruns:0 frame:0
          TX packets:16890 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:5023134 (4.7 Mb)  TX bytes:2095373 (1.9 Mb)
          Interrupt:5 Base address:0x4000

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:20 errors:0 dropped:0 overruns:0 frame:0
          TX packets:20 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:1668 (1.6 Kb)  TX bytes:1668 (1.6 Kb)



Активен

Slackware 12.0