Автор Тема: Какво е това PKG_CONFIG_PATH  (Прочетена 1773 пъти)

eisen

  • Напреднали
  • *****
  • Публикации: 22
  • Distribution: Debian GNU/Linux stretch/sid 64-bit & 32-bit
  • Window Manager: Gnome 3.20.2
    • Профил
Какво е това PKG_CONFIG_PATH
« -: May 01, 2013, 23:50 »
Компилирам новия релийз на gimp 2.8.4 обаче ми искача това нещо постоянно и не мога да завърша конфигурирането.Инсталирал съм всички други зависимости, само това не разбрах как се оправя.Разглеждах из нета за подобни проблеми, но няма конкретен отговор, като за моя проблем.

Цитат
Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.
Активен

Processor - Intel® Core™ i7-4702MQ CPU @ 2.20GHz × 8 & Turbo Boost up to 3.2GHz
Graphics - Intel® Haswell Mobile & NVIDIA GeForce GTX 760M

neter

  • Global Moderator
  • Напреднали
  • *****
  • Публикации: 3408
  • Distribution: Debian, SailfishOS, CentOS
  • Window Manager: LXDE, Lipstick
    • Профил
    • WWW
Re: Какво е това PKG_CONFIG_PATH
« Отговор #1 -: May 02, 2013, 00:46 »
PKG_CONFIG_PATH е променлива на средата. Променливите на средата съдържат информация, в съответствие с която много програми определят начина си на работа. В частност, PKG_CONFIG_PATH съдържа пътищата до всички директории, които pkg-config проверява за файлове, нужни за работата му, като това обикновено е директорията /usr/lib/pkgconfig. Можеш да провериш имаш ли зададена стойност в момента за PKG_CONFIG_PATH с някоя от тези две команди
Цитат
echo $PKG_CONFIG_PATH
env | grep PKG_CONFIG_PATH
Стойност за тази променлива можеш да зададеш с подобна команда
Цитат
export PKG_CONFIG_PATH=/usr/lib/pkgconfig

В много случаи предложение за наместване стойността на PKG_CONFIG_PATH се показва, точно когато липсва някоя зависимост, макар да си мислиш, че всичко си инсталирал. Първо, увери се, че всичко е наред с пакета pkg-config, а след това ни покажи по-голяма част от изхода около това съобщение.
Активен

"Да си добре приспособен към болно общество не е признак за добро здраве" - Джиду Кришнамурти

eisen

  • Напреднали
  • *****
  • Публикации: 22
  • Distribution: Debian GNU/Linux stretch/sid 64-bit & 32-bit
  • Window Manager: Gnome 3.20.2
    • Профил
Re: Какво е това PKG_CONFIG_PATH
« Отговор #2 -: May 02, 2013, 01:50 »
Стигнах до конфигурирането на babl и накрая ми изписа това:

Цитат
./configure: line 5014: syntax error near unexpected token `2.2'
./configure: line 5014: `LT_PREREQ(2.2)'
danail@debian:~/babl$

И ме заби за пореден път с тази зависимост, а стойностите съм ги задал.

Цитат
export PATH=/opt/gimp-2.8/bin:$PATH

export PKG_CONFIG_PATH=/opt/gimp-2.8/lib/pkgconfig

export LD_LIBRARY_PATH=/opt/gimp-2.8/lib

Имам чуството, че това няма завършване....


Взех да се отчайвам:

Цитат
danail@debian:~/Program/gimp-2.8.0$ ./configure
./configure: line 446: sed: command not found
./configure: line 445: expr: command not found
./configure: line 460: sed: command not found
./configure: line 446: sed: command not found
: error: cannot create .lineno; rerun with a POSIX shell
« Последна редакция: May 02, 2013, 16:05 от eisen »
Активен

Processor - Intel® Core™ i7-4702MQ CPU @ 2.20GHz × 8 & Turbo Boost up to 3.2GHz
Graphics - Intel® Haswell Mobile & NVIDIA GeForce GTX 760M

d1saster

  • Напреднали
  • *****
  • Публикации: 182
    • Профил
Re: Какво е това PKG_CONFIG_PATH
« Отговор #3 -: May 02, 2013, 17:02 »
/usr/lib/pkgconfig съдържа файлове, които са опиесание на devel пакети. Явно ти липсват някои пакети нужни за компилиране на програми (*-devel или както се казват за твоята дистрибуция).

Не мисля, че това е правилно:
export PKG_CONFIG_PATH=/opt/gimp-2.8/lib/pkgconfig
Активен

eisen

  • Напреднали
  • *****
  • Публикации: 22
  • Distribution: Debian GNU/Linux stretch/sid 64-bit & 32-bit
  • Window Manager: Gnome 3.20.2
    • Профил
Re: Какво е това PKG_CONFIG_PATH
« Отговор #4 -: May 02, 2013, 22:46 »
Ами как е правилно тогава?Защото трябва да сетна и това:

Цитат
checking for GLIB - version >= 2.28.0...
*** 'pkg-config --modversion glib-2.0' returned 2.28.8, but GLIB (2.24.2)
*** was found! If pkg-config was correct, then it is best
*** to remove the old version of GLib. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ld.so.conf. Make sure you have run ldconfig if that is
*** required on your system.
*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
*** to point to the correct configuration files
no
configure: error:
*** GLIB 2.28.0 or better is required. The latest version of
*** GLIB is always available from ftp://ftp.gtk.org/.

Само едно уточнение, аз инсталирах Glib 2.28.0, като по вода обаче след, като почнах компилирането на gegl ми изписва това отгоре.

УжасТ!!!
« Последна редакция: May 02, 2013, 23:21 от eisen »
Активен

Processor - Intel® Core™ i7-4702MQ CPU @ 2.20GHz × 8 & Turbo Boost up to 3.2GHz
Graphics - Intel® Haswell Mobile & NVIDIA GeForce GTX 760M

neter

  • Global Moderator
  • Напреднали
  • *****
  • Публикации: 3408
  • Distribution: Debian, SailfishOS, CentOS
  • Window Manager: LXDE, Lipstick
    • Профил
    • WWW
Re: Какво е това PKG_CONFIG_PATH
« Отговор #5 -: May 03, 2013, 00:28 »
./configure: line 5014: syntax error near unexpected token `2.2'
./configure: line 5014: `LT_PREREQ(2.2)'
Имаш ли инсталиран libtool?

export PKG_CONFIG_PATH=/opt/gimp-2.8/lib/pkgconfig
Когато се стигне до четене на PKG_CONFIG_PATH, хубаво е в стойността ѝ да присъства и пътят /usr/lib/pkgconfig. Задаване на повече от един директориен път в стойността на PKG_CONFIG_PATH става с подобна структура в командата
Цитат
export PKG_CONFIG_PATH=/usr/lib/pkgconfig:/opt/gimp-2.8/lib/pkgconfig

danail@debian:~/Program/gimp-2.8.0$ ./configure
./configure: line 446: sed: command not found
./configure: line 445: expr: command not found
./configure: line 460: sed: command not found
./configure: line 446: sed: command not found
: error: cannot create .lineno; rerun with a POSIX shell
Интересно. Ти нямаш ли идея как постигна това? :) Но явно си си омазал нещо PATH променливата на средата.
« Последна редакция: May 03, 2013, 00:31 от neter »
Активен

"Да си добре приспособен към болно общество не е признак за добро здраве" - Джиду Кришнамурти

eisen

  • Напреднали
  • *****
  • Публикации: 22
  • Distribution: Debian GNU/Linux stretch/sid 64-bit & 32-bit
  • Window Manager: Gnome 3.20.2
    • Профил
Re: Какво е това PKG_CONFIG_PATH
« Отговор #6 -: May 03, 2013, 00:32 »
Да същото ми се получи и с компилирането на gegl, но ей сега го излъгах


Цитат
root@debian:/home/danail# export LD_LIBRARY_PATH=/usr/lib
root@debian:/home/danail# ldconfig
root@debian:/home/danail#

Вече имам libtool

Цитат
Но явно си си омазал нещо PATH променливата на средата

Омазал съм, само GTK+ пише, че е неправилно инсталирано.
« Последна редакция: May 03, 2013, 01:12 от eisen »
Активен

Processor - Intel® Core™ i7-4702MQ CPU @ 2.20GHz × 8 & Turbo Boost up to 3.2GHz
Graphics - Intel® Haswell Mobile & NVIDIA GeForce GTX 760M

satir

  • Напреднали
  • *****
  • Публикации: 1073
  • Distribution: FreeBSD-10.1 & LMDE
  • Window Manager: i prefer MATE
    • Профил
    • WWW
Re: Какво е това PKG_CONFIG_PATH
« Отговор #7 -: May 03, 2013, 08:31 »
Код:
sudo apt-get install libdbusmenu-glib-dev
инсталирай този пакет и опитай пак
едит: дава тези съобщения за променливите на средата, защото имаш неудовлетворени зависимости. чети добре всичко което ти излиза като изход, там пише кои са липсващите пакети или техни заместители в твоята дистрибуция.
« Последна редакция: May 03, 2013, 08:34 от satir »
Активен