Автор Тема: Проблеми със звука  (Прочетена 1446 пъти)

abadon

  • Напреднали
  • *****
  • Публикации: 510
  • Distribution: Debian
  • Window Manager: KDE
    • Профил
    • WWW
Проблеми със звука
« -: Sep 26, 2007, 10:06 »
Здравейте.
По изписах доста теми за настройката на този мой лаптоп Lenovo 3000 N100... Както и да е вчера установих, че като си пусна музика, филм или каквото и да било в което има звук и го чувам но с леко лошо качество. Звука се чува, но все едно че "задират" колонките/слушалките, а те не "задират" защото звука е на 20-30% увеличен. Пробвах с увеличаване намаляване няма промяна — звука се увеличава и респективно с него и този шум, звука се намалява и шума почва да се чува по-слабо. Пробвах да пусна друга mp3-ка, оригинално CD, DVD с филм резултата е един и същ '<img'> Явно не се влияе от качеството на парчето а си е някакъв проблем с драйвера или поне така си мисля. Тъй като и под windows имах подобен проблем — качих драйвера за звука. Той тръгна но по същия начин, след което трябваше да кача някакъв миксер към самия драйвер за да се оправят нещата, обаче там нещата бяха лесни тъй като всички тези неща си ги имах с лаптопа.
Някой има ли някаква идея как да се реша проблема под линукс, защото до сега не съм имал такива проблеми.
Ето ми изхода на lspci
 
Цитат
lspci
00:00.0 Host bridge: Intel Corporation Mobile 945GM/PM/GMS/940GML and 945GT Express Memory Controller Hub (rev 03)
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS/940GML Express Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/940GML Express Integrated Graphics Controller (rev 03)
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1 (rev 02)
00:1c.1 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 2 (rev 02)
00:1d.0 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI #3 (rev 02)
00:1d.3 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI #4 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801G (ICH7 Family) USB2 EHCI Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e2)
00:1f.0 ISA bridge: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge (rev 02)
00:1f.2 IDE interface: Intel Corporation 82801GBM/GHM (ICH7 Family) Serial ATA Storage Controller IDE (rev 02)
00:1f.3 SMBus: Intel Corporation 82801G (ICH7 Family) SMBus Controller (rev 02)
03:00.0 Network controller: Broadcom Corporation Dell Wireless 1390 WLAN Mini-PCI Card (rev 01)
05:01.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
05:04.0 CardBus bridge: ENE Technology Inc CB1410 Cardbus Controller (rev 01)
05:06.0 FireWire (IEEE 1394): Ricoh Co Ltd Unknown device 0832
05:06.1 Generic system peripheral [0805]: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter (rev 19)
05:06.2 System peripheral: Ricoh Co Ltd Unknown device 0843 (rev 01)
05:06.3 System peripheral: Ricoh Co Ltd R5C592 Memory Stick Bus Host Adapter (rev 0a)
05:06.4 System peripheral: Ricoh Co Ltd xD-Picture Card Controller (rev 05)

Дистрибуцията ми е Debian Lenny, kernel 2.6.21-2-686

Предварително благодаря!
Активен

Успешното Boot-ване на Windows завършва с рестарт!!!
You are registered as user #382190 with the Linux Counter
Всеки пост - отговор на въпрос

Gaara

  • Напреднали
  • *****
  • Публикации: 631
  • Distribution: Debian
  • Window Manager: E17
    • Профил
Проблеми със звука
« Отговор #1 -: Sep 26, 2007, 10:19 »
С каква графична среда си?
Настроен ли ти е входящият и изходящият звук на алса?
Приложенията ти настроени ли са да ползват алса?
С коя версия на алсата си?
Активен

Last night, Darth Vader came down from planet Vulcan and told me that if you don't install Debian, he'd melt your brain.

abadon

  • Напреднали
  • *****
  • Публикации: 510
  • Distribution: Debian
  • Window Manager: KDE
    • Профил
    • WWW
Проблеми със звука
« Отговор #2 -: Sep 26, 2007, 11:54 »
Графичната ми среда е KDE 3.5.7

Настроен ли ти е входящият и изходящият звук на алса?
Какво трябва да му е настроено? Звука си тръгна веднага след инсталацията, като микрофона на слушалките ми не работеше и като сложих слушалките колонките продължаваха да свирят. Но този неща ги оправих през  kmix като избрах за вход mic (по подразбиране беше на internal mic) и махнах опцията External Amplifter. Eто тука ми е настройката на kmix

Приложенията ти настроени ли са да ползват алса?
Аз нещата ги пробвах с Mplayer-а и за аудио изход съм му задал alsa.

С коя версия на алсата си?
alsa-base и alsa-utils са версии 1.014-1
Активен

Успешното Boot-ване на Windows завършва с рестарт!!!
You are registered as user #382190 with the Linux Counter
Всеки пост - отговор на въпрос

cat

  • Напреднали
  • *****
  • Публикации: 339
  • Distribution: Debian
  • Window Manager: Gnome
    • Профил
    • WWW
Проблеми със звука
« Отговор #3 -: Sep 26, 2007, 12:35 »
Здравей,
За да зададеш на системата да ползва ALSA, отиваш в Контролен център-> Мултимедия -> Аудиосистема, там има два таба: Общи и Хардуер. Щракаш на Хардуер и от там задаваш да се ползва ALSA. Даваш ОК и си готов. После с KMix си оправяш настройките за звук. Ако искаш ползвай alsamixer в конзолата.
Настройваш си програмките за аудио и видео да ползват ALSA.

Успех!  '<img'>
Активен

Човек се учи докато е жив и греши също толкова!
http://debianbg.wordpress.com

abadon

  • Напреднали
  • *****
  • Публикации: 510
  • Distribution: Debian
  • Window Manager: KDE
    • Профил
    • WWW
Проблеми със звука
« Отговор #4 -: Sep 27, 2007, 00:07 »
Направих го това, но нещата не се промениха. Изредих всички възможни опции на kmix и на настройките от контролния център на КДЕ-то. честота, качество на звука и т.н.
Някакви други идеи?

P.S>инсталирах си и някакъв пакет alsa-firmware-loaders на който описанието е следното:
Цитат
ALSA software loaders for specific hardware
A collection of software loaders for specific hardware:

 cspctl - Sound Blaster 16 ASP/CSP control program
 hdsploader - firmware loader for the RME Hammerfall DSP cards
 mixartloader - firmware loader for Digigram's miXart board sound drivers
 pcxhrloader - firmware loader for Digigram pcxhr compatible soundcards
 sscape_ctl - SoundScape control utility and firmware loader
 usx2yloader - firmware loader for Tascam USX2Y USB soundcards
 vxloader - firmware loader for Digigram VX soundcards


Обаче как се ползва този пакет  '<img'>  Тъй каот под " уин бозата" ползам това Sound Blaster
Цитат
cspctl --help
Usage: cspctl command [-options] <filename>

Available commands:
  load    load microcode from filename
  unload  unload microcode from CSP

Available options:
  -h,--help        this help
  -c card          select card number, default = 0
  -f function      select CSP function #, defaults to 1
  -d description   optional codec description string

Какво се прави с това.... '<img'>



Активен

Успешното Boot-ване на Windows завършва с рестарт!!!
You are registered as user #382190 with the Linux Counter
Всеки пост - отговор на въпрос

cartman

  • Напреднали
  • *****
  • Публикации: 288
    • Профил
Проблеми със звука
« Отговор #5 -: Sep 27, 2007, 00:14 »
Ами да попитам друго тогава:
правилния драйвер ли ползваш?Пробва ли с други драйвери?Би ли дал изхода на lsmod snd?
Активен

old:Mandriva 2007.0, kernel 2.6.17-5mdv, Qt: 3.3.6,KDE: 3.5.4
current:Mandriva 2008.0,kernel 2.6.22.9-desktop-1mdv, Qt:3.3.8,KDE:3.5.7, gcc: 4.2.2

abadon

  • Напреднали
  • *****
  • Публикации: 510
  • Distribution: Debian
  • Window Manager: KDE
    • Профил
    • WWW
Проблеми със звука
« Отговор #6 -: Sep 27, 2007, 10:01 »
Не знам дали ползвам правилния драйвер. Не съм пробвал с други драйвери защото не знам какви трябва да са, а и не съм много на ясно как да го направя. Трябва с rmmod да прехмахна тези след което с modprobe да заредя други или? Ето и изхода на lsmod |grep snd
Цитат
snd_hda_intel          20312  2
snd_hda_codec         198336  1 snd_hda_intel
snd_pcm_oss            39168  0
snd_mixer_oss          15328  1 snd_pcm_oss
snd_pcm                71940  3 snd_hda_intel,snd_hda_codec,snd_pcm_oss
snd_timer              20868  1 snd_pcm
snd                    48132  10 snd_hda_intel,snd_hda_codec,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer
soundcore               7424  1 snd
snd_page_alloc          9512  2 snd_hda_intel,snd_pcm


P.S> Тука в kmix не е ли нормално да имам повече плъзгачи? Защото в къщи на настолното РС което е вече на почти 4 години, инсталиран му е Debian Sid и е с вградена звукова карта в този прозорец имам 7-8 плъзгача.



Активен

Успешното Boot-ване на Windows завършва с рестарт!!!
You are registered as user #382190 with the Linux Counter
Всеки пост - отговор на въпрос

acidrain

  • Напреднали
  • *****
  • Публикации: 119
    • Профил
Проблеми със звука
« Отговор #7 -: Sep 27, 2007, 10:20 »
За Ubuntu е, но дано да ти помогне.  цък
Активен

Все идет по плану

abadon

  • Напреднали
  • *****
  • Публикации: 510
  • Distribution: Debian
  • Window Manager: KDE
    • Профил
    • WWW
Проблеми със звука
« Отговор #8 -: Sep 28, 2007, 10:03 »
Направих нещата които пише в линка който си ми дал, като не съм компилирал драйвера и т.н от сорс, тъй като в aptitude версията на пакетите е същата като примера с компилирането. Просто промених нещата в /etc/modprobe.d/alsa-base. Изпробвах следните варианти:
Цитат
options snd-hda-intel model=lenovo
options snd-hda-intel model=laptop-eapd
options snd-hda-intel model=auto
options snd-hda-intel model=3stack

Обаче нямаше никаква промяна. При тези мой опити установих следното нещо, което не бях забелязал до този момент. Като си пусна в kmix опцията Еxternal Amplifter, сиреч да ми работят тон-колонките на лаптопа и звука в слушалките става кристален. Махна ли я тази опция веднага почва да се чува това "кривене" на звука. Няма как да я държа пустата постоянно, защото ако е включена и съм сложил и слушалки — чувам звука и през колонките и през слушалките.

Да не би проблема да е в периферията?  '<img'>  Нали картата е HDA и затова да дава звук с много голямо качество който не може да се възпроизведе коректно от слушалките, защото те са някакви средно качество за около 30 лв. А когато и колонките свирят тя да се натоварва повече и от тук мощността която отива към слушалките да е по-малка и следователно нещата при тях да се чуват нормално.

Всичко друго със звука изглежда нормално. Бутоните на лаптопа за увеличаване, намаляване, спиране и т.н. си работят нормално. Когато работя с тях нещата в kmix се променят, получавам и OSD индикация...
Активен

Успешното Boot-ване на Windows завършва с рестарт!!!
You are registered as user #382190 with the Linux Counter
Всеки пост - отговор на въпрос