Автор Тема: Audacious на Maemo 5  (Прочетена 4753 пъти)

vipthx

  • Напреднали
  • *****
  • Публикации: 23
  • Distribution: Kubuntu 14, Maemo 5
  • Window Manager: KDE+LXDE, Hildon
    • Профил
Audacious на Maemo 5
« -: Dec 28, 2012, 03:12 »
Здравейте колеги!
От няколко часа се занимавам с това предизвикателство, но нямам особен успех. Стигнах до това, но удрям на  греда с libmad0. Хардуерът е Nokia N900 и ако някой знае нещо с което да ми помогне, ще съм благодарен да сподели.
Активен

vyrgozunqk

  • Гост
Re: Audacious на Maemo 5
« Отговор #1 -: Dec 28, 2012, 07:45 »
Проект за последно пипан 2010 г. ...
На хардуерно и морално остарял хардуер с неподдържана отдавна софтуерна платформа...

Мисля, че е време да идеш до магазина за нови "чаркалъци".. Току виж си и случил на нещо с добър вграден плеър...

Иначе libmad0 неможеш ли да го свалиш от репото на дебиан, повечето библиотеки са компилирани и за арм...
« Последна редакция: Dec 28, 2012, 07:50 от vyrgozunqk »
Активен

neter

  • Global Moderator
  • Напреднали
  • *****
  • Публикации: 3408
  • Distribution: Debian, SailfishOS, CentOS
  • Window Manager: LXDE, Lipstick
    • Профил
    • WWW
Re: Audacious на Maemo 5
« Отговор #2 -: Dec 28, 2012, 13:48 »
но удрям на  греда с libmad0
В какъв смисъл удряш на греда? Не намираш пакета или не успяваш да инсталираш пакета? Ако не го намираш, трябва ти пакетът libmad0-dev, намиращ се в хранилищата Extras, Extras-testing и Extras-devel. Включи си някое от тези хранилища и го инсталирай с apt-get оттам или го дръпни оттук (гледай Fremantle) и го инсталирай с dpkg. Ако нещо не успяваш да го инсталираш или самият audacious е несъвместим с текущата му версия (или някакъв друг проблем), покажи ни грешките, които получаваш, за да видим какво точно те спъва. Между другото, да кажа и, че трябва да инсталираш и останалите пакети, които си дал в линка, ако не си го направил - те затова са дадени, защото Audacious зависи от тях. Първо инсталирай пакетите, започващи с lib*.
Преди време (повече от година) инсталирах Audacious на моето Maemo, така че, ако не са се променили твърде много пакетите около него, би трябвало и ти да успееш. Но отдавна съм го затрил (по-точно не го инсталирах пак след едно счупване на системата; аз често я чупя от играчки), понеже не ми се стори удобен на малкия екран, но... ти ще прецениш за себе си :)
А, между другото, ако не успееш да инсталираш нещо под Maemo, остава шансът да тръгне под Debian. Пакетите на Maemo са базирани на него, а самият Debian има по-богата база от библиотеки и други пакети. Ако не го знаеш, да кажа, че с Debian на N900 най-лесно можеш да се сдобиеш като инсталираш пакета Easy Debian. Това е изображение на Debian, което се зарежда от Maemo, не е dual-boot. Можеш да си заредиш цялата му среда, а можеш да пускаш и само отделни приложения от него. По подразбиране готови за такова изпълнение са програми като OpenOffice, GIMP и Leafpad (макар че последният си има и готова версия за Maemo). Ако инсталираш Audacious в Debian, може да си го изпълняваш оттам - малко по-тежко е (зависи от приложението), но може да свърши работа.

На хардуерно и морално остарял хардуер с неподдържана отдавна софтуерна платформа...
vyrgozunqk, не си съвсем прав. Да, хардуерът е старичък, но успява да се справя добре. Системата работи по-леко от Android (или, по-точно, от Java-та върху него), така че компенсира донякъде по-слабия хардуер. Процесорът може да се overclock-ва динамично, така че в някои ситуации може да се възползваш и от това. Разбира се, винаги може да се предявят изисквания и за по-бърз хардуер, но... то това важи за всички компютри. Единственото, което на мен ми липсва като хардуер за момента, е хардуерен компас - малко си е дразнещо да трябва да минеш 50-100 метра, докато установиш, че си тръгнал в грешна посока. Но човек може да си сложи компас и на ключодържателя, с което да компенсира :)
Относно софтуерната платформа, развитието ѝ не е спирало - както на самата система, така и на приложенията за нея. Дори, ако се загледаш, ще се учудиш колко живо е все още Maemo-то. Nokia зарязаха проекта, но отвореността на системата позволи на общността да продължи разработките, побрани в т.нар. Community SSU, което всеки може да си инсталира и на което продължават да излизат нови версии с нови подобрения и функционалности. Дори да не искаш да инсталираш целия Community SSU, други ентусиасти пък компилират разширени ядра за системата, в които добавят наготово за потребителите много полезни модули, примери за които са модули за Bluetooth мишки и клавиатури, и възможности за закачане към USB-то на телефона всякаква периферия, като мишки и клавиатури (пак), твърди дискове и други памети, че дори и да си вържеш преходник USB към Ethernet и да си пуснеш Интернет по кабел на телефона, ако ти се налага. Та... не, Maemo не е мъртво, много е живо дори. Да, обикновеният потребител не може да усети цялата ѝ живост, и дори би се противял на много неща в нея, но и мисля, че Maemo от самото си начало не беше замислено за обикновения потребител. Просто няма място за сравнение с масово разпространените потребителски системи в момента - Maemo е друга бира ;)
Активен

"Да си добре приспособен към болно общество не е признак за добро здраве" - Джиду Кришнамурти

vipthx

  • Напреднали
  • *****
  • Публикации: 23
  • Distribution: Kubuntu 14, Maemo 5
  • Window Manager: KDE+LXDE, Hildon
    • Профил
Re: Audacious на Maemo 5
« Отговор #3 -: Dec 28, 2012, 15:28 »
Проблема се свежда до ниво зависимости. Тези от горния линк съм ги инсталирал. Стигнах до следните зависимости - libmad0>libc6>libsamplerate. С apt-get ми казва Couldn't fint package (в случая libsamplerate). Намирам библиотеката тук, отварям с браузъра и опитвам да инсталирам с aplication manager, който ми изписва Unable to install libsamplerate0-dev_0.1.3-1maemo0.deb. Instalation file corrupted. Ако бъркам реда на инсталация, поправете ме, вече се сбърках да изпълнявам зависимости. Чудя се, ако в sources.list добавя хранилище от дебиан, дали няма да се получи само с apt-get install audacious  да си изтегли само каквото му е нужно или ще скапя маемото по тоя начин.
Активен

neter

  • Global Moderator
  • Напреднали
  • *****
  • Публикации: 3408
  • Distribution: Debian, SailfishOS, CentOS
  • Window Manager: LXDE, Lipstick
    • Профил
    • WWW
Re: Audacious на Maemo 5
« Отговор #4 -: Dec 28, 2012, 15:56 »
С apt-get ми казва Couldn't fint package (в случая libsamplerate). Намирам библиотеката тук, отварям с браузъра и опитвам да инсталирам с aplication manager, който ми изписва Unable to install libsamplerate0-dev_0.1.3-1maemo0.deb. Instalation file corrupted.
Както виждаш от линка, който си дал сега, и пакетът libsamplerate0-dev е наличен в хранилищата Extras, Extras-testing и Extras-devel. Както ти казах и по-горе, активирай си някое от тези хранилища и тогава apt-get ще го намери. След като пакетите ги има в някое хранилище, защо се мъчиш като грешен дявол с ръчно дърпане и инсталиране? Активирай си хранилищата! Ако, все пак, някога се наложи да инсталираш някой deb пакет, свален ръчно отнякъде, не го инсталирай с Aplication Manager, а инсталирай в конзолата с dpkg - така ще виждаш по-ясно какъв е проблемът, ако пакетът не иска да се инсталира, и можеш да ни покажеш грешката и на нас.
За момента всички пакети, които си споменал, ги има или в линка, от който си дръпнал deb пакета на Audacious, или в някое от хранилищата на Maemo. Нека след следващия ти пост да не пиша пак да си активираш хранилищата ;)

П.П.: Възможно е успешно да инсталираш някой пакет за Debian в Maemo (особено някоя библиотека), стига да е компилиран за този процесор, но, въпреки че Maemo е базирано на Debian, не е съвсем Debian, така че има голям шанс да счупиш нещо или просто да не работи. Няма да е фатално, разбира се, най-много да се наложи да си преинсталираш Maemo-то, но си е неудобство, ако целта ти не е просто тестове с очакване за счупване. Ако инсталираш някой пакет за Debian в Maemo, особено внимавай за такива, които казват, че ще премахнат конфликтиращи пакети или имат нужда от по-нови версии на зависимостите - при тях вероятността от счупване е най-голяма. Ако пакетът ще инсталира само себе си без да се променят никакви други пакети в системата, то е много вероятно инсталацията му да е безопасна, макар и да не гарантира, че ще работи.
Моите съвети по въпроса. Ако ще инсталираш пакети за Debian в Maemo, по добре ги инсталирай в Easy Debian и си ги ползвай оттам, вместо да цапаш Maemo-то. Ако пакетът е наличен за Maemo, зарежи пакета за Debian и си пребори пакета за Maemo.
« Последна редакция: Dec 28, 2012, 16:12 от neter »
Активен

"Да си добре приспособен към болно общество не е признак за добро здраве" - Джиду Кришнамурти

vipthx

  • Напреднали
  • *****
  • Публикации: 23
  • Distribution: Kubuntu 14, Maemo 5
  • Window Manager: KDE+LXDE, Hildon
    • Профил
Re: Audacious на Maemo 5
« Отговор #5 -: Dec 28, 2012, 18:08 »
Добре, понеже виждам, че имаш опит с маемото, (а аз телефона го имам от 4 дена) ще ми обясниш ли как да ги добавя хранилищата? Инсталирах mc, влизам в sources.list и гледам че е празен. Във hildon-appliation-manager.list обаче намерих следното:
deb http://downloads.maemo.nokia.com/fremantle/ssu/apps ./
deb http://downloads.maemo.nokia.com/fremantle/ssu/mr0 ./
deb http://repository.maemo.org/extras/ fremantle-1.3 free nonfree
deb http://repository.maemo.org/extras-devel/ fremantle-1.3 free nonfree

Не знам обаче защо има празно място пред fremantle на долните 2 реда.
« Последна редакция: Dec 28, 2012, 18:11 от vipthx »
Активен

neter

  • Global Moderator
  • Напреднали
  • *****
  • Публикации: 3408
  • Distribution: Debian, SailfishOS, CentOS
  • Window Manager: LXDE, Lipstick
    • Профил
    • WWW
Re: Audacious на Maemo 5
« Отговор #6 -: Dec 28, 2012, 19:06 »
Много пресен си се юрнал да си чупиш системата :) Защо не си дадеш малко време да опознаеш системата, да разгледаш приложенията, написани специално за нея, да видиш кое къде как се случва и тогава да експериментираш? Сега си мисля, че инсталирането на Audacious ти е излишно и желанието за него ти е породено от това, че ползваш него на настолния си компютър или лаптопа. На малкия екран на телефона нещата се случват по малко по-различен начин, и дори да подкараш програмите, които ползваш на големия компютър, е твърде вероятно да не са ти толкова удобни, колкото някое приложение, написано специално за малкия екран. Тук има богат списък от приложения в стабилни версии, откъдето можеш да им видиш описания и снимки, и да си избереш. Тук има по-подробен каталог от приложения, някои в стабилни версии, други все още в testing и devel хранилищата (което не значи, че не работят, но има вероятност от някой и друг бъг в повече). Тук също има известен избор от още приложения, само че първо трябва да се регистрираш и да зададеш, че телефонът ти е N900, за да виждаш само приложенията за него, да не ти се бъркат с несъвместими приложения. Разбира се, най-подробен е списъкът от самите хранилища, отворен в Application Manager, като си активираш хранилищата, които са ти нужни (когато аз разглеждам за приложения, си активирам всички, които имам), само дето описанията им там са по-кратки, няма и снимки и коментари на потребители, в които да се зачетеш, но не пречи, ако си харесаш нещо оттам, да го потърсиш по име в Интернет и да прочетеш повече за него. Много ще се спъваш, ако така тръгваш от вратата за краката, вместо систематизирано да си разучиш нещата. Но ти си преценяваш :)

Иначе, това са хранилищата, които ползвам аз
Цитат
deb https://downloads.maemo.nokia.com/fremantle/ssu/apps/ ./
deb https://downloads.maemo.nokia.com/fremantle/ssu/mr0 ./
deb https://downloads.maemo.nokia.com/fremantle1.2/ovi/ ./
deb http://repository.maemo.org/extras/ fremantle-1.3 free non-free
deb http://repository.maemo.org/extras/ fremantle free non-free
deb http://repository.maemo.org/extras-devel/ fremantle free non-free
deb http://repository.maemo.org/extras-devel/ fremantle-1.3 free non-free
deb http://repository.maemo.org/extras-testing/ fremantle free non-free
deb http://repository.maemo.org/extras-testing/ fremantle-1.3 free non-free
Няма да ти обяснявам защо редовете изглеждат така - пише го в документацията на apt, която е една и съща за всички Linux дистрибуции, които го ползват. Доколкото съм гледал, текущо fremantle и fremantle-1.3 каталозите във всяко едно хранилище са еднакви, но аз си ги държа и двете за всеки случай. Като начинаещ ти препоръчвам да си управляваш хранилищата през Application Manager, откъдето предполагам, че си добавил последните ти две хранилища, след като не си запознат със структурата, и е малко странно защо не ти намира библиотеките, с които текущо имаш спънка, понеже си ги има там. Ако си ги добавил ръчно в hildon-appliation-manager.list, то трябва да изпълниш
Цитат
apt-get update
като root или със sudo, за да влязат в сила. Ако ръчно си ги добавил и не си изпълнил тази команда, е разбираемо защо не ти ги намира.
Пример как се добавя ново хранилище през Application Manager. Отваряш го, цъкваш на заглавието му, избираш "Приложни каталози" (превеждай си, ако системата ти не е на български), цъкваш "Нов" и вписваш (ще дам пример за Extras-testing хранилището с fremantle каталога)
Цитат
Име на каталога: Extras-testing (не е задължително да е точно така)
Интернет адрес: http://repository.maemo.org/extras-testing/
Дистрибуция: fremantle
Елементи: free non-free
Изключен: не
Предполагам, че ще се ориентираш и за другите хранилища. След като затвориш прозорчето за управление на хранилищата, изчакай системата да провери за обновления (това е моментът, когато Application Manager изпълнява командата apt-get update), след което затвори Application Manager (не трябва да е отворен, когато оперираш с пакетите конзолно), изпълни
Цитат
apt-cache search libsamplerate0-dev
и дай да видим какво точно казва apt за този пакет.
Активен

"Да си добре приспособен към болно общество не е признак за добро здраве" - Джиду Кришнамурти

vyrgozunqk

  • Гост
Re: Audacious на Maemo 5
« Отговор #7 -: Dec 28, 2012, 23:48 »
Е хубаво де, ама поне Н9 да беше взел, 900 си е жива реликва с безумен дисплей с резистивен тъч, процесора на каквато и честота да работи, все е много старо поколение и  GPUто никакво го няма...
А липсата на хардуерният компас е най-малкият проблем...
« Последна редакция: Dec 28, 2012, 23:49 от vyrgozunqk »
Активен

vipthx

  • Напреднали
  • *****
  • Публикации: 23
  • Distribution: Kubuntu 14, Maemo 5
  • Window Manager: KDE+LXDE, Hildon
    • Профил
Re: Audacious на Maemo 5
« Отговор #8 -: Dec 28, 2012, 23:54 »
изпълни
Цитат
apt-cache search libsamplerate0-dev
и дай да видим какво точно казва apt за този пакет.
libsamplerate0-dev - development files for audio rate conversion (libsamplerate)
Активен

neter

  • Global Moderator
  • Напреднали
  • *****
  • Публикации: 3408
  • Distribution: Debian, SailfishOS, CentOS
  • Window Manager: LXDE, Lipstick
    • Профил
    • WWW
Re: Audacious на Maemo 5
« Отговор #9 -: Dec 29, 2012, 01:07 »
libsamplerate0-dev - development files for audio rate conversion (libsamplerate)
Ми инсталирай :)
Цитат
apt-get install libsamplerate0-dev

Е хубаво де, ама поне Н9 да беше взел, 900 си е жива реликва с безумен дисплей с резистивен тъч, процесора на каквато и честота да работи, все е много старо поколение и  GPUто никакво го няма...
А липсата на хардуерният компас е най-малкият проблем...
Е, N9 няма хардуерна qwerty клавиатура, инфрачервен порт, още няколко бутона по корпуса, резистивен дисплей (ще поясня) и тази общност, която се изгради около Maemo (има, но е далеч назад, макар че това може и да се промени с излизането на Sailfish). Не съм достатъчно добре запознат със самата система, наличния софтуер и възможностите им, но като цяло оставам с впечатлението, че MeeGo е доста по-потребителски настроена система от Maemo, което за обикновения потребител е добре, но може да доведе до доста спънки тези, които са решили да експериментират. N900 и Maemo заедно са една отлична платформа за експерименти. Разбира се, може да се използва и като всеки друг стандартен потребителски телефон, но истинската му красота въобще не е там. Целият плаче за експерименти. И колкото повече си играеш, толкова повече установяваш, че ти трябват бутони и периферия. Колкото повече, толкова по-добре. Ако можех да го направя, щях да го осея целия с бутони, не знам защо са решили да оставят празни места :) Тук се намесва и резистивният дисплей. Първо, макар и лично, аз за момента харесвам повече резистивни дисплеи. Машинките ми с тъч екрани, които съм имал досега, винаги са били с резистивни дисплеи и изпадам в ужас, когато хвана машинка с капацитивен дисплей и тя започва да действа сякаш още преди да ми е стигнал пръстът до дисплея (всъщност, на някои телефони с капацитивен дисплей понякога се получава точно така, буквално от въздуха) и така допускам много грешки. Разбира се, това е субективно и в значителна степен се обуславя от навика, но да си кажа :) Второ, вече не лично, резистивният дисплей има множество степени на натиск, което позволява в една и съща точка на допир софтуерът да изпълнява различни задачи в зависимост от натиска, който е приложен. Много хора в Интернет се кефят на тази функционалност най-вече с програмата MyPaint, където различната степен на натиск динамично променя дебелината на четката. Аз все още не съм стигнал да се възползвам в лични експерименти от тази функционалност, не си падам художник, но ми се въртят някои идеи в главата за в бъдеще. Та така... N900 и Maemo са платформа за съвсем друг вид забавление от това, което предлагат масово разпространените потребителски машинки. Всъщност, някои хора си имат отделен телефон, който да ползват като стандартен телефон и (ако е с повечко възможности) за масово разпространените потребителски забавления, но си имат и N900, където да си се вихрят на воля. То и аз на два пъти за по няколко дена си държах SIM картата в друг телефон, за да могат хората да ме търсят, докато си чупя системата, но по принцип ми е по-удобно всичко да ми е в едно, пък гледам бързо да възстановявам, когато се стигне до това. Както казах и одеве, N900 и Maemo са съвсем друга бира и няма смисъл да бъдат сравнявани по някакъв начин с масово разпространените машинки и техните системи. Следващият ми телефон (едва ли ще е по-рано от след година, стига сегашният ми да е добре или да се намира все още на пазара) вероятно ще е с Tizen или Sailfish, затворен в някаква безлична плочка, но докато хардуерът на моя N900 е жив, няма да бъде прибран в чекмеджето, дори и след като си взема друг ;)
Активен

"Да си добре приспособен към болно общество не е признак за добро здраве" - Джиду Кришнамурти

vipthx

  • Напреднали
  • *****
  • Публикации: 23
  • Distribution: Kubuntu 14, Maemo 5
  • Window Manager: KDE+LXDE, Hildon
    • Профил
Re: Audacious на Maemo 5
« Отговор #10 -: Dec 29, 2012, 03:36 »
Колега, не ми се получава и това си е... Пробвах и с apt-get f install, но пак без успех. На две зависимости ми каза, че са not installable и не инсталира. Ако ти се занимава да пробваш ще разбереш за какво става дума. Ако пък успееш сподели стъпка по стъпка.
Активен

vyrgozunqk

  • Гост
Re: Audacious на Maemo 5
« Отговор #11 -: Dec 29, 2012, 12:34 »
/Spam ( отново )

Нетер: помня аз, помня как и едно време ми обясяваше ( на маса за предимствата на резистива, ама тогава реших да си затрая...)  :D
Сега относно капацитивите, има и такива, които също усещат нивото на натиск...(зависи от производителя и хардуера, повечето таблети за рисуване, тъчпадове и дигитайзери на Синаптик примерно имат...) А резистива е бавен, много бавен, тромав и неточен, нямаш прецизността, която имаш в новите капацитиви...  Можеби защото почнаха да зарязват технологията и никой не се занимава с нея - незнам и не ме интересува... А за  висока скорост на работа и особено писане е безумие човек да се бори с резистивен тъч. - Имах бая PDA-та преди...
Да не говорим за гадните "точки", които се виждат по дисплеят на слънце(имаше ги и при старите капацитиви), точно заради резистивната технология...

Това са неща, които могат да ме извадят извън релси. А хардуера, че става за ръчкане - става... Но е толкова бавен, че е безумие... По-добре си купи дуъл-куад кор  таб с отключен буутлоудър и си ръчкай колкото искаш...
Относно бутоните... хубаво има бутони и все пак, каквото и да си говорим и на теб ти е ясно, колкото и на мен, че едно десктоп дистро е безумно неудобно и бавно в/у такава машина и освен за да покажеш, че просто можеш да го пуснеш за друго, почти не става...  :P

USB Host има всеки андроид или джейлбрейкнат айфон...
За почти всички андроиди вече има портове за разни десктоп дистрота..Мултибуут и т.н.
А на някой можеш да инсталираш и Ми-Го-то...

Не виждам смисъл, просто човек да подмята тази тухла, особено като на пазара има и нови поколения смартфони с хардуерни ЯВЕРТ клавиатури и много по-големи дисплей, а на всеки таблет можеш спокойно да му сложиш калъф с пълна нетбук клавиатура, та даже и УСБ портове...
Активен

neter

  • Global Moderator
  • Напреднали
  • *****
  • Публикации: 3408
  • Distribution: Debian, SailfishOS, CentOS
  • Window Manager: LXDE, Lipstick
    • Профил
    • WWW
Re: Audacious на Maemo 5
« Отговор #12 -: Dec 29, 2012, 15:51 »
/по темата

Ако ти се занимава да пробваш ще разбереш за какво става дума. Ако пък успееш сподели стъпка по стъпка.
Общо ръководство за инсталацията има в линка, откъде си дръпнал Audacious, няма да го преписвам. Ето стъпките, които трябва да изпълниш от текущото си положение:
1. Премахни пакетите audacious и audacious-plugins, за да не пищят постоянно, докато инсталираме зависимостите
Цитат
dpkg -r audacious audacious-plugins
2. Ако не си инсталирал всички библиотеки от линка, откъдето си дръпнал Audacious, направи го (ако не си в папката, където са файловете, добави и пътя до тях)
Цитат
dpkg -i lib*
3. Предполагаме, че си активирал Extra-devel хранилището. Изпълни командата
Цитат
apt-get install libsamplerate0-dev libmad0-dev libvorbis0a libvorbisenc2 libvorbisfile3
с което ще инсталираш останалите зависимости без gtk2-engines-pixbuf. Може и вече да си инсталирал част от тях или всичките тези, но за всеки случай го изпълни цялото. Пакетът gtk2-engines-pixbuf не е наличен в хранилищата на Maemo, а пакетът от хранилищата на Debian влиза в конфликт с пакета libgtk2.0-0 на Maemo, и по-точно заради файла /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so. Вероятно ще може да се излъже, ако премахнеш пакета libgtk2.0-0 (провери дали се е премахнал и конфликтният файл), инсталираш Debian-ския gtk2-engines-pixbuf, изтриеш конфликтния файл и инсталираш отново пакета libgtk2.0-0 (който пак ще добави изтрития файл; по-сигурно е да се ползва този от пакета за Maemo), но в момента не ми се рискува да счупя системата, за да пробвам. Ако си оптимист и имаш свободно време, пробвай :)
4. Инсталирай двата пакета за Audacious
Цитат
dpkg -i audacious-plugins_1.5.1-2_armel.deb audacious_1.5.1-4_armel.deb
Audacious ще изреве, че му липсва gtk2-engines-pixbuf, но ще се наложи да си затвориш очите. Audacious е инсталиран, но остава без последното действие по конфигуриране на инсталацията при инсталиране на пакет, което донякъде може да се пренебрегне, само дето, докато държиш инсталиран пакета audacious, при всяко действие apt и dpkg ще напомнят за липсващата зависимост. Неудобство, което съм сигурен, че ще ти остане като дразнител, но ако държиш да ползваш Audacious, ще трябва да се примириш с него.
5. Копирай изтегления файл config в папката /home/user/.config/audacious, като, ако в момента я няма, я създай, но като обикновен потребител (не като root и не със sudo)
Цитат
mkdir /home/user/.config/audacious
Не забравяй тази стъпка, за да не питаш после защо Audacious е толкова ситен и защо бутоните в горната част са скрити, при което не можеш да изключиш Audacious. Аз бях смел да пробвам, но при положение, че имах отворена SSH сесия към телефона, за да мога да реагирам :)
6. Стартираш Audacious от конзолата с команда audacious като обикновен потребител и, ако си доволен от постигнатото, можеш да си добавиш .desktop файл в /usr/share/applications/hildon (можеш да ползваш някой от наличните там .desktop файлове за пример), за да можеш да си изведеш пряк път до Audacious на десктопа и да го имаш в менюто с програми, или (вместо да го правиш ръчно) да ползваш за целта някоя програма като Shortcut Maker или Cmd Shortcuts (има ги в хранилищата; давам линковете само за преглед).

/извън темата
vyrgozunqk, няма да стигнем с теб до консенсус по този въпрос, ама не е и нужно ;D [_]3
« Последна редакция: Dec 29, 2012, 16:02 от neter »
Активен

"Да си добре приспособен към болно общество не е признак за добро здраве" - Джиду Кришнамурти

vipthx

  • Напреднали
  • *****
  • Публикации: 23
  • Distribution: Kubuntu 14, Maemo 5
  • Window Manager: KDE+LXDE, Hildon
    • Профил
Re: Audacious на Maemo 5
« Отговор #13 -: Dec 30, 2012, 16:32 »
/по темата
И пак не се получава. libvorbis0a е бил инсталиран, а останалите пищят за зависимости. Добавил съм си хранилищата които ми показа и се чудя защо apt не си сваля само зависимостите. На настолния с Debian пиша apt-get install "нещо" и ми показва какви са зависимостите, като ме пита дали да си ги слага.

/офф
Как да си оправя потребителския акаунт, защото гледам че предишния собственик си е именувал телефона, а и някои програми вписват името от акаунта му? И още един въпрос - Как да накарам телефона да се закачи към WPA/WPA2 криптирани мрежи?

/П.П.
Пишейки audacious в конзолата, ми иписва:
Audacious: error wile loading shahrrinh libraries: libsamplerate.so.0: cannot open shared object file: No such file or directory

П.П. 2
След псувания с apt-get се изнервих, изтеглих си пакетите и ги инсталирах с dpkg и докарах нещата до следната грешка:
I/O warning : failed to load external entity "/root/.config/audacious/playlist.xspf"

П.П. 3
И вече работи, но се чудя дали няма начин и плейлиста да се уголемини?
« Последна редакция: Dec 30, 2012, 19:54 от vipthx »
Активен

neter

  • Global Moderator
  • Напреднали
  • *****
  • Публикации: 3408
  • Distribution: Debian, SailfishOS, CentOS
  • Window Manager: LXDE, Lipstick
    • Профил
    • WWW
Re: Audacious на Maemo 5
« Отговор #14 -: Dec 30, 2012, 20:51 »
Нещо пак си пропуснал в алгоритъма, но няма да хвърлям боб сега, за да разбера - гледам, че все пак си го докарал до някъде по-напред (а дали не си и готов?).

и се чудя защо apt не си сваля само зависимостите. На настолния с Debian пиша apt-get install "нещо" и ми показва какви са зависимостите, като ме пита дали да си ги слага.
Защото, в случая, ползваш dpkg, а не apt, а dpkg не може сам да сваля зависимости. Освен ако не говориш за единствената команда с apt, която ти дадох, за инсталирането на допълнителните библиотеки, но там всички зависимости би трябвало да са налични (някои от които съм ги вписал в самата команда), ако наистина си активирал Extras-devel хранилището и нямаш някакви изначални странности в системата. Което отвежда към следващия цитат.

гледам че предишния собственик
Защо не каза още в началото, че телефонът е имал предишен собственик? Да пропуснеш да го споменеш баш при този телефон е все едно да си вземеш Лада на старо и да звъннеш в АвтоВАЗ да ги питаш защо нещо не работело - толкова модификации може да има, направени от предишния собственик, че производителят ще трябва да врачува, за да ти помогне.
Съветвам те да хванеш и да му направиш един пълен reflash, за да си сигурен, че системата ти е такава, каквато и на нов телефон. В противен случай никога няма да си сигурен какво в системата ти не е такова, каквото очакваш, и може често да се спъваш без отговор. Ръководството за reflash-ване е тук, но можеш да си потърсиш и други в Интернет, ако това не те удовлетворява. На теб ти трябва eMMC reflash, което ще презапише не само системата, но и домашната ти папка, а ако имаш сложена допълнителна памет карта, тя ще бъде изпразнена. Така че, ако за тези няколко дена си качил на телефона някакви файлове, които ти трябват, си ги копирай преди reflash-а и извади допълнителната памет карта (ако имаш такава).

Как да си оправя потребителския акаунт
Потребителският акаунт по подразбиране се казва user. Ако в момента е друг, след eMMC reflash-а ще се казва пак user. Като начинаещ те съветвам засега да не променяш и триеш потребителя user. Иначе, потребителите се управляват със същите команди, каквито са и във всяка Linux дистрибуция - useradd, userdel, usermod... Но не го прави засега. Опознай системата!
Ако не говориш за името на този потребител, а за името на телефона (това, което виждаш, когато влезеш във файловия мениджър), то това име се задава от настройките на bluetooth-а - по подразбиране Maemo използва един и същи запис за името на телефона в графичната част и името на телефона през bluetooth.
Ако говориш за името на хоста, което виждаш в конзолата, тогава трябва да промениш надписа във файла /etc/hostname.

Как да накарам телефона да се закачи към WPA/WPA2 криптирани мрежи?
Така, както и към другите мрежи - като цъкнеш върху лентата с часовника в появилото се меню имаш бутонче "Интернет връзка" (превеждай си, ако се налага). Когато цъкнеш на него ти се показват всички мрежи, към които можеш да се вържеш. Цъкваш на нужната ти мрежа и, ако е нужна парола, ще ти се даде възможност да я въведеш. Може и през конзолата, ама ти е рано :) А ако нещо в това указание не е така, ще стане така след reflash-а.

I/O warning : failed to load external entity "/root/.config/audacious/playlist.xspf"
Това е нормално. Ако файлът липсва, Audacious просто казва, че липсва и си го създава. След това няма да ти го дава.

но се чудя дали няма начин и плейлиста да се уголемини?
Не забравяй, все пак, че това, което правиш в момента, е в напълно експериментален статус. Но търси из Интернет, някой може да си е поиграл и да е успял. На мен не ми се занимава с това :)
Активен

"Да си добре приспособен към болно общество не е признак за добро здраве" - Джиду Кришнамурти