Автор Тема: Mplayer  (Прочетена 1140 пъти)

Agent_SMITH

  • Administrator
  • Напреднали
  • *****
  • Публикации: 3082
  • matrix kernel module
    • Профил
Mplayer
« -: Dec 02, 2003, 00:34 »
#apt-get install mplayer

Reading Package Lists...
Building Dependency Tree...
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  mplayer: Depends: xlibs (> 4.2.99) but 4.2.1-14 is to be installed

С този синтаксис не ми е ясно - инсталираната при мен версия ли е по-висока от търсената, или не? "is to be installed" - няма такъв смислен израз!?!?!?

И батко Гуугъл не помогна...

smith
Активен

-= СПАЗВАЙТЕ ПРАВИЛАТА НА ФОРУМА =-

ray

  • Напреднали
  • *****
  • Публикации: 1312
    • Профил
Mplayer
« Отговор #1 -: Dec 02, 2003, 06:38 »
Здрасти,
Съобщението ти казва, че инсталираната версия на lib... /сега не виждам съобщението/ е по-стара от нужната lib...
Опитай да инсталираш пакет от testing или unstable пакетите:
apt-get install -t [testing | unstable] lib...
после: apt-get install mplayer
Вероятно mplayer-ра зависи от по-нова версия на библиотеката.
Успех.
Румен.
Активен

IvanST

  • Напреднали
  • *****
  • Публикации: 369
    • Профил
Mplayer
« Отговор #2 -: Dec 02, 2003, 08:27 »
Еми ти от къде инсталираш mplyer от тука ли : http://marillat.free.fr/ защото има различни версии за woody за testing и за unstable (те зависят от различни  версии на библиотеки-виж дъното на страницата)  така че ако си на woody  си добави сътветнят ред в sources.list  за сътветната версия която ползваш най вероятно това си объркал или другия вариант е да ъпдейтваш до testing или  unstable. Защото mplayer иска xlibs версия > 4.2.99 а твойта е 4.2.1 '<img'>
Активен

n_antonov

  • Напреднали
  • *****
  • Публикации: 1185
    • Профил
    • WWW
Mplayer
« Отговор #3 -: Dec 02, 2003, 09:23 »
Вероятно инсталираш от мен'<img'> Видях този проблем, просто съм го компилирал за по-висока версия на тази библиотека. До вечерта ще оправя проблема и ще можеш да го инсталираш.



Активен

-------------------------------------------------------------------------
./debian/rules

n_antonov

  • Напреднали
  • *****
  • Публикации: 1185
    • Профил
    • WWW
Mplayer
« Отговор #4 -: Dec 02, 2003, 09:27 »
А защо теглиш предварително компилиран пакет? Използвай следната процедура.

apt-get install auto-apt
auto-apt update updatedb update-local

После си разархивираш сорса на mplayer, влизаш в него и пишеш:

auto-apt run ./configure --enable-gui

Следиш какво прави конфигурационният скрипт. Когато стигне до липсваща библиотека, той ще бъде прекъснат и ще бъде предложено да се инсталират необходимите хедърни файлове или -devel библиотеки. Като рпиключи процедурата:

make && make install

А може  и така:

dpkg-buildpackage -uc -us

Така ще получиш дебиански пакет. После:

dpkg -i mplayer*.deb

В Дебиан начини много'<img'>
Активен

-------------------------------------------------------------------------
./debian/rules

n_antonov

  • Напреднали
  • *****
  • Публикации: 1185
    • Профил
    • WWW
Mplayer
« Отговор #5 -: Dec 02, 2003, 09:43 »
BTW, това с високата версия на xlibs няма скоро да го оправя, но е и безсмислено. Трябва направиш upgrade на целия Х към 4.3, като си избереш източници с бекпортове от http://www.apt-get.org  примерно.

Виж сега, честно да ти кажа, този предварително компилиран пакет е несериозна работа. MPlayer е приложение, което наистина ТРЯБВА да си се компилира на системата, на която ще работи. Особено ако си с AMD или PII, т.е. по-стар от PIII, за който е компилиран самият пакет. Използвай горната процедура и ще имаш пълноценен mplayer с всички екстри'<img'>
Активен

-------------------------------------------------------------------------
./debian/rules

n_antonov

  • Напреднали
  • *****
  • Публикации: 1185
    • Профил
    • WWW
Mplayer
« Отговор #6 -: Dec 02, 2003, 11:33 »
До вечерта в repository-то ще има нов mplayer и KDE 3.2cvs.
Активен

-------------------------------------------------------------------------
./debian/rules

Подобни теми
Заглавие Започната от Отговора Прегледи Последна публикация
mplayer help
Настройка на програми
dafo 4 2925 Последна публикация May 04, 2002, 18:07
от dafo
mplayer
Настройка на програми
Neznaiko 10 3629 Последна публикация Nov 11, 2002, 08:58
от mrvoland
Oтново за MPlayer (за кой ли път)
Настройка на програми
maestross 0 1187 Последна публикация Dec 13, 2002, 16:42
от maestross
mplayer
Настройка на хардуер
uDuoT 11 3400 Последна публикация Jan 10, 2003, 15:54
от Crazy_hatteR
mplayer
Настройка на програми
sodom 2 1718 Последна публикация Apr 15, 2003, 13:27
от sodom