Автор Тема: Проблеми с поставяне на ново ядро на отдалечена с.  (Прочетена 516 пъти)

Emooo

  • Гост
Така, винаги като слагам ново ядро и ми е свито сърцето че в новото ядро може да съм пропуснал нещо или самото то да е проблемно на моя хардуер и отдалечената ми машина спре което пък е голям проблем защото машините са на голямо разтояние от мен и не мога просто да ги ребоотна или да им сложа монитор защото просто няма такъв там. До сега не ми се е случвало но усещам ще рано или късно че стане '<img'>. Естествено при инсталация на ново ядро старото присъства като опция на LILO но пак е нужно някой на място да ръчка на място. Въпроса ми е дали някои случайно е измислил някакво решение на този въпрос?
Активен

  • Гост
тестваш на твоя компютър и щом тръгва няма проблем.
Номера е да си сигурен с модулите за мрежовите интерфейси.
Инак типът на процесора няма значение. Щом твоя компютър успява да се рестартира няма да имаш ядове (е, ясно е че е важен и типа на дисковете)
Активен

rpetrov

  • Напреднали
  • *****
  • Публикации: 571
    • Профил
    • WWW
Ако държиш на достъпа до сървера, ще трябва да си пуснеш резервна връзка по телефон+модем до него.

lilo има възможност за достъп през сериен порт.
Повече не мога да помогна - подробностите/тънкостите отдавна съм забравил.
grub би трябвало да поддържа също.

Може би в Remote-Serial-Console-HOWTO има нещо интересно ?
Активен

vlad73

  • Напреднали
  • *****
  • Публикации: 130
    • Профил
Grub имаше някакъв "fallback" като опция да го накара да зареди нещо друго ако основното пропадне, но това мисля може да те спаси само когато пропадне самото извикване на кернела.
Но не съм  го ползвал това, само съм го виждал из "info grub"

Сега погледнах в google - има такава опция и в lilo, дано ти е от полза!
Активен