Автор Тема: Не мога да подкарам ssh(ламер)  (Прочетена 804 пъти)

Rag

  • Напреднали
  • *****
  • Публикации: 18
    • Профил
Здравейте пак.
Цяла сутрин (от 9':0'0) се боря да го подкарам(ползвам Suse 9.3). Само че съм до под кривата круша...
Минах sshd.conf и host.allow и host.deny. Коментирах каквото трябва. Накарах един приятел да си инсталира SSH Клиент за Win, само че когато се connect-към мен не става нищо - казва му хост ънрийчъбъл.
При мен проблема е следния - пиша sshd - отвръща ми:
Примерен код

Rag:/etc/ssh # sshd
sshd re-exec requires execution with an absolute path


Порових се в google и открих в един форум, че това е характерно за по-новите версии на openssh:
Примерен код

If im understanding correctly... you will likely want to rebuild the initd ssh start script using the full path to sshd. (eg, "/usr/sbin/sshd" and not just "sshd").
********************************
Bug that crept in through the upgrade to the latest openssh, they want full path now

 За съжаление не мога да разбера къде ми е грешката и какво трябва да направя. Попрегледах man-a само че пак нищо не ми стана ясно.
Може ли някой да ми обясни след като мина през конфигурационните файлове как да стартирам самия сървър на моя компютър, за да мога да кънектвам към него отвън.
Предварително ви благодаря.

П.С. Направих и сърч на форума тук, но открих обяснения за проблеми, възникнали след пускането на ssh daemon-a.
Активен

professional novice in UNIX

  • Гост
Не мога да подкарам ssh(ламер)
« Отговор #1 -: May 07, 2005, 14:01 »
На Слак беше много лесно. Просто пишеш

/etc/rc.d/rc.sshd start

и би трябвало да тръгне.
Активен

Rag

  • Напреднали
  • *****
  • Публикации: 18
    • Профил
Не мога да подкарам ssh(ламер)
« Отговор #2 -: May 07, 2005, 14:07 »
Цитат (Guest @ Май 07 2005,16:01)
На Слак беше много лесно. Просто пишеш

/etc/rc.d/rc.sshd start

и би трябвало да тръгне.

Не, не става... за съжалени.. Мерси все пак.
Иначе - някакви други предложения от някой, който ползва Suse 9.3?
Активен

professional novice in UNIX

Йордан

  • Напреднали
  • *****
  • Публикации: 1451
  • Distribution: Ubuntu / Gentoo
  • Window Manager: Gnome
  • не е важно колко ти е голяма пишката, а какво можеш с нея
    • Профил
    • WWW
Не мога да подкарам ssh(ламер)
« Отговор #3 -: May 07, 2005, 14:48 »
От рън левел си пусни сървърчето
Активен

Всеки пост - отговор на въпрос !!!

Йордан Георгиев
http://ygeorgiev.net/

dpm

  • Напреднали
  • *****
  • Публикации: 81
    • Профил
Не мога да подкарам ssh(ламер)
« Отговор #4 -: May 07, 2005, 15:42 »
Yast > System > Runlevel Editor: Services > sshd > Enable
Активен

Rag

  • Напреднали
  • *****
  • Публикации: 18
    • Профил
Не мога да подкарам ssh(ламер)
« Отговор #5 -: May 07, 2005, 22:50 »
Мерси много момчета! Настроих го и тръгна. Накарах и firewall-a да пропуска ssh. Благодаря ви много пак!
Активен

professional novice in UNIX