Автор Тема: проблеми с B-Trust и Linux Mint 17  (Прочетена 4186 пъти)

ummon

  • Участници
  • ***
  • Публикации: 4
    • Профил
проблеми с B-Trust и Linux Mint 17
« -: Mar 08, 2016, 00:11 »
Здравейте,

До преди няколко седмици използвах успешно b-trust ел.подпис с Firefox 32 (според Борика работи само с версия 32...) под Linux Mint 17, но след ъпдейт нещо се прецака и спря да ми разпознава подписа.

Purge-нах Firefox-a и инсталирах отново версия 32. Сега виждам подписа в FF, но не мога да подпиша нищо :( - примерно за банков превод не ми излиза поп-ъпа за ПИН-а на подписа.
Имам инсталирани 2 Firefox add-on-а: B-Trust Tool 1.18 и signTextJS 0.7.4.

Интересното е, че мога да влизам в epay.bg примерно (въвеждам успешно пин-а), но не мога да подписвам преводи - зацикля там където би трябвало да излиза попъп за пина :'(

За всеки случай си направих виртуална машина с Mint 17 и направих всичко отначало:
 - инсталирах scInterface
 - инсталирах opensc, libccid, pcscd, libengine-pkcs11-openssl, pcsc-tools и libacr38u
 - $ sudo pcsc_scan уж намира подписа
 - инсталирах двата адд-она - B-Trust Tool + signTextJS
 - свалих FF 32 (дефолтната версия за Mint 17 e 33)
 - екстрактвам и стартирам FF с root права иначе не намира подписа
 ===> пак стигам до същото положение: зацикля като трябва да подпиша

Имам чувството, че проблемът е в signTextJS, но не съм сигурен. Или пък нещо с правата се омазва? Или ми е прецакан подписа?

Не знам какво да правя.
Помагайте !  ???
Активен

BRADATA

  • Напреднали
  • *****
  • Публикации: 833
  • Distribution: Slackware/Mint/CentOS
  • Window Manager: console/KDE/LXDE
    • Профил
    • WWW
Re: проблеми с B-Trust и Linux Mint 17
« Отговор #1 -: Mar 08, 2016, 07:14 »
Ползвам минт 17.3 кде с последния файърфокс, б-тръст работи без проблем.

Деисталирай всички добавки от б-тръст, sign-js също. Отвори папката на профила в мозила от about:support и изтрий cert8.db. Това ще нулира базата със сертификатите.

Добави си библиотеката както съветват от б-тръст

b-trust
Инсталирай си базовите вериги с тяхната добавка и sign-js. Рестартирай браузъра с включен подпис и тествай на тяхната страница. Би трябвало да нямаш проблем.
Активен

ummon

  • Участници
  • ***
  • Публикации: 4
    • Профил
Re: проблеми с B-Trust и Linux Mint 17
« Отговор #2 -: Mar 08, 2016, 21:00 »
Добавям библиотеката libcvP11.so (къде в инструкциите от б-тръст е казано??).
Инсталирам B-Trust Tool аддон-а и рестартирам.
След рестарт ми излиза следното:

"The following conflicted PKCS#11 modules unregistered: New PKCS#11 Module (/usr/local/lib64/libcvP11.so). If you want to use them please choose `B-Trust Config` option `Other Card` and register again"

`B-Trust Config` option няма...
?!
Активен

ummon

  • Участници
  • ***
  • Публикации: 4
    • Профил
Re: проблеми с B-Trust и Linux Mint 17
« Отговор #3 -: Mar 08, 2016, 21:05 »
А ако пак добавя libcvP11.so подписът работи... до следващия рестарт на FF   >:D
Активен

BRADATA

  • Напреднали
  • *****
  • Публикации: 833
  • Distribution: Slackware/Mint/CentOS
  • Window Manager: console/KDE/LXDE
    • Профил
    • WWW
Re: проблеми с B-Trust и Linux Mint 17
« Отговор #4 -: Mar 09, 2016, 13:36 »
Аз го правя само ръчно - т.е. не използвам никакви пакети от никой. Копирам си файла libcvP11.so в /usr/local/lib64, добавям го във фирефокса, и използвам само добавката за удостоверителните вериги от тук https://www.b-trust.org/bg/elektronni-podpisi/udostoveritelni-verigi

Ако искам да сменявам пин - правя го през виндовса на счетито :)
Активен

ummon

  • Участници
  • ***
  • Публикации: 4
    • Профил
Re: проблеми с B-Trust и Linux Mint 17
« Отговор #5 -: Mar 10, 2016, 17:44 »
libcvP11.so се екстрактва в /usr/local/lib64 при инсталацията на пакет scInterface (в инсталационния пакет на Б-труст е). Би трябвало ефектът да е същия :)

Твоя libcvP11.so откъде е ?
Активен

BRADATA

  • Напреднали
  • *****
  • Публикации: 833
  • Distribution: Slackware/Mint/CentOS
  • Window Manager: console/KDE/LXDE
    • Профил
    • WWW
Re: проблеми с B-Trust и Linux Mint 17
« Отговор #6 -: Mar 10, 2016, 19:24 »
От същия пакет, само че не го инсталирам.
Активен