Автор Тема: KDE Update  (Прочетена 2163 пъти)

cenata

  • Напреднали
  • *****
  • Публикации: 116
  • Distribution: Fedora
  • Window Manager: Gnome
    • Профил
KDE Update
« -: Oct 13, 2005, 16:18 »
Значи питането ми е следното.
Със Slackware 10.1 съм, което идва със KDE 3.3.2. Свалил съм пакетите на KDE 3.4.2 (tgz-тата), инсталирах ги и си бачка. Но когато исках да премахна старите версии (тези на 3.3.2) чрез мениджъра на пакетите, те не се махнаха поради грешки в това че били използвани в момента или нещо такова. Та питането ми е мога ли да ги махна, за да не заемат място или не мога. Или самия подход е грешен, имам предвид подхода на инсталирането на новите (махането на старите).
Активен

Lord Bad

  • Напреднали
  • *****
  • Публикации: 1667
  • Distribution: Fedora 13
  • Window Manager: GNOME
  • Jedi Knight
    • Профил
KDE Update
« Отговор #1 -: Oct 13, 2005, 17:10 »
Новите пакети трябва да се overwrite-нали старите.
Активен

Fuelled by Fedora 13 "Goddard"
====================================
Rock it!

cenata

  • Напреднали
  • *****
  • Публикации: 116
  • Distribution: Fedora
  • Window Manager: Gnome
    • Профил
KDE Update
« Отговор #2 -: Oct 13, 2005, 17:12 »
Значи това което направих бе да ги инсталирам  командата installpkg. Сега в Мениджъра на пакетите присъстват и новите и старите, примерно kdebase-3.4.2 и kdebase-3.3.2. така за всички пакети
Активен

  • Гост
KDE Update
« Отговор #3 -: Oct 13, 2005, 22:04 »
Следващия път използвай командата upgradepkg или пък ги инсталирай с pkgtool.
Активен

  • Гост
KDE Update
« Отговор #4 -: Oct 13, 2005, 22:07 »
Искам да си обновя КДЕ-то от 3.2.2
до 3.4.2
Дръпнах си рпм пакетите за Сусе 9.1
Само ми кажете как да го инсталирам.
Тръгвам да инсталирам пакет по пакет ли?
Няма ли автоматизиран начин?
Как да го направя? Обяснете като за човек който има линукс от 10 дена.
Рових из интерент ама не намерих никъде статия като за начинаещ?
Във този форум не откривам подобна тема.

Помощ?
Активен

  • Гост
KDE Update
« Отговор #5 -: Oct 13, 2005, 22:37 »
Не ще де се обнови направих следното:

 rpm -Uvh --test /media/cdrecorder/kde/stable/3.4.2/SuSE/ix86/9.1/*.rpm
error: Failed dependencies:
        glib2-devel is needed by arts-devel-1.4.2-3
        jack-devel is needed by arts-devel-1.4.2-3
        libogg-devel is needed by arts-devel-1.4.2-3
        libvorbis-devel is needed by arts-devel-1.4.2-3
        alsa-devel is needed by arts-devel-1.4.2-3
        libqscintilla.so.5 is needed by kdebindings3-python-3.4.2-3
        libruby.so.1.8 is needed by kdebindings3-ruby-3.4.2-3
        povray is needed by kdegraphics3-3D-3.4.2-3
        tiff is needed by kdegraphics3-fax-3.4.2-3
        xpdf is needed by kdegraphics3-pdf-3.4.2-3
        tetex is needed by kdegraphics3-tex-3.4.2-3
        libvorbis-devel is needed by kdelibs3-devel-3.4.2-3
        autoconf is needed by kdelibs3-devel-3.4.2-3
        automake is needed by kdelibs3-devel-3.4.2-3
        libxslt-devel is needed by kdelibs3-devel-3.4.2-3
        libxml2-devel is needed by kdelibs3-devel-3.4.2-3
        libart_lgpl-devel is needed by kdelibs3-devel-3.4.2-3
        fam-devel is needed by kdelibs3-devel-3.4.2-3
        pcre-devel is needed by kdelibs3-devel-3.4.2-3
        libidn-devel is needed by kdelibs3-devel-3.4.2-3
        libtunepimp.so.1 is needed by kdemultimedia3-jukebox-3.4.2-3
        cvs is needed by kdesdk3-3.4.2-3
        libapr-0.so.0 is needed by kdesdk3-3.4.2-3
        libaprutil-0.so.0 is needed by kdesdk3-3.4.2-3
        libneon.so.24 is needed by kdesdk3-3.4.2-3
        libsvn_client-1.so.0 is needed by kdesdk3-3.4.2-3
        libsvn_delta-1.so.0 is needed by kdesdk3-3.4.2-3
        libsvn_diff-1.so.0 is needed by kdesdk3-3.4.2-3
        libsvn_fs-1.so.0 is needed by kdesdk3-3.4.2-3
        libsvn_ra-1.so.0 is needed by kdesdk3-3.4.2-3
        libsvn_ra_dav-1.so.0 is needed by kdesdk3-3.4.2-3
        libsvn_ra_local-1.so.0 is needed by kdesdk3-3.4.2-3
        libsvn_ra_svn-1.so.0 is needed by kdesdk3-3.4.2-3
        libsvn_repos-1.so.0 is needed by kdesdk3-3.4.2-3
        libsvn_subr-1.so.0 is needed by kdesdk3-3.4.2-3
        libsvn_wc-1.so.0 is needed by kdesdk3-3.4.2-3
        valgrind >= 1.9.6 is needed by kdesdk3-profile-3.4.2-3
        flex is needed by kdevelop3-3.2.2-3
        cvs is needed by kdevelop3-3.2.2-3
        graphviz is needed by kdevelop3-3.2.2-3
        doxygen is needed by kdevelop3-3.2.2-3
        docbook-toys is needed by kdevelop3-3.2.2-3
        html-dtd is needed by kdevelop3-3.2.2-3
        tidy is needed by kdewebdev3-3.4.2-3
        freetype2-devel is needed by qt3-devel-3.3.4-24
        libmng-devel is needed by qt3-devel-3.3.4-24
        libpng-devel is needed by qt3-devel-3.3.4-24
        c++_compiler is needed by qt3-devel-3.3.4-24
        zlib-devel is needed by qt3-devel-3.3.4-24
        xorg-x11-Mesa-devel is needed by qt3-devel-3.3.4-24
        freeglut-devel is needed by qt3-devel-3.3.4-24
        xdevel is needed by qt3-devel-3.3.4-24

Какво да направя??
Активен

  • Гост
KDE Update
« Отговор #6 -: Oct 13, 2005, 23:16 »
rpm -Fvh --nodeps  /media/cdrecorder/kde/stable/3.4.2/SuSE/ix86/9.1/*.rpm

Написах това горе. Мина обновяването на 100% после
реших че трябва да рестартирам и вместо да имам кде 3.4.2
пак си се стартира 3.2.1

Къде бъркам? Нали съм формулирал правилно rpm?
Защо не тръгва новото кде'<img'>
Активен

phantomlord

  • Напреднали
  • *****
  • Публикации: 1832
  • Distribution: Debian Sid
  • Window Manager: KDE 4
  • Fall to your knees and bow to the Phantom Lord
    • Профил
    • WWW
KDE Update
« Отговор #7 -: Oct 14, 2005, 00:16 »
В момента правят maintenance на сървъра с официалното БГ огледало на SuSE и затова сега няма да се получи, но утре (14.10) би трябвало да стане. Виж тук. Принципа е същия.
Активен

http://myfreesoft.net/phpBB2/index.php?c=7
Помогни си сам, за да ти помогне и Господ
Linux - connecting people...

PlamenB

  • Напреднали
  • *****
  • Публикации: 62
    • Профил
KDE Update
« Отговор #8 -: Oct 14, 2005, 08:10 »
howto за slack! правено многократно и работи без грешка! ползваш pkgtool. махаш старите kde пакети. отиваш в папката с новите и пак с pkgtool инстапираш новите. готово!  '<img'>  '<img'>
Активен

PlamenB

  • Напреднали
  • *****
  • Публикации: 62
    • Профил
KDE Update
« Отговор #9 -: Oct 14, 2005, 08:12 »
малко пояснение... трябва да си в чиста конзола! а не в конзолен прозорец на kde!!!  '<img'>
Активен

cenata

  • Напреднали
  • *****
  • Публикации: 116
  • Distribution: Fedora
  • Window Manager: Gnome
    • Профил
KDE Update
« Отговор #10 -: Oct 14, 2005, 08:25 »
Пропуснал съм момента с премахването на старите пакети преди да фрасна новите с pkgtool. Колко съм злеееее!  '<img'>
Благодаря на всички '<img'>
Със здраве!
Активен

  • Гост
KDE Update
« Отговор #11 -: Oct 14, 2005, 21:16 »
Цитат (phantomlord @ Окт. 14 2005,01:16)
В момента правят maintenance на сървъра с официалното БГ огледало на SuSE и затова сега няма да се получи, но утре (14.10) би трябвало да стане. Виж тук. Принципа е същия.

Mersi polu4i se po tozi na4in '<img'>

obnovih go ot netbg.com

samo o6te edin vupros
kakvo zna4i KDE Level B??

i kagete mi bulgarski izto4nik za linux software
Активен

phantomlord

  • Напреднали
  • *****
  • Публикации: 1832
  • Distribution: Debian Sid
  • Window Manager: KDE 4
  • Fall to your knees and bow to the Phantom Lord
    • Профил
    • WWW
KDE Update
« Отговор #12 -: Oct 14, 2005, 22:25 »
Цитат
Mersi polu4i se po tozi na4in

obnovih go ot netbg.com

samo o6te edin vupros
kakvo zna4i KDE Level B??

i kagete mi bulgarski izto4nik za linux software


Отвори конкерор-а и виж "about". Там пишеше нещо като: "Unofficial build of SuSE". Няма значение.
За български източник за SuSE, сложи в YOU (YaST Online Update): ftp://mirrors.netbg.com/suse
Други в Б-я няма.
И между другото... ПИШИ НА КИРИЛИЦА!
Активен

http://myfreesoft.net/phpBB2/index.php?c=7
Помогни си сам, за да ти помогне и Господ
Linux - connecting people...

voyager

  • Напреднали
  • *****
  • Публикации: 152
    • Профил
KDE Update
« Отговор #13 -: Oct 17, 2005, 00:59 »
Цитат (cenata @ Окт. 14 2005,09:25)
Пропуснал съм момента с премахването на старите пакети преди да фрасна новите с pkgtool. Колко съм злеееее!  '<img'>
Благодаря на всички '<img'>
Със здраве!

Можеш да им махнеш описанията от /var/log/packages/kde-3.2* или нещо от сорта, но почти със сигурност смея да твърдя че ще ти се появят някакви файлове, дето не се използват от нищо, и ти ядат място на диска...  . С diff можеш да провериш кои файлове са различните и евентуално ако ти се занимава... да ги парснеш към rm.
Активен

Подобни теми
Заглавие Започната от Отговора Прегледи Последна публикация
Update на KDE
Настройка на програми
Al_Kapone 10 6235 Последна публикация Apr 13, 2004, 18:07
от kicker
KDE update?
Настройка на програми
Al_Kapone 1 2898 Последна публикация Apr 20, 2004, 19:40
от empty
update kde 3.1.4
Настройка на програми
drakar 1 2868 Последна публикация Apr 27, 2004, 16:31
от
iso update
Настройка на програми
didddd 5 3652 Последна публикация Aug 11, 2004, 11:18
от the_real_maniac
update на библиотеки
Настройка на програми
worthless 6 3502 Последна публикация Jan 24, 2005, 22:41
от bsurgery