Автор Тема: Субтитри на черното  (Прочетена 4099 пъти)

HarleyBG

  • Напреднали
  • *****
  • Публикации: 375
    • Профил
Субтитри на черното
« -: Aug 31, 2004, 23:17 »
Как може да се направи GMPlayer да изобразява суба върху черната част при fullscreen?'<img'>?'<img'>
Активен

AMD Duron 800MHz, 256 MB DDR, K7S5A, VC GeForce2 32MB, HDD WD20GB

IvanST

  • Напреднали
  • *****
  • Публикации: 369
    • Профил
Субтитри на черното
« Отговор #1 -: Aug 31, 2004, 23:58 »
mplayer -vo sdl ......
Активен

HarleyBG

  • Напреднали
  • *****
  • Публикации: 375
    • Профил
Субтитри на черното
« Отговор #2 -: Sep 01, 2004, 00:03 »
Пробвал съм го, но не става. Прозореца става черен, появява се още един с филма и не може да се вкл на fullscreen '<img'>
Активен

AMD Duron 800MHz, 256 MB DDR, K7S5A, VC GeForce2 32MB, HDD WD20GB

HarleyBG

  • Напреднали
  • *****
  • Публикации: 375
    • Профил
Субтитри на черното
« Отговор #3 -: Sep 01, 2004, 00:03 »
Wersiata mi e 1opre5
Активен

AMD Duron 800MHz, 256 MB DDR, K7S5A, VC GeForce2 32MB, HDD WD20GB

Филип Бонев

  • Напреднали
  • *****
  • Публикации: 517
  • Distribution: Debian
  • Window Manager: KDE
    • Профил
Субтитри на черното
« Отговор #4 -: Sep 01, 2004, 00:22 »
Здравей,

Пробвай с това mplayer -vf=expand=0:-60:0:0 така картината на екрана се измества с 60 точки на горе. Тоя въпрос и аз съм го задавал преди и за мен това стана.

Аз да питам някой имали представа, защото като пусна -vo sdl ми се пуска в 640х480, а не 1024х768(xorg бачка в него) и сменям режима с "C" после ми става черен екрана и xorg умира.

Съжалявам, но не ми се отваря нова тема, а пък може и да е от полза :)
Активен

Поздрави,
Филип Бонев

  • Гост
Субтитри на черното
« Отговор #5 -: Sep 01, 2004, 00:45 »
Нещо не става.
Би ли ми дал линк към темата
Активен

Филип Бонев

  • Напреднали
  • *****
  • Публикации: 517
  • Distribution: Debian
  • Window Manager: KDE
    • Профил
Субтитри на черното
« Отговор #6 -: Sep 01, 2004, 02:18 »
vf=expand=0:-60:00:0 пробвай да го сложиш в конфиг файла и ще стане
Активен

Поздрави,
Филип Бонев

iko

  • Напреднали
  • *****
  • Публикации: 27
    • Профил
    • WWW
Субтитри на черното
« Отговор #7 -: Sep 01, 2004, 09:15 »
Ако не искаш да го слагаш в config файла, просто трябва да е без пърото "="
Примерен код
mplayer -vf expand=0:-60:0:0 film.avi
Активен

HarleyBG

  • Напреднали
  • *****
  • Публикации: 375
    • Профил
Субтитри на черното
« Отговор #8 -: Sep 01, 2004, 09:32 »
Стана, но има ЕДИН ГОЛЯМ НЕДОСТАТЪК:
Ако размера на филма е квадратен, т.е. без mplayer -vf expand=0:-60:0:0  film.avi  да заема изцяло екрана, то после под него има черно. Някакви идей как това може да се иззбегне.
Активен

AMD Duron 800MHz, 256 MB DDR, K7S5A, VC GeForce2 32MB, HDD WD20GB

HarleyBG

  • Напреднали
  • *****
  • Публикации: 375
    • Профил
Субтитри на черното
« Отговор #9 -: Sep 01, 2004, 09:41 »
Между другото,на gmplayer като дам preferences -->video има само тези драйвъри: xv, x11 ,dfbmga ,xvidix. sdl липсва. Това проблем ли е?
Активен

AMD Duron 800MHz, 256 MB DDR, K7S5A, VC GeForce2 32MB, HDD WD20GB

sverdlov

  • Напреднали
  • *****
  • Публикации: 351
    • Профил
Субтитри на черното
« Отговор #10 -: Sep 01, 2004, 11:32 »
Някой знае ли как става номера с xine?'<img'>
Активен

Nuclear_man

  • Напреднали
  • *****
  • Публикации: 121
    • Профил
Субтитри на черното
« Отговор #11 -: Sep 01, 2004, 11:34 »
Аз доколкото знам sdl върви само с mplayer
С GUI-то (gmplayer) не става.

П.П. В офиса инсталирах mplayer за windows '<img'>) Направо е трепач. Там върви с vo=directx '<img'>))
Активен

Home: A64(E3)@1,1V, Asus A8N-E+CM Blue Ice2, 2x512 TwinMos, 200SATA+40ATA, GB6600, LG DVD-RW, Ozaki 5+1, 17" iiyama E431S TFT, powered by FSP 400W & Slack 10.2 :)
Office: Compaq nx9110 (P4 3,2 MB ATI, 2x256 Infineon, 40ATA, Mob. Radeon 9000, 15,4" TFT, slow down by WinXP and Norton Antivirus :(

  • Гост
Субтитри на черното
« Отговор #12 -: Sep 01, 2004, 11:52 »
Dobre togawa, nqkoj znae li kak stawa s GUI
Активен

HarleyBG

  • Напреднали
  • *****
  • Публикации: 375
    • Профил
Субтитри на черното
« Отговор #13 -: Sep 01, 2004, 12:49 »
А може ли да се направи някакъв скрипт с оператор if?'<img'>?'<img'>
Примерен код
if razmer then -vf=expand=0:0:0:0
else  -vf=expand=0:-80:0:40


 '<img'>
Активен

AMD Duron 800MHz, 256 MB DDR, K7S5A, VC GeForce2 32MB, HDD WD20GB

Hapkoc

  • Напреднали
  • *****
  • Публикации: 2117
    • Профил
Субтитри на черното
« Отговор #14 -: Sep 01, 2004, 13:03 »
Може, стига да измислиш как да вземеш "razmer" '<img'>
Активен