Автор Тема: UBUNTU и LAMP  (Прочетена 1981 пъти)

aspirina97

  • Напреднали
  • *****
  • Публикации: 80
  • Distribution: Ubuntu 9.04/Slackware 12.2
  • Window Manager: Gnome/Xfce
  • пингвинаджя
    • Профил
UBUNTU и LAMP
« -: Mar 26, 2009, 09:24 »
Здравейте.
Инсталирах си LAMP по точно така

    sudo apt-get install apache2
    sudo apt-get install php5
    sudo apt-get install mysql-server
    sudo apt-get install php5-mysql
    sudo apt-get install phpmyadmin

Но влязох в http://localhost/ и там работеше но сложих PHP в HTML и не работеше също и http://localhost/phpmyadmin не работеше

Not Found

The requested URL /phpmyadmin was not found on this server.
Apache/2.2.9 (Ubuntu) PHP/5.2.6-2ubuntu4.1 with Suhosin-Patch Server at localhost Port 80

Рестартирах apache2 и MSQL

sudo /etc/init.d/apache2 restart
   
sudo /etc/init.d/mysql restart

Но без да проработи
Активен

Сънувах те - ти спа до мен, без гащи и без сутиен. Ръцете ми по теб пълзят, и все те хващат за гъза, но се събуждам изпотен, изпразнен сам и уморен...

tolostoi

  • Напреднали
  • *****
  • Публикации: 1337
  • Distribution: Ubuntu
  • Window Manager: Unity
  • левел: авераж :)
    • Профил
Re: UBUNTU и LAMP
« Отговор #1 -: Mar 26, 2009, 12:17 »
Линк на phpmyadmin направи ли?
Код:
ls -l /var/www/
общо 32
-rw-r--r-- 1 root root 1364 2009-01-20 18:19 favicon.ico
-rw-r--r-- 1 root root 1046 2008-09-10 15:35 HEADER.html
-rw-r--r-- 1 root root 1049 2008-09-10 15:35 HEADER.html~
lrwxrwxrwx 1 root root   22 2008-04-02 16:48 phpmyadmin -> /usr/share/phpmyadmin/
-rw-r--r-- 1 root root   94 2008-09-10 15:35 README.html
-rw-r--r-- 1 root root   94 2008-09-10 15:02 README.html~
drwxr-xr-x 2 root root 4096 2008-10-06 17:12 sharedip
drwxr-xr-x 4 root root 4096 2008-11-18 11:05 su
drwxr-xr-x 2 root root 4096 2009-03-01 08:34 webalizer
Активен


... в Столичен инспекторат една година след миграцията, продължават да работят под Linux. Което, май прави "експеримента" успешен
by entusiast

aspirina97

  • Напреднали
  • *****
  • Публикации: 80
  • Distribution: Ubuntu 9.04/Slackware 12.2
  • Window Manager: Gnome/Xfce
  • пингвинаджя
    • Профил
Re: UBUNTU и LAMP
« Отговор #2 -: Mar 26, 2009, 19:50 »
Ми защо имам само тези


aspirina@aspirina:~$ ls -l /var/www/
total 8
-rw-r--r-- 1 root root 227 2009-03-26 09:15 index.html
-rw-r--r-- 1 root root 227 2009-03-26 09:15 index.html~
aspirina@aspirina:~$


Активен

Сънувах те - ти спа до мен, без гащи и без сутиен. Ръцете ми по теб пълзят, и все те хващат за гъза, но се събуждам изпотен, изпразнен сам и уморен...

R3sp3k7

  • Напреднали
  • *****
  • Публикации: 60
  • Distribution: Fedora 12 (Constantine)
  • Window Manager: Xfce4
    • Профил
    • WWW
Re: UBUNTU и LAMP
« Отговор #3 -: Mar 26, 2009, 19:58 »
За php инсталирай го така
Цитат
apt-get install php5 php5-gd php5-mcrypt php5-mysql libapache2-mod-php5
и след това изпълни
Цитат
/etc/init.d/apache2 restart
Би трябвало да тръгне, phpmyadmin може да го свалиш от интернет и го слагаш в /var/www/ и би трябвало след като си го инсталирал да ти тръгне ;]
ПП:Може да свалиш phpmyadmin от http://www.phpmyadmin.net/home_page/downloads.php
Активен

http://dev-bg.eu Уроци за десктоп програмиране

aspirina97

  • Напреднали
  • *****
  • Публикации: 80
  • Distribution: Ubuntu 9.04/Slackware 12.2
  • Window Manager: Gnome/Xfce
  • пингвинаджя
    • Профил
Re: UBUNTU и LAMP
« Отговор #4 -: Mar 26, 2009, 21:39 »
aspirina@aspirina:~$ sudo apt-get install php5 php5-gd php5-mcrypt php5-mysql libapache2-mod-php5
[sudo] password for aspirina:
Reading package lists... Done
Building dependency tree       
Reading state information... Done
php5 is already the newest version.
php5-gd is already the newest version.
php5-gd set to manually installed.
php5-mcrypt is already the newest version.
php5-mcrypt set to manually installed.
php5-mysql is already the newest version.
libapache2-mod-php5 is already the newest version.
libapache2-mod-php5 set to manually installed.
The following packages were automatically installed and are no longer required:
  libjna-java libswing-layout-java libfreemarker-java javahelp2 subversion
  liblucene2-java jetty libsvn1 libnb-platform8-devel-java libini4j-java
  libjline-java libdb-je-java libswingworker-java libdb4.5-java-gcj
  libdb4.5-java libjtidy-java libxml-commons-resolver1.1-java
  libappframework-java libnb-javaparser-java libnb-svnclientadapter-java
  libbeansbinding-java
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
 
явно съм ги инсталирал

p.s оправих се
« Последна редакция: Mar 26, 2009, 22:02 от aspirina97 »
Активен

Сънувах те - ти спа до мен, без гащи и без сутиен. Ръцете ми по теб пълзят, и все те хващат за гъза, но се събуждам изпотен, изпразнен сам и уморен...

Подобни теми
Заглавие Започната от Отговора Прегледи Последна публикация
Специалист по LAMP
Търсене
BanishMemory 0 1508 Последна публикация Jul 04, 2005, 13:24
от BanishMemory
LAMP на Р2@333/64/2.5+3ГБ
Настройка на програми
Yasen6275 5 2069 Последна публикация Oct 10, 2005, 13:30
от Yasen6275
Предложете lamp дистрибуция....
Идеи и мнения
unguzov 3 1893 Последна публикация Oct 11, 2006, 22:25
от empty
Lamp как да тествам
Настройка на програми
lsdlsd 3 2178 Последна публикация Jan 23, 2008, 11:48
от lsdlsd
Помощ в изграждане на LAMP сървар
Настройка на програми
aspirina97 2 1489 Последна публикация May 06, 2009, 08:27
от Neo2SHYAlien