Автор Тема: Проблем със стартирането от SATA HDD  (Прочетена 2386 пъти)

dmvic

  • Напреднали
  • *****
  • Публикации: 46
    • Профил
    • WWW
Първо добър ден (утро, вечер).
Ситуацията е следната. Купих си преди 2 дена нов хард диск (Seagate 120gb/sata/8mb cache) и реших да мина изцяло на него. До тогава бях (а и все още съм) със един 6gb ide диск и slackware с 2.4.27 ядро. Свалих си slackware current от 23.11. и инсталирах без значителни проблеми директно на sata диска, като бях откачил ide дисковете. Записах lilo-то в MBR-а на sata-та и рестартирах. Менюто излиза, давам да зарежда, изписва loading linux... BIOS data check successfull и машината рестартира. Рових се доста време, но не успях да намеря решение. Ето го и lilo.conf съдържанието, защото си мисля, че проблема е в това. Ако знаете как да го оправя, моля помогнете.

Примерен код

# Start LILO global section
boot = /dev/sda
lba32
disk = /dev/sda      #тези ги добавих след като видях някакво
    inaccessible #обяснение в интернет, ама без резултат
compact        # faster, but won't work on all systems.
prompt
timeout = 300
# Normal VGA console
vga = normal
# VESA framebuffer console @ 1024x768x64k
# vga=791
# VESA framebuffer console @ 1024x768x32k
# vga=790
# VESA framebuffer console @ 1024x768x256
# vga=773
# VESA framebuffer console @ 800x600x64k
# vga=788
# VESA framebuffer console @ 800x600x32k
# vga=787
# VESA framebuffer console @ 800x600x256
# vga=771
# VESA framebuffer console @ 640x480x64k
# vga=785
# VESA framebuffer console @ 640x480x32k
# vga=784
# VESA framebuffer console @ 640x480x256
# vga=769
# ramdisk = 0     # paranoia setting
# End LILO global section
# Linux bootable partition config begins
image = /boot/vmlinuz
  root = /dev/sda1
  label = Linux
  read-only # Non-UMSDOS filesystems should be mounted read-only for checking
# Linux bootable partition config ends
Активен

"...don't care what people say, just follow your own way..."

dmvic

  • Напреднали
  • *****
  • Публикации: 46
    • Профил
    • WWW
Проблем със стартирането от SATA HDD
« Отговор #1 -: Nov 28, 2004, 18:17 »
OK. Проблема се оказа не в лило а в ядрото. Заредих от инсталационния диск, прекомпилирах ядрото и рестартирах. Лило започна да си зарежда нормално обаче изведнъж хоп:
Примерен код
VFS: Cannot open root device "801" or 08:01
Please append a correct "root=" boot option
Kernel Panic:VFS:Unable to mount root fs

Използвам reiserfs ако това има значение, ако не си нямам представа какво да правя по-нататък не ми се минава на 2.6.х ядро, 2.4.27 трябва да остане.
Активен

"...don't care what people say, just follow your own way..."

dmvic

  • Напреднали
  • *****
  • Публикации: 46
    • Профил
    • WWW
Проблем със стартирането от SATA HDD
« Отговор #2 -: Nov 28, 2004, 20:53 »
OK. Съжалявам че това стана просто един дневник на мъките ми, но се оказа, че поради малко мозък в главата съм пуснал поддръжката на VIA SATA като модул. Сега диска върви и всичко е наред... Извинявам се за безпокойството...
Активен

"...don't care what people say, just follow your own way..."