Автор Тема: Проблем с limewire  (Прочетена 688 пъти)

_NetCutter_

  • Напреднали
  • *****
  • Публикации: 513
    • Профил
Проблем с limewire
« -: Nov 07, 2006, 11:37 »
Инсталирах си limewire.
Но при опит за стартиране. . . .то просто не се състоеше.
Пуснах го през конзолата и вижте какво ми извади:
Примерен код
netcutter@ubuntu:~$ limewire
runLime.sh: 44: Syntax error: "(" unexpected (expecting "}")
netcutter@ubuntu:~$


Грешката е на 44 ред, опитах да заменя двете са намиращи скоби с { , но пак същото.
За това ето съдържанието на файла от ред 10 до ред 100:
Цитат
# try to discover java
MSG0="Loading LimeWire:"
MSG1="Starting LimeWire..."
MSG2="Java exec found in "
MSG3="OOPS, your java version is too old "
MSG4="You need to upgrade to JRE 1.4.x or newer from http://www.java.com"
MSG5="Suitable java version found "
MSG6="Configuring environment..."
MSG7="OOPS, you don't seem to have a valid JRE. LimeWire works best with Sun JRE available at http://www.java.com "
MSG8="OOPS, unable to locate java exec in "
MSG9=" hierarchy"
MSG10="Java exec not found in PATH, starting auto-search..."
MSG11="Java exec found in PATH. Verifying..."

look_for_java()
{
 JAVADIR=/usr/lib  
 if look_for_javaImpl ; then
    return 0
 fi
 JAVADIR=/usr/java
 if look_for_javaImpl ; then
       return 0
 fi
 JAVADIR=/opt
 if look_for_javaImpl ; then
       return 0
 fi
 return 1
}

look_for_javaImpl()
{
  IFS=$'\n'
  potential_java_dirs=(`ls -d1 "$JAVADIR"/j* | sort | tac`)
  for D in "${potential_java_dirs}"; do
    if [[ -d "$D" && -x "$D/bin/java" ]]; then
      JAVA_PROGRAM_DIR="$D/bin/"
      echo $MSG2 $JAVA_PROGRAM_DIR
      if check_version ; then
   return 0
      fi
    fi
  done
  echo $MSG8 "${JAVADIR}/" $MSG9 ; echo $MSG4
  return 1
}

check_version()
{
  # short-circuit gcj
  ISGCJ=`${JAVA_PROGRAM_DIR}java -version 2>&1 | grep -i gcj`
  if [ "$ISGCJ" != "" ] ; then
      echo $MSG7
      return 1
  fi

  JAVA_HEADER=`${JAVA_PROGRAM_DIR}java -version 2>&1 | head -n 1`
  JAVA_IMPL=`echo ${JAVA_HEADER} | cut -f1 -d' '`
  if [ "$JAVA_IMPL" = "java" ] ; then
    VERSION=`echo ${JAVA_HEADER} | sed "s/java version \"\(.*\'<img'>\"/\1/"`
    if echo $VERSION | grep "^1.[0-3]" ; then
      echo $MSG3 "[${JAVA_PROGRAM_DIR}java = ${VERSION}]" ; echo $MSG4
      return 1
    else
      echo $MSG5 "[${JAVA_PROGRAM_DIR}java = ${VERSION}]" ; echo $MSG6
      return 0         
    fi
  else
    echo $MSG7 "[${JAVA_PROGRAM_DIR}java = ${JAVA_IMPL}]" ; echo $MSG4
    return 1
  fi
}

echo $MSG1

# locate and test the java executable
if [ `uname` = "Linux" ]; then
  if ! command -v java &>/dev/null; then
    echo $MSG10
    if ! look_for_java ; then
      exit 1
    fi
  else
    echo $MSG11
    if ! check_version ; then
      if ! look_for_java ; then
        exit 1
      fi
    fi
  fi

Удебеленият ред е ред 44.
Ако някой си има понятие от джава и/или знае как да се оправи проблема, моля да сподели.
10х предварително  ':p'
Активен

Linux - Connecting People!

Italianeca

  • Напреднали
  • *****
  • Публикации: 386
    • Профил
Проблем с limewire
« Отговор #1 -: Nov 07, 2006, 12:37 »
Разкарай целия скрипт който търси java. Ако си конфигурирал java-та не ти трябва. Аз така си го оправих даже и не мислих защо не става.
Активен

Deathmaster

  • Напреднали
  • *****
  • Публикации: 184
  • Distribution: Kubuntu 8.04.2 & Kubuntu 9.04
  • Window Manager: KDE 3.5.10 & KDE 4.2.2
  • Do not disturb - already DISTURBED (rock)
    • Профил
Проблем с limewire
« Отговор #2 -: Nov 07, 2006, 18:15 »
Мой човек решението ти е следното:
отвори като руут с любим текстов редактор файла : /usr/bin/limewire
и го направи да изглежда така:
Примерен код
#!/bin/bash
cd /usr/lib/LimeWire
bash runLime.sh

Запиши го и си пусни програмата. Би трябвало да работи. Освен това аз си ползвам настройките на джава от ubuntuguide.org.
Успех.

Едит: Лайма не е много готин заради новата си политика и още защото е правен на джава(много тежък иде). Ако искаш да ползваш бърз и надежден клиент за гнутела(това е мрежата в която работи лайма) препоръчвам ти GTK-Gnutella. Има я в хранилищата на кубунту.



Активен

Freedom is divine! Open Source is Freedom! Do you wanna be free ?
Kubuntu 8.04.2 & Kubuntu 9.04 - The power of Linux!

_NetCutter_

  • Напреднали
  • *****
  • Публикации: 513
    • Профил
Проблем с limewire
« Отговор #3 -: Nov 07, 2006, 21:29 »
Значи тоя gtk gnutella, хич не ми хареса.
А искам да ви питам нещо:
Инсталирах си джава 5.0 със self-extracting файла, според инструкциите в java.com, но все пак. .. .:
Примерен код
netcutter@ubuntu:~$ java --version
java version "1.4.2"
gij (GNU libgcj) version 4.1.2 20060928 (prerelease) (Ubuntu 4.1.1-14ubuntu7)

Copyright (C) 2006 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
netcutter@ubuntu:~$

После го инсталнах и от synaptic-a и пак същата работа ':huh:'
Активен

Linux - Connecting People!

_NetCutter_

  • Напреднали
  • *****
  • Публикации: 513
    • Профил
Проблем с limewire
« Отговор #4 -: Nov 08, 2006, 10:42 »
Ето по-точно за какво говоря!
http://kvvpics.hit.bg/java-wtf.png
Активен

Linux - Connecting People!

redcure

  • Напреднали
  • *****
  • Публикации: 914
    • Профил
Проблем с limewire
« Отговор #5 -: Nov 08, 2006, 11:59 »
update-alternatives --config java
П.П. А ти защо не ползва търсачката? Аз лично съм давал три пъти този отговор.



Активен

Debian testing 2.6.18, Enlightenment DR17

http://www.debian.org/doc/manuals/apt-howto/index.en.html

_NetCutter_

  • Напреднали
  • *****
  • Публикации: 513
    • Профил
Проблем с limewire
« Отговор #6 -: Nov 08, 2006, 19:12 »
Търсих, но единственото, което намерих от тебе е линка до един урок в linux-index.org
Както и да е, съжалявам, че не съм успял да го намеря и искрено ти благодаря, че ОТНОВО благоволи да ми помогнеш  '<img'>
Активен

Linux - Connecting People!