Автор Тема: Странен проблем с настройка на мрежата  (Прочетена 1072 пъти)

KPETEH

  • Напреднали
  • *****
  • Публикации: 584
    • Профил
Чисто нов инсталиран Slackware 11 имам проблем с настройката на мрежата.Инсталирано ядро 2.6.18 или така нареченото test26.s което избрах по време на инсталацията.Проблема е следният при команда
# lspci
ми показва PCI устройствата на pc-to.
От друга страна като пусна един
# ifconfig -a
детектва единствено loopback-a без мрежовата карта.
При команда
# ifconfig eth0 up
no such device
Което е доста странно при положение че lspci ми показва че мрежовата карта е разпозната. В момента се чудя какво да правя някой има ли идея за какво иде реч ?
 ':huh:'
Активен

Най-добрата страна на алчността е способността и да стопява коефициента на интелигентност дори на най-умния човек.

GoodT

  • Напреднали
  • *****
  • Публикации: 361
    • Профил
Странен проблем с настройка на мрежата
« Отговор #1 -: Nov 09, 2006, 21:03 »
Зареди й модула/драйвера.
Активен

kdpetkov

  • Напреднали
  • *****
  • Публикации: 40
    • Профил
Странен проблем с настройка на мрежата
« Отговор #2 -: Nov 09, 2006, 21:11 »
Първо съжелявам, че прекъсвам темата, но имам едно много содно питане. На Slackware 11.0 с ядро hude26.s и мрежова карта Nvidia Nforce установих, че модула й се казва forcedeath. При стартиране на системата се зарежда модула (вижда се в lsmod), но въпреки това няма eth0. След като махна модула с rmmod и после го добавя с modprobe forcedeath се зарежда и вече има eth0. Това ми е много странно и не мога да разбера защо става така. Ако някой има идея нека да я сподели, че мойте се изчерпаха '<img'>
Активен

Keep Walking!

redcure

  • Напреднали
  • *****
  • Публикации: 914
    • Профил
Странен проблем с настройка на мрежата
« Отговор #3 -: Nov 09, 2006, 21:20 »
KPETEH, ако е Realtek, зареди модула 8139too и премахни 8139cp
Активен

Debian testing 2.6.18, Enlightenment DR17

http://www.debian.org/doc/manuals/apt-howto/index.en.html

KPETEH

  • Напреднали
  • *****
  • Публикации: 584
    • Профил
Странен проблем с настройка на мрежата
« Отговор #4 -: Nov 09, 2006, 21:31 »
едит:
Хъх момчета борих го до сега и какво забелязаааах
при lsmod ми дава следното съобщение
Module Size Used by
a долното ми го дава при
modprobe -r 8139too
Fatal: Could not load /lib/modules/2.6.18/modules.dep:
No such file or directory

redcure в /etc/modprobe.d/blacklist
blacklist 8139cp
значи е в блеклиста тъй че не се зарежда.
Точно това констратирах преди малко.



Активен

Най-добрата страна на алчността е способността и да стопява коефициента на интелигентност дори на най-умния човек.

redcure

  • Напреднали
  • *****
  • Публикации: 914
    • Профил
Странен проблем с настройка на мрежата
« Отговор #5 -: Nov 09, 2006, 21:43 »
Прекомпилирай си ядрото и включи тази поддръжка.
Активен

Debian testing 2.6.18, Enlightenment DR17

http://www.debian.org/doc/manuals/apt-howto/index.en.html

kdpetkov

  • Напреднали
  • *****
  • Публикации: 40
    • Профил
Странен проблем с настройка на мрежата
« Отговор #6 -: Nov 10, 2006, 08:28 »
Или вместо да си прекомпилираш ядрото си инсталирай kernel-modules-2.6.18, kernel-headers-2.6.18 и kernel-source-2.6.18. Намери ги на диска на Slackware и после installpkg името-на-пакета в директорията.
Активен

Keep Walking!

KPETEH

  • Напреднали
  • *****
  • Публикации: 584
    • Профил
Странен проблем с настройка на мрежата
« Отговор #7 -: Nov 10, 2006, 11:22 »
Цитат (kdpetkov @ Ноември 10 2006,08:28)
Или вместо да си прекомпилираш ядрото си инсталирай kernel-modules-2.6.18, kernel-headers-2.6.18 и kernel-source-2.6.18. Намери ги на диска на Slackware и после installpkg името-на-пакета в директорията.

kdpetkov точно така и направих мерси за съвета имам си мрежа  
не съм прекомпилирал ядрото ще го направя по-късно. :-)
Така интересува ме следното нещо понеже въпреки всичко не ми зарежда явно модула за видео картата въпреки че ядрото е 2.16.18.
Видео картата е SiS 661FX та предполагам,че ще трябва да инсталирам Xfree86, за да мога да ползвам по-висока разделителна способност.В момента съм на 1024х768 но монитора ми работи на 61 Hz '<img'> Да действам ли с Xfree86 или има нещо което аз не съм настроил ?
Активен

Най-добрата страна на алчността е способността и да стопява коефициента на интелигентност дори на най-умния човек.

redcure

  • Напреднали
  • *****
  • Публикации: 914
    • Профил
Странен проблем с настройка на мрежата
« Отговор #8 -: Nov 10, 2006, 11:34 »
Какъв ти е монитора и как е описан в xorg.conf?
Активен

Debian testing 2.6.18, Enlightenment DR17

http://www.debian.org/doc/manuals/apt-howto/index.en.html

KPETEH

  • Напреднали
  • *****
  • Публикации: 584
    • Профил
Странен проблем с настройка на мрежата
« Отговор #9 -: Nov 10, 2006, 11:46 »
Примерен код
# **********************************************************************
# Monitor section
# **********************************************************************

# Any number of monitor sections may be present

Section "Monitor"

    Identifier  "My Monitor"

# HorizSync is in kHz unless units are specified.
# HorizSync may be a comma separated list of discrete values, or a
# comma separated list of ranges of values.
# NOTE: THE VALUES HERE ARE EXAMPLES ONLY.  REFER TO YOUR MONITOR'S
# USER MANUAL FOR THE CORRECT NUMBERS.

    HorizSync   31.5 - 50.0

#    HorizSync  30-64         # multisync
#    HorizSync  31.5, 35.2    # multiple fixed sync frequencies
#    HorizSync  15-25, 30-50  # multiple ranges of sync frequencies

# VertRefresh is in Hz unless units are specified.
# VertRefresh may be a comma separated list of discrete values, or a
# comma separated list of ranges of values.
# NOTE: THE VALUES HERE ARE EXAMPLES ONLY.  REFER TO YOUR MONITOR'S
# USER MANUAL FOR THE CORRECT NUMBERS.

    VertRefresh 40-90

EndSection


# **********************************************************************
# Graphics device section
# **********************************************************************

# Any number of graphics device sections may be present

Section "Device"
    Identifier  "VESA Framebuffer"
    Driver      "vesa"
    #VideoRam    4096
    # Insert Clocks lines here if appropriate
EndSection

# **********************************************************************
# Screen sections
# **********************************************************************

# Any number of screen sections may be present.  Each describes
# the configuration of a single screen.  A single specific screen section
# may be specified from the X server command line with the "-screen"
# option.
Section "Screen"
    Identifier  "Screen 1"
    Device      "VESA Framebuffer"
    Monitor     "My Monitor"

# If your card can handle it, a higher default color depth (like 24 or 32)
# is highly recommended.

#   DefaultDepth 8
#   DefaultDepth 16
   DefaultDepth 24
#   DefaultDepth 32

# "1024x768" is also a conservative usable default resolution.  If you
# have a better monitor, feel free to try resolutions such as
# "1152x864", "1280x1024", "1600x1200", and "1800x1400" (or whatever your
# card/monitor can produce)

    Subsection "Display"
        Depth       8
        Modes "1024x768" "800x600" "640x480"
    EndSubsection
    Subsection "Display"
        Depth       16
        Modes "1024x768" "800x600" "640x480"
    EndSubsection
    Subsection "Display"
        Depth       24
        Modes "1024x768" "800x600" "640x480"
    EndSubsection
    Subsection "Display"
        Depth       32
        Modes "1024x768" "800x600" "640x480"
    EndSubsection

EndSection

Това е изхода от xorg.conf
Монитора е Philips 107 T6
Активен

Най-добрата страна на алчността е способността и да стопява коефициента на интелигентност дори на най-умния човек.

redcure

  • Напреднали
  • *****
  • Публикации: 914
    • Профил
Странен проблем с настройка на мрежата
« Отговор #10 -: Nov 10, 2006, 13:33 »
Промени в xorg.conf следните неща:
Примерен код

.......................................
HorizSync   30-71
VertRefresh 50-160
......................................
Subsection "Display"
       Depth       32
       Modes "1280x1024" "1024x768" "800x600" "640x480"
   EndSubsection
............................

Спецификацията на монитора съм ти взел от тук.
 '<img'>
Активен

Debian testing 2.6.18, Enlightenment DR17

http://www.debian.org/doc/manuals/apt-howto/index.en.html

KPETEH

  • Напреднали
  • *****
  • Публикации: 584
    • Профил
Странен проблем с настройка на мрежата
« Отговор #11 -: Nov 10, 2006, 15:12 »
redcure мерси,всичко е наред вече с настройката на монитора  '<img'>
Активен

Най-добрата страна на алчността е способността и да стопява коефициента на интелигентност дори на най-умния човек.