Автор Тема: Проблем с тв тунер и уебкамера  (Прочетена 2006 пъти)

Nik123

  • Напреднали
  • *****
  • Публикации: 1089
  • Distribution: Mageia
    • Профил
Здравейте! Имам юесби уебкамера x-eye /по принцип работи с драйвър gspcav1 под линукс/ и тв тунер Zoltrix Genie TV - разпознаван и работещ досега като bt878 Genie TV/F .Наскоро ми гръмна компютъра и се наложи да поъпгрейдна някои неща- в момента машината е Семпрон 2800+, работещ на 1600 мхз, 768 рам ддр1- 400 мхз, два ИДЕ харддиска - макстор 40 гб и хитачи 80 гб, дъното е K&N с чипсет нвидия. Значи, на предишния компютър- анд дюрон 1100 мхз, дъно гигабайт - чипсет Виа- и камерата, и тунера със същата мандрива 2008.1 си работеха. А сега- камерата просто я няма. Значи, имам си /dev/video0- тунера- i /dev/video1 - камерата. Само че- скайп например- както и ekiga- откриват само тунера- /dev/video0. Ето modprobe.conf :
alias eth0 forcedeth
alias sound-slot-0 snd_intel8x0
install scsi_hostadapter /sbin/modprobe sata_nv; /bin/true
install usb-interface /sbin/modprobe ehci_hcd; /sbin/modprobe ohci_hcd; /bin/true
install ide-controller /sbin/modprobe amd74xx; /bin/true
remove snd_intel8x0 /sbin/modprobe --first-time -r --ignore-remove snd_intel8x0
install snd_intel8x0 /sbin/modprobe --first-time --ignore-install snd_intel8x0
alias pci:v000010DEd000000DFsv00001043sd000080A7bc06sc80i00 forcedeth

options bttv card=46 video_nr=0 radio=0 gbuffers=4
options sn9c102 video_nr=1

мених местата на камерата и тв- бях сложил камерата /sn9c102/ video_nr=0 а за тунера 1- и все-тая. инсталирал съм dkms-gspcav1 от мирърите на мандрива- преди си работеше с него.
ето и изхода от lsusb
[root@mandriva ~]# lsusb
Bus 001 Device 001: ID 0000:0000  
Bus 003 Device 003: ID 0c45:6029 Microdia Triplex i-mini PC Camera
Bus 003 Device 002: ID 043d:0078 Lexmark International, Inc.
Bus 003 Device 001: ID 0000:0000  
Bus 002 Device 001: ID 0000:0000  
и от lsmod /пействам само редовете касаещи камерата и тунера, че да не правя прекалено голям поста/ :
sn9c102               122276  0
k8temp                  5120  0
compat_ioctl32          1920  2 bttv,sn9c102
videodev               27104  3 gspca,bttv,sn9c102
shpchp                 29940  0
v4l1_compat            14340  2 bttv,videodev
pci_hotplug            26048  1 shpchp
v4l2_common            16128  4 tuner,bttv,sn9c102,videodev
ir_common              31172  1 bttv
videobuf_core          15460  2 bttv,videobuf_dma_sg
parport                31592  1 parport_pc
btcx_risc               4808  1 bttv
tveeprom               14928  1 bttv
tea5767                 5892  1 tuner
tda8290                11108  1 tuner
tuner_simple            8840  1 tuner
mt20xx                 11784  1 tuner
tea5761                 5156  1 tuner
snd_mpu401              7176  0
bttv                  165044  1 bt878

по принцип модула за камерата е gspca
Но в момента скайпа и екига намират като видеоустройство само тунера. Някакви идеи как да подкарам камерата? Благодаря предварително.

Едит: И след това:
[root@mandriva ~]# modprobe gspca
[root@mandriva ~]# lsmod | grep gspca
gspca                 676048  0
videodev               27104  3 gspca,bttv,sn9c102
usbcore               121932  8 usb_storage,gspca,sn9c102,usblp,uhci_hcd,ohci_hcd,ehci_hcd
[root@mandriva ~]#
 пак е все-същото- за скайпа и екига камерата я няма. А в /dev ги има и двете:
[root@mandriva dev]# ls | grep video
video@
video0
video1
[root@mandriva dev]#

Системата е Мандрива 2008.1, Гноме2.22 kernel- 2.6.24.5-desktop-2mnb #1 SMP Thu Jun 12 14:37:30 EDT 2008 i686 AMD Sempron™ Processor 2800+ GNU/Linux



Активен

"-Аз съм орех и приличам на мозък!" "-Аз съм карфиол и приличам на дърво!" "-А аз съм гъба и мразя тази игра.. "

eka

  • Напреднали
  • *****
  • Публикации: 136
    • Профил
Проблем с тв тунер и уебкамера
« Отговор #1 -: Jul 01, 2008, 20:01 »
Включваш камерата и рестартираш Скайпа.Понякога така става.И трябва да си с версия над 2.х.х.За камерата има и други програми които да ти покажат дали работи.Пишеш "сам" в софтуерния мениджър.
Активен

Duron 1050-Mandriva 2010.2;Asus F5N Turion64 1800-Mandriva 2010.2
KDE 4.5.5

Nik123

  • Напреднали
  • *****
  • Публикации: 1089
  • Distribution: Mageia
    • Профил
Проблем с тв тунер и уебкамера
« Отговор #2 -: Jul 02, 2008, 18:10 »
Камерата изобщо не се изключва от юесби-то. Пробвах-маха, слагах кабели- тц. А това да пиша "сам" в софтуерния мениджър- не го разбрах, съжалявам...  Интересното е, че със същата мандрива 2008.1 - само че с процесор Дюрон 1100 мхз и дъно гигабайт с чипсет Виа нямаше такива проблеми
Активен

"-Аз съм орех и приличам на мозък!" "-Аз съм карфиол и приличам на дърво!" "-А аз съм гъба и мразя тази игра.. "

Nik123

  • Напреднали
  • *****
  • Публикации: 1089
  • Distribution: Mageia
    • Профил
Проблем с тв тунер и уебкамера
« Отговор #3 -: Jul 03, 2008, 21:17 »
Опитах и директно със сорса, свален оттук
- и пак същото- нико екига, нито скайпа я намират тая камера- а си има /dev/video0 /камерата/ и /dev/video1 /тунера/ - а скайпа и екига "виждат" само тунера.
Някой да помогне?
Активен

"-Аз съм орех и приличам на мозък!" "-Аз съм карфиол и приличам на дърво!" "-А аз съм гъба и мразя тази игра.. "

komatevo

  • Новаци
  • *
  • Публикации: 1
    • Профил
Re: Проблем с тв тунер и уебкамера
« Отговор #4 -: Dec 01, 2008, 15:36 »
Ники първо виж дали имаш инсталиран libv4l ако не го инсталирай и след това  копирай това и  го постави в терминал

 LD_PRELOAD=/usr/lib/libv4l/v4l2convert.so skype LD_PRELOAD = usr/lib/libv4l/v4l2convert.so Skype
Активен

Nik123

  • Напреднали
  • *****
  • Публикации: 1089
  • Distribution: Mageia
    • Профил
Re: Проблем с тв тунер и уебкамера
« Отговор #5 -: Dec 08, 2008, 01:47 »
мерси, макар че отдавна оправих проблема- с новата мандрива 2009 си върви всичко ок
Активен

"-Аз съм орех и приличам на мозък!" "-Аз съм карфиол и приличам на дърво!" "-А аз съм гъба и мразя тази игра.. "