Автор Тема: Направо...снимков ма'трял :(  (Прочетена 3024 пъти)

Acidtrance

  • Напреднали
  • *****
  • Публикации: 65
    • Профил
Привет.

Проблема е следния: графичната среда (ГНОМ, КДЕ, ЕксФейс, няма-значение-какво), е отвратително бавна на лаптопа ми. Всичко се изобразява със скоростта на охлюв. Особено, ако пусна и FF, положението е трагично. Цялата система е ЛАГАВА (графична среда). Инсталирал съм последните драйвери за видео-то.

Системата е следната:

Лаптоп Compaq Presario CQ61-125EQ,
OS: Fedora Core 14 (i386),
CPU: Intel Core2Duo - 2GHz (T6400)
Video: nVidia GeForce G 103M
Video Driver version: 260.19.12
GUI: GNOME 2.23.0

Xorg.conf: http://pastebin.ca/1996972
lspci: http://pastebin.ca/1996974

Изход от lsmod за nvidia:

[atan@ariel ~]$ lsmod | grep nv
nvidia               9317956  31
snd_hda_codec_nvhdmi    11784  1
snd_hda_codec          71701  3 snd_hda_codec_nvhdmi,snd_hda_codec_idt,snd_hda_intel
snd                    47357  16 snd_hda_codec_nvhdmi,snd_hda_codec_idt,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_seq,snd_seq_device,snd_pcm,snd_timer
i2c_core               21328  3 nvidia,i2c_i801,videodev
[atan@ariel ~]$

Просто е ужасно да се работи в такава графична среда. Някой има ли идея/предложение, как това нещо да "лети", както и би трябвало?

Благодаря.
Активен

Златко

  • Напреднали
  • *****
  • Публикации: 2147
    • Профил
Re: Направо...снимков ма'трял :(
« Отговор #1 -: Nov 20, 2010, 13:19 »
Ами занеси си лаптопа на ОпенФест и помоли някой да ти помогне.  ;)
Активен

Без правила няма игра

b2l

  • Напреднали
  • *****
  • Публикации: 4786
  • Distribution: MCC Interim
  • Window Manager: - // - // -
  • ...sometimes I feel like screaming... || RTFM!
    • Профил
    • WWW
Re: Направо...снимков ма'трял :(
« Отговор #2 -: Nov 20, 2010, 13:27 »
Ами занеси си лаптопа на ОпенФест и помоли някой да ти помогне.  ;)

Съмнявам се - това обикновенно се прави на Install fest-овете.
Активен

"Човекът е въже, опънато между звяра и свръхчовека, въже над пропаст. Човекът е нещо, което трябва да бъде превъзмогнато." - Фр. Ницше

Златко

  • Напреднали
  • *****
  • Публикации: 2147
    • Профил
Re: Направо...снимков ма'трял :(
« Отговор #3 -: Nov 20, 2010, 13:42 »
Съмнявам се - това обикновенно се прави на Install fest-овете.

Е, може да има някой отегчен и скучаещ хакер, знам ли.  ^-^
Активен

Без правила няма игра

spec1

  • Напреднали
  • *****
  • Публикации: 230
    • Профил
Re: Направо...снимков ма'трял :(
« Отговор #4 -: Nov 20, 2010, 16:01 »
Поне ни дай резултата от:
top
Активен

Acidtrance

  • Напреднали
  • *****
  • Публикации: 65
    • Профил
Re: Направо...снимков ма'трял :(
« Отговор #5 -: Nov 20, 2010, 18:18 »
Ами занеси си лаптопа на ОпенФест и помоли някой да ти помогне.  ;)

Благодаря за съвета. Няма да стане. Попитах, ако някой има идея, предложение или нещо от сорта. Безсмислени идеи мога да генерирам сам и на рандъм принцип ;–) Не го приемай като заяждане.

За top output-a -- няма товарене на процесор/памет. Интересно наблюдение констатирах. С КДЕ мизерията я изчезна след подновяване на драйвера. Което разбира се не афектира в GTK средата. Което ме навежда на една много неприятна мисъл.
Активен

trosho

  • Напреднали
  • *****
  • Публикации: 321
    • Профил
Re: Направо...снимков ма'трял :(
« Отговор #6 -: Nov 20, 2010, 18:37 »
От къде си гледал, за да сглобиш този Xorg.conf? Тук има един почти като твоя - цък.
Само че там версията на драйвера е друга, а вероятно и версията на Xorg, та не знам дали е добра идея да се копират директно тези опции.

Вижда се, че в твоя xorg.conf е забранен AIGLX (Option "AIGLX"   "False"). Защо е нужно това, какъв проблем ти решава?
Редът за Modeline е изкопиран директно. Ако си имал проблем с установяването на резолюцията, не е ли по-добре да си генерираш сам подходящия Modeline? Ето как става с помощта на xresprobe, ddcprobe и cvt - цък (написаното е за Ubuntu 9.10, но ако във Fedora ги има тези пакети, би трябвало да работи и там).

Аз бих опитал да стартирам без xorg.conf и ако има проблем, тогава да генерирам нов и в него да добавям една по една опции, които знам какво правят.
Активен

Acidtrance

  • Напреднали
  • *****
  • Публикации: 65
    • Профил
Re: Направо...снимков ма'трял :(
« Отговор #7 -: Nov 20, 2010, 19:03 »
От къде си гледал, за да сглобиш този Xorg.conf? Тук има един почти като твоя - цък.
Само че там версията на драйвера е друга, а вероятно и версията на Xorg, та не знам дали е добра идея да се копират директно тези опции.

Вижда се, че в твоя xorg.conf е забранен AIGLX (Option "AIGLX"   "False"). Защо е нужно това, какъв проблем ти решава?
Редът за Modeline е изкопиран директно. Ако си имал проблем с установяването на резолюцията, не е ли по-добре да си генерираш сам подходящия Modeline? Ето как става с помощта на xresprobe, ddcprobe и cvt - цък (написаното е за Ubuntu 9.10, но ако във Fedora ги има тези пакети, би трябвало да работи и там).

Аз бих опитал да стартирам без xorg.conf и ако има проблем, тогава да генерирам нов и в него да добавям една по една опции, които знам какво правят.

Благодарско за поста. Да, точно от тук е копирано. Защо е копирано....да обясня.

Не знам точно какъв е дерта на мойта карта с тези драйвери (по подразбиране с празен Xorg.conf тръгва ... ). Проблема започва, след като сложа nv или nvidia за драйвер. Дисплея тотално полудява тогава -- екрана ми се разделя на 6 (шест) части -> 3x2 реда и реално имам 6 десктопа на един екран...неизползваемо. Това, което ползвам, като Xorg.conf е доста изрязания пост от форума, който посочи. Пробвал съм да махам различните настройки, както и да ги променям, но и при най-малката промяна дисплея гърми (горния резултат). Работи единствено с тази конфигурация.
Активен

trosho

  • Напреднали
  • *****
  • Публикации: 321
    • Профил
Re: Направо...снимков ма'трял :(
« Отговор #8 -: Nov 20, 2010, 20:40 »
Ясно.

Не знам какво друго да предложа, освен да видиш написаното тук - цък, и да опиташ с добавяне (в наново генериран xorg.conf) само на предложената там опция - Option "ModeValidation" "NoTotalSizeCheck"  (не я виждам в текущия xorg.conf). Дано да подейства.
Можеш и да пробваш по-новата версия на драйвъра. На сайта на NVidia виждам, че има драйвър с версия 260.1921 (от 11 ноември), който е "NVIDIA Recommended". Ако проблемът се дължи на някакъв бъг, може да са го оправили.
Активен

Acidtrance

  • Напреднали
  • *****
  • Публикации: 65
    • Профил
Re: Направо...снимков ма'трял :(
« Отговор #9 -: Nov 20, 2010, 21:01 »
Благодаря ти. Не ги бях видял тези опции до сега. Ще пробвам.
Активен

Acidtrance

  • Напреднали
  • *****
  • Публикации: 65
    • Профил
Re: Направо...снимков ма'трял :(
« Отговор #10 -: Nov 23, 2010, 13:58 »
Trosho, благодарско за връзката към онзи пост. Изтрих целия Xorg.conf, генерирах го наново и единственото, което добавих, бе опцията, която ми даде. Друго, което нарпавих беше да разкарам nspluginwrapper, който ненужно товари за i386. В момента е пушка отвсякъде.

Поздрави.
Активен