Автор Тема: Wine наxorg.conf ubuntu 6.10  (Прочетена 1619 пъти)

bashi1

  • Напреднали
  • *****
  • Публикации: 115
    • Профил
Wine наxorg.conf ubuntu 6.10
« -: Jun 11, 2007, 22:00 »
Здравейте всички! Проблемът ми е следният: искам да си инсталирам една програма, която е в ехе файл. При опит да конфигурерам вине ми дава грешки:
Примерен код
bashi@26:~$ sudo wine /media/cdrom0/SETUP.EXE
Password:
Application tried to create a window, but no driver could be loaded.
The X11 driver is missing.  Check your build!
fixme:bitmap:SetDIBits shouldn't require a DC for DIB_RGB_COLORS
Application tried to create a window, but no driver could be loaded.
The X11 driver is missing.  Check your build!
bashi@26:~$  winecfg
err:imagelist:ImageList_ReplaceIcon no color!
err:imagelist:ImageList_ReplaceIcon no color!
err:imagelist:ImageList_ReplaceIcon no color!
err:imagelist:ImageList_ReplaceIcon no color!
Application tried to create a window, but no driver could be loaded.
The X11 driver is missing.  Check your build!
Application tried to create a window, but no driver could be loaded.
The X11 driver is missing.  Check your build!
В същото време уж имам инсталиран драйвер за видеокартата. Ето и xorg.conf за всеки случаи
Примерен код
# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 1.0  (buildmeister@builder3)  Mon Feb 26 23:39:38 PST 2007

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    Screen      1  "Screen1" RightOf "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
    RgbPath         "/usr/lib/X11/rgb"
EndSection

Section "Module"
    Load           "dbe"
    Load           "extmod"
    Load           "type1"
    Load           "freetype"
    Load           "glx"
EndSection

Section "ServerFlags"
    Option         "Xinerama" "0"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    # HorizSync source: xconfig, VertRefresh source: xconfig
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "CRT-0"
    HorizSync       28.0 - 204.0
    VertRefresh     43.0 - 60.0
    Option         "DPMS"
EndSection

Section "Monitor"
    # HorizSync source: xconfig, VertRefresh source: xconfig
    Identifier     "Monitor1"
    VendorName     "Unknown"
    ModelName      "TV-0"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Videocard0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce FX 5500"
    BusID          "PCI:1:0:0"
    Screen          0
EndSection

Section "Device"
    Identifier     "Videocard1"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce FX 5500"
    BusID          "PCI:1:0:0"
    Screen          1
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Videocard0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "metamodes" "CRT: 1440x900 +0+0; CRT: 1024x768 +0+0; CRT: 800x600 +0+0; CRT: 640x480 +0+0"
    SubSection     "Display"
        Depth       24
        Modes      "1600x1200" "1280x1024" "1024x768" "800x600" "640x480"
    EndSubSection
EndSection

Section "Screen"
    Identifier     "Screen1"
    Device         "Videocard1"
    Monitor        "Monitor1"
    DefaultDepth    16
    Option         "metamodes" "TV: nvidia-auto-select +0+0"
    SubSection     "Display"
        Depth       16
        Modes      "1600x1200" "1280x1024" "1024x768" "800x600" "640x480"
    EndSubSection
EndSection

От какво може да е този проблем и как може да го оправя? Предварително благодаря!
Активен

arghoslent

  • Напреднали
  • *****
  • Публикации: 41
    • Профил
Wine наxorg.conf ubuntu 6.10
« Отговор #1 -: Jun 11, 2007, 22:32 »
Пробай да инсталираш пакета libxxf86dga1
Активен

Clarity of thought before rashness of action.

mimosh

  • Напреднали
  • *****
  • Публикации: 310
  • Distribution: Kubuntu
  • Window Manager: KDE
    • Профил
Wine наxorg.conf ubuntu 6.10
« Отговор #2 -: Jun 12, 2007, 12:20 »
А защо се опитваш да инсталираш програмата като руут?
просто пишеш това:
Цитат
wine /media/cdrom0/SETUP.EXE
Активен

bashi1

  • Напреднали
  • *****
  • Публикации: 115
    • Профил
Wine наxorg.conf ubuntu 6.10
« Отговор #3 -: Jun 12, 2007, 17:22 »
Пробвах и двата метода резултатът е същият  '<img'>
Активен

Gaara

  • Напреднали
  • *****
  • Публикации: 631
  • Distribution: Debian
  • Window Manager: E17
    • Профил
Wine наxorg.conf ubuntu 6.10
« Отговор #4 -: Jun 12, 2007, 18:05 »
Инсталирай си dev пакета за Х-а.
Активен

Last night, Darth Vader came down from planet Vulcan and told me that if you don't install Debian, he'd melt your brain.

Подобни теми
Заглавие Започната от Отговора Прегледи Последна публикация
Проблем с Xorg.conf
Настройка на хардуер
pe6ohh 6 2395 Последна публикация Sep 29, 2004, 08:54
от pe6ohh
Съвместимост на xorg.conf?
Настройка на програми
abscent 0 934 Последна публикация Jan 17, 2005, 15:49
от abscent
xorg.conf Редактиране
Настройка на хардуер
3viltux 8 3712 Последна публикация May 22, 2006, 04:26
от
xorg.conf
Настройка на програми
lamby 5 1804 Последна публикация Jun 25, 2005, 11:54
от lamby
xorg.conf в ubuntu
Настройка на програми
ilian_BIOS 2 1872 Последна публикация Apr 12, 2009, 17:06
от Goust