Автор Тема: gentoo + qt + i18n  (Прочетена 1044 пъти)

todorb

  • Участници
  • ***
  • Публикации: 3
    • Профил
gentoo + qt + i18n
« -: Feb 26, 2004, 14:59 »
значи проблемът е следния:

имам едно gentoo инсталирано и всичко е на 6, с изключение на това, че всички програми, които ползват qt не искат да се покажат на език, различен от английски. LANG променливата е сетната и всички други програми с превод като mc, xmms, gqview си работят на български. само които ползват qt не искат. проблемът си е налице още от както инсталирах gentoo-то.

някой има ли идея какво не е наред или поне има ли хора с gentoo, които нямат този проблем?
Активен

  • Гост
gentoo + qt + i18n
« Отговор #1 -: Feb 26, 2004, 16:33 »
Като гледам какво пишеш най-вероятно не си инсталирал преводите. :-)

Пробвай да инсталираш някакъв файл подобен на kde-i18n-bg-3.2.0...

Ако става въпрос за Qt програми, те може да нямат превод или да не е инсталиран.

Българският превод на КДЕ 3.1 беше счупен (КДЕ не работеше с него, просто крашеше). Поради тази причина някои дистрибуции не го включваха в инсталациите си. И сега по навик може и да не го включват с КДЕ 3.2.
Активен

Regia

  • Напреднали
  • *****
  • Публикации: 293
  • Distribution: Tilix
  • Window Manager: KDE
    • Профил
    • WWW
gentoo + qt + i18n
« Отговор #2 -: Feb 26, 2004, 16:47 »
Странно.
Тиликс 0.2 си е наред с превода на KDE 3.1.3
Активен

kolio_kolev

  • Напреднали
  • *****
  • Публикации: 356
  • Distribution: Mandriva 2011, Mandriva Cooker
  • Window Manager: KDE 4.6.x
    • Профил
    • WWW
gentoo + qt + i18n
« Отговор #3 -: Feb 26, 2004, 18:06 »
От KDE Control Center пробвай да избереш за език Bulgarian ...


Кольо Колев
Активен

Кольо Колев
Mandriva BG: http://mandriva.biotronica.net
Bitronica.Net форуми: http://forum.biotronica.net

ray

  • Напреднали
  • *****
  • Публикации: 1254
    • Профил
gentoo + qt + i18n
« Отговор #4 -: Feb 26, 2004, 19:50 »
Здравейте,
При мен всичко работи на 6.
Още при инсталацията зададох - dokeymap и после задавате БГ.
След това инсталирах BGLinux v.5.1 и после всичко си работеше.
Мисля че съм с UTF-8 кодиране.
Успех.
Румен.
Активен

todorb

  • Участници
  • ***
  • Публикации: 3
    • Профил
gentoo + qt + i18n
« Отговор #5 -: Feb 28, 2004, 17:26 »
благодаря за мненията дотук, но от тях не ми олеква много.

значи малко разяснения:

ясно ми е, че ако няма инсталиран превод не мога да чакам нещо да се преведе. имаим работеща кирилица и преводи навсякъде, включително конзолата, но не в програмите, които ползват qt за GUI.

примерно имам файл /usr/share/locale/bg/LC_MESSAGES/sim.mo, но sim-а не излиза преведен (sim-icq.sf.net). под виндовс ми е преведен и под другите линукси.

има файл /usr/share/locale/bg/LC_MESSAGES/xmms.mo и xmms-а си е преведен.

проблемът е конкретно в библиотеката qt доколкото мога да заключа.

ray, казваш, че при теб всичко е наред. кажи си ако обичаш USE флаговете и CFLAGS. аз съм с

USE="acpi gtk2 imap mozilla pic samba sasl -oss -encode -gnome -mikmod -svga -gtk"

CFLAGS="-march=pentium2 -O2 -mmmx -frename-registers -pipe"

всички пакети са немаскирани.
Активен

Подобни теми
Заглавие Започната от Отговора Прегледи Последна публикация
Gentoo
Настройка на програми
BladeNet 6 2590 Последна публикация Jun 14, 2011, 09:55
от bazu
GENTOO HELP
Настройка на програми
fubar 2 1733 Последна публикация Dec 27, 2003, 08:13
от
Gentoo + графичен инсталатор
Коментар
residentx 7 2888 Последна публикация Feb 08, 2005, 13:01
от
Gentoo...?
Настройка на хардуер
grey 3 2017 Последна публикация Apr 08, 2004, 19:46
от ray
Проблеми при инсталирането на kde-i18n-bg
Настройка на програми
enlove 8 1409 Последна публикация Feb 15, 2007, 10:34
от aaaaaa