Автор Тема: Не ми работи kbd в kde  (Прочетена 1193 пъти)

Nilak

  • Участници
  • ***
  • Публикации: 5
    • Профил
Не ми работи kbd в kde
« -: Apr 13, 2006, 10:05 »
SuSE10, допреди няколко дена работеше, сега на лог-ин екрана (KDE) не мога да пиша ни един символ, мишката работи, Alt+F2 работи и там в конзолата също, но в КДЕ не ще...
Дайте идеи, моля!
Активен

  • Гост
Не ми работи kbd в kde
« Отговор #1 -: Apr 13, 2006, 11:54 »
То това от самосебе си няма как да се е саморазвалило :))
Много е верятно като си си играл с настройките на kdm (Control Panel -> Login Manager) и да си му задал на Echo Mode да няма echo като си пишеш паролата.
Пробвай все пак да си напишеш паролата и да се логнеш.
За справка си погледни kdmrc файла и виж какво е зададено на EchoMode, по подразбиране трябва да е EchoMode=OneStar, ако твоето е NoEcho, това ще да ти е проблема.
Активен

Nilak

  • Участници
  • ***
  • Публикации: 5
    • Профил
Не ми работи kbd в kde
« Отговор #2 -: Apr 13, 2006, 13:35 »
В никой от 3-те файла kdmrc (/etc/opt/kde3/...
/opt/kde3/share/config/SuSE/...) не е зададено такова нещо.
Ако беше това проблемът щеше да може да се пише поне в полето за потребител, а то и там не може, нито клавиша [Enter] работи.
Активен

rat

  • Напреднали
  • *****
  • Публикации: 266
    • Профил
Не ми работи kbd в kde
« Отговор #3 -: Apr 13, 2006, 14:44 »
Пипайки по настройките в конрол центъра не пипаш по глобалните конфиг файлове, а по тези в .kde

В пристъп на отчаяние '<img'> можеш да направиш това :
mv .kde .kde_old
и рестартирай KDE.
Полсе можеш да си върнеш старат директория ако не е от това.

Nilak

  • Участници
  • ***
  • Публикации: 5
    • Профил
Не ми работи kbd в kde
« Отговор #4 -: Apr 13, 2006, 16:32 »
и отчаянието не помага  '<img'>
други предложения?
Активен

  • Гост
Не ми работи kbd в kde
« Отговор #5 -: Apr 13, 2006, 22:24 »
Когато се пипат настройките в Control Center -> System Administration -> Login Manager, трябва да си в Administrator Mode (т.е. да си root) и настройките се отразяват в глобалния kdmrc файл. Нямам представа в Suse къде се намира този файл, но това не е от голямо значение.
Предлагам ти да превключиш в някоя конзола, да се логнеш като root, да спреш kdm (killall -9 kdm) и след това да си стартираш X-a ръчно (startx). Ако не ти е зададено по подразбиране да ти се стартира KDE, то ще ти се стартира default window managera-a, на X-a и в него ще имаш един xterminal, в който може да напишеш startkde (ако имаш само черен екран с X за мишка, кликни с левия бутон и задръж, ще ти се покаже меню от което може да избереш да стартираш terminal).
Оправи си настройките в Contрол Center-a, излез от X-a, стартирай наново kdm (kdm &) и пробвай дали всичко е наред.
Активен

Nilak

  • Участници
  • ***
  • Публикации: 5
    • Профил
Не ми работи kbd в kde
« Отговор #6 -: Apr 14, 2006, 11:02 »
В ControlCenter-а като задам EnableKeyboardLayouts и долу на таск-бара се появява индикатор на който пише ERR и надписа гласи: "Error changing keyboard layouts to 'us' ", съответно ако оставая само BG, грешката е за 'bg'...
Оставих само 'us'-тогава грешки няма, след стартиране на >kdm & има пак същия ефект. След рестарт - пак няма kbd.
Активен

  • Гост
Не ми работи kbd в kde
« Отговор #7 -: Apr 14, 2006, 12:24 »
Хмм, изглежда проблема е по-сериозен.
Поразрових се из форумите тук там за подобни проблеми.
Много сходен проблем (грешка в клавиатурната подредба) се е обсъждал подробно в

http://lists.debian.org/debian-qt-kde/2005/01/msg00154.html

Там след дълго пробване се оказало, че проблема е, че не може да бъде създаден файла us_intl.xkm и виновника за това бил X11.
Та съветът е бил да се ъпгрейдне Х сървъра.
Аз все пак бих ти предложил първо да преинсталираш kdebase (или ако имаш kdm на отделен пакет ... не съм запознат със Suse) и да видиш дали това няма да оправи нещатата при теб, защото ти имаш проблем и с KDM и случая ти е малко по-различен. Все пак може да ти се наложи да ъпгрейднеш/преинсталираш и xorg-a ... знам ли.

Успех!
Активен

Nilak

  • Участници
  • ***
  • Публикации: 5
    • Профил
Не ми работи kbd в kde
« Отговор #8 -: Apr 17, 2006, 12:16 »
Решението на проблема е:
в секцията (на /etc/X11/xorg.conf)=>
Цитат

Section "ServerLayout"
  Identifier  "Layout[all]"
  InputDevice  "Keyboard[2]" "CoreKeyboard"
  InputDevice  "Mouse[1]" "CorePointer"
  InputDevice  "Mouse[3]" "SendCoreEvents"
  Option      "Clone" "off"
  Option      "Xinerama" "off"
  Screen      "Screen[0]"
EndSection

се редактира  
Цитат
InputDevice  "Keyboard[2]" "CoreKeyboard"

и се заменя с
Цитат
InputDevice  "Keyboard[0]" "CoreKeyboard"

И вече работи клавиатурата. Как се е сменило не знам-не съм пипал този конфигурационен файл, явно става при някаква ситуация на настройка или и аз не знам какво...
Благодаря за помощта!



Активен