Автор Тема: bash is needed ???  (Прочетена 2351 пъти)

Warstomp

  • Напреднали
  • *****
  • Публикации: 344
  • Distribution: Debian, Ubuntu
    • Профил
bash is needed ???
« -: Feb 16, 2004, 20:44 »
Защо като се опитам да инсталирам някои пакети ми дава това:
 
 #rpm -ivh pysol-4.82-1mdk.i586.rpm
error: Failed dependencies:
 bash is needed by pysol-4.82-1mdk
 
Това се случва и с някои други пакети,но не всички.От конзолата и от rpmdrake е все едно и също.С Mandrake 9.2 съм.
Активен

LinuxFanUNIX

  • Напреднали
  • *****
  • Публикации: 408
  • Distribution: Slackware 12.2
  • Window Manager: KDE 3.5.10
    • Профил
Re: bash is needed ???
« Отговор #1 -: Aug 20, 2010, 20:07 »
Код
GeSHi (Bash):
  1. if [! -x /bin/sh] ; then ln -s /bin/sh /bin/bash ; fi
Активен

romeo_ninov

  • Напреднали
  • *****
  • Публикации: 2155
    • Профил
Re: bash is needed ???
« Отговор #2 -: Aug 20, 2010, 23:48 »
Код
GeSHi (Bash):
  1. if [! -x /bin/sh] ; then ln -s /bin/sh /bin/bash ; fi
в слакуер можете да си правите щуротии, но тук не е това случая

Защо като се опитам да инсталирам някои пакети ми дава това:
 
 #rpm -ivh pysol-4.82-1mdk.i586.rpm
error: Failed dependencies:
 bash is needed by pysol-4.82-1mdk
 
Това се случва и с някои други пакети,но не всички.От конзолата и от rpmdrake е все едно и също.С Mandrake 9.2 съм.
rpm -i bash.......
Активен

0x2B|~0x2B

VladSun

  • Напреднали
  • *****
  • Публикации: 2166
    • Профил
Re: bash is needed ???
« Отговор #3 -: Aug 21, 2010, 09:16 »
Пренебрегвайки опита за флейм, искам да попитам - що за пакетна система е тази, при която трябва да правиш ръчни *щуротии* за решаване на зависимости?
Активен

KISS Principle ( Keep-It-Short-and-Simple )
http://openfmi.net/projects/flattc/
Има 10 вида хора на този свят - разбиращи двоичния код и тези, които не го разбират :P

gat3way

  • Напреднали
  • *****
  • Публикации: 6050
  • Relentless troll
    • Профил
    • WWW
Re: bash is needed ???
« Отговор #4 -: Aug 21, 2010, 11:35 »
Не се налага според мен - просто трябва да се инсталира съответния пакет. rpm в това отношение се държи като dpkg - няма да отиде и да ги издърпа вместо теб. В redhat-ските системи това го прави yum, в debian - apt-get/aptitude, в mandriva не знам. После, няма идеална система за решаване на зависимости - в повечето случаи трябва силно да разчиташ на тези дето са пакетирали софтуера. Решението със симлинка е хакерия и въпреки че ще сработи, нещата не трябва да се правят така. Ако тръгнеш да си решаваш проблемите по този начин и накрая системата заприличва на някоя картинка от redneck repairs.
Активен

"Knowledge is power" - France is Bacon

aaaaaa

  • Напреднали
  • *****
  • Публикации: 971
    • Профил
Re: bash is needed ???
« Отговор #5 -: Aug 21, 2010, 15:15 »
Темата не е ли то 2004 г?
Активен

...to boldly go where no one has gone before...

Acho

  • Напреднали
  • *****
  • Публикации: 3646
  • Distribution: Slackware, MikroTik - сървърно
  • Window Manager: console only
    • Профил
    • WWW
Re: bash is needed ???
« Отговор #6 -: Aug 21, 2010, 15:25 »
Хахахахаааааааааа, ами оттогава е. Ама LinuxFanUNIX я е изнамерил отнякъде и дискусията почна.
Активен

CPU - Intel Quad-Core Q8400, 2.66 GHz; Fan - Intel Box; MB - Intel G41M-T2; RAM - DDR2-800, Kingston HyperX, 2X2048 MB; VC - onboard, Intel G41 Express Chipset; HDD - SeaGate, 160 GB, SATAII; SB - Realtek HD Audio; DVD-RW - TSSTcorp DVD-RW; LAN - Realtek PCI-E GBE Controller; PSU - Fortron 350 Watt.

VladSun

  • Напреднали
  • *****
  • Публикации: 2166
    • Профил
Re: bash is needed ???
« Отговор #7 -: Aug 22, 2010, 02:46 »
Не се налага според мен - просто трябва да се инсталира съответния пакет. rpm в това отношение се държи като dpkg - няма да отиде и да ги издърпа вместо теб. В redhat-ските системи това го прави yum, в debian - apt-get/aptitude, в mandriva не знам. После, няма идеална система за решаване на зависимости - в повечето случаи трябва силно да разчиташ на тези дето са пакетирали софтуера. Решението със симлинка е хакерия и въпреки че ще сработи, нещата не трябва да се правят така. Ако тръгнеш да си решаваш проблемите по този начин и накрая системата заприличва на някоя картинка от redneck repairs.

Хм ... щом рамката налагана от пакетната система не предоставя достатъчно задължения към разработчика защо да я ползвам? Нали това е основната идея?!? 
Активен

KISS Principle ( Keep-It-Short-and-Simple )
http://openfmi.net/projects/flattc/
Има 10 вида хора на този свят - разбиращи двоичния код и тези, които не го разбират :P

Подобни теми
Заглавие Започната от Отговора Прегледи Последна публикация
Programmer needed
Търсене
lukam 0 1750 Последна публикация May 07, 2003, 21:45
от lukam
Идеи needed
Живота, вселената и някакви други глупости
zeridon 6 2062 Последна публикация Oct 19, 2004, 16:40
от zeridon
BASH: Как да поддържам една програма работеща
Общ форум
Regia 1 7534 Последна публикация Feb 16, 2005, 08:51
от
bash
Настройка на програми
tuxi 7 2828 Последна публикация Jun 11, 2005, 19:12
от tuxi
Ajax/php freelancer needed
Търсене
walktec 0 1643 Последна публикация Feb 20, 2007, 23:31
от walktec