Автор Тема: Проблем с latex  (Прочетена 2597 пъти)

kill_u

  • Напреднали
  • *****
  • Публикации: 1058
  • Distribution: Ubuntu 9.10
  • Window Manager: Gnome
  • Out of here....
    • Профил
    • WWW
Проблем с latex
« -: Feb 12, 2008, 22:52 »
Здравейте, не знам дали за този раздел е това питане но мисля че проблема е за тук.
Значи мой роднина реши да публикува статия в американски  електронен журнал. Проблема възникна обаче когато поискаха статията и се оказа, че трябва да е в ТЕХ файл. До тогава не бях чувал за ЛаТеК но само мога да съжалявам за това. Оказа се, че това е превъзходно средство за писане на формули(математически, физични, химични и статистически). Успях да разуча основните правила и направих статията без проблеми, като при това успях да науча и как се вмъкват графики. До тук всичко добре моя ентусиазъм и този на моя роднина ми дадоха възможност да се регистрираме в сайта и да изпратим съответната статия. Оказа се, че веднага получихме следния е-мейл:
Примерен код
Dear Author,
 
Thank you for submitting your paper to EJS. However we can
not create the PDF file from the received source files.
Could you please check if you have added the correct TEX
file to the ZIP archive you have uploaded to the system (the
compiler stops because of the errors in TEX file).
 
If you have any questions, please do not hesitate to contact me.
 
 
Best regards,
 
Ieva Spudulyte (on behalf of Ina Talandiene, EJS admin,
during her vacation)

Това страшно ме озадачи въпреки, че самото изпращане та ТЕХ файлове от самото начало ми навя мисли за различни компилатори, как и къде работят и тем подобни. Оказа се, че мадамата от щатите не може да компилира моя ТЕХ файл независимо от това, че съм и пратил всичките файлове. При мен си ги компилирам в PDF и DVI без проблеми но там явно системата е друга. Прочетох пак страницата им и се оказа, че файловете се "processed with the hyperref package".
Сега моля присъстващите тук да ми обяснят каква е разликата между това да компилираш с pdflatex и този пакет.

Благодаря предварително!!!



Активен

Всеки пост - отговор на въпрос!!!
Gnu/Linux user 411527

Nikolavp

  • Напреднали
  • *****
  • Публикации: 408
    • Профил
    • WWW
Проблем с latex
« Отговор #1 -: Feb 12, 2008, 23:37 »
Прати пак архива. Не би трябвало да има някаква разлика в различните компилатори особено за неспецифичен документ, какъвто е статията. Попитай за грешка от тяхна страна и виж кои пакети си ползвал в статията(може при тях нещо да липсва)

\usepackage{packagename}

hyperref е точно пакет за вмъкване на хипервръзки в документи, така че не виждам да има някаква връзка.
Активен

http://blog-nikolavp.rhcloud.com - простотиите, с които се занимавам в свободното време

kill_u

  • Напреднали
  • *****
  • Публикации: 1058
  • Distribution: Ubuntu 9.10
  • Window Manager: Gnome
  • Out of here....
    • Профил
    • WWW
Проблем с latex
« Отговор #2 -: Feb 13, 2008, 07:33 »
Примерен код
\usepackage{graphicx}
\RequirePackage[dvips]{hyperref}
\RequirePackage[dvi]{hyperref}
% use this package if hyperref and natbib is used:
%\RequirePackage{hypernat}

Това е при мен може би трябва да махна тези коментари педи него?
Активен

Всеки пост - отговор на въпрос!!!
Gnu/Linux user 411527

dvasilev

  • Напреднали
  • *****
  • Публикации: 200
  • Distribution: Kubuntu, Debian
  • Window Manager: KDE
    • Профил
    • WWW
Проблем с latex
« Отговор #3 -: Feb 13, 2008, 09:23 »
@kill_u: Може ли да кажеш в какъв формат са ти графиките и как правиш pdf файла, т.е. дали го компилираш директно чрез pdflatex или минаваш през dvi или ps?
Също така, ако може сложи целият preamble за да видя какви пакети използваш.
Активен

kill_u

  • Напреднали
  • *****
  • Публикации: 1058
  • Distribution: Ubuntu 9.10
  • Window Manager: Gnome
  • Out of here....
    • Профил
    • WWW
Проблем с latex
« Отговор #4 -: Feb 13, 2008, 09:46 »
Графиките ми са в png и eps тоест може ако иска да ги конвертира и в pdf и в dvi.
В тази бланка няма preamble но ти слагам всичко до \begin{documents}
Примерен код
%Author:
%All other lines should be ignored.  After editing, there should be
%no instances of '<img'> after this line.

% use option [preprint] to remove info line at bottom
\documentclass[twocolumn,sts]{imsart}
\arxiv{math.PR/0000000}

\usepackage{graphicx}
\RequirePackage[dvips]{hyperref}
\RequirePackage[dvi]{hyperref}
% use this package if hyperref and natbib is used:
%\RequirePackage{hypernat}

% put your definitions there:
%\startlocaldefs
%\setattribute{Economic thought annual}{Encho Zhekov}{Bulgarian Academy of Sciences}
%\endlocaldefs




Активен

Всеки пост - отговор на въпрос!!!
Gnu/Linux user 411527

dvasilev

  • Напреднали
  • *****
  • Публикации: 200
  • Distribution: Kubuntu, Debian
  • Window Manager: KDE
    • Профил
    • WWW
Проблем с latex
« Отговор #5 -: Feb 13, 2008, 10:23 »
Прегледах нещата и имам следните коментари:
1. използва се нестандартен latex пакет и като гледам инструкциите за подаване на публикацията се изисква съответните sty и cls файлове на imsart да присъстват. Предполагам си ги сложил, но все пак провери.
2. Поне при мен има проблем с \RequirePackage[dvi]{hyperref}
Според мен е добре да го махнеш, както и предходния ред. Така или иначе imsart включва hypperref пакета с разни опции, най-много да стават някакви колизии, които да се отразяват по различен начин в зависимост на каква система компилираш файла.
За друго не се сещам.
Активен

kill_u

  • Напреднали
  • *****
  • Публикации: 1058
  • Distribution: Ubuntu 9.10
  • Window Manager: Gnome
  • Out of here....
    • Профил
    • WWW
Проблем с latex
« Отговор #6 -: Feb 13, 2008, 10:25 »
Ако махна както ми казваш, \RequirePackage[dvi]{hyperref} ще могат ли да си ги компилират в dvi?
Във файла който ъплоуднах - zip архив сложих и двата sty и cls, защото иначе не се компилира правилно.



Активен

Всеки пост - отговор на въпрос!!!
Gnu/Linux user 411527

dvasilev

  • Напреднали
  • *****
  • Публикации: 200
  • Distribution: Kubuntu, Debian
  • Window Manager: KDE
    • Профил
    • WWW
Проблем с latex
« Отговор #7 -: Feb 13, 2008, 12:48 »
Би трябвало да няма проблем. Проблемът е, че поне при мен hyperref няма такава опция. Даже ми е странно при теб как се компилира.
Активен

kill_u

  • Напреднали
  • *****
  • Публикации: 1058
  • Distribution: Ubuntu 9.10
  • Window Manager: Gnome
  • Out of here....
    • Профил
    • WWW
Проблем с latex
« Отговор #8 -: Feb 13, 2008, 15:45 »
В крайна сметка се наложи да кача PDF файлчето като учитиво попитах каката дали иска и DVI оказа се, че не ще. В крайна сметка за какъв чеп искат да качва човек TEX файлове след като не могат да ги компилират? Защо не сложат условие да са писани на ЛаТеК това предполагам, че може да се провери винаги.



Активен

Всеки пост - отговор на въпрос!!!
Gnu/Linux user 411527

Подобни теми
Заглавие Започната от Отговора Прегледи Последна публикация
LateX+Debian-->Help
Настройка на програми
Ivan_dr 3 1538 Последна публикация Jun 04, 2004, 11:47
от n_antonov
LaTeX
Търсене
Katya 0 1504 Последна публикация Nov 01, 2004, 15:40
от Katya
LaTeX i Fedora
Настройка на програми
paranoid 7 2350 Последна публикация Aug 19, 2005, 16:06
от Agent_SMITH
Latex cyrillic Slack 10
Настройка на програми
akif 3 2025 Последна публикация Aug 20, 2005, 00:01
от kbd
Предлагам работа с LaTeX, Emacs
Търсене
Ptan 3 2033 Последна публикация Sep 25, 2013, 11:11
от go_fire