Автор Тема: X terminal broadcasting  (Прочетена 2246 пъти)

ivanatora

  • Напреднали
  • *****
  • Публикации: 658
  • Distribution: Ubuntu 10.04
  • Window Manager: Fluxbox
    • Профил
    • WWW
X terminal broadcasting
« -: May 02, 2005, 00:21 »
Тая тема си нямам ни най-малка идея в кой форум да я зафича.
Как да обясня какво точно имам предвид.. Виждал съм го при Solaris. Когато root се логне на всичките Х терминали, които си отворил показва съобщение 'root се логна в толкоз часа, на тая конзола/терминал'. Нещо подобно мисля се показва и преди shutdown на машина. Някакво съобщение което се разпръсква до всички конзоли или терминали, видими от потребителя. Как се прави това нещо? Мога ли да го направя с някакво приложение? Дайте идеи, да чуем какво мислите '<img'>
Активен

Decoy

  • Напреднали
  • *****
  • Публикации: 46
    • Профил
X terminal broadcasting
« Отговор #1 -: May 02, 2005, 00:55 »
ФрееБСД-то прави същото (аз смятам че е много досадно и сега с Дебиан мога да кажа че живея спокойно). Когато се логне главния потребител и изписва досадни съобщения. На някой може да му трябват, но мен лично ме дразнят.
Активен

PhobosK

  • Напреднали
  • *****
  • Публикации: 282
  • Distribution: Ubuntu, Mandriva, Gentoo, Slackware, Fedora, SuSe
  • Window Manager: KDE, GNOME
    • Профил
    • WWW
X terminal broadcasting
« Отговор #2 -: May 02, 2005, 02:09 »
Цитат
Дайте идеи, да чуем какво мислите

Това тест за интелигентност ли е, що ли?

=======
Командата е:
wall message

Само трябва потребителите да са дали:
mesg y
Активен

...I could drown in your eyes,
 Die in your arms,
 Live for these moments,
 Here in the dark
 I don't know where I end,
 Not sure where you start,
 When we're body to body...

ivanatora

  • Напреднали
  • *****
  • Публикации: 658
  • Distribution: Ubuntu 10.04
  • Window Manager: Fluxbox
    • Профил
    • WWW
X terminal broadcasting
« Отговор #3 -: May 02, 2005, 10:21 »
Нещо не става..
Примерен код

(10:23:30)[root@/home/ivanatora]# echo "Message: blablabla" > walled
(10:23:52)[root@/home/ivanatora]# wall walled                               (10:23:56)[root@/home/ivanatora]# mesg                                      
is y
(10:24:07)[root@/home/ivanatora]# exit                                          
(10:24:07)[ivanatora@~]$ mesg                                                    
is y

Нищо не се изписва по другите терминали.
ПП. Уточнение. В истинските конзоли това работи, аз питам за терминалите пуснати в Х-а.
Активен

rpetrov

  • Напреднали
  • *****
  • Публикации: 571
    • Профил
    • WWW
X terminal broadcasting
« Отговор #4 -: May 03, 2005, 11:06 »
Цитат (ivanatora @ Май 02 2005,10:21)
ПП. Уточнение. В истинските конзоли това работи, аз питам за терминалите пуснати в Х-а.

Сигурен ли си, че не работи в xterm ?"
Активен

ivanatora

  • Напреднали
  • *****
  • Публикации: 658
  • Distribution: Ubuntu 10.04
  • Window Manager: Fluxbox
    • Профил
    • WWW
X terminal broadcasting
« Отговор #5 -: May 03, 2005, 11:33 »
Хм, в xterm работело.. но в aterm - не  '<img'>
Активен

rpetrov

  • Напреднали
  • *****
  • Публикации: 571
    • Профил
    • WWW
X terminal broadcasting
« Отговор #6 -: May 03, 2005, 12:26 »
Съобщението ще бъде получено на терминалите, за които има запис в utmp.
Команди като "who" и "w" показват това.
Активен

ivanatora

  • Напреднали
  • *****
  • Публикации: 658
  • Distribution: Ubuntu 10.04
  • Window Manager: Fluxbox
    • Профил
    • WWW
X terminal broadcasting
« Отговор #7 -: May 04, 2005, 20:31 »
А защо aterm не прави такъв запис? И може ли да получавам такива съобщения в aterm?
ПП. Прекомпилирах aterm-а с опции --enable-wtmp --enable-utmp, нямаше файда.
Активен

rpetrov

  • Напреднали
  • *****
  • Публикации: 571
    • Профил
    • WWW
X terminal broadcasting
« Отговор #8 -: May 05, 2005, 12:24 »
само суперпотребител трябва да може да пише в utmp/wtmp => aterm трябва да е "set user id root" ....
Активен

rpetrov

  • Напреднали
  • *****
  • Публикации: 571
    • Профил
    • WWW
X terminal broadcasting
« Отговор #9 -: May 05, 2005, 12:27 »
Цитат (ivanatora @ Май 02 2005,00:21)
Тая тема си нямам ни най-малка идея в кой форум да я зафича.

май вече стана за напреднали '<img'>
Активен

ivanatora

  • Напреднали
  • *****
  • Публикации: 658
  • Distribution: Ubuntu 10.04
  • Window Manager: Fluxbox
    • Профил
    • WWW
X terminal broadcasting
« Отговор #10 -: May 05, 2005, 12:38 »
Цитат (rpetrov @ Май 05 2005,12:24)
само суперпотребител трябва да може да пише в utmp/wtmp => aterm трябва да е "set user id root" ....

Благодаря, така вече се оправи '<img'>
# chmod +s /usr/local/bin/aterm
вече и в who се виждам и wall получавам '<img'>
Активен

Подобни теми
Заглавие Започната от Отговора Прегледи Последна публикация
Sys Terminal (Console) настройки
Настройка на програми
senser 1 1238 Последна публикация Aug 27, 2004, 10:18
от Hapkoc
Xfce Terminal
Настройка на програми
Rooted 3 1331 Последна публикация Jan 30, 2005, 16:50
от kalifi
Terminal
Идеи и мнения
Йордан 12 2819 Последна публикация Jun 12, 2006, 22:16
от Йордан
MIK character encoding в terminal
Настройка на програми
plamensl 0 1221 Последна публикация Dec 07, 2010, 09:54
от plamensl
Ubunt, C & Terminal
Настройка на програми
lizarda 1 1171 Последна публикация Jun 06, 2011, 02:34
от lizarda