Автор Тема: LILO boot  (Прочетена 6214 пъти)

ma3x_smith

  • Участници
  • ***
  • Публикации: 8
    • Профил
LILO boot
« -: May 03, 2003, 22:43 »
ОПИСАНИЕ

Машината ми е с 2 диска, както следва:

/dev/hda1 = windows98se
/dev/hda5 = mandrake 9
/dev/hdb5 = redhat 9

първо на машината имаше САМО win98, в последствие инсталирах mandrake, и последно инсталирах redhat9.

когато инсталирах Мандрейк, по подразбиране инсталирах ЛИЛО за мениджър, и всичко беше ок, докато не качих и РедХета. Понеже съм начинаещ, и нямам и бегла представа как се конфигурира (добавя) LILO, избрах опцията RedHat да се зарежда от боот дискета.

сега, ако ми трябва win98, или Mandrake, стартирам от диска, а ако ми трябва RedHat, слагам дискетата... (доста примитивно, но работи).

сега реших, че трябва да оправя този проблем, и да обединя всичко в LILO, което е инсталирано в MBR.

КАКВО НАПРАВИХ ДОСЕГА:

1. копирах всички файлове от дискетата в /hdb5/boot/
2. добавих в LILO описание, АБСОЛЮТНО същото като това на мадрейк, с разликата, че root = /dev/hdb5, и initrd=initrd-2.4.20-8, vmlinuz=vmlinuz-2.4.20-8.img
3. рестартирах ЛИЛО от конзолата като root, като в конзолата показва, че зарежда всичките системи БЕЗ проблем.

ПРОБЛЕМА

Когато зарежедам РедХет от LILO (MBR), започва да бълва тонове грешки, и в края на краищата НЕ зарежда системата. Всичко останало бачка (щото не съм го пипал естествено '<img'> )

След подобен неуспех не зная къде е лог-файла с грешките, които да приложа тук (за да ми отговорите по-лесно).

Моля за помощ и напътствия как мога да се справя с този проблем?
Активен

* what does not #kill -9 me, only makes me stronger *

mrvoland

  • Напреднали
  • *****
  • Публикации: 382
    • Профил
LILO boot
« Отговор #1 -: May 04, 2003, 09:59 »
важно е да знаем какви са грешките...
/var/log/dmesg
/var/log/kern.log
/var/log/syslog
следи какви грешки ти дава като зарежда ядрото и ги потърси в файловете в /var/log, после ги paste тук '<img'>
Активен

no pain no gain!

Michael

  • Напреднали
  • *****
  • Публикации: 39
    • Профил
LILO boot
« Отговор #2 -: May 04, 2003, 15:56 »
Понеже не става ясно кое LILO си пипнал, оставам с впечатлението, че си коригирал LILO на RedHat, но понеже, според това което пишеш Mandrake, ти е водеща дистрибуция, в смисъл че, като си качвал RedHat LILO вече е имало то тези промени е необходимо да се направят в lilo.conf на Mandrake. Иначе като гледам не си объркал нещо !
Така че опитай и успех !

Michael
Активен

  • Гост
LILO boot
« Отговор #3 -: May 05, 2003, 12:34 »
Първо - необходимото уточнение: понеже ЛИЛОто в МБР е на Мандрейк, него съм пипал (т.е. лог като root в Мандрейк, и т.н.)

сега copy+paste подред:

първо, когато рестартирам ЛИЛО от конзолата на Мандрейк се получава това:
#lilo
Added RedHat9
Added Mandrake9
Added failsafe
Added win98se *
Added floppy

самият /etc/lilo.conf (тоя, дето е в МБР, на Мандрейка) е със следното съдържание:

boot=/dev/hda
map=/boot/map
vga=normal
default=win98se
keytable=/boot/us.klt
prompt
nowarn
timeout=100
message=/boot/message
menu-scheme=wb:bw:wb:bw
ignore-table
image=/boot/vmlinuz
   label=RedHat9
   root=/dev/hdb5
   initrd=/boot/initrd.img
   append="hdc=ide-scsi"
   read-only
image=/boot/vmlinuz
   label=Mandrake9
   root=/dev/hda6
   initrd=/boot/initrd.img
   append="devfs=mount hdc=ide-scsi"
   read-only
image=/boot/vmlinuz
   label=failsafe
   root=/dev/hda6
   initrd=/boot/initrd.img
   append="failsafe devfs=nomount hdc=ide-scsi"
   read-only
other=/dev/hda1
   label=win98se
   table=/dev/hda
other=/dev/fd0
   label=floppy
   unsafe

в /hdb5/boot vmlinuz & initrd са "вързани" -> към съответните дълги имена с 2.4.20-8 ...

съдъжанието на RedHat  /var/log/dmesg e:

Linux version 2.4.20-8 (bhcompile@porky.devel.redhat.com) (gcc version 3.2.2 20030222 (Red Hat Linux 3.2.2-5)) #1 Thu Mar 13 17:54:28 EST 2003
BIOS-provided physical RAM map:
 BIOS-e820: 0000000000000000 - 000000000009fc00 (usable)
 BIOS-e820: 000000000009fc00 - 00000000000a0000 (reserved)
 BIOS-e820: 00000000000e0000 - 0000000000100000 (reserved)
 BIOS-e820: 0000000000100000 - 000000001ffd0000 (usable)
 BIOS-e820: 000000001ffd0000 - 000000001fff0000 (ACPI NVS)
 BIOS-e820: 000000001fff0000 - 0000000020000000 (reserved)
 BIOS-e820: 00000000feea0000 - 0000000100000000 (reserved)
0MB HIGHMEM available.
511MB LOWMEM available.
On node 0 totalpages: 131024
zone(0): 4096 pages.
zone(1): 126928 pages.
zone(2): 0 pages.
Kernel command line: initrd=initrd.img hdc=ide-scsi root=/dev/hdb5 BOOT_IMAGE=vmlinuz
ide_setup: hdc=ide-scsi
Initializing CPU#0
Detected 996.776 MHz processor.
Console: colour VGA+ 80x25
Calibrating delay loop... 1985.74 BogoMIPS
Memory: 511224k/524096k available (1347k kernel code, 10308k reserved, 999k data, 132k init, 0k highmem)
Dentry cache hash table entries: 65536 (order: 7, 524288 bytes)
Inode cache hash table entries: 32768 (order: 6, 262144 bytes)
Mount cache hash table entries: 512 (order: 0, 4096 bytes)
Buffer-cache hash table entries: 32768 (order: 5, 131072 bytes)
Page-cache hash table entries: 131072 (order: 7, 524288 bytes)
CPU: L1 I cache: 16K, L1 D cache: 16K
CPU: L2 cache: 256K
Intel machine check architecture supported.
Intel machine check reporting enabled on CPU#0.
CPU:     After generic, caps: 0383fbff 00000000 00000000 00000000
CPU:             Common caps: 0383fbff 00000000 00000000 00000000
CPU: Intel Pentium III (Coppermine) stepping 0a
Enabling fast FPU save and restore... done.
Enabling unmasked SIMD FPU exception support... done.
Checking 'hlt' instruction... OK.
POSIX conformance testing by UNIFIX
mtrr: v1.40 (20010327) Richard Gooch (rgooch@atnf.csiro.au)
mtrr: detected mtrr type: Intel
PCI: PCI BIOS revision 2.10 entry at 0xe838d, last bus=2
PCI: Using configuration type 1
PCI: Probing PCI hardware
Transparent bridge - Intel Corp. 82801BA/CA/DB PCI Bridge
PCI: Using IRQ router PIIX [8086/2440] at 00:1f.0
isapnp: Scanning for PnP cards...
isapnp: No Plug & Play device found
Linux NET4.0 for Linux 2.4
Based upon Swansea University Computer Society NET3.039
Initializing RT netlink socket
apm: BIOS version 1.2 Flags 0x03 (Driver version 1.16)
Starting kswapd
VFS: Disk quotas vdquot_6.5.1
pty: 2048 Unix98 ptys configured
Serial driver version 5.05c (2001-07-08) with MANY_PORTS MULTIPORT SHARE_IRQ SERIAL_PCI ISAPNP enabled
ttyS0 at 0x03f8 (irq = 4) is a 16550A
ttyS1 at 0x02f8 (irq = 3) is a 16550A
Real Time Clock Driver v1.10e
Floppy drive(s): fd0 is 1.44M
FDC 0 is a post-1991 82077
NET4: Frame Diverter 0.46
RAMDISK driver initialized: 16 RAM disks of 4096K size 1024 blocksize
Uniform Multi-Platform E-IDE driver Revision: 7.00beta-2.4
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
ICH2: IDE controller at PCI slot 00:1f.1
ICH2: chipset revision 2
ICH2: not 100% native mode: will probe irqs later
    ide0: BM-DMA at 0x3460-0x3467, BIOS settings: hda:DMA, hdb:DMA
    ide1: BM-DMA at 0x3468-0x346f, BIOS settings: hdc:DMA, hdd:DMA
hda: Maxtor 6Y120L0, ATA DISK drive
hdb: WDC WD200BB-60AUA1, ATA DISK drive
blk: queue c03c9f40, I/O limit 4095Mb (mask 0xffffffff)
blk: queue c03ca084, I/O limit 4095Mb (mask 0xffffffff)
hdc: _NEC CD-RW NR-7900A, ATAPI CD/DVD-ROM drive
hdd: HL-DT-ST CD-ROM CRD-8484B, ATAPI CD/DVD-ROM drive
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
ide1 at 0x170-0x177,0x376 on irq 15
hda: host protected area => 1
hda: 240121728 sectors (122942 MB) w/2048KiB Cache, CHS=15881/240/63, UDMA(33)
hdb: host protected area => 1
hdb: 39102336 sectors (20020 MB) w/2048KiB Cache, CHS=2586/240/63, UDMA(33)
ide-floppy driver 0.99.newide
Partition check:
 hda: hda1 hda2 < hda5 hda6 hda7 hda8 hda9 >
 hdb: hdb1 hdb2 < hdb5 hdb6 hdb7 >
ide-floppy driver 0.99.newide
md: md driver 0.90.0 MAX_MD_DEVS=256, MD_SB_DISKS=27
md: Autodetecting RAID arrays.
md: autorun ...
md: ... autorun DONE.
NET4: Linux TCP/IP 1.0 for NET4.0
IP Protocols: ICMP, UDP, TCP, IGMP
IP: routing cache hash table of 4096 buckets, 32Kbytes
TCP: Hash tables configured (established 32768 bind 65536)
Linux IP multicast router 0.06 plus PIM-SM
NET4: Unix domain sockets 1.0/SMP for Linux NET4.0.
RAMDISK: Compressed image found at block 0
Freeing initrd memory: 146k freed
VFS: Mounted root (ext2 filesystem).
Journalled Block Device driver loaded
kjournald starting.  Commit interval 5 seconds
EXT3-fs: mounted filesystem with ordered data mode.
Freeing unused kernel memory: 132k freed
usb.c: registered new driver usbdevfs
usb.c: registered new driver hub
usb-uhci.c: $Revision: 1.275 $ time 17:59':0'1 Mar 13 2003
usb-uhci.c: High bandwidth mode enabled
PCI: Found IRQ 5 for device 00:1f.4
PCI: Setting latency timer of device 00:1f.4 to 64
usb-uhci.c: USB UHCI at I/O 0x3440, IRQ 5
usb-uhci.c: Detected 2 ports
usb.c: new USB bus registered, assigned bus number 1
hub.c: USB hub found
hub.c: 2 ports detected
usb-uhci.c: v1.275:USB Universal Host Controller Interface driver
usb.c: registered new driver hiddev
usb.c: registered new driver hid
hid-core.c: v1.8.1 Andreas Gal, Vojtech Pavlik <vojtech@suse.cz>
hid-core.c: USB HID support drivers
mice: PS/2 mouse device common for all mice
hub.c: new USB device 00:1f.4-1, assigned address 2
usb.c: USB device 2 (vend/prod 0x50f/0x180) is not claimed by any active driver.
EXT3 FS 2.4-0.9.19, 19 August 2002 on ide0(3,69), internal journal
Adding Swap: 824000k swap-space (priority -1)
hub.c: new USB device 00:1f.4-2, assigned address 3
usb.c: USB device 3 (vend/prod 0x67b/0x1) is not claimed by any active driver.
usb.c: registered new driver serial
usbserial.c: USB Serial support registered for Generic
usbserial.c: USB Serial Driver core v1.4
usbserial.c: USB Serial support registered for IR Dongle
usbserial.c: IR Dongle converter detected
usbserial.c: IR Dongle converter now attached to ttyUSB0 (or usb/tts/0 for devfs)
ir-usb.c: USB IR Dongle driver v0.4
usb.c: registered new driver irda-usb
USB IrDA support registered
usb.c: registered new driver usbnet
divert: allocating divert_blk for usb0
usb0: register usbnet usb-00:1f.4-2, Prolific PL-2301/PL-2302
kjournald starting.  Commit interval 5 seconds
EXT3 FS 2.4-0.9.19, 19 August 2002 on ide0(3,70), internal journal
EXT3-fs: mounted filesystem with ordered data mode.
hdd: ATAPI 48X CD-ROM drive, 128kB Cache, DMA
Uniform CD-ROM driver Revision: 3.12
SCSI subsystem driver Revision: 1.00
scsi0 : SCSI host adapter emulation for IDE ATAPI devices
  Vendor: _NEC      Model: NR-7900A          Rev: 1.23
  Type:   CD-ROM                             ANSI SCSI revision: 02

странно за мен, след като питахте, не очаквах да НЕ намеря изобщо
/var/log/kern.msg
/var/log/syslog

във РедХет... ето и какво имам в /var/log/ на РедХета
$ ls -al
total 1512
drwxr-xr-x    6 root     root         4096 May  5 11:54 .
drwxr-xr-x   17 root     root         4096 Apr 21 01':0'5 ..
-rw-------    1 root     root        17998 May  5 11:54 boot.log
-rw-------    1 root     root        30870 Apr 28 04':0'2 boot.log.1
drwxr-xr-x    2 bin      bin          4096 Feb  4 11:32 canna
-rw-------    1 root     root         3199 May  5 12':0'1 cron
-rw-------    1 root     root         5940 Apr 28 04':0'2 cron.1
drwxr-xr-x    2 lp       sys          4096 Apr 28 04':0'2 cups
-rw-r--r--    1 root     root         6778 May  5 11:53 dmesg
drwxr-xr-x    2 root     root         4096 May  5 11:54 gdm
-rw-r--r--    1 root     root        73460 May  5 11:53 ksyms.0
-rw-r--r--    1 root     root        73460 May  3 04':0'8 ksyms.1
-rw-r--r--    1 root     root        73460 May  2 02:25 ksyms.2
-rw-r--r--    1 root     root        73460 May  2 00:56 ksyms.3
-rw-r--r--    1 root     root        73460 Apr 29 21:24 ksyms.4
-rw-r--r--    1 root     root        48444 Apr 28 04:31 ksyms.5
-rw-r--r--    1 root     root        73460 Apr 28 03:49 ksyms.6
-r--------    1 root     root     19136220 May  5 12':0'2 lastlog
-rw-------    1 root     root         3978 May  5 11:54 maillog
-rw-------    1 root     root         7226 Apr 28 04':0'2 maillog.1
-rw-------    1 root     root       134039 May  5 12':0'4 messages
-rw-------    1 root     root       221765 Apr 28 04':0'2 messages.1
-rw-r--r--    1 root     root        16988 May  2 02':0'5 rpmpkgs
-rw-r--r--    1 root     root        16986 Apr 23 23':0'3 rpmpkgs.1
-rw-r--r--    1 root     root        14787 Apr 21 01':0'9 scrollkeeper.log
-rw-------    1 root     root         1213 May  5 12':0'2 secure
-rw-------    1 root     root         2617 Apr 28 03:52 secure.1
-rw-------    1 root     root            0 Apr 28 04':0'2 spooler
-rw-------    1 root     root            0 Apr 21 00:55 spooler.1
-rw-r--r--    1 root     root         1182 May  2 01:55 up2date
-rw-r--r--    1 root     root         1779 Apr 23 23:23 up2date.1
drwxr-xr-x    2 root     root         4096 Feb  4 02:13 vbox
-rw-rw-r--    1 root     utmp        38400 May  5 12':0'3 wtmp
-rw-rw-r--    1 root     utmp       262656 May  2 01':0'8 wtmp.1
-rw-r--r--    1 root     root        39426 May  5 12':0'2 XFree86.0.log
-rw-r--r--    1 root     root        39559 May  3 04:25 XFree86.0.log.old
-rw-r--r--    1 root     root        39403 Apr 21 09:43 XFree86.1.log

ако е необходимо още нещо, с удоволствие ще го изровя.

thanks,
smith
Активен

ma3x_smith

  • Участници
  • ***
  • Публикации: 8
    • Профил
LILO boot
« Отговор #4 -: May 05, 2003, 12:37 »
съжелявам, че забравих да се логна, и не изключих емотиконите - сега прилича на детска тетрадка...
Активен

* what does not #kill -9 me, only makes me stronger *

Michael

  • Напреднали
  • *****
  • Публикации: 39
    • Профил
LILO boot
« Отговор #5 -: May 05, 2003, 14:53 »
Според мен ти практически зареждаш едно и съшо ядро. Първо провери, дали във Mandrake име /dev/hd5, според мен би трябвало да е там, после, кдето ти е секцита image за RedHat, промени я по следния начин image=/dev/hdb5/boot/vmlinuz, с това мисля че ще ти се реши проблема, но не мога да съм сигурен.

Успех

Michael
Активен

  • Гост
LILO boot
« Отговор #6 -: May 06, 2003, 21:20 »
абе и мен ме преследва това чувство, особено, като сред милионите грешки при буут на РедХета ми показва ни в клин, ни в ръкав от време на време /2,4,19mdk '<img'>?

ето какво стана като редактирах ЛИЛО както ти предложи, и го рестартирах...

# lilo
Fatal: open /dev/hdb5/boot/vmlinuz:

а когато проверя дали го има това чудо /dev/hdb5 в Mandrake, ми дава, че няма такова нещо, а ако пробвам да го mount:

[root@localhost smith]# mount /dev/hdb5/ /mnt/hd/
mount: special device /dev/hdb5/ does not exist
       (a path prefix is not a directory)

истерията на българските гласове ... чуствам се като блондинка пред уиндоус мамка му...

помощ!
Активен

  • Гост
LILO boot
« Отговор #7 -: May 07, 2003, 04:23 »
Да, добре се е омазало. Това че всеки път зареждаш едно и също ядро си е неоспорим факт. Аз понеже отдавна съм се отказал от RedHat, не мога да си спомня, тези дялове, които са в скобите <..>, дали не бяха някакви псевдо дялове или реални, затова можеш да опиташ още веднъж като посочиш в image=/dev/hdb1/boot/vmlinuz. Защото ако не се лъжа в твоя случай hdb1 и hdb5 са един и същ физически дял.Като влезеш в Mandrake, провери в /dev дали има hdb5 или hdb1. Откровенно нищо друго не ми идва наум.

Michael
Активен

  • Гост
LILO boot
« Отговор #8 -: May 07, 2003, 04:49 »
Между другото, това последното съобщение означава, че Mandrake, нещо не му "харесва" дяла hdb5, което може да означава че там го няма.

Michael
Активен

ma3x_smith

  • Участници
  • ***
  • Публикации: 8
    • Профил
LILO boot
« Отговор #9 -: May 07, 2003, 20:17 »
няма го'<img'>

няма го, в смисъл, че Мандрейк не го вижда, предполагам... защото не само че го има, а когато зарежда от дискетата РедХета е ПЕСЕН!!! само дето е бавна песен, щото докато зареди vmlinuz и пия 2 бири...

а има ли вариант според който мога да си направя (от РедХет) ЛИЛО, в което да добавя после Мандрейка?

(загуедах се)
Активен

* what does not #kill -9 me, only makes me stronger *

mrvoland

  • Напреднали
  • *****
  • Публикации: 382
    • Профил
LILO boot
« Отговор #10 -: May 08, 2003, 09:08 »
един въпрос:
какви файлови системи използваш за redhat и mandrake ? също имам съмнение дали версиите на lilo са едни и същи, може от това да е проблема.
можеш да пробваш някой независим boot-manager, grub или manager-a на partition magic също е добър след като имаш widnows на системата
Активен

no pain no gain!

ma3x_smith

  • Участници
  • ***
  • Публикации: 8
    • Профил
LILO boot
« Отговор #11 -: May 08, 2003, 09:50 »
и двете системи са инсталирани на ext3 дялове.

колкото до GRUB, искам да опитам, но така и не успях да намеря читаво HOWTO, в което да е описано стъпка по стъпка как мога да го инстлаирам в MBR, и да добавя други системи за зареждане в менютата...

ако някои се сеща за добро HOWTO за GRUB, или пък направо някои GUI tool като за начинаещи... ще ми е от полза.
Активен

* what does not #kill -9 me, only makes me stronger *

kolio_kolev

  • Напреднали
  • *****
  • Публикации: 356
  • Distribution: Mandriva 2011, Mandriva Cooker
  • Window Manager: KDE 4.6.x
    • Профил
    • WWW
LILO boot
« Отговор #12 -: May 08, 2003, 10:40 »
Здравей,

проблема ти е много прост и се учудвам на това, че никой не ти отговаря по същество!

Ето стъпките, които се изпълняват при зареждане на ОС.
1. Прочитане на MBR записа на първия IDE master диск. Дължината на този запис е 800 байта. можеш да си го копираш по следния начин във файл (hdambr.bin) :
dd if=/dev/hda  of=/tmp/hdambr.bin  bs=800 count=1 ; sync

Възтановяването става по следния начин:
dd if=/tmp/hdambr.bin  of=/dev/hda ; sync

Този MBR запис съдържа таблица с физическото разположение и големината на дяловете, типове файлове системи, и др.  Но и съдържа информация за това на кой дял да се предаде управлението по подразбиране. В твоя случай в MBR е установено зареждане на loader от /dev/hda6.
 
2. Прочитат се първите 512 байта от дяла по подразбиране, който трябва да съдържат кратка програма за стартиране на ОС - так. нар. mini loader, и се предава управлението на тази малка програма. След това се зарежда същинската част на  loader-а (в случая LILO) и му се предава управлението.

Дотука стъпките се изпълняват от всички ОС и loader-и.

3. LILO прочита конфигурационния си файл (в твоя случай от /dev/hda6  директория /etc/lilo.conf) и генерира менюто за избор. Ето кратко разяснение на този файл:
Реда boot=/dev/hda указва къде да се инсталира LILO, в случая в MBR.

Редовете

image=/boot/vmlinuz
label=RedHat9
root=/dev/hdb5
initrd=/boot/initrd.img
append="hdc=ide-scsi"
read-only

image=/boot/vmlinuz
label=Mandrake9
root=/dev/hda6
initrd=/boot/initrd.img
append="devfs=mount hdc=ide-scsi"
read-only

указват да се зареди от /dev/hda6 (директория /boot) kernal-a . И както се вижда сочат към един и същи дял и файл!!! За да зареждаш от друг дял kernal-a, трябва да постъпиш както е конфигурирано зареждането на Win98. Промени редовете за RedHat така:

other=/dev/hda5
   label=RedHat9
   table=/dev/hda

Така ще предадеш безусловно управлението на първите 512 байта на дял /dev/hda5, където се предполага, че си задал да се инсталира loader-а (по подразбиране в RedHat GRUB). Ако не си инсталирал loader в дяла на RedHat, това можеш да сториш от първото CD с RedHat. В началния екран избери F1 и след това linux rescue. И следвай инструкциите от ръководството на RH за system recovery... '<img'>

След промяната на lilo.conf (например с текстов редактор) не забравяй да изпълниш  lilo !!!


....

Копиране на първите 512 от дял във файл (hda6boot.bin) става така:
dd if=/dev/hda  of=/tmp/hda6boot.bin  bs=512 count=1 ; sync

....

ЗАКЛЮЧЕНИЕ:
===============================================
Накратко правилата са такива:
Трябва да имаш един loader в MBR (с големина 800 байта ), който поема управлението. Другите ОС трябва да си сложат loader-ите в дяловете, където да инсталирани (бeз тази ОС, на която вече loader-а и е сложен в MBR ). Първите  512 байта на тези дялове са ключови за зареждането на ОС.
LILO предава безусловно управлението на друг дял като се избере “друга OS” (в Mandrake Control center се избира като тип other/Windows). Ако избереш Linux, ще се зарежда всеки път един и същ kernal.

Това е!



Кольо Колев

Biotronica Ltd.
kolio_kolev@europe.com
Активен

Кольо Колев
Mandriva BG: http://mandriva.biotronica.net
Bitronica.Net форуми: http://forum.biotronica.net

ma3x_smith

  • Участници
  • ***
  • Публикации: 8
    • Профил
LILO boot
« Отговор #13 -: May 09, 2003, 02:44 »
Кольо,

Ти си спасителя, човече... Светна ми, прогледнах... колко просто било да се обясни простичко. Върна надеждата '<img'>

Имам обаче малък проблем. Прочетох де що имаше по RH manuals и онлайн, и на дисковете за system recovery, но никъде не срещнах описание на това как да се възстанови / инсталира loader в партитишъна на РедХет (/dev/hdb5)...

Успях без проблем да вляза в rescue mode с първия диск, имам си #, мога да се движа навсякъде, но ...  в /boot няма нито grub, нито grub.conf, който евентуално да променя(видя на първо време...)

Допускам, че след като при инсталацията съм избрал само boot disk, и не съм инсталирал boot loader, GRUB просто е инсталиран на дискетата, с която се мъча'<img'> Но тогава си задавам въпроса - след като копирах всичко от дискетата в /boot (на редхета, т.е. /dev/hdb5/boot/), защо след корекциите в Mandrake LILO (/dev/hda6/etc/lilo.conf), при команда в конзола #lilo, ми изписва, че в /dev/hdb5/ няма никой?!?!?

Ако предположението ми, че в /dev/hdb5/boot няма loader, било то GRUB или LILO, въпроса (проблема) ми е:

Как да го инсталирам там? От къде да го инсталирам - от РедХета, в конзола? През CD1, <boot> rescue? Ако можеш да ми драснеш командите...

Благодаря ти за времето, и великолепното обяснение. '<img'>

Smith

p.s. btw, отдавна чакам да прочета тук нещо за курс 2ро ниво... Първото беше супер (макар и само на Mandrake9), но сега съм нон-стоп в #IRC, help, man, info и където другаде се сетиш...
Активен

* what does not #kill -9 me, only makes me stronger *

ma3x_smith

  • Участници
  • ***
  • Публикации: 8
    • Профил
LILO boot
« Отговор #14 -: May 12, 2003, 01:48 »
Кольо,

Каде изчезна amigo?!?!?!?!?!

 '<img'>
Активен

* what does not #kill -9 me, only makes me stronger *

Подобни теми
Заглавие Започната от Отговора Прегледи Последна публикация
lilo cant boot;(
Настройка на програми
nix 5 2818 Последна публикация Jan 21, 2004, 03:59
от D0ct0rA
LILO Boot Loader
Настройка на програми
empty 25 10249 Последна публикация Apr 27, 2004, 19:10
от empty
Boot на Linux + Windows без lilo?
Настройка на програми
silvesterjunior 9 7402 Последна публикация Apr 21, 2005, 10:50
от silvesterjunior
Lilo.conf проблем при boot
Настройка на програми
preslavxxx 9 3177 Последна публикация Nov 22, 2006, 20:21
от preslavxxx
Проблем с boot loader-a lilo на slackware 12.1
Настройка на програми
dobritu 0 2194 Последна публикация Sep 08, 2008, 23:20
от dobritu