Автор Тема: Проблем с pppoe  (Прочетена 1427 пъти)

Glarusman

  • Напреднали
  • *****
  • Публикации: 31
    • Профил
Проблем с pppoe
« -: May 11, 2006, 11:22 »
Качих си Ubuntu Dapper Drake Flight 7. Със Breezy нямах абсолютно никакъв проблем при настройкатас rp-pppoe. Сега когато стартирам adsl-start ми дава грешка "TIMED OUT". Когато използвам ifconfig -a и двете ми ланкарти изглежда че работят без проблеми.
 Когато пробвам да конфигурирам връзката с pppoeconf ми дава грешка
Примерен код
Timeout waiting for PADO packets

 Също така пурвият път когато ползвах adsl-start ми върна и грешка:
Примерен код
/usr/sbin/adsl-start: line 193:9376 Terminates $CONNECT "$@">/dev/null 2>&1

Изпробвах както rp-pppoe-3.5 от ubuntu repository, така и най-новото rp-pppoe-3.9.

 Нямам абсолютно никакви проблеми при настройка на връзката под Knoppix с pppoeconf и под Gentoo с rp-pppoe (макар че там всъщност не използвам клиент а ръчно обработвам конфигурационните файлове). Някой да има някакви идеи? Кажете какъв допълнителен output да постна. Благодаря предварително!
Активен

  • Гост
Проблем с pppoe
« Отговор #1 -: May 11, 2006, 13:19 »
https://wiki.ubuntu.com/ADSLPPPoE
Активен

Glarusman

  • Напреднали
  • *****
  • Публикации: 31
    • Профил
Проблем с pppoe
« Отговор #2 -: May 11, 2006, 15:22 »
И това съм пробвал. Не става. Пък и почети всички използват rp-pppoe. Пробвах и ръчно конфигуриране на файловете и пак не става.
Активен

antonofff

  • Напреднали
  • *****
  • Публикации: 44
    • Профил
Проблем с pppoe
« Отговор #3 -: May 11, 2006, 15:48 »
Може би случая не е такъв, но все пак .....

http://www.linux-bg.org/cgi-bin....5752993

http://www.linux-bg.org/cgi-bin....9911239
Активен

Drakula

  • Напреднали
  • *****
  • Публикации: 319
  • Distribution: Gentoo
  • Window Manager: KDE 4
    • Профил
Проблем с pppoe
« Отговор #4 -: May 11, 2006, 16:36 »
Цитат (Glarusman @ Май 11 2006,11:22)
Timeout waiting for PADO packets

Ето какво всъщност значи PADO.
Имах абсолютно същия проблем когато от Homelan промениха името на service-a без предупреждение. Затова, провери името му в твоя конфигурационен файл. За да получиш списък от достъпните сървиси:
Примерен код
pppoe -I ethX -A

където ethX ти е мрежовия интерфейс.
Активен

kill_u

  • Напреднали
  • *****
  • Публикации: 1058
  • Distribution: Ubuntu 9.10
  • Window Manager: Gnome
  • Out of here....
    • Профил
    • WWW
Проблем с pppoe
« Отговор #5 -: May 11, 2006, 16:48 »
Абе аз махнах ADSL с
Примерен код
apt-get remove adsl

и после си сложих последна версия на rp-pppoe
нямам никакви проблеми.
Активен

Всеки пост - отговор на въпрос!!!
Gnu/Linux user 411527

duhast

  • Напреднали
  • *****
  • Публикации: 25
  • Distribution: Ubuntu
  • Window Manager: Gnome
    • Профил
    • WWW
Активен

Glarusman

  • Напреднали
  • *****
  • Публикации: 31
    • Профил
Проблем с pppoe
« Отговор #7 -: May 11, 2006, 19:46 »
Моят доставчик е нет ис сат. В един от опитите плътно се придържах към инструкциите им : http://cityconnect.netissat.bg/files/Linux1.html
така че servicename си е както трябва, но пак нищо не се получи.
Странното е че когато пробвах pppoe -I eth0 -A ми даде грешка:
Примерен код
Timeout waiting for PADO packets


Тогава си спомних че имах подобни проблеми и под Gentoo и трябваше да прекомпилирам ядрото с PPP поддръжка. Проблема е обаче че при Ubuntu в /usr/src няма нищо. Без сорсове на кернела ли идва или са някъде другаде? Ако е без сорсове има ли някакъв начин да разбера при какви настройки е компилиран (след като не мога да ползвам menuconfig) , за да видя дали са включени ppp и дали има нужда да го прекомпилирам. Някой друг да е на Ubuntu Dapper Flight 7 и да има подобни проблеми или липса на такива? При Breezy нямаше нужда от прекомпилиране на ядрото.
Активен

Drakula

  • Напреднали
  • *****
  • Публикации: 319
  • Distribution: Gentoo
  • Window Manager: KDE 4
    • Профил
Проблем с pppoe
« Отговор #8 -: May 11, 2006, 23:11 »
Цитат (Glarusman @ Май 11 2006,19:46)

Странното е че когато пробвах pppoe -I eth0 -A ми даде грешка:
Примерен код
Timeout waiting for PADO packets

Лоша работа! Може би е по-добре да се обадиш на доставчика си - изглежда access concentratora го няма...

А иначе при мен:

Примерен код
root@drakula:~# pppoe -I eth0 -A
Access-Concentrator: rtr-geomilev
       Service-Name: gm1
       Service-Name: gm2
       Service-Name: int
       Service-Name: nbu
Got a cookie: 95 5e df d7 05 91 f3 f3 e2 bc 69 e9 d2 b7 4e ba 8f 01 00 00
AC-Ethernet-Address: 00:15:f2:5e:76:19
--------------------------------------------------


Респективно в /etc/ppp/pppoe.conf имам:
Примерен код
# Specific desired AC Name
ACNAME=rtr-geomilev

# Specific desired service name
SERVICENAME=gm1
Активен

Glarusman

  • Напреднали
  • *****
  • Публикации: 31
    • Профил
Проблем с pppoe
« Отговор #9 -: May 11, 2006, 23:30 »
аccess concentratora си е наред. В момента пиша от Knoppix където връзката си се конфигурира идеално с  pppoeconfig който си намира аccess concentratora и всичко си е наред, "pppoe -I eth0 -A" също си бачка на 6. Точно затова започвам да си мисля че е проблем в ядрото - при Gentoo беше така и се оправи с прекомпилация , само че би било много странно защото в предишната версия на Ubuntu нямаше никакъв проблем. Във форума на Ubuntu не получавам никакви отговори от 10 сутринта насам. Тия хора на запад не ползват ли pppoe подяволите.



Активен

Подобни теми
Заглавие Започната от Отговора Прегледи Последна публикация
about PPPoE
Настройка на програми
fonzi 0 1663 Последна публикация May 12, 2002, 15:31
от fonzi
pppoe
Настройка на програми
nulll 0 1323 Последна публикация Oct 08, 2002, 14:09
от nulll
Проблем с pppoe
Настройка на програми
empty 6 2072 Последна публикация Jan 20, 2004, 13:15
от
Проблем с pppoe
Настройка на програми
empty 12 3018 Последна публикация Feb 15, 2004, 15:42
от empty
PPPoE
Настройка на програми
growchie 2 1369 Последна публикация Feb 17, 2004, 23:37
от